xml-commons-apis-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. # Copyright (c) 2000-2007, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. Name: xml-commons-apis
  31. Summary: APIs for DOM, SAX, and JAXP
  32. Version: 1.3.04
  33. Release: 1%{?_dist_release}
  34. #Group: Text Processing/Markup/XML
  35. Group: System Environment/Libraries
  36. License: ASL 2.0 and W3C and Public Domain
  37. URL: http://xml.apache.org/commons/
  38. # using binary package for bootstrap
  39. Source0: xml-commons-external-%{version}-bin.tar.gz
  40. # svn export http://svn.apache.org/repos/asf/xml/commons/tags/xml-commons-external-1_4_01/java/external/
  41. # tar czf xml-commons-external-1.4.01-src.tar.gz external
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. BuildArch: noarch
  44. BuildRequires: jpackage-utils >= 1.5
  45. #BuildRequires: ant
  46. Requires: jpackage-utils >= 1.5
  47. Obsoletes: xml-commons <= 1.3.02
  48. Provides: xml-commons = %{version}-%{release}
  49. Provides: jaxp = 1.3
  50. Provides: xml-commons-jaxp-1.3-apis = %{version}-%{release}
  51. %description
  52. xml-commons-apis is designed to organize and have common packaging for
  53. the various externally-defined standard interfaces for XML. This
  54. includes the DOM, SAX, and JAXP.
  55. %package manual
  56. Summary: Manual for %{name}
  57. Group: Applications/Documentation
  58. %description manual
  59. Manual for %{name}.
  60. # -----------------------------------------------------------------------------
  61. %prep
  62. %setup -q -n xml-commons-external-%{version}
  63. # -----------------------------------------------------------------------------
  64. %build
  65. # -----------------------------------------------------------------------------
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. # Jars
  69. mkdir -p $RPM_BUILD_ROOT%{_javadir}
  70. cp -p xml-apis.jar \
  71. $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
  72. cp -p xml-apis-ext.jar \
  73. $RPM_BUILD_ROOT%{_javadir}/%{name}-ext-%{version}.jar
  74. # Jar versioning
  75. (cd $RPM_BUILD_ROOT%{_javadir} && for jar in %{name}-%{version}.jar; do ln -sf ${jar} dom3-${jar}; done)
  76. (cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
  77. # for better interoperability with the jpp apis packages
  78. ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/jaxp13.jar
  79. ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/jaxp.jar
  80. ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/xml-commons-jaxp-1.3-apis.jar
  81. # -----------------------------------------------------------------------------
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. # -----------------------------------------------------------------------------
  85. %files
  86. %defattr(-,root,root,-)
  87. %doc LICENSE NOTICE
  88. %doc LICENSE.dom-documentation.txt README.dom.txt
  89. %doc LICENSE.dom-software.txt
  90. %doc LICENSE.sax.txt README.sax.txt
  91. %{_javadir}/*
  92. %files manual
  93. %defattr(-,root,root,-)
  94. %doc docs/*
  95. #files javadoc
  96. #defattr(-,root,root,-)
  97. #{_javadocdir}/*
  98. # -----------------------------------------------------------------------------
  99. %changelog
  100. * Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.04-1
  101. - Initial build for Vine Linux
  102. - used version 1.3.04
  103. * Sat Jan 9 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.4.01-1
  104. - Update to 1.4.01.
  105. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3.04-3.5
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  107. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3.04-2.5
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  109. * Fri Feb 6 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.04-1.5
  110. - Add osgi metadata to the ext jar too.
  111. * Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.04-1.4
  112. - Add osgi metadata.
  113. * Fri Sep 19 2008 Matt Wringe <mwringe@redhat.com> - 0:1.3.04-1.3
  114. - Remove natively compiled bits from the javadoc package (462809)
  115. * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.3.04-1.2
  116. - drop repotag
  117. - fix license tag
  118. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.3.04-1jpp.1
  119. - Autorebuild for GCC 4.3
  120. * Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:1.3.04-0jpp.1
  121. - Update to 1.3.04
  122. * Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:1.3.03-0jpp.1
  123. - Split xml-commons package up into 2 separate package: xml-commons-apis
  124. and xml-commons-which.
  125. * Mon Aug 21 2006 Fernando Nasser <fnasser@redhat.com> - 0:1.3.02-0.b2.7jpp.10
  126. - Add missing Requires for post and postun javadoc sections
  127. * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:1.3.02-0.b2.7jpp_9fc
  128. - Rebuilt
  129. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:1.3.02-0.b2.7jpp_8fc
  130. - rebuild
  131. * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:1.3.02-0.b2.7jpp_7fc
  132. - stop scriptlet spew
  133. * Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:1.3.02-0.b2.7jpp_6fc
  134. - Updated to 1.3
  135. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:1.0-0.b2.7jpp_5fc
  136. - bump again for double-long bug on ppc(64)
  137. * Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:1.0-0.b2.7jpp_4fc
  138. - rebuilt again
  139. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
  140. - rebuilt for new gcj
  141. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  142. - rebuilt
  143. * Fri Jul 15 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_3fc
  144. - Build on ia64, ppc64, s390 and s390x.
  145. - Switch to aot-compile-rpm (also BC-compiles the which jar).
  146. * Wed Jun 15 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_2fc
  147. - Remove all prebuilt stuff from the tarball.
  148. * Thu May 26 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_1fc
  149. - Upgrade to 1.0-0.b2.7jpp.
  150. - Remove now-unnecessary workaround for #130162.
  151. - Rearrange how BC-compiled stuff is built and installed.
  152. * Mon May 23 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_13fc
  153. - Add alpha to the list of build architectures (#157522).
  154. - Use absolute paths for rebuild-gcj-db.
  155. * Thu May 5 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_12fc
  156. - Add dependencies for %%post and %%postun scriptlets (#156901).
  157. * Tue May 3 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_11fc
  158. - BC-compile the API jar.
  159. * Tue Apr 26 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_10fc
  160. - Remove gcj endorsed dir support (#155693).
  161. * Mon Apr 25 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_9fc
  162. - Provide a default transformer when running under libgcj.
  163. * Mon Apr 25 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_8fc
  164. - Provide a default DOM builder when running under libgcj (#155693).
  165. * Fri Apr 22 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_7fc
  166. - Provide a default SAX parser when running under libgcj (#155693).
  167. * Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_6fc
  168. - Add gcj endorsed dir support.
  169. * Tue Jan 11 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_5fc
  170. - Sync with RHAPS.
  171. * Thu Nov 4 2004 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_4fc
  172. - Build into Fedora.
  173. * Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_3fc
  174. - Bootstrap into Fedora.
  175. * Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> - 0:1.0-0.b2.6jpp_3rh
  176. - add coreutils BuildRequires
  177. * Thu Mar 4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:1.0-0.b2.6jpp_2rh
  178. - RH vacuuming part II
  179. * Tue Mar 2 2004 Frank Ch. Eigler <fche@redhat.com> - 0:1.0-0.b2.6jpp_1rh
  180. - RH vacuuming
  181. * Thu Aug 26 2003 Ralph Apel <r.apel at r-apel.de> - 0:1.0-0.b2.7jpp
  182. - Build with ant-1.6.2
  183. * Mon May 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.0-0.b2.6jpp
  184. - Fix non-versioned javadoc symlinking.
  185. * Mon Apr 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.0-0.b2.5jpp
  186. - Fix xml-which script.
  187. - Include non-versioned javadoc symlinks.
  188. - Add Epoch: 0.
  189. - Fix jpackage-utils dependency versions.
  190. * Thu Mar 13 2003 Nicolas Mailhot <Nicolas.Mailhot at jpackage.org> - 1.0-0.b2.4jpp
  191. - For jpackage-utils 1.5
  192. * Wed Nov 13 2002 Ville Skyttä <ville.skytta at iki.fi> - 1.0-0.b2.3jpp
  193. - Following upstream changes, resolver is now built from its own package.
  194. * Sun Nov 3 2002 Ville Skyttä <ville.skytta at iki.fi> 1.0-0.b2.2jpp
  195. - Split resolver into its own subpackage.
  196. - Fix Group, Vendor and Distribution tags.
  197. - Use sed instead of bash 2 extension when symlinking jars.
  198. - Add resolver and which shell scripts.
  199. * Thu Jul 11 2002 Henri Gomez <hgomez@users.sourceforge.net> 1.0-0.b2.1jpp
  200. - 1.0.b2
  201. - get tarball from xml.apache.org
  202. - add macro section
  203. * Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.0-0.b1.1jpp
  204. - first jpp release