file-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define __libtoolize :
  4. Summary: A utility for determining file types.
  5. Summary(ja): ファイルの種類を判別するユーティリティー
  6. Name: file
  7. Version: 5.28
  8. Release: 1%{?_dist_release}
  9. License: BSD
  10. Group: Applications/System
  11. Obsoletes: file-static
  12. Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  13. # Addtional magic file for Vine
  14. Source10: magic.printer-j
  15. # Upstream says it's up to distributions to add a way to support local-magic.
  16. Patch0: file-localmagic.patch
  17. # sent upstream
  18. Patch1: file-5.10-strength.patch
  19. Patch3: file-4.17-rpm-name.patch
  20. Patch4: file-5.04-volume_key.patch
  21. Patch5: file-5.04-man-return-code.patch
  22. Patch6: file-5.04-generic-msdos.patch
  23. Patch7: file-5.14-x86boot.patch
  24. Patch8: file-5.14-perl.patch
  25. Patch14: file-5.19-cafebabe.patch
  26. Patch15: file-5.22-awk-perl.patch
  27. Patch17: file-5.24-varied.patch
  28. # https://github.com/file/file/pull/8
  29. Patch100: file-5.28-compress-sigsegv.patch
  30. # Vine
  31. Patch1000: file-5.14-magicbuild-fix.patch
  32. # Security
  33. # none
  34. Buildroot: %{_tmppath}/%{name}-%{version}-root
  35. #BuildRequires: automake
  36. #BuildRequires: autoconf
  37. BuildRequires: zlib-devel
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: daisuke
  41. %description
  42. The file command is used to identify a particular file according to the
  43. type of data contained by the file. File can identify many different
  44. file types, including ELF binaries, system libraries, RPM packages, and
  45. different graphics formats.
  46. You should install the file package, since the file command is such a
  47. useful utility.
  48. %description -l ja
  49. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  50. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  51. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  52. を含む、多くの異なるファイルの種類を見分けることができます。
  53. %package devel
  54. Summary: Libraries and header files for file development
  55. Summary(ja): libmagic の開発用ファイル
  56. Group: Development/Libraries
  57. Requires: %{name} = %{version}-%{release}
  58. %description devel
  59. The file-devel package contains the header files and libmagic library
  60. necessary for developing programs using libmagic.
  61. %package -n python-magic
  62. Summary: Python bindings for the libmagic API
  63. Group: Development/Libraries
  64. BuildRequires: python-devel python-setuptools
  65. Requires: %{name} = %{version}-%{release}
  66. %description -n python-magic
  67. This package contains the Python bindings to allow access to the
  68. libmagic API. The libmagic library is also used by the familiar
  69. file(1) command.
  70. %prep
  71. %setup -q
  72. # Don't use -b -- it will lead to problems when compiling magic file!
  73. %patch0 -p1
  74. %patch1 -p1
  75. %patch3 -p1
  76. %patch4 -p1
  77. %patch5 -p1
  78. %patch6 -p1
  79. %patch7 -p1
  80. %patch8 -p1
  81. %patch14 -p1
  82. %patch15 -p1
  83. %patch17 -p1
  84. %patch100 -p1
  85. # Vine
  86. %patch1000 -p1
  87. # Security
  88. # none
  89. cat %{SOURCE10} >> ./magic/Localstuff
  90. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  91. touch -r doc/libmagic.man doc/libmagic.man_
  92. mv doc/libmagic.man_ doc/libmagic.man
  93. %build
  94. autoreconf
  95. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  96. %configure --enable-fsect-man5 --disable-rpath
  97. # remove hardcoded library paths from local libtool
  98. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  99. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  100. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  101. make
  102. cd python
  103. CFLAGS="%{optflags}" %{__python} setup.py build
  104. %install
  105. rm -rf $RPM_BUILD_ROOT
  106. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  107. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  108. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  109. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  110. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  111. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  112. make install DESTDIR=$RPM_BUILD_ROOT
  113. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  114. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  115. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  116. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  117. cd python
  118. %{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT}
  119. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  120. # LIBTOOL=/usr/bin/libtool
  121. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  122. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  123. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  124. #{ cd ${RPM_BUILD_ROOT}
  125. # strip .%{_bindir}/file
  126. # cp %SOURCE1 .%{_datadir}/magic.mime
  127. #}
  128. # remove unuse files
  129. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  130. %clean
  131. rm -rf $RPM_BUILD_ROOT
  132. %post -p /sbin/ldconfig
  133. %postun -p /sbin/ldconfig
  134. %files
  135. %defattr(-,root,root)
  136. %doc COPYING ChangeLog README
  137. %{_bindir}/*
  138. %{_libdir}/libmagic.so.*
  139. %{_datadir}/file/*
  140. %{_datadir}/magic*
  141. %{_datadir}/misc/*
  142. %{_mandir}/man[15]/*
  143. %files devel
  144. %defattr(-,root,root,-)
  145. %{_libdir}/*.so
  146. %{_includedir}/magic.h
  147. %{_mandir}/man3/*
  148. %files -n python-magic
  149. %defattr(-, root, root, -)
  150. %doc python/README COPYING python/example.py
  151. %{python_sitelib}/magic.py
  152. %{python_sitelib}/magic.pyc
  153. %{python_sitelib}/magic.pyo
  154. %{python_sitelib}/*egg-info
  155. %changelog
  156. * Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
  157. - new upstream release.
  158. - dropped Patch200: fixed in upstream.
  159. - updated patches.
  160. - imported Patch15,17 and 100.
  161. * Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
  162. - new upstream release
  163. - update/drop patches based on fc22
  164. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
  165. - reflected 6.0 updates and bumped release
  166. * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
  167. - drop patch230 (moved to patch320)
  168. - add Patch240 for fix CVE-2014-0207
  169. - add Patch250 for fix CVE-2014-0237
  170. - add Patch260 for fix CVE-2014-0238
  171. - add Patch270 for fix CVE-2014-3478
  172. - add Patch280 for fix CVE-2014-3479
  173. - add Patch290 for fix CVE-2014-3480
  174. - add Patch300 for fix CVE-2014-3487
  175. - add Patch310 for fix CVE-2014-3538
  176. - add Patch320 for fix CVE-2014-3587
  177. These patches are from debian/ubuntu, thanks.
  178. * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
  179. - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
  180. * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
  181. - add patch110,220 for fix regression of CVE-2014-2270
  182. * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
  183. - add patch210 for fix CVE-2014-2270
  184. * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
  185. - add patch200 for fix CVE-2014-1943
  186. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
  187. - rebuild with VineSeed environment
  188. * Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
  189. - new upstream reelase
  190. - add patch100 to fix build error
  191. - remove -static subpackage and add Obs: file-static
  192. - fix old changelog date...
  193. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  194. - new upstream reelase
  195. - drop all local patches
  196. - import fedora patches
  197. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  198. - rebuild with python-2.7.2
  199. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  200. - rebuild package
  201. - fix Patch100
  202. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  203. - new upstream release
  204. - updated Vine patches (but Patch100 has not been ported yet...)
  205. - split to devel and static subpackcages
  206. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  207. - rebuilt with rpm-4.8.1
  208. - add environment variable LIBTOOL for make command
  209. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  210. - spec in utf-8
  211. - removed *.la
  212. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  213. - applied new versioning policy
  214. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  215. - new upstream release
  216. - import debian/fedora patches
  217. - drop obsolete vine magic.
  218. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  219. - rebuild for VineSeed with new tool chain
  220. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  221. - add patch110 for fix CVE-2007-2799
  222. - add zlib-devel to BuildPreReq tag
  223. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  224. - add patch100 for fix CVE-2007-1536
  225. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  226. - changed Group to Applications/System
  227. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  228. - new upstream release
  229. - update vine patches
  230. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  231. - update Patch10, use 'size_t' in src/jcode.[ch]
  232. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  233. - update to 4.03
  234. - update Patch0, 1, 10 for 4.03
  235. - s/Copyright/License/
  236. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  237. - update to 4.02
  238. - update Vine patches for 4.02
  239. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  240. - new upstream release
  241. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  242. - remove unneeded patches.
  243. - update Vine patches for 3.41
  244. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  245. - added NPDL2 data [Vine:02348]
  246. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  247. - update to 3.37
  248. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  249. - 3.35-0vl3
  250. - disable some entries in elf for problems on big-endian archs
  251. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  252. - file-3.35-0vl1
  253. - ver.up
  254. - added %doc
  255. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  256. - file-3.33-1vl4
  257. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  258. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  259. - file-3.33-1vl3
  260. - fix again jtext patch (file-3.33-vinejtext.patch)
  261. - added file-3.33-vinenames.patch to avoid miss-judgement
  262. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  263. - file-3.33-1vl2
  264. - update jtext patch (file-3.33-vinejtext.patch)
  265. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  266. - file-3.33-1vl1
  267. - modify description-ja and spec
  268. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  269. - file-3.28-2vl2
  270. - fixed %files section to handle compressed man pages
  271. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  272. - marged RH 3.28-2 and Vine 3.27-3vl3
  273. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  274. - add ia64 patch from rth
  275. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  276. - handle compressed manpages
  277. - update to 3.28
  278. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  279. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  280. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  281. - patch dues not apply bug.
  282. * Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  283. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  284. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  285. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  286. - identify ELF stripped files correctly (#4665).
  287. - use SPARC (not sparc) consistently throughout (#4665).
  288. - add entries for MS Office files (#4665).
  289. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  290. - diddle magic so that *.tfm files are identified correctly.
  291. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  292. - update to 3.27.
  293. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  294. - experimental support for realmedia files added
  295. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  296. - auto rebuild in the new build environment (release 5)
  297. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  298. - strip binary.
  299. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  300. - add SPARC V9 magic.
  301. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  302. - update to 3.26.
  303. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  304. - update to 3.25.
  305. - detect gimp XCF versions.
  306. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  307. - translations modified for de, fr, tr
  308. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  309. - updated to 3.24
  310. - buildrooted
  311. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  312. - built against glibc
  313. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  314. - Fixed problems caused by 64 bit time_t.
  315. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  316. - Improved recognition of Linux kernel images.