OpenImageIO-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. %global subname oiio
  2. Name: OpenImageIO
  3. Version: 1.8.17
  4. Release: 1%{?_dist_release}
  5. Summary: Library for reading and writing images
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: https://sites.google.com/site/openimageio/home
  9. Source0: https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
  10. # Images for test suite
  11. #Source1: oiio-images.tar.gz
  12. BuildRequires: cmake
  13. BuildRequires: txt2man
  14. BuildRequires: qt5-qtbase-devel
  15. BuildRequires: libboost-devel
  16. BuildRequires: libboost-python
  17. BuildRequires: libboost-filesystem
  18. BuildRequires: glew-devel
  19. BuildRequires: OpenEXR-devel ilmbase-devel
  20. BuildRequires: python-devel
  21. # BuildRequires: openssl-devel
  22. BuildRequires: libpng-devel libtiff-devel openjpeg-devel giflib-devel
  23. BuildRequires: libwebp-devel
  24. BuildRequires: Field3D-devel
  25. BuildRequires: hdf5-devel
  26. BuildRequires: zlib-devel
  27. BuildRequires: jasper-devel
  28. BuildRequires: LibRaw-devel
  29. BuildRequires: pugixml-devel
  30. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  31. # If an ABI incompatible update is done in one, the other also needs to be
  32. # rebuilt.
  33. BuildRequires: OpenColorIO-devel
  34. # We don't want to provide private python extension libs
  35. %{?filter_setup:
  36. %filter_provides_in %{python_sitearch}/.*\.so$
  37. %filter_setup
  38. }
  39. %description
  40. OpenImageIO is a library for reading and writing images, and a bunch of related
  41. classes, utilities, and applications. Main features include:
  42. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  43. writing 2D images that is format agnostic.
  44. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  45. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  46. PNM/PPM/PGM/PBM, Field3d.
  47. - An ImageCache class that transparently manages a cache so that it can access
  48. truly vast amounts of image data.
  49. %package -n python-%{name}
  50. Summary: Python 2 bindings for %{name}
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n python-%{name}
  53. Python bindings for %{name}.
  54. %package utils
  55. Summary: Command line utilities for %{name}
  56. Requires: %{name} = %{version}-%{release}
  57. %description utils
  58. Command-line tools to manipulate and get information on images using the
  59. %{name} library.
  60. %package iv
  61. Summary: %{name} based image viewer
  62. Requires: %{name} = %{version}-%{release}
  63. %description iv
  64. A really nice image viewer, iv, based on %{name} classes (and so will work
  65. with any formats for which plugins are available).
  66. %package devel
  67. Summary: Documentation for %{name}
  68. Group: Development/Libraries
  69. Requires: %{name} = %{version}-%{release}
  70. %description devel
  71. Development files for package %{name}
  72. %prep
  73. %setup -q -n oiio-Release-%{version}
  74. # Remove bundled pugixml
  75. %{__rm} -f src/include/pugixml.hpp \
  76. src/include/pugiconfig.hpp \
  77. src/libutil/pugixml.cpp
  78. # Remove bundled tbb
  79. %{__rm} -rf src/include/tbb
  80. # Install test images
  81. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  82. #tar --strip-components=1 -xzf %{SOURCE1}
  83. %build
  84. %{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
  85. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  86. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  87. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  88. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  89. -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
  90. -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
  91. -DINSTALL_DOCS:BOOL=FALSE \
  92. -DINSTALL_FONTS:BOOL=FALSE \
  93. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  94. -DUSE_TBB:BOOL=FALSE \
  95. -DUSE_OPENSSL:BOOL=TRUE \
  96. -DSTOP_ON_WARNING:BOOL=FALSE \
  97. -DUSE_CPP:STRING=14 \
  98. %ifarch ppc ppc64
  99. -DNOTHREADS:BOOL=FALSE \
  100. %endif
  101. -DJPEG_INCLUDE_DIR=%{_includedir} \
  102. -DVERBOSE=TRUE \
  103. ../../
  104. %{__make} %{?_smp_mflags}
  105. popd
  106. %install
  107. pushd build/linux
  108. %{make_install}
  109. popd
  110. # # Move man pages to the right directory
  111. # mkdir -p %{buildroot}%{_mandir}/man1
  112. # cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  113. %post -p %{_syssbindir}/ldconfig
  114. %postun -p %{_syssbindir}/ldconfig
  115. %files
  116. %doc CHANGES.md CONTRIBUTING.md README.md LICENSE
  117. %{_libdir}/libOpenImageIO.so.*
  118. %{_libdir}/libOpenImageIO_Util.so.*
  119. %files -n python-%{name}
  120. %{python_sitearch}/OpenImageIO.so
  121. %files utils
  122. %exclude %{_bindir}/iv
  123. %{_bindir}/*
  124. # %exclude %{_mandir}/man1/iv.1.gz
  125. # %{_mandir}/man1/*.1.gz
  126. %files iv
  127. %{_bindir}/iv
  128. # %{_mandir}/man1/iv.1.gz
  129. %files devel
  130. %doc src/doc/*.pdf
  131. %{_libdir}/libOpenImageIO.so
  132. %{_libdir}/libOpenImageIO_Util.so
  133. %{_includedir}/*
  134. %changelog
  135. * Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
  136. - update to 1.8.17
  137. * Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
  138. - update to 1.8.16
  139. - change BuildRequires: qt4-devel to qt5-qtbase-devel
  140. - drop BuildRequires: openssl-devel
  141. * Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
  142. - update to 1.7.19
  143. - using macro
  144. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
  145. - rebuild with hdf5-1.8.20
  146. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
  147. - update to 1.7.17
  148. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  149. - rebuilt with LibRaw-0.17.2.
  150. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  151. - rebuild with gcc-5.4.0
  152. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  153. - new upstream release
  154. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  155. - new upstream release
  156. - remove Patch0
  157. - create python-%%{name} subpackage
  158. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  159. - rebuild with glew-1.13.0
  160. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  161. - initial build for Vine Linux
  162. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  163. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  164. - rebuild (openexr)
  165. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  166. - Update to latest upstream release.
  167. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  168. - Update to latest upstream release.
  169. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  170. - Rebuild for Field3D 1.4.3.
  171. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  172. - Rebuild for pugixml 1.4
  173. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  175. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  176. - Update to latest upstream release.
  177. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  179. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  180. - Rebuild for boost 1.55.0
  181. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  182. - rebuild for boost 1.55.0
  183. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  184. - Update to latest upstream release.
  185. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  186. - Update to latest upstream release.
  187. - Add libgif as build requirement.
  188. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  189. - rebuild (openexr)
  190. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  191. - rebuilt for GLEW 1.10
  192. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  193. - Update to latest upstream release.
  194. - Fix ppc builds (BZ#1021977).
  195. - Add conditionals to build requirements for EPEL 6.
  196. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  197. - Update to latest upstream release.
  198. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  199. - rebuild (ilmbase/openexr)
  200. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  201. - Update to latest upstream release.
  202. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  204. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  205. - Rebuild for boost 1.54.0