curl-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.66.0
  9. Release: 1%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: http://curl.haxx.se/
  13. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # avoid reporting spurious error in the HTTP2 framing layer (#1690971)
  15. Patch2: 0002-curl-7.65.3-h2-framing-layer-error.patch
  16. # patch making libcurl multilib ready
  17. Patch101: 0101-curl-7.32.0-multilib.patch
  18. # prevent configure script from discarding -g in CFLAGS (#496778)
  19. Patch102: 0102-curl-7.36.0-debug.patch
  20. # migrate tests/http_pipe.py to Python 3
  21. Patch103: 0103-curl-7.59.0-python3.patch
  22. # use localhost6 instead of ip6-localhost in the curl test-suite
  23. Patch104: 0104-curl-7.19.7-localhost6.patch
  24. # prevent valgrind from reporting false positives on x86_64
  25. Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: openssl-devel
  28. BuildRequires: gnutls-devel
  29. BuildRequires: libidn-devel zlib-devel
  30. BuildRequires: openldap-devel
  31. BuildRequires: openssh-server
  32. BuildRequires: openssh-clients
  33. BuildRequires: pkgconfig
  34. %if "%{?_dist_release}" != "vl6"
  35. BuildRequires: libssh2-devel
  36. %endif
  37. %if 0%{?with_http2}
  38. BuildRequires: libnghttp2-devel
  39. %endif
  40. Requires: ca-certificates
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. Packager: daisuke
  44. %description
  45. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  46. Dict servers, using any of the supported protocols. cURL is designed
  47. to work without user interaction or any kind of interactivity. cURL
  48. offers many useful capabilities, like proxy support, user
  49. authentication, FTP upload, HTTP post, and file transfer resume.
  50. %package devel
  51. Summary: Files needed for building applications with libcurl.
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: openssl-devel libidn-devel zlib-devel
  55. %description devel
  56. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  57. Dict servers, using any of the supported protocols. The curl-devel
  58. package includes files needed for developing applications which can
  59. use cURL's capabilities internally.
  60. #'
  61. ## to build compat32 for x86_64 architecture support
  62. %package -n compat32-%{name}
  63. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  64. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  65. Group: System Environment/Libraries
  66. %description -n compat32-%{name}
  67. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  68. Dict servers, using any of the supported protocols. cURL is designed
  69. to work without user interaction or any kind of interactivity. cURL
  70. offers many useful capabilities, like proxy support, user
  71. authentication, FTP upload, HTTP post, and file transfer resume.
  72. %package -n compat32-%{name}-devel
  73. Summary: Files needed for building applications with libcurl.
  74. Group: Development/Libraries
  75. %description -n compat32-%{name}-devel
  76. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  77. Dict servers, using any of the supported protocols. The curl-devel
  78. package includes files needed for developing applications which can
  79. use cURL's capabilities internally.
  80. #'
  81. %prep
  82. %setup -q
  83. # upstream patches
  84. # Fedora patches
  85. %patch101 -p1
  86. %patch102 -p1
  87. #patch103 -p1
  88. %patch104 -p1
  89. %patch105 -p1
  90. # make tests/*.py use Python 3
  91. sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
  92. # regenerate Makefile.in files
  93. aclocal -I m4
  94. automake
  95. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  96. # with errno 98: Address already in use' in Koji environment), and test 1801
  97. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  98. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  99. # <https://github.com/curl/curl/pull/2705>
  100. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  101. # disable test 1319 on ppc64 (server times out)
  102. %ifarch ppc64
  103. echo "1319" >> tests/data/DISABLED
  104. %endif
  105. # temporarily disable test 582 on s390x (client times out)
  106. %ifarch s390x
  107. echo "582" >> tests/data/DISABLED
  108. %endif
  109. # adapt test 323 for updated OpenSSL
  110. sed -e 's/^35$/35,52/' -i tests/data/test323
  111. %build
  112. %configure \
  113. --with-ssl=%{_prefix} \
  114. --with-libidn \
  115. --enable-ipv6 \
  116. --enable-threaded-resolver \
  117. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  118. %if "%{?_dist_release}" != "vl6"
  119. --with-libssh2 \
  120. %endif
  121. %if 0%{?with_http2}
  122. --with-nghttp2 \
  123. %endif
  124. --enable-ldaps \
  125. --disable-static \
  126. --enable-hidden-symbols
  127. make %{?_smp_mflags}
  128. %install
  129. rm -rf $RPM_BUILD_ROOT
  130. make DESTDIR=$RPM_BUILD_ROOT install
  131. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  132. %clean
  133. rm -rf $RPM_BUILD_ROOT
  134. %post -p /sbin/ldconfig
  135. %postun -p /sbin/ldconfig
  136. %files
  137. %defattr(-,root,root)
  138. %{!?_licensedir:%global license %%doc}
  139. %license COPYING
  140. %doc CHANGES README
  141. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  142. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  143. %doc docs/TheArtOfHttpScripting docs/TODO
  144. %{_bindir}/curl
  145. #{_datadir}/curl/*
  146. %{_libdir}/*.so.*
  147. %{_mandir}/man1/*.1*
  148. %files devel
  149. %defattr(-,root,root)
  150. %{_bindir}/curl-config
  151. %{_includedir}/curl
  152. %{_libdir}/*.so
  153. %{_libdir}/pkgconfig/*.pc
  154. %{_mandir}/man1/curl-config.1*
  155. %{_mandir}/man3/*
  156. %{_datadir}/aclocal/libcurl.m4
  157. ## to build compat32 for x86_64 architecture support
  158. %if %{build_compat32}
  159. %files -n compat32-%{name}
  160. %defattr(-,root,root)
  161. %{_libdir}/*.so.*
  162. %files -n compat32-%{name}-devel
  163. %defattr(-,root,root)
  164. %{_libdir}/*.so
  165. %{_libdir}/pkgconfig/*.pc
  166. %endif
  167. %changelog
  168. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
  169. - new upstream release.
  170. - dropped Patch1 and 2: fixed in upstream.
  171. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
  172. - new upstream release.
  173. - updated patches.
  174. - imported Patch1, 2 and 105 from rawhide.
  175. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  176. - new upstream release.
  177. - imported patches from rawhide.
  178. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  179. - new upstream release.
  180. - imported Patch1 and 103 from rawhide.
  181. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  182. - new upstream release with security fix
  183. - update patch101
  184. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  185. - new upstream release.
  186. - updated Patch101-104.
  187. - dropped Patch107.
  188. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  189. - new upstream release.
  190. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  191. - new upstream release.
  192. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  193. - new upstream release.
  194. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  195. - new upstream release.
  196. - disabled HTTP/2 on Vine6.
  197. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  198. - added HTTP/2 support.
  199. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  200. - new upstream release with security fix.
  201. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  202. - new upstream release.
  203. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  204. - new upstream release
  205. - built with openssl 1.0.2g
  206. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  207. - new upstream release with security fix .
  208. - removed Patch108 (fixed in upstream).
  209. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  210. - new upstream release with security fix
  211. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  212. - new upstream release
  213. - add libcurl.m4 to -devel package
  214. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  215. - new upstream release
  216. - import upstream/fedora patches
  217. - disable libssh2 on Vine Linux 6
  218. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  219. - new upstream reelase
  220. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  221. - update to 7.28.0
  222. - add configure options
  223. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  224. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  225. - use ca-certificates package
  226. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  227. - R: ca-certificates
  228. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  229. - new upstream release
  230. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  231. - add patch100 for fix CVE-2011-2192 (gssapi)
  232. - add Vendor/Distri tags
  233. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  234. - rebuild with openssl-1.0.0c
  235. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  236. - rebuilt with rpm-4.8.1 for pkg-config
  237. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  238. - new upstream release
  239. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  240. - new upstream release with security fix
  241. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  242. - added compat32 subpackages
  243. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  244. - new upstream release
  245. - use "_smp_mflags" flag
  246. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  247. - rebuild with openldap-2.4.11
  248. - add BR: openldap-devel
  249. - remove static library
  250. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  251. - new upstream release with security fix (CVE-2009-0037)
  252. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  253. - new upstream release
  254. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  255. - new upstream release
  256. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  257. - new upstream release
  258. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  259. - new upstream release
  260. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  261. - new upstream release
  262. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  263. - rebuilt with openssl-0.9.8e
  264. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  265. - new upstream release
  266. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  267. - new upstream release
  268. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  269. - new upstream release
  270. - add pkgconfig file to devel package
  271. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  272. - new upstream release
  273. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  274. - new upstream release
  275. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  276. - new upstream release
  277. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  278. - added libidn, zlib in Requires
  279. - added libidn-devel, zlib-devel in BuildPrereq
  280. - added zlib-devel in curl-devel's Requires
  281. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  282. - added openssl-devel, libidn-devel in curl-devel's Requires
  283. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  284. - new upstream release
  285. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  286. - new upstream release
  287. - rebuild with openssl-0.9.7d
  288. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  289. - upstream release
  290. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  291. - add %%{_datadir}/curl/* to %%files section
  292. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  293. - source upgrade
  294. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  295. - source upgrade
  296. - add PreReq: ldconfig
  297. - add %%{_libdir}/*.la to %%files devel section
  298. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  299. - build for VineSeed
  300. - add Requires: openssl
  301. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  302. - automated rebuild
  303. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  304. - 7.9.2
  305. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  306. - include curl-config in curl-devel
  307. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  308. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  309. - added openssl-devel build req
  310. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  311. - built for the distro
  312. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  313. - upgrade to curl-7.7.2.
  314. - enable IPv6.
  315. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  316. - rebuilt against openssl-0.9.6-1
  317. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  318. - fixed mising ldconfigs
  319. - updated to 7.5.2, bug fixes
  320. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  321. - updated to 7.5.1
  322. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  323. - update to 7.4.1 to fix bug #20337, problems with curl -c
  324. - not using patch anymore, it's included in the new source. Keeping
  325. for reference
  326. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  327. - fix bogus req in -devel package
  328. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  329. - devel package needed defattr so that root owns the files
  330. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  331. - update to 7.3
  332. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  333. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  334. - enable SSL support
  335. - fix packager tag
  336. - move buildroot to %%{_tmppath}
  337. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  338. - fixed vendor tag for bug #15028
  339. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  340. - rebuilt
  341. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  342. - workaround alpha build problems with optimizations
  343. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  344. - rebuilt
  345. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  346. - put man pages in correct place
  347. - use %%makeinstall
  348. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  349. - updated to 6.5.2
  350. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  351. - updated sources to 6.2
  352. - gzip man page
  353. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  354. - changed group
  355. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  356. - changelog started
  357. - general cleanups, changed prefix to /usr, added manpage to files section
  358. - including in Powertools