octave-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363
  1. %define pkg_name octave
  2. %define pkg_version 5.1.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: GNU Octave -- a high-level language for numerical computations
  5. Summary(ja): 数値計算のための高級言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv3
  10. Group: Applications/Edutainment
  11. URL: http://www.gnu.org/software/octave/
  12. Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
  13. Buildroot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gcc-gfortran
  15. BuildRequires: bison flex gperf texinfo less
  16. BuildRequires: gnuplot
  17. BuildRequires: ghostscript-devel
  18. BuildRequires: mesa-libOSMesa-devel
  19. BuildRequires: blas-devel lapack-devel
  20. BuildRequires: pcre-devel
  21. BuildRequires: readline-devel
  22. %if %{?_dist_release} == "vl6"
  23. BuildRequires: arpack
  24. %endif
  25. %if %{?_dist_release} >= "vl7"
  26. BuildRequires: arpack-devel
  27. %endif
  28. BuildRequires: curl-devel
  29. BuildRequires: fftw3-devel
  30. BuildRequires: fontconfig-devel
  31. BuildRequires: freetype-devel
  32. BuildRequires: glpk-devel
  33. BuildRequires: GraphicsMagick-c++-devel
  34. BuildRequires: hdf5-devel
  35. BuildRequires: java-devel
  36. BuildRequires: qhull-devel
  37. BuildRequires: qrupdate
  38. BuildRequires: suitesparse-devel
  39. BuildRequires: zlib-devel
  40. BuildRequires: xz-devel
  41. BuildRequires: libtool-ltdl-devel
  42. BuildRequires: libXext-devel
  43. BuildRequires: openssl-devel
  44. BuildRequires: desktop-file-utils
  45. BuildRequires: freeglut-devel
  46. BuildRequires: fltk-devel
  47. BuildRequires: gl2ps-devel
  48. %if %{?_dist_release} == "vl6"
  49. BuildRequires: qt4-devel
  50. BuildRequires: qscintilla-devel
  51. %endif
  52. %if %{?_dist_release} >= "vl7"
  53. BuildRequires: qt5-qtbase-devel
  54. BuildRequires: qt5-qttools-devel
  55. %endif
  56. BuildRequires: portaudio-devel
  57. BuildRequires: libsndfile-devel
  58. BuildRequires: lzip
  59. Requires: ghostscript
  60. Requires: blas lapack
  61. Requires: pcre
  62. Requires: readline
  63. Requires: mesa-libOSMesa
  64. Requires: gnuplot
  65. Requires: arpack
  66. Requires: curl
  67. Requires: fftw3
  68. Requires: fontconfig
  69. Requires: freetype
  70. Requires: glpk
  71. Requires: GraphicsMagick-c++
  72. Requires: hdf5
  73. Requires: libqhull
  74. Requires: qrupdate
  75. Requires: suitesparse
  76. Requires: zlib
  77. Requires: openssl
  78. Requires: pstoedit epstool transfig
  79. Requires: freeglut
  80. Requires: fltk
  81. Requires: gl2ps
  82. %if %{?_dist_release} == "vl6"
  83. Requires: qt4
  84. Requires: qscintilla
  85. %endif
  86. %if %{?_dist_release} >= "vl7"
  87. Requires: qt5-qtbase
  88. Requires: qt5-qttools-libs-help
  89. %endif
  90. Requires: portaudio
  91. Requires: libsndfile
  92. Requires(post): /sbin/install-info
  93. Requires(postun): /sbin/ldconfig
  94. Requires(post): /sbin/ldconfig
  95. Requires(preun): /sbin/install-info
  96. Vendor: Project Vine
  97. Distribution: Vine Linux
  98. Packager: ara_t
  99. %description
  100. GNU Octave is a high-level language, primarily intended for numerical
  101. computations. It provides a convenient command line interface for
  102. solving linear and nonlinear problems numerically, and for performing
  103. other numerical experiments using a language that is mostly compatible
  104. with Matlab. It may also be used as a batch-oriented language.
  105. Octave has extensive tools for solving common numerical linear algebra
  106. problems, finding the roots of nonlinear equations, integrating
  107. ordinary functions, manipulating polynomials, and integrating ordinary
  108. differential and differential-algebraic equations. It is easily
  109. extensible and customizable via user-defined functions written in
  110. Octave's own language, or using dynamically loaded modules written in
  111. C++, C, Fortran, or other languages.
  112. # '
  113. %description -l ja
  114. GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
  115. 問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
  116. を行うための使いやすいコマンドライン・インタフェースを備えています。
  117. バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
  118. 一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
  119. 行うことができます。
  120. Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
  121. 書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
  122. (注意)
  123. デフォルトではグラフの描画にOpenGL/fltkを使用してます。
  124. もし不安定な場合には、
  125. gnuplotをデフォルトとするために ~/.octaverc に
  126. graphics_toolkit("gnuplot");
  127. を追加してから起動して下さい。
  128. %prep
  129. %{__rm} -rf ${RPM_BUILD_ROOT}
  130. %setup -q
  131. %build
  132. %{configure} \
  133. CPPFLAGS="-I%{_includedir}/pcre" \
  134. --with-x \
  135. --with-magick=GraphicsMagick \
  136. --with-curl-includedir=%{_includedir}/curl \
  137. --with-glpk-includedir=%{_includedir}/glpk \
  138. --with-qhull-includedir=%{_includedir}/libqhull \
  139. --with-amd-includedir=%{_includedir}/suitesparse \
  140. --with-camd-includedir=%{_includedir}/suitesparse \
  141. --with-colamd-includedir=%{_includedir}/suitesparse \
  142. --with-ccolamd-includedir=%{_includedir}/suitesparse \
  143. --with-cholmod-includedir=%{_includedir}/suitesparse \
  144. --with-cxsparse-includedir=%{_includedir}/suitesparse \
  145. --with-umfpack-includedir=%{_includedir}/suitesparse \
  146. --enable-java \
  147. --with-qt=5
  148. %{__make} %{?_smp_mflags}
  149. %install
  150. %{make_install}
  151. find %{buildroot} -name "*.oct" | xargs strip
  152. # Make library links
  153. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  154. echo "%{_libdir}/octave-%{version}" > \
  155. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
  156. # desktop file
  157. %{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
  158. ${RPM_BUILD_ROOT}%{_datadir}/applications/org.octave.Octave.desktop
  159. %check
  160. %{__make} %{?_smp_mflags} check
  161. %clean
  162. %{__rm} -rf ${RPM_BUILD_ROOT}
  163. %post -p %{_syssbindir}/ldconfig
  164. %postun -p %{_syssbindir}/ldconfig
  165. %files
  166. %defattr(-,root,root)
  167. %doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
  168. %doc examples doc/interpreter/octave.pdf doc/refcard
  169. %config(noreplace) /etc/ld.so.conf.d/
  170. %{_bindir}/
  171. %{_libdir}/octave
  172. %{_libdir}/pkgconfig/*.pc
  173. %{_includedir}/octave-%{version}
  174. %{_datadir}/applications/
  175. %{_datadir}/icons/
  176. %{_datadir}/metainfo/
  177. %{_datadir}/octave
  178. %{_libexecdir}/octave
  179. %changelog
  180. * Sun Apr 21 2019 Toshiaki Ara <ara_t@384.jp> 5.1.0-1
  181. - update to 5.1.0
  182. - drop gui/sound option
  183. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 4.4.1-3
  184. - rebuild with gfortran-8.2.0
  185. * Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 4.4.1-2
  186. - rebuild with qhull-2015.2
  187. * Thu Aug 30 2018 Toshiaki Ara <ara_t@384.jp> 4.4.1-1
  188. - update to 4.4.1
  189. * Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-4
  190. - using qt5 for VineSeed
  191. - add configure option: --with-qt=5
  192. - add BuildRequires: qt5-qtbase-devel and qt5-qttools-devel
  193. - add Requires: qt5-qtbase and qt5-qttools-libs-help
  194. * Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-3
  195. - rebuild with hdf5-1.8.20 for VineSeed
  196. * Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-2
  197. - add BuildRequires: arpack-devel for VineSeed
  198. * Sun May 20 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-1
  199. - update to 4.4.0
  200. - correct License
  201. * Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
  202. - update to 4.2.2
  203. * Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
  204. - rebuild under glpk-4.63
  205. * Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
  206. - update to 4.2.1
  207. * Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
  208. - update to 4.2.0
  209. - add make check
  210. - add BuildRequires: lzip
  211. - change BuildRequires: java-devel
  212. * Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
  213. - update to 4.0.3
  214. - change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
  215. * Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
  216. - update to 4.0.2
  217. - add BuildRequires: openssl-devel
  218. - add Requires: openssl
  219. * Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
  220. - update to 4.0.1
  221. - change dependencies
  222. * Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
  223. - [BTS:0002801] add configure option --with-magick=Magick
  224. - delete BuildRequires: texlive-collection-texinfo
  225. - add BuildRequires: texlive-collection-plainextra
  226. - add BuildRequires: texlive-collection-latexextra
  227. - add BuildRequires: texlive-collection-fontsrecommended
  228. - for VineSeed
  229. * Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
  230. - update to 3.6.4
  231. - add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
  232. * Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
  233. - delete octave from menu (programming)
  234. * Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
  235. - update to 3.6.2
  236. - correct spec file for version 3.6.2
  237. - add BuildRequires: pcre-devel fltk-devel
  238. - add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
  239. - add BuildRequires: gcc-gfortran
  240. - add BuildRequires: texlive texlive-common texlive-collection-basic
  241. - add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
  242. - chanfe Group to Applications/Edutainment
  243. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  244. - update to 3.0.2
  245. - applied new versioning policy, spec in utf-8
  246. * Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
  247. - update to 3.0.0
  248. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
  249. - rebuilt for VineSeed
  250. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
  251. - update to 2.9.13
  252. - rebuilt with new toolchain and environment
  253. * Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  254. - update to 2.0.17
  255. - rebuild with new toolchains
  256. - add BuildRequires: gcc295, gcc295-c++
  257. * Sun Mar 3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
  258. - ver.up
  259. * Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
  260. - build for Vine Linux 2.1
  261. * Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
  262. - automatically added BuildRequires
  263. * Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
  264. - Macros, BM, add multiple icons sizes
  265. * Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
  266. - strip oct file
  267. - add menu entry
  268. * Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
  269. - corrected for new groups
  270. * Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
  271. - mandrake build
  272. - v2.0.16
  273. * Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
  274. - update to 2.0.13.90
  275. * Thu Jul 9 1998 Jeff Johnson <jbj@redhat.com>
  276. - repackage in powertools.
  277. * Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
  278. - Add %attr, build as user.
  279. * Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
  280. - Add BuildRoot, installinfo, require gnuplot, description from
  281. Octave's web page, update to Octave 2.0.13.
  282. - Adapt from existing spec file.
  283. * Tue Dec 2 1997 Otto Hammersmith <otto@redhat.com>
  284. - removed libreadline stuff from the file list
  285. * Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
  286. - changed configure command to put things in $RPM_ARCH-rehat-linux,
  287. rather than genereated one... was causing problems between building
  288. on i686 build machine.
  289. * Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
  290. - moved buildroot from /tmp to /var/tmp
  291. * Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
  292. - Upgraded to version 2.0.9 and built for glibc system
  293. * Thu May 01 1997 Michael Fulbright <msf@redhat.com>
  294. - Updated to version 2.0.5 and changed to build using a BuildRoot