subversion-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581
  1. %define neon_version 0.30.2
  2. %define swig_version 3.0.0
  3. %define apache_version 2.4
  4. %define apache_dir /usr
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.10.4
  12. Release: 1%{?_dist_release}
  13. License: ASL 2.0
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: iwaim, daisuke
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch1: subversion-1.10.0-rpath.patch
  24. Patch2: subversion-1.10.0-pie.patch
  25. Patch4: subversion-1.8.0-rubybind.patch
  26. Patch5: subversion-1.8.5-swigplWall.patch
  27. BuildRequires: apache2-devel >= %{apache_version}
  28. BuildRequires: apr-devel, apr-util-devel
  29. BuildRequires: autoconf >= 2.53
  30. BuildRequires: libdb-devel
  31. BuildRequires: expat-devel
  32. BuildRequires: gdbm-devel
  33. BuildRequires: libtool >= 1.4.2
  34. BuildRequires: neon-devel >= %{neon_version}
  35. BuildRequires: openssl-devel
  36. BuildRequires: python
  37. BuildRequires: python-devel
  38. BuildRequires: swig >= %{swig_version}
  39. BuildRequires: texinfo
  40. BuildRequires: zlib-devel
  41. BuildRequires: lz4-devel
  42. BuildRequires: utf8proc-devel
  43. BuildRequires: openldap-devel
  44. BuildRequires: ruby >= 2.2.3
  45. BuildRequires: ruby-devel >= 2.2.3
  46. BuildRequires: perl >= 2:5.26.2
  47. BuildRequires: sqlite3-devel
  48. BuildRequires: krb5-devel
  49. BuildRequires: keyutils-libs-devel
  50. BuildRequires: dbus-devel
  51. BuildRequires: libsecret-devel
  52. BuildRequires: libserf-devel
  53. BuildRequires: libxcrypt-devel
  54. BuildRequires: libnsl2-devel
  55. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  56. %define __perllib_requires %{SOURCE3}
  57. %description
  58. Subversion is a concurrent version control system which enables one
  59. or more users to collaborate in developing and maintaining a
  60. hierarchy of files and directories while keeping a history of all
  61. changes. Subversion only stores the differences between versions,
  62. instead of every complete file. Subversion is intended to be a
  63. compelling replacement for CVS.
  64. %package devel
  65. Group: Development/Libraries
  66. Summary: Development package for Subversion developers.
  67. Requires: subversion = %{version}-%{release}
  68. Requires: apr-devel, apr-util-devel
  69. %description devel
  70. The subversion-devel package includes the static libraries and include files
  71. for developers interacting with the subversion package.
  72. %package mod_dav_svn
  73. Group: System Environment/Daemons
  74. Summary: Apache server module for Subversion server.
  75. Requires: apache2 >= %{apache_version}
  76. Requires: subversion = %{version}-%{release}
  77. %description mod_dav_svn
  78. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  79. the Apache directories and configuration.
  80. %package tools
  81. Group: Development/Tools
  82. Summary: Tools for Subversion
  83. BuildRequires: perl >= 5.8.0
  84. Requires: perl >= 5.8.0
  85. Requires: subversion = %{version}-%{release}
  86. %description tools
  87. Tools for Subversion.
  88. %package perl
  89. Group: Development/Libraries
  90. Summary: Perl bindings to the Subversion libraries
  91. Requires: subversion = %{version}-%{release}
  92. Requires: perl >= 5.8.0
  93. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  94. %description perl
  95. This package includes the Perl bindings to the Subversion libraries.
  96. %package ruby
  97. Group: Development/Libraries
  98. Summary: Ruby bindings to the Subversion libraries
  99. Requires: subversion = %{version}-%{release}
  100. Requires: ruby >= 2.0
  101. %description ruby
  102. This package includes the Ruby bindings to the Subversion libraries.
  103. %package python
  104. Group: Development/Libraries
  105. Summary: Python bindings to the Subversion libraries
  106. Requires: subversion = %{version}-%{release}, python
  107. %description python
  108. This package includes the Python bindings to the Subversion libraries.
  109. %prep
  110. %setup -q
  111. %patch1 -p1 -b .rpath
  112. %patch2 -p1 -b .pie
  113. %patch4 -p1 -b .rubybind
  114. %patch5 -p1 -b .swigplWall
  115. %build
  116. # Regenerate the buildsystem, so that:
  117. # 1) patches applied to configure.in take effect
  118. # 2) the swig bindings are regenerated using the system swig
  119. # (2) is not ideal since typically upstream test with a different
  120. # swig version
  121. # This PATH order makes the fugly test for libtoolize work...
  122. mv build-outputs.mk build-outputs.mk.old
  123. #export PYTHON=%{__python3}
  124. PATH=/usr/bin:$PATH ./autogen.sh --release
  125. # fix shebang lines, #111498
  126. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  127. # override weird -shrext from ruby
  128. export svn_cv_ruby_link="%{__cc} -shared"
  129. export svn_cv_ruby_sitedir_libsuffix=""
  130. export svn_cv_ruby_sitedir_archsuffix=""
  131. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  132. export LIBTOOL=/usr/bin/libtool
  133. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  134. --with-swig --with-serf=%{_prefix} \
  135. --with-ruby-sitedir=%{rarchdir} \
  136. --with-apxs=%{_bindir}/apxs \
  137. --disable-mod-activation \
  138. --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
  139. --with-gnome-keyring \
  140. --with-berkeley-db \
  141. --disable-mod-activation \
  142. --disable-static
  143. make %{?_smp_mflags} all tools
  144. make swig-py swig-py-lib %{swigdirs}
  145. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  146. %install
  147. echo %{rarchdir}
  148. rm -rf $RPM_BUILD_ROOT
  149. make install \
  150. install-swig-py \
  151. install-swig-pl-lib \
  152. install-swig-rb \
  153. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  154. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  155. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  156. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  157. install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
  158. # Add subversion.conf configuration file into apache2/conf.d directory.
  159. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  160. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  161. # Remove unpackaged files
  162. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  163. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  164. $RPM_BUILD_ROOT%{_libdir}/*.la
  165. # The SVN build system is broken w.r.t. DSO support; it treats
  166. # normal libraries as DSOs and puts them in $libdir, whereas they
  167. # should go in some subdir somewhere, and be linked using -module,
  168. # etc. So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
  169. # since nothing should ever link against them directly.
  170. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
  171. # remove stuff produced with Perl modules
  172. find $RPM_BUILD_ROOT -type f \
  173. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  174. -print0 | xargs -0 rm -f
  175. # make Perl modules writable so they get stripped
  176. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  177. xargs -0 chmod 755
  178. # unnecessary libraries for swig bindings
  179. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  180. # Remove unnecessary ruby libraries
  181. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  182. # Trim what goes in docdir
  183. rm -rf tools/*/*.in tools/test-scripts
  184. # Rename authz_svn INSTALL doc for docdir
  185. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  186. # Install bash completion
  187. install -Dpm 644 tools/client-side/bash_completion \
  188. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
  189. for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
  190. ln -s svn \
  191. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
  192. done
  193. # Install tools ex diff*
  194. make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
  195. rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
  196. for f in svn-populate-node-origins-index \
  197. svnauthz-validate svnmucc svnraisetreeconflict; do
  198. echo %{_bindir}/$f
  199. done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
  200. %find_lang %{name}
  201. cat %{name}.lang exclude.tools.files >> %{name}.files
  202. %clean
  203. rm -rf $RPM_BUILD_ROOT
  204. %post -p /sbin/ldconfig
  205. %postun -p /sbin/ldconfig
  206. %post perl -p /sbin/ldconfig
  207. %postun perl -p /sbin/ldconfig
  208. %post ruby -p /sbin/ldconfig
  209. %postun ruby -p /sbin/ldconfig
  210. %post python -p /sbin/ldconfig
  211. %postun python -p /sbin/ldconfig
  212. %post tools -p /sbin/ldconfig
  213. %postun tools -p /sbin/ldconfig
  214. %files
  215. %defattr(-,root,root)
  216. %license LICENSE subversion/LICENSE
  217. %doc BUGS CHANGES COMMITTERS NOTICE INSTALL README
  218. %{_bindir}/*
  219. %{_libdir}/libsvn_*.so.*
  220. %{_localedir}/*/*/subversion.mo
  221. %{_mandir}/man*/*
  222. %{_datadir}/bash-completion/completions/*
  223. %dir %{_sysconfdir}/subversion
  224. %exclude %{_mandir}/man*/*::*
  225. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  226. %exclude %{_libdir}/libsvn_swig_py*.so.*
  227. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  228. %files devel
  229. %defattr(-,root,root)
  230. %{_includedir}/subversion-1
  231. %{_libdir}/libsvn*.so
  232. %exclude %{_libdir}/libsvn_swig_perl*
  233. %exclude %{_libdir}/libsvn_swig_py*
  234. %exclude %{_libdir}/libsvn_swig_ruby*
  235. %{_datadir}/pkgconfig/*
  236. %files mod_dav_svn
  237. %defattr(-,root,root)
  238. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  239. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  240. %files tools -f tools.files
  241. %defattr(-,root,root)
  242. %files perl
  243. %defattr(-,root,root,-)
  244. %{perl_vendorarch}/auto/SVN
  245. %{perl_vendorarch}/SVN
  246. %{_libdir}/libsvn_swig_perl*
  247. %{_mandir}/man*/*::*
  248. %files ruby
  249. %defattr(-,root,root,-)
  250. %{_libdir}/libsvn_swig_ruby*
  251. %{rarchdir}/svn
  252. %files python
  253. %defattr(-,root,root,-)
  254. %{_libdir}/libsvn_swig_py*
  255. %{python_sitearch}/libsvn
  256. %{python_sitearch}/svn
  257. %changelog
  258. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  259. - new upstream release.
  260. - rebuilt with perl-5.26.
  261. - dropped BR:libgnome-keyring-devel.
  262. - added BR:libxcrypt-devel,libnsl2-devel,libsecret-devel,utf8proc-devel.
  263. * Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
  264. - update to 1.8.17
  265. * Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
  266. - rebuild with ruby-2.2.3
  267. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
  268. - build with Perl 5.16
  269. - using %%__perllib_requires
  270. * Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
  271. - rebuild with ruby-2.1.2-6
  272. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
  273. - update to 1.8.9
  274. - remove unneeded explisit dependency
  275. - add BR: apache2-devel >= 2.4
  276. - add BR: libdb-devel instead of db4-devel
  277. - add R: apache2 > 2.4 to mod_dav_svn
  278. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  279. - update to 1.8.8
  280. - add BR: libserf-devel to handle http* scheme
  281. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  282. - update to 1.7.7
  283. - rebuild with ruby-1.9.3
  284. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  285. - new upstream release
  286. - update License
  287. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  288. - drop deplibs patch (Patch1)
  289. - drop obsolete patch files: Patch6, 10
  290. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  291. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  292. - add configure option with-gnome-keyring
  293. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  294. - fix Packager name
  295. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  296. - build with perl 5.12.3
  297. - add Requires: perl(:MODULE_COMPAT_...)
  298. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  299. - new upstream release with security fix
  300. - add Vendor/Distri tags
  301. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  302. - new upstream release
  303. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  304. - fix <BTS:VineLinux:941>
  305. - using rpm macro: rarchdir
  306. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  307. - using rpm macros: perl_vendorarch and python_sitearch
  308. - add BuildRequires: sqlite3-devel krb5-devel
  309. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  310. - new upstream release
  311. - update URL
  312. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  313. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  314. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  315. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  316. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  317. - new upstream release
  318. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  319. - new upstream release
  320. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  321. - rebuilt with python-2.5.2
  322. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  323. - new upstream release
  324. - rebuild with neon-0.28.2
  325. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  326. - added Patch6, 8, 9, 10 from Fedora Core
  327. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  328. - Correct install location of java stuff (#433295)
  329. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  330. - fix build with new glibc open()-as-macro
  331. - build all swig code in %%build, not %%install
  332. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  333. - build /usr/bin/* as PIEs
  334. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  335. - rebuild with expat-2.0.1
  336. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  337. - new upstream release
  338. - add Patch10 to build with neon.
  339. 1.3.2-0vl5 does not support neon..
  340. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  341. - rebuild with new neon
  342. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  343. - rebuilt with new toolchain and db4-4.3.x
  344. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  345. - modified %%files section for lib64 architecture
  346. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  347. - new upstream release
  348. - rebuild with new openldap-2.3.24
  349. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  350. - new upstream release
  351. - change Group to Develoment/Tools
  352. - build with apr-1.2.7/apr-util-1.2.7
  353. - require apr/apr-util instead of apache2-apr
  354. - build with swig-1.3.29
  355. - split {perl,python,ruby} related files to subpackage.
  356. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  357. - new upstream release
  358. - add noreplace option for config file
  359. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  360. - fix Requires and BuildPreReq.
  361. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  362. - new upstream release.
  363. - add swig-runtime to 'BuildPreReq:'.
  364. - fix %%files.
  365. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  366. - require neon version 0.24.7 for ra_dav
  367. - add BuildPreReq: openldap-devel
  368. - replace BuildPreReq: httpd to BuildPreReq: apache2
  369. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  370. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  371. - new upstream release
  372. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  373. - new upstream release
  374. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  375. - new upstream release
  376. - clean up specfile.
  377. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  378. - new upstream release
  379. - build with apache2-2.0.47
  380. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  381. - build Vine Linux
  382. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  383. - Enabled RA_DAV checking.
  384. Now requires httpd package to build because of RA_DAV tests.
  385. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  386. - Created tools package to hold the tools.
  387. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  388. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  389. version of APR/APR-UTILS as of 2003.01.15.
  390. - Added svnversion command.
  391. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  392. - Create a svnadmin.static which is copied to svnadmin-version-release
  393. when the package is erased, so users can still dump/load their repositories
  394. even after they have upgraded the RPM package.
  395. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  396. - SWIG now builds so we can use cvs2svn.
  397. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  398. - Made cvs2svn conditional (at least until we can get it to build consistently
  399. and work).
  400. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  401. - Added SWIG dependencies to add cvs2svn capabilities.
  402. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  403. - Now requires neon-0.22.0.
  404. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  405. - Took out loading mod_dav_svn from subversion.spec file and put it in
  406. subversion.conf file which goes into the apache conf directory.
  407. - Simplify what gets put into httpd.conf to only the include for the
  408. subversion.conf file.
  409. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  410. me to do this).
  411. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  412. - Updated to APR/APR-UTIL 2002-08-08.
  413. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  414. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  415. - Previous version had a few problems because of missing apache error/ files.
  416. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  417. - Updated to apache-2.0.40-0.3.
  418. - Updated to subversion-0.13.1-2318.
  419. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  420. - Updated for RedHat 7.3 (autoconf253).
  421. - Added a bunch of pre-requisites I didn't know were needed because I built a
  422. new machine that didn't have them already installed.
  423. - Fixed installation of man and info documentation pages.
  424. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  425. - Back to apache-libapr* stuff, hopefully to stay.
  426. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  427. - Fixed expat.patch to not have to make so many changes by writing a small
  428. shell script that changes libexpat to -lexpat.
  429. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  430. - Updated to neon-0.19.2.
  431. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  432. - Back to using apr and apr-util separately from apache.
  433. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  434. - Updated to APR and APR-UTIL 2002.02.11.
  435. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  436. - Took out a (now non-existant) documentation file.
  437. - Moved SPEC file changelog to after all package definitions.
  438. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  439. - Updated to neon-0.18.5.
  440. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  441. apache-apr-utils, and apache-apr-utils-devel.
  442. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  443. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  444. - Now builds without the separate APR package as it is built into and
  445. "exported" from apache-2.0.31-0.3.
  446. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  447. - Took out patches to install procedure now not required because of fixes
  448. in rev 1130.
  449. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  450. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  451. program was added.
  452. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  453. - Release M5-r340: Added the subversion-server package.
  454. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  455. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  456. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  457. - Release M3-r117: Initial Version.