python-asn1crypto-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. # Created by pyp2rpm-3.2.2
  2. %global pypi_name asn1crypto
  3. %bcond_without python2
  4. %bcond_without python3
  5. %{!?python3_pkgversion:%global python3_pkgversion 3}
  6. Name: python-%{pypi_name}
  7. Version: 0.24.0
  8. Release: 6%{?_dist_release}
  9. Summary: Fast Python ASN.1 parser and serializer
  10. License: MIT
  11. URL: https://github.com/wbond/asn1crypto
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Source0: https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  15. BuildArch: noarch
  16. %if 0%{?with_python2}
  17. BuildRequires: python-rpm-macros
  18. BuildRequires: python-devel
  19. BuildRequires: python-setuptools
  20. %{?python_provide:%python_provide python2-%{pypi_name}}
  21. %endif
  22. %if 0%{?with_python3}
  23. BuildRequires: python%{python3_pkgversion}-rpm-macros
  24. BuildRequires: python%{python3_pkgversion}-devel
  25. BuildRequires: python%{python3_pkgversion}-setuptools
  26. %endif
  27. %description
  28. Fast ASN.1 parser and serializer with definitions for private keys,
  29. public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
  30. PKCS#12, PKCS#5, X.509 and TSP.
  31. %if 0%{?with_python3}
  32. %package -n python%{python3_pkgversion}-%{pypi_name}
  33. Summary: %{summary}
  34. %{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
  35. %description -n python%{python3_pkgversion}-%{pypi_name}
  36. Fast ASN.1 parser and serializer with definitions for private keys,
  37. public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
  38. PKCS#12, PKCS#5, X.509 and TSP.
  39. %endif
  40. %prep
  41. %autosetup -n %{pypi_name}-%{version}
  42. # Remove bundled egg-info
  43. rm -rf %{pypi_name}.egg-info
  44. %build
  45. %if 0%{?with_python2}
  46. %py_build
  47. %endif
  48. %if 0%{?with_python3}
  49. %py3_build
  50. %endif
  51. %install
  52. %if 0%{?with_python2}
  53. %py_install
  54. %endif
  55. %if 0%{?with_python3}
  56. %py3_install
  57. %endif
  58. %check
  59. # asn1crypto source distribution doesn't come with tests
  60. # {__python2} setup.py test
  61. %if 0%{?with_python3}
  62. # {__python3} setup.py test
  63. %endif
  64. %if 0%{?with_python2}
  65. %files
  66. %doc
  67. %{python_sitelib}/%{pypi_name}
  68. %{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
  69. %endif
  70. %if 0%{?with_python3}
  71. %files -n python%{python3_pkgversion}-%{pypi_name}
  72. %doc
  73. %{python3_sitelib}/%{pypi_name}
  74. %{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
  75. %endif
  76. %changelog
  77. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24.0-6
  78. - initial build for Vine Linux.
  79. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-5
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  81. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-4
  82. - Rebuilt for Python 3.7
  83. * Tue Jun 19 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-3
  84. - Build Python 2 package conditionally
  85. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-2
  86. - Rebuilt for Python 3.7
  87. * Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-1
  88. - New upstream release 0.24.0
  89. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.23.0-2
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  91. * Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 0.23-1
  92. - New upstream release 0.23.0
  93. * Fri Aug 04 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-5
  94. - Use python2-setuptools, add with_python3
  95. * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-4
  96. - Modernize spec
  97. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-3
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  99. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-2
  100. - Address rpmlint issues
  101. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-1
  102. - Initial package.