compiz-vl.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869
  1. # build with kde4
  2. %bcond_with kde
  3. %define dialogversion 0.7.18
  4. %define kde_dialogversion 0.0.5
  5. %define core_plugins blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
  6. %define gnome_plugins annotate gconf glib svg gnomecompat
  7. # List of plugins passed to ./configure. The order is important
  8. %define plugins core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
  9. Summary: OpenGL window and compositing manager
  10. Summary(ja): OpenGL ウィンドウ・コンポジットマネージャ
  11. Name: compiz
  12. URL: http://www.go-compiz.org
  13. License: X11/MIT/GPL
  14. Group: User Interface/Desktops
  15. Version: 0.8.8
  16. Release: 3%{?_dist_release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # libdrm is not available on these arches
  19. ExcludeArch: s390 s390x ppc64
  20. Requires: xorg-x11-server-Xorg
  21. Requires: mesa-libGL
  22. Requires(post): desktop-file-utils
  23. BuildRequires: mesa-libGLU-devel
  24. BuildRequires: libdrm-devel
  25. BuildRequires: libwnck-devel
  26. BuildRequires: libX11-devel
  27. BuildRequires: libXcomposite-devel
  28. BuildRequires: libXdamage-devel
  29. BuildRequires: libXext-devel
  30. BuildRequires: libXfixes-devel
  31. BuildRequires: libXmu-devel
  32. BuildRequires: libXrandr-devel
  33. BuildRequires: libXrender-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libSM-devel
  36. BuildRequires: GConf2-devel
  37. BuildRequires: control-center-devel
  38. BuildRequires: dbus-devel
  39. BuildRequires: dbus-glib-devel
  40. BuildRequires: fuse-devel
  41. BuildRequires: gnome-desktop-devel >= 2.30.0
  42. BuildRequires: libglade2-devel
  43. BuildRequires: librsvg2-devel
  44. BuildRequires: libxslt-devel
  45. BuildRequires: metacity-devel
  46. BuildRequires: desktop-file-utils
  47. BuildRequires: intltool >= 0.35
  48. BuildRequires: gettext
  49. %if %{with kde}
  50. BuildRequires: kdebase-workspace-devel
  51. BUildRequires: dbus-qt-devel
  52. %endif
  53. Conflicts: control-center < 2.32.1-2
  54. # Make sure that former beryl users still have bling
  55. Obsoletes: beryl-core
  56. Source0: http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
  57. Source1: desktop-effects-%{dialogversion}.tar.bz2
  58. Source2: kde-desktop-effects-%{kde_dialogversion}.tar.bz2
  59. # Sources from fedora
  60. Source11: compiz-gtk
  61. Source12: compiz-gtk.desktop
  62. Source13: compiz-gnome.desktop
  63. Source14: compiz-gnome.session
  64. # Patches from fedora
  65. Patch102: desktop-effects-0.7.17-wall-plugin.patch
  66. Patch103: composite-cube-logo.patch
  67. Patch111: gconf-core-plugin-loopfix.patch
  68. # Make sure configuration plugins never get unloaded
  69. Patch123: compiz-0.7.8-pin-initial-plugins.patch
  70. # Patches from ubuntu
  71. Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
  72. Patch1150: 015_optional-fbo.patch
  73. Patch1160: 016_call_glxwaitx_before_drawing.patch
  74. Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
  75. Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
  76. Patch1490: 049-damage-report-non-empty.patch
  77. Patch1600: 060_move_checks_to_compiz.patch
  78. # Patches from upstream
  79. Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
  80. Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
  81. # Vine default options
  82. Patch3000: compiz-0.8.6-vine-default.patch
  83. Vendor: Project Vine
  84. Distribution: Vine Linux
  85. %description
  86. Compiz is one of the first OpenGL-accelerated compositing window
  87. managers for the X Window System. The integration allows it to perform
  88. compositing effects in window management, such as a minimization
  89. effect and a cube workspace. Compiz is an OpenGL compositing manager
  90. that use Compiz use EXT_texture_from_pixmap OpenGL extension for
  91. binding redirected top-level windows to texture objects.
  92. %package devel
  93. Summary: Development packages for compiz
  94. Summary(ja): compiz の開発パッケージ
  95. Group: Development/Libraries
  96. Requires: compiz = %{version}-%{release}
  97. Requires: pkgconfig
  98. Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
  99. Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
  100. Requires: libxslt-devel startup-notification-devel
  101. %description devel
  102. The compiz-devel package includes the header files,
  103. and developer docs for the compiz package.
  104. Install compiz-devel if you want to develop plugins for the compiz
  105. windows and compositing manager.
  106. %package gnome
  107. Summary: Compiz gnome integration bits
  108. Summary(ja): Compiz gnome integration bits
  109. Group: User Interface/Desktops
  110. Requires: gnome-session
  111. Requires: metacity
  112. Requires: libwnck
  113. Requires: glx-utils
  114. Requires: %{name} = %{version}
  115. Requires(pre): GConf2
  116. Requires(post): GConf2
  117. Requires(preun): GConf2
  118. Obsoletes: compiz < 0.5.2-8
  119. Obsoletes: beryl-gnome
  120. %description gnome
  121. The compiz-gnome package contains gtk-window-decorator,
  122. and other gnome integration related stuff.
  123. %if %{with kde}
  124. %package kde
  125. Summary: Compiz kde integration bits
  126. Summary(ja): Compiz kde integration bits
  127. Group: User Interface/Desktops
  128. Requires: %{name} = %{version}
  129. Requires: compiz-manager
  130. Obsoletes: beryl-kde
  131. %description kde
  132. The compiz-kde package contains kde-window-decorator,
  133. and other kde integration related stuff.
  134. %endif
  135. %prep
  136. %setup -q -T -b1 -n desktop-effects-%{dialogversion}
  137. #%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
  138. %setup -q
  139. pushd ../desktop-effects-%{dialogversion}
  140. %patch102 -p1 -b .wall-plugin
  141. popd
  142. %patch103 -p1 -b .composite-cube-logo
  143. %patch111 -p1 -b .gconf-core-loop
  144. ## %patch123 -p1 -b .initial-plugins
  145. # ubuntu patch
  146. %patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
  147. %patch1150 -p1 -b .disable-fbo
  148. %patch1160 -p1 -b .call_glxwaitx_before_drawing
  149. %patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
  150. %patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
  151. %patch1490 -p1 -b .damage-report-non-empty
  152. %patch1600 -p1 -b .move-check-to-compiz
  153. # upstream patch
  154. #%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
  155. #%patch2010 -p1 -b .fix-pixmap-size-calculation
  156. # vine patch
  157. %patch3000 -p1 -b .vine-default
  158. %build
  159. rm -rf $RPM_BUILD_ROOT
  160. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  161. export CPPFLAGS
  162. #needed to find kde4 libs
  163. #LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
  164. #export LDFLAGS
  165. libtoolize
  166. autoreconf
  167. %configure \
  168. %{?with_kde: --enable-kde4 } \
  169. %{!?with_kde: --disable-kde4 } \
  170. --disable-kde \
  171. --enable-gconf \
  172. --enable-dbus \
  173. --enable-place \
  174. --enable-librsvg \
  175. --enable-gtk \
  176. --enable-metacity \
  177. --enable-gnome \
  178. --with-default-plugins=%{plugins} \
  179. --enable-gnome-keybindings
  180. make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
  181. # desktop-effects
  182. cd ../desktop-effects-%{dialogversion}
  183. %configure
  184. %install
  185. rm -rf $RPM_BUILD_ROOT
  186. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  187. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
  188. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  189. echo INSTALLING DESKTOP EFFECTS
  190. pushd ../desktop-effects-%{dialogversion}
  191. make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
  192. #desktop-file-install --vendor vine --delete-original \
  193. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  194. # $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  195. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  196. popd
  197. %if %{with kde}
  198. # kde-desktop-effects
  199. echo INSTALLING KDE DESKTOP EFFECTS
  200. pushd ../kde-desktop-effects-%{kde_dialogversion}
  201. cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
  202. mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  203. cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  204. iconlist="16 24 32 36 48 96"
  205. for i in $iconlist; do
  206. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
  207. cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
  208. done
  209. desktop-file-install --vendor="" \
  210. --dir=%{buildroot}%{_datadir}/applications/kde \
  211. kde-desktop-effects.desktop
  212. popd
  213. %endif
  214. %if !%{with kde}
  215. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
  216. %endif
  217. install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
  218. desktop-file-install --vendor="" \
  219. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  220. %{SOURCE12}
  221. # set up an X session
  222. mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
  223. install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
  224. mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
  225. install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
  226. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  227. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  228. %find_lang compiz
  229. %find_lang desktop-effects
  230. cat compiz.lang > core-files.txt
  231. cat desktop-effects.lang > gnome-files.txt
  232. for f in %{core_plugins}; do
  233. echo %{_libdir}/compiz/lib$f.so
  234. echo %{_datadir}/compiz/$f.xml
  235. done >> core-files.txt
  236. for f in %{gnome_plugins}; do
  237. echo %{_libdir}/compiz/lib$f.so
  238. echo %{_datadir}/compiz/$f.xml
  239. done >> gnome-files.txt
  240. %post -p /sbin/ldconfig
  241. %postun -p /sbin/ldconfig
  242. %post gnome
  243. update-desktop-database -q %{_datadir}/applications
  244. export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
  245. for f in %{core_plugins} %{gnome_plugins} core; do
  246. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  247. | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
  248. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  249. touch --no-create %{_datadir}/icons/hicolor
  250. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  251. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  252. fi
  253. %pre gnome
  254. if [ "$1" -gt 1 ]; then
  255. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  256. for f in %{core_plugins} %{gnome_plugins} core; do
  257. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  258. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  259. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  260. fi
  261. %preun gnome
  262. if [ "$1" -eq 0 ]; then
  263. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  264. for f in %{core_plugins} %{gnome_plugins} core; do
  265. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  266. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  267. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  268. fi
  269. %postun gnome
  270. touch --no-create %{_datadir}/icons/hicolor
  271. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  272. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  273. fi
  274. %if %{with kde}
  275. %post kde
  276. update-desktop-database -q %{_datadir}/applications/kde
  277. touch --no-create %{_datadir}/icons/hicolor
  278. %postun kde
  279. touch --no-create %{_datadir}/icons/hicolor
  280. %endif
  281. %clean
  282. rm -rf $RPM_BUILD_ROOT
  283. %files -f core-files.txt
  284. %defattr(-, root, root)
  285. %doc AUTHORS ChangeLog COPYING* README TODO
  286. %{_bindir}/compiz
  287. %{_libdir}/libdecoration.so.*
  288. %dir %{_libdir}/compiz
  289. %dir %{_datadir}/compiz
  290. %{_datadir}/compiz/*.png
  291. %{_datadir}/compiz/core.xml
  292. %files gnome -f gnome-files.txt
  293. %defattr(-, root, root)
  294. %{_bindir}/compiz-gtk
  295. %{_bindir}/gtk-window-decorator
  296. %{_bindir}/desktop-effects
  297. #%{_libdir}/window-manager-settings/libcompiz.so
  298. #%{_datadir}/gnome/wm-properties/compiz-wm.desktop
  299. #%{_datadir}/applications/compiz.desktop
  300. #%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
  301. #%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
  302. %{_datadir}/applications/compiz-gtk.desktop
  303. %{_datadir}/compiz/desktop-effects.glade
  304. %{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
  305. %{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
  306. %{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
  307. %{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
  308. %{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
  309. %{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
  310. %{_datadir}/xsessions/compiz-gnome.desktop
  311. %{_datadir}/gnome-session/sessions/compiz-gnome.session
  312. %{_sysconfdir}/gconf/schemas/*.schemas
  313. %if %{with kde}
  314. %files kde
  315. %defattr(-, root, root)
  316. %{_bindir}/kde4-window-decorator
  317. %{_docdir}/compiz-kde-%{version}
  318. %{_bindir}/kde-desktop-effects.sh
  319. %{_datadir}/applications/kde/kde-desktop-effects.desktop
  320. %{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
  321. %{_datadir}/compiz/kconfig.xml
  322. %endif
  323. %files devel
  324. %defattr(-, root, root)
  325. %{_libdir}/pkgconfig/compiz.pc
  326. %{_libdir}/pkgconfig/libdecoration.pc
  327. %{_libdir}/pkgconfig/compiz-cube.pc
  328. %{_libdir}/pkgconfig/compiz-gconf.pc
  329. %{_libdir}/pkgconfig/compiz-scale.pc
  330. %{_datadir}/compiz/schemas.xslt
  331. %{_includedir}/compiz
  332. %{_libdir}/libdecoration.so
  333. %changelog
  334. * Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
  335. - remove SandyBridge chipset from blacklist
  336. - add BR: dbus-glib-devel
  337. * Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
  338. - add Source files from Fedora
  339. Source11 (compiz-gtk)
  340. Source12 (compiz-gtk.desktop)
  341. Source13 (compiz-gnome.desktop)
  342. Source14 (compiz-gnome.session)
  343. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
  344. - new upstream release
  345. - add BuildRequires: libxslt-devel, libglade2-devel
  346. - drop Patch2000,2010
  347. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
  348. - add Patch3000
  349. - disable Sync to vblank
  350. - increase drop-shadow radius
  351. - set default decorator to gtk-window-decorator
  352. - change default daces in cube plugin
  353. - use "smart" placement mode
  354. * Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
  355. - drop compiz-gtk
  356. - add Conflicts: control-center < 2.32.1-2
  357. * Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
  358. - rebuild with mesa-7.10.1
  359. - add cherry picked ubuntu patch
  360. - Patch1150: add --no-fbo option
  361. - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
  362. - Patch1160: call glxwaitx before drawing
  363. - Patch1170: always unredirect screensaver on nvidia
  364. - Patch1490: damage report non empty
  365. - Patch1600: move check to compiz
  366. - add upstream patch
  367. - Patch2000: replace gdk_draw_drawable with cairo equivalents
  368. - Patch2010: fix pixmap size calculation
  369. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
  370. - rebuild with rpm-4.8.1 for pkg-config file
  371. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  372. - new upstream release (build on GNOME-2.30)
  373. - drop Patch123, Patch300
  374. * Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
  375. - rebuild with mesa-7.6
  376. - add Patch300 to build with gconf-2.28
  377. * Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
  378. - disable glib plugin in compiz-gtk
  379. - use direct rendering on virtualbox video adaptor.
  380. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
  381. - add Requires: glx-utils to compiz-gnome
  382. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  383. - new upstream release
  384. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
  385. - re-enable metacity decoration on gtk-window-decorator
  386. - BR: metacity-devel instead of metacity
  387. * Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
  388. - fix pre/post scripts for speeding up gconf schema installation
  389. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
  390. - add ccp compiz option to compiz-gtk
  391. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
  392. - remove desktop-effect.desktop
  393. - we use gnome-appearance-properties integrated version.
  394. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
  395. - add Patch121,122 from upstream fix.
  396. - add Patch123: make sure configuration plugins never get unloaded
  397. - add Patch124: memleak fix from upstream
  398. - add Patch125: make the terminal keybind work
  399. - add Patch120,126,127 for kde42
  400. - add Patch128: gwd fix from upstream
  401. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
  402. - rebuild with gnome-desktop-2.26.0
  403. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
  404. - add compiz-gtk scripts and desktop file from fedora
  405. * Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
  406. - new upstream release
  407. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
  408. - rebuild with gnome-desktop-2.24.0
  409. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
  410. - new upstream release
  411. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
  412. - new upstream release
  413. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  414. - initial build for Vine Linux
  415. * Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
  416. - Fix gconf plugin loop RH #438794, patch based on
  417. older one from Guillaume Seguin
  418. - Add core to default plugin list
  419. * Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
  420. - Reword kde-desktop-effects messages to mention Compiz by name (#438883)
  421. * Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
  422. - Update to 0.7.2
  423. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
  424. - Autorebuild for GCC 4.3
  425. * Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
  426. - Update to desktop-effects version 0.7.17 which include more
  427. translations and move desktop-effects translations to compiz-gnome.
  428. - Fix spelling in beryl-core obsoletes.
  429. * Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
  430. - Update buildrequires (kwd uses the kde3 api)
  431. * Tue Nov 6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
  432. - Fix a typo in description of the main package.
  433. - All descriptions should end with a dot (unlike the summary line)
  434. * Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
  435. - Include kde-desktop-effects in kde subpackage
  436. * Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
  437. - Obsolete berly-core
  438. * Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
  439. - 0.6.2
  440. * Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
  441. - Disable scale corner initiate and install a GNOME key config entry.
  442. * Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
  443. - 0.6.0 final
  444. - always-restack-windows-on-map
  445. * Tue Oct 9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
  446. - Make compiz behave with gnome-terminal (#304051)
  447. * Fri Oct 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
  448. - Also install gwd.schemas (#319621)
  449. * Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
  450. - Update to more recent 0.6 branch snapshot (fixes #253575).
  451. * Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
  452. - compiz-gnome: install core schema so it actually works
  453. - remove unnecessary gconf stuff from %%install
  454. * Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
  455. - Make compiz-gnome Obsolete the older compiz package so yum/anaconda
  456. will pull it in (thans to Adel Gadllah).
  457. * Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
  458. - Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
  459. up dialog.
  460. - Fix broken gconf install and uninstall rules.
  461. - Pick up shadowman logo for RHEL builds (#232398).
  462. * Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
  463. - Add more-sm-junk.patch so we set SM restart style to
  464. SmRestartIfRunning on exit (#247163, #245971).
  465. - Add Requires to compiz-devel (#253407).
  466. - Update to desktop-effects 0.7.6, which terminates decorator when
  467. switching to metacity or on compiz failure (#215247, #215032).
  468. * Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
  469. - Split into gnome and kde subpackages
  470. - Minor cleanups
  471. * Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
  472. - Reorder plugin list to avoid 'place' getting removed on startup.
  473. - Add run-command-key.patch to put the run command key in the GNOME
  474. keyboard shortcut dialog (#213576).
  475. - Drop a bunch of obsolete patches.
  476. - Bump mesa-libGL and X server requires to fix TFP bugs for
  477. power-of-two textures (#251935).
  478. - Rebase fedora-logo and composite-cube-logo patch.
  479. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
  480. - Build with desktop-effects so we don't pick up metacity work spaces.
  481. Fixes #250568.
  482. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
  483. - Build git snapshot from fedora branch at
  484. git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
  485. branch.
  486. - Fixes #237486.
  487. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
  488. - Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
  489. 'glib' on the command line too.
  490. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
  491. - Move xml meta data files to main package.
  492. * Thu Aug 9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
  493. - Update to 0.5.2.
  494. - Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
  495. with LIBGL_ALWAYS_INDIRECT set.
  496. * Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
  497. - Update to 0.5.0
  498. * Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  499. - Update to 0.4.0
  500. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
  501. - Rebuild against new libwnck
  502. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
  503. - Don't install INSTALL
  504. * Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
  505. - Update metacity build requires to metacity-devel.
  506. * Wed Apr 4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
  507. - Fix typo in ./configure option.
  508. * Wed Apr 4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
  509. - Add place and clone plugins to default plugin list.
  510. * Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
  511. - Update URL (#208214).
  512. - Require at least metacity 2.18 (#232831).
  513. - Add close-session.patch to deregister from SM when replaced (#229113).
  514. * Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
  515. - Explicitly disable KDE parts (#234128).
  516. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
  517. - Fix some directory ownership issues (#233825)
  518. - Small spec cleanups
  519. * Tue Feb 6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
  520. - Require gnome-session > 2.16 so it starts gtk-window-decorator.
  521. - Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
  522. * Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
  523. - Update to 0.3.6, update patches.
  524. - Drop autotool build requires.
  525. - Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
  526. - Add libdecoration.so
  527. - Update to desktop-effects-0.7.0, which spawns the right decorator
  528. and plays nicely with unknown plugins.
  529. * Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
  530. - Update the fedora logo patch (#217224)
  531. * Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  532. - Update to 0.3.4
  533. * Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  534. - Use cow by default, bug 208044
  535. * Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  536. - Update to 0.3.2
  537. - Drop upstreamed patches
  538. - Work with new metacity theme api
  539. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
  540. - Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
  541. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  542. - Add buildrequires on intltool
  543. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  544. - Build
  545. * Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
  546. - Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
  547. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
  548. - Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
  549. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
  550. - Change default plugin list to not include the plane plugin. (Bug 208448).
  551. - Change default keybinding for shrink to be Pause (Bug 206187).
  552. * Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
  553. - Add patch to show a menu when the window icon is clicked. (Bug 201629).
  554. * Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
  555. - Add restart.patch to make compiz ask the session manager to restart it
  556. if it crashes (bug 200280).
  557. * Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
  558. - Change plane.patch to not do cyclical window movement in dimensions
  559. where the desktop has size 1 (bug 207263).
  560. * Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
  561. - Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
  562. * Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
  563. - Change .plane patch to
  564. (a) not set the background color to pink in the plane plugin.
  565. (b) allow workspaces with horizontal sizes less then 4.
  566. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
  567. - Change plane patch to correctly initialize the screen size to the
  568. defaults (bug 206088).
  569. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  570. - Run update-desktop-database and gtk-update-icon-cache in post. Add icons
  571. to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
  572. directories before attempting to install to them).
  573. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  574. - Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
  575. that the new version has icons.
  576. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  577. - Add patch to fix mispositioning of window decorator event windows (bug 201624)
  578. * Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
  579. - Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
  580. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  581. - Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
  582. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  583. - Add patch to fix thumbnail sorting (bug 201605)
  584. * Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
  585. - Add patch to fix double clicking (bug 201783).
  586. * Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
  587. - Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
  588. * Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
  589. - Fix plane.patch to draw correctly when no timeout is running. (206088).
  590. * Wed Sep 6 2006 Kristian H淡gsberg <krh@redhat.com>
  591. - Update fbconfig-depth-fix.patch to also skip fbconfigs without
  592. corresponding visuals.
  593. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
  594. - Make number of vertical size configurable
  595. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
  596. - Fix vertical viewport support in the plane patch.
  597. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
  598. - Upgrade to 0.6.61 of the dialog
  599. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  600. - Add libtool to BuildRequires
  601. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  602. - Add automake and autoconf to BuildRequires
  603. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  604. - Add a patch to put viewports on a plane.
  605. * Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
  606. - Drop gl-include-inferiors.patch now that compiz uses COW and the X
  607. server evicts offscreen pixmaps automatically on
  608. GLX_EXT_texture_from_pixmap usage.
  609. * Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
  610. - Add cow.patch to make compiz use the composite overlay window.
  611. * Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
  612. - Rebase to desktop-effects 0.6.41
  613. * Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
  614. - Rebase to desktop-effects 0.6.19 and drop
  615. desktop-effects-0.6.1-delete-session.patch
  616. * Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
  617. - Add patch from upstream to also use sync protocol for override
  618. redirect windows (sync-override-redirect-windows.patch).
  619. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
  620. - Rebase to latest upstream changes which has the rest of the bindings
  621. rewrite. Add resize-move-keybindings.patch to make move and resize
  622. bindings work like metacity.
  623. - Add back scale plugin.
  624. * Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
  625. - Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
  626. - unlink session file on changing wms (bug 201473)
  627. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
  628. - Add Requires: gnome-session 2.15.4-3
  629. * Wed Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  630. - New version of dialog box. Macro the version number.
  631. * Wed Aug 2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  632. - Add 'desktop effects' dialog box.
  633. * Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
  634. - Add libwnck requires.
  635. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
  636. - Bump and build for fc5 AIGLX repo.
  637. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
  638. - Fix gconf hooks.
  639. * Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
  640. - Require system-logos instead.
  641. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
  642. - Bump version to work around tagging weirdness.
  643. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
  644. - Add devel package and require redhat-logos instead of fedora-logos (#199757).
  645. * Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
  646. - Add workaround for AIGLX throttling problem.
  647. * Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
  648. - Drop scale plugin from snapshot.
  649. * Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
  650. - Don't build on s390
  651. * Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
  652. - Do some changes forced upon us by package review
  653. * Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
  654. - Use sane numbering scheme.
  655. * Fri Jul 7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
  656. - Drop the fullscreen hardcode patch and require X server that has
  657. GLX_MESA_copy_sub_buffer.
  658. * Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
  659. - Unbreak --replace.
  660. * Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
  661. - Add Requires, fix start-compiz.sh.
  662. * Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
  663. - Spec file for compiz, borrowing bits and pieces from Alphonse Van
  664. Assches spec file (#192432).