incron-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. Summary: Inotify cron system
  2. Name: incron
  3. Version: 0.5.10
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Base
  6. License: GPLv2
  7. URL: http://inotify.aiken.cz
  8. Source0: http://inotify.aiken.cz/download/incron/%{name}-%{version}.tar.bz2
  9. Source1: incrond.init
  10. #Patch0: incron-gcc44.patch
  11. Patch1: incron-gcc47.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. Requires(post): /sbin/chkconfig
  14. Requires(preun): /sbin/chkconfig, /sbin/service
  15. %description
  16. This program is an "inotify cron" system.
  17. It consists of a daemon and a table manipulator.
  18. You can use it a similar way as the regular cron.
  19. The difference is that the inotify cron handles
  20. filesystem events rather than time periods.
  21. %prep
  22. %setup -q
  23. #%patch0 -p1 -b .orig
  24. %patch1 -p0 -b .gcc47
  25. %build
  26. make %{?_smp_mflags} CXXFLAGS="%{optflags}"
  27. %install
  28. rm -rf %{buildroot}
  29. #install files manually since source Makefile tries to do it as root
  30. install -D -p incrond %{buildroot}%{_sbindir}/incrond
  31. install -D -p -m 4755 incrontab %{buildroot}%{_bindir}/incrontab
  32. install -d %{buildroot}%{_localstatedir}/spool/%{name}
  33. install -d %{buildroot}%{_sysconfdir}/%{name}.d
  34. install -D -p -m 0755 %{SOURCE1} %{buildroot}%{_initdir}/incrond
  35. install -D -p -m 0644 incron.conf.example %{buildroot}%{_sysconfdir}/%{name}.conf
  36. # install manpages
  37. make install-man MANPATH="%{buildroot}%{_mandir}" INSTALL="install -D -p"
  38. %post
  39. if [ $1 -eq 1 ]; then
  40. /sbin/chkconfig --add incrond
  41. fi
  42. %preun
  43. if [ $1 -eq 0 ]; then
  44. /sbin/service %{name} stop >/dev/null 2>&1 || :
  45. /sbin/chkconfig --del incrond
  46. fi
  47. %postun
  48. if [ $1 -ge 1 ]; then
  49. /sbin/service incrond condrestart >/dev/null 2>&1 || :
  50. fi
  51. %clean
  52. rm -rf %{buildroot}
  53. %files
  54. %defattr(-,root,root,-)
  55. %attr(4755,root,root) %{_bindir}/incrontab
  56. %{_sbindir}/incrond
  57. %{_initdir}/incrond
  58. %config(noreplace) %{_sysconfdir}/%{name}.conf
  59. %{_mandir}/man1/incrontab.1.gz
  60. %{_mandir}/man5/incrontab.5.gz
  61. %{_mandir}/man5/incron.conf.5.gz
  62. %{_mandir}/man8/incrond.8.gz
  63. %dir %{_localstatedir}/spool/%{name}
  64. %dir %{_sysconfdir}/%{name}.d
  65. %doc COPYING CHANGELOG README TODO LICENSE-GPL
  66. %changelog
  67. * Fri May 04 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.10-1
  68. - new upstream release.
  69. - built for Vine Linux.
  70. * Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.5.9-4
  71. - Migrate to systemd, BZ 789688.
  72. - gcc47 patch.
  73. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-3
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  75. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.9-2
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  77. * Mon Dec 21 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.9-1
  78. - Upstream released new version
  79. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.8-2
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  81. * Wed Feb 25 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 0.5.8-1
  82. - Upstream released new version
  83. - GCC 4.4 fixes
  84. - Drop GCC 4.3 patch, fixed upstream
  85. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  87. * Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 0.5.7-1
  88. - Sync with upstream
  89. * Thu Mar 13 2007 <ruben@rubenkerkhof.com> 0.5.5-1
  90. - Sync with upstream
  91. * Mon Feb 12 2007 <ruben@rubenkerkhof.com> 0.5.4-1
  92. - Update to new upstream version
  93. - Upstream fixed permissions on pidfile
  94. - New manpage for incron.conf
  95. - Upstream fixed example conf file
  96. * Sun Feb 04 2007 <ruben@rubenkerkhof.com> 0.5.1-1
  97. - Updated to new upstream version
  98. - Upstream fixed the incorrect encoding of the LICENSE-GPL file
  99. * Sun Jan 27 2007 <ruben@rubenkerkhof.com> 0.5.0-1
  100. - Updated to new upstream version
  101. - Changed the service name in the scriptlets
  102. - Added a configuration file
  103. - Included GPL License
  104. * Sat Jan 27 2007 <ruben@rubenkerkhof.com> 0.4.0-1
  105. - First try at packaging it up