kbd-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388
  1. Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
  2. Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
  3. Name: kbd
  4. Version: 1.12
  5. Release: 21%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
  9. Source1: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2.sign
  10. #Source2: kbdrate.apps
  11. #Source3: kbdrate.pam
  12. Source4: kbd-latsun-fonts.tar.bz2
  13. Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
  14. BuildRequires: bison, flex, gettext
  15. BuildRoot: %{_tmppath}/%{name}-root
  16. Patch0: kbd-1.12-sparc.patch
  17. Patch1: kbd-1.08-compose.patch
  18. Patch2: kbd-1.08-terminal.patch
  19. Patch3: kbd-1.08-rukbd.patch
  20. Patch4: kbd-1.12-setfont-man.patch
  21. Patch5: kbd-1.12-Meta_utf8.patch
  22. Patch6: kbd-1.12-nostrip.patch
  23. Patch7: kbd-1.12-alias.patch
  24. Patch8: kbd-1.12-dir.patch
  25. Patch9: kbd-1.12-no-user-map.patch
  26. Patch10: kbd-1.12-resizecon-man.patch
  27. Patch11: kbd-1.12-gr-el.patch
  28. Patch12: kbd-1.12-keycodes-man.patch
  29. Obsoletes: console-tools open
  30. Provides: console-tools open
  31. Conflicts: util-linux < 2.11r-9
  32. Prereq: initscripts >= 5.86-1
  33. ExcludeArch: s390 s390x
  34. %description
  35. The %{name} package contains tools for managing a Linux
  36. system's console's behavior, including the keyboard, the screen
  37. fonts, the virtual terminals and font files.
  38. %prep
  39. %setup -q -a 4
  40. %patch0 -p1 -b .sparc
  41. %patch1 -p1
  42. %patch2 -p1 -b .terminal
  43. %patch3 -p1
  44. %patch4 -p1 -b .man
  45. %patch5 -p1 -b .Meta_utf8
  46. %patch6 -p1 -b .nostrip
  47. %patch7 -p1 -b .alias
  48. %patch8 -p1 -b .dir
  49. %patch9 -p1 -b .no-user-map
  50. %patch10 -p1 -b .resizecon-man
  51. %patch11 -p1 -b .gr-el
  52. %patch12 -p1 -b .keycodes-man
  53. # 7-bit maps are obsolete; so are non-euro maps
  54. pushd data/keymaps/i386
  55. mv qwerty/fi.map qwerty/fi-old.map
  56. cp qwerty/fi-latin9.map qwerty/fi.map
  57. cp qwerty/pt-latin9.map qwerty/pt.map
  58. cp qwerty/sv-latin1.map qwerty/se-latin1.map
  59. mv azerty/fr.map azerty/fr-old.map
  60. cp azerty/fr-latin9.map azerty/fr.map
  61. cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
  62. popd
  63. # Default to latarcyrheb-sun16 font for unicode
  64. perl -pi -e 's/LatArCyrHeb-16/latarcyrheb-sun16/' src/unicode_start
  65. %build
  66. export OLD_PO_FILE_INPUT=yes
  67. # We don't use % {configure} because the ./configure included here does not
  68. # understand most of the options.
  69. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  70. ./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
  71. # Override CFLAGS because this configure ignores them anyway, and LDFLAGS
  72. # because it defaults to -s, but that's a build policy decision.
  73. make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. # Basic install.
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. # The rhpl keyboard layout table is indexed by kbd layout names, so we need a
  79. # Korean keyboard
  80. ln -s us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty/ko.map.gz
  81. # Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
  82. for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop ; do
  83. mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin
  84. done
  85. # Some microoptimization
  86. sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
  87. $RPM_BUILD_ROOT/bin/unicode_start
  88. # Set up kbdrate to be userhelpered.
  89. #mkdir -p $RPM_BUILD_ROOT%{_sbindir}
  90. #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
  91. #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
  92. #mv $RPM_BUILD_ROOT%{_bindir}/kbdrate $RPM_BUILD_ROOT%{_sbindir}
  93. #ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kbdrate
  94. #install -c -m644 %{SOURCE2} \
  95. # $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
  96. #install -c -m644 %{SOURCE3} \
  97. # $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
  98. rm -f %{buildroot}/%{_bindir}/kbdrate
  99. # Link open to openvt
  100. ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
  101. %find_lang %{name}
  102. %clean
  103. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  104. %triggerun -- kbd < 1.08-10.2
  105. /sbin/chkconfig --del keytable || :
  106. %files -f %{name}.lang
  107. %defattr(-,root,root)
  108. %doc CHANGES CREDITS README doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf*
  109. /bin/*
  110. %{_bindir}/*
  111. %{_mandir}/*/*
  112. /lib/kbd
  113. %changelog
  114. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
  115. - applied new versioning policy, spec in utf-8
  116. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
  117. - initial build for Vine Linux based on Fedora package.
  118. * Tue Jan 9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
  119. - Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
  120. Resolves: #220151
  121. * Thu Dec 7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
  122. - Document that setkeycodes doesn't affect USB keyboards and that the kernel
  123. doesn't provide the raw scan codes by default
  124. Resolves: #211803
  125. * Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
  126. - Ship "el" translation instead of the obsolete "gr" translation
  127. Resolves: #210749
  128. - Fix %% quoting in %%changelog
  129. * Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
  130. - Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
  131. * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
  132. - Obsoletes/Provides open
  133. - Create a symlink from open to openvt
  134. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
  135. - rebuild
  136. * Sun Jul 9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
  137. - Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
  138. <dennis@ausil.us>)
  139. * Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
  140. - Fix missing BuildRequires (#193406)
  141. * Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
  142. - Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
  143. <kmori@redhat.com>)
  144. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
  145. - bump again for double-long bug on ppc(64)
  146. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
  147. - rebuilt for new gcc4.1 snapshot and glibc changes
  148. * Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
  149. - Fix build with new coreutils
  150. - Hardcode paths in unicode_start to avoid a few file lookups (#178329)
  151. - Drop unnecessary Prereq: sed mktemp
  152. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  153. - rebuilt
  154. * Thu Dec 1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
  155. - Don't reload the keymap in unicode_start (#172425)
  156. * Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
  157. - Don't ship character set lists (they are already in glibc-common) and an
  158. obsolete copy of kbd.FAQ
  159. * Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
  160. - Don't attempt to open directories as source files (#141634, original patch by
  161. Paul Nasrat)
  162. * Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
  163. - Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
  164. * Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
  165. - Fix violation of C aliasing rules (#150440)
  166. * Sun Mar 6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
  167. - Don't run ldconfig
  168. - Don't strip executables
  169. * Fri Mar 4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
  170. - Rebuild with gcc4
  171. * Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
  172. - Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
  173. (patch by Jochen Schmitt)
  174. - Don't ship patch backup files, simpler way
  175. * Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
  176. - Don't ship a patch backup file
  177. - Mention in setfont.8 that 512-glyph fonts reduce the number of available
  178. colors (#140935, patch by Dmitry Butskoj)
  179. - Remove "Meta_acute" from German keymaps (#143124)
  180. - Make the %%triggerun script condition more precise, ignore failure of the
  181. script
  182. * Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
  183. - rebuilt
  184. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  185. - rebuilt
  186. * Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
  187. - update to 1.12
  188. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  189. - rebuilt
  190. * Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
  191. - remove speakup patch at request of author
  192. * Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
  193. - remove keytable init script (#106783)
  194. * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
  195. - bump for RHEL
  196. * Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
  197. - apply the rukbd patch (#78218)
  198. * Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
  199. - don't print "plus before..." warnings about non-supported capslock
  200. in unimode <Andries.Brouwer@cwi.nl> (#81855)
  201. * Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
  202. - replaced Russian keyboard map with working UTF-8 equivalent (#79338)
  203. * Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
  204. - make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
  205. - fix swedish keymap; se, not sv (#88791)
  206. - add fr-latin0 legacy alias of fr-latin-9 (#88324)
  207. - add ".map" ext to filename param of init script (#90562)
  208. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  209. - rebuilt
  210. * Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  211. - build new rpm
  212. * Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  213. - ExcludeArch mainframe
  214. * Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
  215. - remove condrestart from initscript
  216. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  217. - rebuilt
  218. * Fri Dec 6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
  219. - only output terminal unicode init sequence if both stdout and stderr are
  220. connected to terminals, so that it doesn't show up when script outputs
  221. get piped to files
  222. * Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
  223. - update to 1.08
  224. - drop updates which went mainline
  225. * Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
  226. - add detached signature
  227. - remove directory names from PAM configuration so that the same config file
  228. can be used for any arch on multilib systems
  229. * Wed Sep 4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
  230. - don't munge /etc/sysconfig/i18n
  231. * Tue Sep 3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
  232. - don't run setsysfont in upgrade trigger on console-tools
  233. * Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
  234. - use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
  235. instead of old LatArCyrHeb-16 chars
  236. - add Euro character to latarcyrheb-sun16
  237. - use latarcyrheb-sun16 by default in unicode_start script
  238. * Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
  239. - add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
  240. * Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
  241. - needs to conflict with older util-linux packages
  242. (kbdrate moved between packages)
  243. * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
  244. - remove Evil Hack in favor of slightly-less-evil-hack in initscripts
  245. * Tue Jul 9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
  246. - fix speakup keymap names
  247. * Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
  248. - Evil hack to make setfont work correctly on all consoles (#68018)
  249. * Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
  250. - move unicode_stop to /bin too
  251. - fix path to loadkeys in keytable.init
  252. - add in speakup keymaps
  253. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  254. - automated rebuild
  255. * Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
  256. - fix incorrect path in console.apps configuration file
  257. * Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
  258. - move some more stuff to /bin (unicode_start and dependencies)
  259. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  260. - automated rebuild
  261. * Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
  262. - Rebuild in new environment
  263. * Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
  264. - Oops, actually list the pam files in %%files
  265. * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
  266. - Add and consolehelper'ify kbdrate
  267. * Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
  268. - Re-remove kbdrate
  269. * Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
  270. - Fix build in current environment
  271. - Get rid of kbdrate, it's in util-linux these days
  272. * Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
  273. - added a patch (Patch4) that allows --tty= in setfont
  274. - modified patch not to break translations
  275. * Tue Jul 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
  276. - Add cyrillic patches from leon@geon.donetsk.ua (#47144)
  277. * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
  278. - Fix "Alt+AltGr=Compose" in qwertz-keyboards
  279. * Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
  280. - Fix "make install" and init script (#45327)
  281. * Sat Jun 16 2001 Than Ngo <than@redhat.com>
  282. - update to 1.0.6
  283. - use %%{_tmppath}
  284. - use find_lang
  285. - support new gettext
  286. - remove some patch files, which are included in 1.0.6
  287. - fix to use RPM_OPT_FLAGS
  288. * Thu May 3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
  289. - Fix up resizecons
  290. * Wed May 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
  291. - Build everything, obsoletes console-tools
  292. - s/Copyright:/License:/
  293. - License is GPL, not just distributable
  294. - Add our compose mappings from old console-tools
  295. - Add triggerpostun -- console-tools magic to get sane fonts and mappings
  296. * Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
  297. - initial packaging for kbdrate