lzo-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: lzo
  3. Summary: Data compression library with very fast (de)compression
  4. Summary(ja): 高速なデータ圧縮ライブラリ
  5. Version: 2.10
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv2+
  9. URL: http://www.oberhumer.com/opensource/lzo/
  10. Source0: http://www.oberhumer.com/opensource/lzo/download/%{name}-%{version}.tar.gz
  11. Patch0: lzo-2.08-configure.patch
  12. Patch1: lzo-2.08-rhbz1309225.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: zlib-devel
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. LZO is a portable lossless data compression library written in ANSI C.
  19. It offers pretty fast compression and very fast decompression.
  20. Decompression requires no memory. In addition there are slower
  21. compression levels achieving a quite competitive compression ratio
  22. while still decompressing at this very high speed.
  23. %package minilzo
  24. Summary: Mini version of lzo for apps which don't need the full version
  25. Group: System Environment/Libraries
  26. %description minilzo
  27. A small (mini) version of lzo for embedding into applications which don't need
  28. full blown lzo compression support.
  29. %package devel
  30. Summary: Development files for the lzo library
  31. Summary(ja): lzo ライブラリの開発ファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: %{name}-minilzo = %{version}-%{release}
  35. Requires: zlib-devel
  36. %description devel
  37. LZO is a portable lossless data compression library written in ANSI C.
  38. It offers pretty fast compression and very fast decompression.
  39. This package contains development files needed for lzo.
  40. %package -n compat32-%{name}
  41. Summary: Data compression library with very fast (de)compression
  42. Summary(ja): 高速なデータ圧縮ライブラリ
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. LZO is a portable lossless data compression library written in ANSI C.
  46. It offers pretty fast compression and very fast decompression.
  47. Decompression requires no memory. In addition there are slower
  48. compression levels achieving a quite competitive compression ratio
  49. while still decompressing at this very high speed.
  50. %package -n compat32-%{name}-minilzo
  51. Summary: Mini version of lzo for apps which don't need the full version
  52. Group: System Environment/Libraries
  53. Requires: %{name}-minilzo = %{version}-%{release}
  54. %description -n compat32-%{name}-minilzo
  55. A small (mini) version of lzo for embedding into applications which don't need
  56. full blown lzo compression support.
  57. %package -n compat32-%{name}-devel
  58. Summary: Development files for the lzo library
  59. Summary(ja): lzo ライブラリの開発ファイル
  60. Group: Development/Libraries
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. Requires: %{name}-minilzo = %{version}-%{release}
  63. Requires: compat32-zlib-devel
  64. %description -n compat32-%{name}-devel
  65. LZO is a portable lossless data compression library written in ANSI C.
  66. It offers pretty fast compression and very fast decompression.
  67. This package contains development files needed for lzo.
  68. %prep
  69. %setup -q
  70. %patch0 -p1 -z .configure
  71. %patch1 -p1 -z .rhbz1309225
  72. # mark asm files as NOT needing execstack
  73. for i in asm/i386/src_gas/*.S; do
  74. echo '.section .note.GNU-stack,"",@progbits' >> $i
  75. done
  76. %build
  77. %configure --disable-dependency-tracking --disable-static --enable-shared
  78. make %{?_smp_mflags}
  79. # build minilzo too (bz 439979)
  80. gcc %{optflags} -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
  81. gcc -g -shared -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. rm $RPM_BUILD_ROOT%{_libdir}/liblzo2.la
  86. install -m 755 libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}
  87. ln -s libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}/libminilzo.so
  88. install -p -m 644 minilzo/minilzo.h $RPM_BUILD_ROOT%{_includedir}/lzo
  89. rm -rf %{buildroot}%{_docdir}/lzo
  90. %check
  91. make check test
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %post minilzo -p /sbin/ldconfig
  97. %postun minilzo -p /sbin/ldconfig
  98. %post -n compat32-%{name} -p /sbin/ldconfig
  99. %postun -n compat32-%{name} -p /sbin/ldconfig
  100. %post -n compat32-%{name}-minilzo -p /sbin/ldconfig
  101. %postun -n compat32-%{name}-minilzo -p /sbin/ldconfig
  102. %files
  103. %defattr(-,root,root,-)
  104. %doc AUTHORS ChangeLog COPYING NEWS README THANKS
  105. %{_libdir}/liblzo2.so.*
  106. %files minilzo
  107. %defattr(-,root,root,-)
  108. %doc minilzo/README.LZO
  109. %{_libdir}/libminilzo.so.*
  110. %files devel
  111. %defattr(-,root,root,-)
  112. %doc doc/LZOAPI.TXT doc/LZO.FAQ doc/LZO.TXT
  113. %{_includedir}/lzo
  114. %{_libdir}/lib*lzo*.so
  115. %{_libdir}/pkgconfig/lzo2.pc
  116. # compat32
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-,root,root,-)
  120. %{_libdir}/liblzo2.so.*
  121. %files -n compat32-%{name}-minilzo
  122. %defattr(-,root,root,-)
  123. %{_libdir}/libminilzo.so.0
  124. %files -n compat32-%{name}-devel
  125. %defattr(-,root,root,-)
  126. %{_libdir}/lib*lzo*.so
  127. %{_libdir}/pkgconfig/lzo2.pc
  128. %endif
  129. %changelog
  130. * Sat Dec 30 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-1
  131. - new upstream release.
  132. - updated Patch0.
  133. - imported Patch1 from rawhide.
  134. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.03-4
  135. - rebuild with VineSeed environment
  136. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.03-3
  137. - rebuilt with current VineSeed
  138. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.03-2
  139. - added compat32 package for x86_64 arch support
  140. * Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.03-1
  141. - initial build for Vine Linux
  142. * Thu May 1 2008 Lubomir Rintel <lkundrak@v3.sk> 2.03-1
  143. - New upstream release
  144. - Changed the license to GPLv2+
  145. * Wed Apr 2 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-5
  146. - Fix configure failure with -Werror-implicit-function-declaration in CFLAGS
  147. - Add a minilzo subpackage which contains a shared version of minilzo, to be
  148. used by all applications which ship with their own copy of it (bz 439979)
  149. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.02-4
  150. - Autorebuild for GCC 4.3
  151. * Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-3
  152. - Update License tag for new Licensing Guidelines compliance
  153. * Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-2
  154. - FE6 Rebuild
  155. * Wed Jul 26 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-1
  156. - New upstream release 2.02, soname change!
  157. * Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
  158. - Taking over as maintainer since Anvil has other priorities
  159. - Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to
  160. Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for the initial patch.
  161. - Removed unused build dependency on nasm
  162. - Remove static lib
  163. - Cleanup %%doc a bit
  164. * Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 1.08-6.fc5
  165. - Rebuild for new gcc
  166. * Tue Jan 17 2006 Dams <anvil[AT]livna.org> - 1.08-5.fc5
  167. - Bumped release for gcc 4.1 rebuild
  168. * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.08-4
  169. - rebuild on all arches
  170. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  171. - rebuilt
  172. * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.08-0.fdr.2
  173. - Typo un devel description
  174. - Added post and postun scriptlets
  175. - Added URL in Source0
  176. * Fri Apr 25 2003 Dams <anvil[AT]livna.org>
  177. - Initial build.