gtk-vnc-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. # Plugin isn't ready for real world use yet - it needs
  2. # a security audit at very least
  3. %define with_plugin 0
  4. Summary: A GTK widget for VNC clients
  5. Summary(ja): VNCクライアント用 GTK ウィジェット
  6. Name: gtk-vnc
  7. Version: 0.3.9
  8. Release: 2%{?_dist_release}
  9. License: LGPLv2+
  10. Group: Development/Libraries
  11. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. Patch100: gtk-vnc-0.3.8-fast.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. URL: http://gtk-vnc.sf.net/
  15. BuildRequires: gtk2-devel pygtk2-devel python-devel zlib-devel
  16. BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
  17. %if %{with_plugin}
  18. BuildRequires: xulrunner-devel
  19. %endif
  20. %description
  21. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  22. allowing it to be completely asynchronous while remaining single threaded.
  23. %package devel
  24. Summary: Development filesdor gtk-vnc library
  25. Summary(ja): gtk-vnc ライブラリの開発ファイル
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}
  28. Requires: pkgconfig
  29. Requires: pygtk2-devel gtk2-devel gnutls-devel
  30. %description devel
  31. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  32. allowing it to be completely asynchronous while remaining single threaded.
  33. Libraries, includes, etc. to compile with the gtk-vnc library
  34. %package python
  35. Summary: Python bindings for the gtk-vnc library
  36. Summary(ja): gtk-vnc ライブラリの python バインディング
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}
  39. %description python
  40. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  41. allowing it to be completely asynchronous while remaining single threaded.
  42. A module allowing use of the GTK-VNC widget from python
  43. %if %{with_plugin}
  44. %package plugin
  45. Summary: Mozilla plugin for the gtk-vnc library
  46. Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}
  49. %description plugin
  50. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  51. allowing it to be completely asynchronous while remaining single threaded.
  52. This package provides a web browser plugin for Mozilla compatible
  53. browsers.
  54. %endif
  55. %prep
  56. %setup -q
  57. %patch100 -p1
  58. %build
  59. %if %{with_plugin}
  60. %configure --enable-plugin=yes
  61. %else
  62. %configure
  63. %endif
  64. %__make %{?_smp_mflags}
  65. %install
  66. rm -fr %{buildroot}
  67. %__make install DESTDIR=%{buildroot}
  68. rm -f %{buildroot}%{_libdir}/*.a
  69. rm -f %{buildroot}%{_libdir}/*.la
  70. rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
  71. rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
  72. %if %{with_plugin}
  73. rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
  74. rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
  75. %endif
  76. %clean
  77. rm -fr %{buildroot}
  78. %post -p /sbin/ldconfig
  79. %postun -p /sbin/ldconfig
  80. %files
  81. %defattr(-, root, root)
  82. %doc AUTHORS ChangeLog NEWS README COPYING.LIB
  83. %{_libdir}/lib*.so.*
  84. %files devel
  85. %defattr(-, root, root)
  86. %doc examples/gvncviewer.c
  87. %{_libdir}/lib*.so
  88. %dir %{_includedir}/%{name}-1.0/
  89. %{_includedir}/%{name}-1.0/*.h
  90. %{_libdir}/pkgconfig/%{name}-1.0.pc
  91. %files python
  92. %defattr(-, root, root)
  93. %doc examples/gvncviewer.py
  94. %{_libdir}/python*/site-packages/gtkvnc.so
  95. %if %{with_plugin}
  96. %files plugin
  97. %defattr(-, root, root)
  98. %{_libdir}/mozilla/plugins/%{name}-plugin.so
  99. %endif
  100. %changelog
  101. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
  102. - rebuild with python-2.6
  103. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
  104. - new upstream release
  105. - add Patch100 to speed up
  106. - add BR: cyrus-sasl-devel
  107. * Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
  108. - rebuild with gnutls-2.6.3
  109. * Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
  110. - new upstream release
  111. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
  112. - initial build for Vine Linux
  113. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.7-1
  114. - Update to 0.3.7
  115. * Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
  116. - Fix key/mouse event propagation (rhbz #454627)
  117. * Mon Jul 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
  118. - fix conditional comparison
  119. * Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
  120. - Rebuild for GNU TLS ABI change
  121. * Wed May 7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
  122. - Updated to 0.3.6 release
  123. * Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
  124. - Update to 0.3.5
  125. * Fri Apr 4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
  126. - Remove bogus chunk of render patch
  127. * Thu Apr 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
  128. - Fix OpenGL rendering artifacts (rhbz #440184)
  129. * Thu Apr 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
  130. - Fixed endianness conversions
  131. - Fix makecontext() args crash on x86_64
  132. - Fix protocol version negotiation
  133. * Thu Mar 6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
  134. - Update to 0.3.4 release
  135. - Fix crash with OpenGL scaling code
  136. * Sun Feb 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
  137. - Update to 0.3.3 release
  138. * Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
  139. - Track keystate to avoid stuck modifier keys
  140. * Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
  141. - Update to 0.3.2 release
  142. - Added dep on zlib-devel
  143. * Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
  144. - Update to 0.3.1 release
  145. * Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
  146. - Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
  147. * Thu Oct 4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
  148. - Fixed coroutine caller to avoid SEGV
  149. * Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
  150. - Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
  151. * Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
  152. - Update to 0.2.0 release
  153. * Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
  154. - Fixed handling of mis-matched client/server colour depths
  155. * Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
  156. - Fix mixed endian handling & BGR pixel format (rhbz #253597)
  157. - Clear widget areas outside of framebuffer (rhbz #253599)
  158. - Fix off-by-one in python demo
  159. * Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
  160. - Tweaked post scripts
  161. - Removed docs from sub-packages
  162. - Explicitly set license to LGPLv2+
  163. - Remove use of macro for install rule
  164. * Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
  165. - Added gnutls-devel requirement to -devel package
  166. * Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
  167. - Initial official release