xulrunner-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782
  1. %define nspr_version 4.8
  2. %define nss_version 3.12.3
  3. %define cairo_version 1.8.6
  4. %define libnotify_version 0.4
  5. %define tarballdir mozilla-1.9.2
  6. %define build_vine6 0
  7. %define build_vine5 0
  8. %if "%{?_dist_release}" == "vl6"
  9. %define build_vine6 1
  10. %define build_vine5 1
  11. %endif
  12. %if "%{?_dist_release}" == "vl5"
  13. %define build_vine5 1
  14. %endif
  15. %if %build_vine6
  16. %define sqlite_version 3.6.21
  17. %endif
  18. %define version_internal 1.9.2
  19. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  20. Summary: XUL Runtime for Gecko Applications
  21. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  22. Name: xulrunner
  23. Version: 1.9.2.2
  24. Release: 1%{?_dist_release}
  25. URL: http://www.mozilla.org/projects/xulrunner/
  26. License: MPLv1.1 or GPLv2+ or LGPLv2+
  27. Group: Applications/Internet
  28. Source0: %{name}-%{version}-source.tar.bz2
  29. Source10: %{name}-mozconfig
  30. Source11: %{name}-mozconfig-vine5
  31. Source12: %{name}-vine-default-prefs.js
  32. Source21: %{name}.sh.in
  33. Source23: %{name}.1
  34. # locale sources
  35. %define MOZ_BUILD_LOCALES "ja"
  36. Source1000: xulrunner-%{version}-ja.tar.bz2
  37. # build patches
  38. Patch0: xulrunner-version.patch
  39. Patch1: mozilla-build.patch
  40. Patch3: mozilla-jemalloc.patch
  41. Patch5: mozilla-jemalloc-526152.patch
  42. Patch8: mozilla-plugin.patch
  43. # patches from Fedora
  44. Patch10: mozilla-192-pkgconfig.patch
  45. # Upstream patches
  46. Patch26: mozilla-ps-pdf-simplify-operators.patch
  47. # ---------------------------------------------------
  48. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  49. BuildRequires: nspr-devel >= %{nspr_version}
  50. BuildRequires: nss-devel >= %{nss_version}
  51. BuildRequires: cairo-devel >= %{cairo_version}
  52. BuildRequires: libpng-devel
  53. BuildRequires: libjpeg-devel
  54. BuildRequires: bzip2-devel
  55. BuildRequires: zlib-devel
  56. BuildRequires: lcms-devel
  57. BuildRequires: libIDL-devel
  58. BuildRequires: gtk2-devel
  59. BuildRequires: gnome-vfs2-devel
  60. BuildRequires: libgnome-devel
  61. BuildRequires: libgnomeui-devel
  62. BuildRequires: pango-devel
  63. BuildRequires: freetype2-devel >= 2.1.9
  64. BuildRequires: libXt-devel
  65. BuildRequires: libXrender-devel
  66. %if %{build_vine6}
  67. BuildRequires: sqlite3-devel >= %{sqlite_version}
  68. %endif
  69. BuildRequires: libnotify-devel >= %{libnotify_version}
  70. BuildRequires: startup-notification-devel
  71. BuildRequires: alsa-lib-devel
  72. BuildRequires: lcms-devel
  73. BuildRequires: zip
  74. # For -sqlite.patch
  75. BuildRequires: autoconf213
  76. Requires: nspr >= %{nspr_version}
  77. Requires: nss >= %{nss_version}
  78. Provides: gecko-libs = %{version}
  79. %description
  80. XULRunner provides the XUL Runtime environment for Gecko applications.
  81. %package devel
  82. Summary: Development files for Gecko
  83. Group: Development/Libraries
  84. Obsoletes: mozilla-devel
  85. Obsoletes: firefox-devel < 2.1
  86. Obsoletes: xulrunner-devel-unstable
  87. Provides: gecko-devel = %{version}
  88. Provides: gecko-devel-unstable = %{version}
  89. Requires: xulrunner = %{version}-%{release}
  90. Requires: nspr-devel >= %{nspr_version}
  91. Requires: nss-devel >= %{nss_version}
  92. Requires: cairo-devel >= %{cairo_version}
  93. Requires: libjpeg-devel
  94. Requires: zip
  95. Requires: bzip2-devel
  96. Requires: zlib-devel
  97. Requires: lcms-devel
  98. Requires: libIDL-devel
  99. Requires: gtk2-devel
  100. Requires: gnome-vfs2-devel
  101. Requires: libgnome-devel
  102. Requires: libgnomeui-devel
  103. Requires: pango-devel
  104. Requires: freetype2-devel >= 2.1.9
  105. Requires: libXt-devel
  106. Requires: libXrender-devel
  107. %if %{build_vine6}
  108. Requires: sqlite3-devel >= %{sqlite_version}
  109. %endif
  110. Requires: startup-notification-devel
  111. Requires: alsa-lib-devel
  112. %description devel
  113. Gecko development files.
  114. #---------------------------------------------------------------------
  115. %prep
  116. %setup -q -c -b 1000
  117. cd %{tarballdir}
  118. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
  119. %{P:%%PATCH0} > version.patch
  120. %{__patch} -p1 -b --suffix .version < version.patch
  121. %patch1 -p1 -b .build
  122. %patch3 -p1 -b .jemalloc
  123. %patch5 -p1 -b .jemalloc-526152
  124. %patch8 -p1 -b .plugin
  125. %patch10 -p1 -b .pkgconfig
  126. %patch26 -p1 -b .ps-pdf-simplify-operators
  127. %{__rm} -f .mozconfig
  128. %if %{build_vine6}
  129. %{__cp} %{SOURCE10} .mozconfig
  130. %else
  131. %{__cp} %{SOURCE11} .mozconfig
  132. %endif
  133. #---------------------------------------------------------------------
  134. %build
  135. cd %{tarballdir}
  136. INTERNAL_GECKO=%{version_internal}
  137. MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
  138. # Mozilla builds with -Wall with exception of a few warnings which show up
  139. # everywhere in the code; so, don't override that.
  140. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
  141. export CFLAGS=$MOZ_OPT_FLAGS
  142. export CXXFLAGS=$MOZ_OPT_FLAGS
  143. export PREFIX='%{_prefix}'
  144. export LIBDIR='%{_libdir}'
  145. MOZ_SMP_FLAGS=-j1
  146. %ifnarch ppc ppc64 s390 s390x
  147. [ -z "$RPM_BUILD_NCPUS" ] && \
  148. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  149. [ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
  150. %endif
  151. export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
  152. make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  153. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  154. # build locales
  155. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  156. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  157. for dir in $LOCALEDIRS
  158. do
  159. for lang in %{MOZ_BUILD_LOCALES} ; do
  160. make -C $dir/locales AB_CD=$lang
  161. done
  162. done
  163. #---------------------------------------------------------------------
  164. %install
  165. cd %{tarballdir}
  166. %{__rm} -rf $RPM_BUILD_ROOT
  167. INTERNAL_GECKO=%{version_internal}
  168. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  169. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  170. INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
  171. MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
  172. #DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  173. DESTDIR=$RPM_BUILD_ROOT make install
  174. %{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
  175. $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  176. $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
  177. %{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
  178. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  179. # set up our default preferences
  180. %{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
  181. %{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
  182. %{__rm} vl-default-prefs
  183. # Start script install
  184. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  185. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
  186. $RPM_BUILD_ROOT%{_bindir}/%{name}
  187. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  188. %{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
  189. cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
  190. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
  191. cd -
  192. # install locales
  193. for lang in %{MOZ_BUILD_LOCALES} ; do
  194. %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
  195. done
  196. # Prepare our devel package
  197. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  198. %{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
  199. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  200. %{__cp} -rL dist/include/* \
  201. $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  202. # Copy pc files (for compatibility with 1.9.1)
  203. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  204. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  205. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  206. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  207. # Fix multilib devel conflicts...
  208. %ifarch x86_64 ia64 s390x ppc64
  209. %define mozbits 64
  210. %else
  211. %define mozbits 32
  212. %endif
  213. function install_file() {
  214. genheader=$*
  215. mv ${genheader}.h ${genheader}%{mozbits}.h
  216. cat > ${genheader}.h << EOF
  217. // This file exists to fix multilib conflicts
  218. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
  219. #include "${genheader}64.h"
  220. #else
  221. #include "${genheader}32.h"
  222. #endif
  223. EOF
  224. }
  225. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  226. install_file "mozilla-config"
  227. popd
  228. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  229. install_file "jsautocfg"
  230. popd
  231. %{__install} -p -c -m 755 dist/bin/xpcshell \
  232. dist/bin/xpidl \
  233. dist/bin/xpt_dump \
  234. dist/bin/xpt_link \
  235. $RPM_BUILD_ROOT/${MOZ_APP_DIR}
  236. %{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  237. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
  238. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  239. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  240. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  241. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  242. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  243. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  244. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  245. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  246. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  247. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  248. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  249. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  250. find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
  251. find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
  252. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
  253. pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
  254. for i in *.so; do
  255. ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
  256. done
  257. popd
  258. # GRE stuff
  259. %ifarch x86_64 ia64 ppc64 s390x
  260. %define gre_conf_file gre64.conf
  261. %else
  262. %define gre_conf_file gre.conf
  263. %endif
  264. MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
  265. %{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
  266. $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  267. chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  268. # Library path
  269. %ifarch x86_64 ia64 ppc64 s390x
  270. %define ld_conf_file xulrunner-64.conf
  271. %else
  272. %define ld_conf_file xulrunner-32.conf
  273. %endif
  274. %{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
  275. %{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
  276. ${MOZ_APP_DIR}
  277. EOF
  278. # Copy over the LICENSE
  279. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
  280. # Use the system hunspell dictionaries
  281. %{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  282. ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  283. # ghost files
  284. %{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
  285. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
  286. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
  287. #---------------------------------------------------------------------
  288. %clean
  289. %{__rm} -rf $RPM_BUILD_ROOT
  290. #---------------------------------------------------------------------
  291. %post
  292. /sbin/ldconfig
  293. %postun
  294. /sbin/ldconfig
  295. %preun
  296. # is it a final removal?
  297. if [ $1 -eq 0 ]; then
  298. %{__rm} -rf ${MOZ_APP_DIR}/components
  299. fi
  300. %files
  301. %defattr(-,root,root,-)
  302. %{_bindir}/xulrunner
  303. %dir /etc/gre.d
  304. /etc/gre.d/%{gre_conf_file}
  305. %dir %{mozappdir}
  306. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  307. %doc %attr(644, root, root) %{mozappdir}/README.txt
  308. %{mozappdir}/chrome
  309. %{mozappdir}/dictionaries
  310. %dir %{mozappdir}/components
  311. %ghost %{mozappdir}/components/compreg.dat
  312. %ghost %{mozappdir}/components/xpti.dat
  313. %{mozappdir}/components/*.so
  314. %{mozappdir}/components/*.xpt
  315. %attr(644, root, root) %{mozappdir}/components/*.js
  316. %{mozappdir}/defaults
  317. %{mozappdir}/greprefs
  318. %dir %{mozappdir}/icons
  319. %attr(644, root, root) %{mozappdir}/icons/*
  320. %{mozappdir}/modules
  321. %{mozappdir}/plugins
  322. %{mozappdir}/res
  323. %{mozappdir}/*.so
  324. %{mozappdir}/mozilla-xremote-client
  325. %{mozappdir}/run-mozilla.sh
  326. %{mozappdir}/regxpcom
  327. %{mozappdir}/xulrunner
  328. %{mozappdir}/xulrunner-bin
  329. %{mozappdir}/xulrunner-stub
  330. %{mozappdir}/platform.ini
  331. %{mozappdir}/dependentlibs.list
  332. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  333. # XXX See if these are needed still
  334. %{mozappdir}/updater*
  335. %exclude %{mozappdir}/update.locale
  336. %exclude %{mozappdir}/components/components.list
  337. %files devel
  338. %defattr(-,root,root,-)
  339. %dir %{_datadir}/idl/%{name}*%{version_internal}
  340. %{_datadir}/idl/%{name}*%{version_internal}/*
  341. %{_includedir}/%{name}*%{version_internal}
  342. %dir %{_libdir}/%{name}-sdk-*
  343. %dir %{_libdir}/%{name}-sdk-*/sdk
  344. %{_libdir}/%{name}-sdk-*/*
  345. %{_libdir}/%{name}-sdk-*/sdk/*
  346. %{_libdir}/pkgconfig/*.pc
  347. %{mozappdir}/xpcshell
  348. %{mozappdir}/xpidl
  349. %{mozappdir}/xpt_dump
  350. %{mozappdir}/xpt_link
  351. #---------------------------------------------------------------------
  352. %changelog
  353. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  354. - update to 1.9.2.2 (sync with firefox-3.6.2)
  355. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  356. - enable libnotify support
  357. - add ac_add_options --enable-libnotify
  358. - disable Necko wifi monitor
  359. - add ac_add_options --disable-necko-wifi
  360. - remove BR: wireless-tools-devel
  361. - fix %%files devel
  362. - add patch3,5 to fix jemalloc alignment assertion
  363. - add Patch8 to fix mozilla-plugin.pc
  364. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  365. - add BR: libnotify-devel, wireless-tools-devel
  366. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  367. - update to 1.9.2 (sync with firefox-3.6)
  368. - obsoletes xulrunner-devel-unstable
  369. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  370. - use internal sqlite3 on vine5
  371. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  372. - update to 1.9.1.7
  373. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  374. - update to 1.9.1.6
  375. - build with sqlite3-3.6.21
  376. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  377. - update to 1.9.1.5
  378. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  379. - update to 1.9.1.3
  380. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  381. - really update to 1.9.1.2 (<BTS:0748>)
  382. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  383. - update to 1.9.1.2 (sync with firefox-3.5.2)
  384. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  385. - update to 1.9.1.1 (sync with firefox-3.5.1)
  386. - add missing Requires to -devel
  387. - add missing BR
  388. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  389. - enable-system-cairo
  390. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  391. - update to 1.9.1 (based on firefox 3.5)
  392. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  393. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  394. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  395. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  396. - remove old patches
  397. - require nspr >= 4.8
  398. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  399. - new upstream release
  400. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  401. - update mozconfig
  402. - disable-system-cairo for stability
  403. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  404. - new upstream release
  405. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  406. - new upstream release
  407. - add ja locale
  408. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  409. - new upstream release
  410. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  411. - new upstream release
  412. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  413. - add Patch3
  414. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  415. - update to xulrunner 1.9.0.2 byild 6
  416. - build with gnome-2.24
  417. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  418. - new upstream release
  419. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  420. - initial build for Vine Linux
  421. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  422. - Update to 1.9 final
  423. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  424. - Simplify PS/PDF operators
  425. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  426. - Upstream patch to fsync() less
  427. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  428. - Ensure we enable startup notification; add BR and modify config
  429. (bug #445543)
  430. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  431. - Some files moved to mozilla-filesystem; kill them and add the Req
  432. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  433. - Clean up the %%files list and get rid of the executable bit on some files
  434. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  435. - Fix font scaling
  436. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  437. - Enabled phishing protection (#443403)
  438. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  439. - Changed "__ppc64__" to "__powerpc64__",
  440. "__ppc64__" doesn't work anymore
  441. - Added fix for #443725 - Critical hanging bug with fix
  442. available upstream (mozbz#429903)
  443. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  444. - Fixed multilib issues, added starting script instead of a symlink
  445. to binary (#436393)
  446. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  447. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  448. - Re-enable system cairo
  449. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  450. - Spec cleanups
  451. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  452. - Beta 5
  453. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  454. - Beta 5 RC2
  455. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  456. - Update to latest trunk (2008-03-27)
  457. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  458. - Update to latest trunk (2008-03-26)
  459. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  460. - Update to latest trunk (2008-03-25)
  461. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  462. - Update to latest trunk (2008-03-24)
  463. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  464. - Update to latest trunk (2008-03-20)
  465. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  466. - Update to latest trunk (2008-03-17)
  467. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  468. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  469. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  470. - Update to latest trunk (2008-03-16)
  471. - Add patch to negate a11y slowdown on some pages (#431162)
  472. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  473. - Update to latest trunk (2008-03-15)
  474. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  475. - Avoid conflicts between gecko debuginfo packages
  476. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  477. - Update to latest trunk (2008-03-12)
  478. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  479. - Update to latest trunk (2008-03-11)
  480. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  481. - Update to latest trunk (2008-03-10)
  482. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  483. - Update to latest trunk (2008-03-09)
  484. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  485. - Update to latest trunk (2008-03-07)
  486. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  487. - Update to latest trunk (2008-03-06)
  488. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  489. - Update to latest trunk (2008-03-04)
  490. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  491. - Update to latest trunk (2008-03-02)
  492. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  493. - Update to latest trunk (2008-03-01)
  494. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  495. - Update to latest trunk (2008-02-29)
  496. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  497. - Update to latest trunk (2008-02-28)
  498. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  499. - Update to latest trunk (2008-02-27)
  500. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  501. - Update to latest trunk (2008-02-26)
  502. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  503. - Update to latest trunk (2008-02-23)
  504. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  505. - Update to latest trunk (2008-02-22)
  506. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  507. - Update to latest trunk (2008-02-21)
  508. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  509. - Update to latest trunk (2008-02-20)
  510. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  511. - Update to latest trunk (2008-02-17)
  512. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  513. - Update to latest trunk (2008-02-15)
  514. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  515. - Update to latest trunk (2008-02-14)
  516. - Use system hunspell
  517. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  518. - Update to latest trunk (2008-02-11)
  519. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  520. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  521. you know, debuginfo.
  522. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  523. - Update to latest trunk (2008-02-10)
  524. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  525. - Update to latest trunk (2008-02-09)
  526. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  527. - Update to latest trunk (2008-02-06)
  528. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  529. - Update to latest trunk (2008-01-30)
  530. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  531. - rebuild agains new nss
  532. - enabled gnome vfs
  533. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  534. - fixed stable pkg-config files (#429654)
  535. - removed sqlite patch
  536. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  537. - Update to latest trunk (2008-01-21)
  538. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  539. - Update to latest trunk (2008-01-15)
  540. - Now with system extensions directory support
  541. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  542. - Update to latest trunk (2008-01-13)
  543. - Use CFLAGS instead of configure arguments
  544. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  545. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  546. - Provide gecko-devel-unstable as well
  547. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  548. - divided devel package to devel and devel-unstable
  549. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  550. - removed fedora specific pkg-config files
  551. - updated to the latest trunk (2008-01-07)
  552. - removed unnecessary patches
  553. - fixed idl dir (#427965)
  554. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  555. - Re-enable camellia256 support now that NSS supports it
  556. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  557. - updated to the latest trunk (2008-01-03)
  558. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  559. - Don't Provide webclient (xulrunner is not itself a webclient)
  560. - Don't Obsolete old firefox, only firefox-devel
  561. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  562. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  563. - added java and plugin subdirs to plugin includes
  564. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  565. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  566. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  567. - updated to Beta 2.
  568. - moved SDK to xulrunner-sdk
  569. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  570. - fixed mozilla-plugin.pc (#412971)
  571. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  572. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  573. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  574. - added xulrunner/js include dir to xulrunner-js
  575. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  576. - update to beta 1
  577. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  578. - packed all gecko libraries (#389391)
  579. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  580. - registered xulrunner libs system-wide
  581. - added xulrunner-gtkmozembed.pc
  582. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  583. - added proper nss/nspr dependencies
  584. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  585. - more build fixes, use system nss libraries
  586. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  587. - build fixes
  588. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  589. - updated to the latest trunk
  590. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  591. - build fixes for ppc/ppc64
  592. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  593. - removed conflicts with the current gecko-based apps
  594. - added updated ppc64 patch
  595. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  596. - build fixes
  597. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  598. - Initial cut at XULRunner 1.9 Alpha 7
  599. - Temporarily revert camellia 256 support since our nss doesn't support it yet