dbus-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. %define gettext_package dbus
  5. %define expat_version 2.0.1
  6. %define dbus_user_uid 81
  7. %global _localstatedir %{_var}
  8. %{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
  9. %{!?_unitdir:%global _unitdir /lib/systemd/system}
  10. %{!?_userunitdir:%global _userunitdir /usr/lib/systemd/user}
  11. Summary: D-BUS message bus
  12. Summary(ja): D-BUS メッセージバスシステム
  13. Name: dbus
  14. Version: 1.12.20
  15. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  16. Group: System Environment/Libraries
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. License: AFL/GPLv2
  20. URL: https://www.freedesktop.org/software/dbus/
  21. Source0: https://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
  22. Source1: 00-start-message-bus.sh
  23. Source2: dbus.init
  24. Source3: dbus.service
  25. Source4: dbus.user.service
  26. Source5: dbus.socket
  27. Source6: dbus.user.socket
  28. # from fedora package
  29. # from gentoo
  30. Patch1000: dbus-enable-elogind.patch
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. # default daemon
  33. Requires: %{name}-daemon = %{version}-%{release}
  34. BuildRequires: autoconf-archive
  35. BuildRequires: libtool
  36. BuildRequires: expat-devel >= %{expat_version}
  37. BuildRequires: libxml2-devel
  38. BuildRequires: python-devel
  39. BuildRequires: doxygen
  40. BuildRequires: xmlto
  41. BuildRequires: libxslt
  42. BuildRequires: gettext
  43. BuildRequires: libX11-devel
  44. BuildRequires: libSM-devel
  45. %if %{with systemd}
  46. BuildRequires: systemd-devel
  47. %else
  48. BuildRequires: elogind-devel
  49. %endif
  50. %description
  51. D-BUS is a system for sending messages between applications. It is
  52. used both for the systemwide message bus service, and as a
  53. per-user-login-session messaging facility.
  54. %description -l ja
  55. D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
  56. システム全体のメッセージバスサービスとしても利用されますが、同様に
  57. ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
  58. %package common
  59. Summary: D-BUS message bus configuration
  60. BuildArch: noarch
  61. %if %{with systemd}
  62. %{?systemd_requires}
  63. Requires: systemd
  64. %endif
  65. %description common
  66. The %{name}-common package provides the configuration and setup files for D-Bus
  67. implementations to provide a System and User Message Bus.
  68. %package daemon
  69. Summary: D-BUS message bus
  70. %{?systemd_requires}
  71. Requires: dbus-common = %{version}-%{release}
  72. Requires: dbus-libs%{?_isa} = %{version}-%{release}
  73. Requires: dbus-tools = %{version}-%{release}
  74. Requires(pre): shadow-utils
  75. %if %{with systemd}
  76. %{?systemd_requires}
  77. Requires: systemd
  78. %else
  79. Requires(post): chkconfig >= 1.3.34
  80. Requires(preun): chkconfig >= 1.3.34
  81. %endif
  82. %description daemon
  83. D-BUS is a system for sending messages between applications. It is
  84. used both for the system-wide message bus service, and as a
  85. per-user-login-session messaging facility.
  86. %package libs
  87. Summary: Libraries for accessing D-BUS
  88. %description libs
  89. This package contains lowlevel libraries for accessing D-BUS.
  90. %package tools
  91. Summary: D-BUS Tools and Utilities
  92. Requires: dbus-libs%{?_isa} = %{version}-%{release}
  93. %description tools
  94. Tools and utilities to interact with a running D-Bus Message Bus, provided by
  95. the reference implementation.
  96. %package devel
  97. Summary: Libraries and headers for D-BUS
  98. Summary(ja): D-BUS 用のライブラリとヘッダファイル
  99. Group: Development/Libraries
  100. Requires: %{name}-libs = %{version}-%{release}
  101. Requires: xml-common
  102. %description devel
  103. Headers and static libraries for D-BUS.
  104. %package x11
  105. Summary: X11-requiring add-ons for D-BUS
  106. Summary(ja): X11 を利用する D-BUS 用ツール
  107. Group: Applications/System
  108. Requires: %{name} = %{version}-%{release}
  109. %description x11
  110. D-BUS contains some tools that require Xlib to be installed, those are
  111. in this separate package so server systems need not install X.
  112. %package doc
  113. Summary: Developer documentation for D-BUS
  114. Group: Documentation
  115. Requires: %{name} = %{version}-%{release}
  116. BuildArch: noarch
  117. %description doc
  118. This package contains developer documentation for D-Bus along with
  119. other supporting documentation such as the introspect dtd file.
  120. # compat32
  121. %package -n compat32-%{name}
  122. Summary: D-BUS message bus
  123. Summary(ja): D-BUS メッセージバスシステム
  124. Group: System Environment/Libraries
  125. %description -n compat32-%{name}
  126. D-BUS is a system for sending messages between applications. It is
  127. used both for the systemwide message bus service, and as a
  128. per-user-login-session messaging facility.
  129. %description -n compat32-%{name} -l ja
  130. D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
  131. システム全体のメッセージバスサービスとしても利用されますが、同様に
  132. ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
  133. %package -n compat32-%{name}-devel
  134. Summary: Libraries and headers for D-BUS
  135. Summary(ja): D-BUS 用のライブラリとヘッダファイル
  136. Group: Development/Libraries
  137. Requires: compat32-%{name} = %{version}-%{release}
  138. Requires: %{name}-devel = %{version}-%{release}
  139. %description -n compat32-%{name}-devel
  140. Headers and static libraries for D-BUS.
  141. %prep
  142. %setup
  143. %if ! %{with systemd}
  144. %patch1000 -p1 -b .elogind
  145. %endif
  146. %build
  147. # Avoid rpath.
  148. if test -f autogen.sh; then env NOCONFIGURE=1 ./autogen.sh; else autoreconf --ve
  149. rbose --force --install; fi
  150. COMMON_ARGS="--enable-selinux=no \
  151. %if %{with systemd}
  152. SYSTEMCTL=/bin/systemctl \
  153. --enable-systemd \
  154. --with-init-scripts=redhat \
  155. --with-systemdsystemunitdir=%{_unitdir} \
  156. --with-systemduserunitdir=%{_userunitdir} \
  157. --enable-user-session \
  158. --with-system-pid-file=/run/messagebus.pid \
  159. --with-system-socket=/run/dbus/system_bus_socket
  160. %else
  161. --enable-elogind \
  162. --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
  163. %endif
  164. --disable-libaudit \
  165. --with-dbus-user=dbus \
  166. --libdir=/%{_lib} --bindir=/bin \
  167. --libexecdir=/lib/dbus-1 \
  168. --docdir=%{_pkgdocdir} \
  169. --sysconfdir=%{_sysconfdir} --exec-prefix=/"
  170. %configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
  171. make V=1 %{?_smp_mflags}
  172. %install
  173. rm -rf %{buildroot}
  174. %__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  175. find %{buildroot} -name '*.a' -type f -delete
  176. find %{buildroot} -name '*.la' -type f -delete
  177. install -Dp -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
  178. # Obsolete, but still widely used, for drop-in configuration snippets.
  179. install --directory %{buildroot}%{_sysconfdir}/dbus-1/session.d
  180. install --directory %{buildroot}%{_sysconfdir}/dbus-1/system.d
  181. install --directory %{buildroot}%{_datadir}/dbus-1/interfaces
  182. %if %{with systemd}
  183. %__make install-data DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  184. # Make sure that when somebody asks for D-Bus under the name of the
  185. # old SysV script, that he ends up with the standard dbus.service name
  186. # now.
  187. ln -s dbus.service %{buildroot}%{_unitdir}/messagebus.service
  188. ## %find_lang %{gettext_package}
  189. # Delete the old legacy sysv init script
  190. #rm -rf %{buildroot}%{_initrddir}
  191. %else
  192. rm -rf %{buildroot}%{_sysconfdir}/systemd
  193. rm -rf %{buildroot}/lib/systemd
  194. rm -rf %{buildroot}%{_prefix}/lib/systemd
  195. rm -rf %{buildroot}%{_prefix}/lib/sysuserd.d
  196. rm -rf %{buildroot}%{_prefix}/lib/tmpfiles.d
  197. install -Dm755 %{SOURCE2} %{buildroot}%{_initrddir}/messagebus
  198. %endif
  199. install --directory %{buildroot}/var/lib/dbus
  200. install --directory %{buildroot}%{_pkgdocdir}
  201. install -pm 644 -t %{buildroot}%{_pkgdocdir} \
  202. doc/introspect.dtd doc/introspect.xsl doc/system-activation.txt
  203. # Make sure that the documentation shows up in Devhelp.
  204. install --directory %{buildroot}%{_datadir}/gtk-doc/html
  205. ln -s %{_pkgdocdir} %{buildroot}%{_datadir}/gtk-doc/html/dbus
  206. # Shell wrapper for installed tests, modified from Debian package.
  207. cat > dbus-run-installed-tests <<EOF
  208. #!/bin/sh
  209. # installed-tests wrapper for dbus. Outputs TAP format because why not
  210. set -e
  211. timeout="timeout 300s"
  212. ret=0
  213. i=0
  214. tmpdir=\$(mktemp --directory --tmpdir dbus-run-installed-tests.XXXXXX)
  215. for t in /lib/dbus-1/installed-tests/dbus/test-*; do
  216. i=\$(( \$i + 1 ))
  217. echo "# \$i - \$t ..."
  218. echo "x" > "\$tmpdir/result"
  219. ( set +e; \$timeout \$t; echo "\$?" > "\$tmpdir/result" ) 2>&1 | sed 's/^/#/'
  220. e="\$(cat "\$tmpdir/result")"
  221. case "\$e" in
  222. (0)
  223. echo "ok \$i - \$t"
  224. ;;
  225. (77)
  226. echo "ok \$i # SKIP \$t"
  227. ;;
  228. (*)
  229. echo "not ok \$i - \$t (\$e)"
  230. ret=1
  231. ;;
  232. esac
  233. done
  234. rm -rf tmpdir
  235. echo "1..\$i"
  236. exit \$ret
  237. EOF
  238. install -pm 755 -t %{buildroot}/lib/dbus-1 dbus-run-installed-tests
  239. ## vine stuff
  240. mkdir -p %{buildroot}%{_libdir}/cmake/DBus1
  241. mv -f \
  242. %{buildroot}/%{_lib}/cmake/DBus1/DBus1Config.cmake \
  243. %{buildroot}/%{_lib}/cmake/DBus1/DBus1ConfigVersion.cmake \
  244. %{buildroot}%{_libdir}/cmake/DBus1/
  245. mkdir -p %{buildroot}/%{_bindir}
  246. mv -f %{buildroot}/bin/dbus-launch %{buildroot}/%{_bindir}/
  247. mkdir -p %{buildroot}/%{_libdir}/dbus-1.0
  248. mv %{buildroot}/%{_lib}/dbus-1.0/include %{buildroot}/%{_libdir}/dbus-1.0/
  249. mkdir -p %{buildroot}/%{_libdir}/pkgconfig
  250. #change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
  251. sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' %{buildroot}/%{_lib}/pkgconfig/dbus-1.pc > %{buildroot}/%{_libdir}/pkgconfig/dbus-1.pc
  252. rm -f %{buildroot}/%{_lib}/pkgconfig/dbus-1.pc
  253. rm -f %{buildroot}/lib/dbus-1/dbus-run-installed-tests
  254. %if %{with systemd}
  255. rm -rf %{buildroot}/var/run/dbus
  256. install -m644 %{SOURCE3} %{buildroot}%{_unitdir}/dbus.service
  257. install -m644 %{SOURCE4} %{buildroot}%{_userunitdir}/dbus.service
  258. install -m644 %{SOURCE5} %{buildroot}%{_unitdir}/dbus.socket
  259. install -m644 %{SOURCE6} %{buildroot}%{_userunitdir}/dbus.socket
  260. %endif
  261. %clean
  262. rm -rf %{buildroot}
  263. %pre daemon
  264. # Add the "dbus" user
  265. /usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
  266. -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
  267. %post daemon
  268. %if %{with systemd}
  269. %systemd_post dbus.service
  270. %systemd_user_post dbus.service
  271. %else
  272. /sbin/chkconfig --add messagebus
  273. /sbin/chkconfig messagebus resetpriorities
  274. %endif
  275. %preun daemon
  276. %if %{with systemd}
  277. %systemd_preun dbus.service
  278. %systemd_user_preun dbus.service
  279. %else
  280. if [ $1 = 0 ]; then
  281. service messagebus stop > /dev/null 2>&1
  282. /sbin/chkconfig --del messagebus
  283. fi
  284. if [ -x /sbin/systemctl ]; then
  285. /sbin/chkconfig --del messagebus
  286. fi
  287. %endif
  288. %postun daemon
  289. %if %{with systemd}
  290. %systemd_postun dbus.service
  291. %systemd_user_postun dbus.service
  292. %endif
  293. %if !%{with systemd}
  294. %triggerpostun daemon -- dbus-daemon < 1.12.16-2
  295. /sbin/chkconfig --add messagebus
  296. /sbin/chkconfig messagebus resetpriorities
  297. %endif
  298. %if %{with systemd}
  299. %post common
  300. %systemd_post dbus.socket
  301. %systemd_user_post dbus.socket
  302. %preun common
  303. %systemd_preun dbus.socket
  304. %systemd_user_preun dbus.socket
  305. %postun common
  306. %systemd_postun dbus.socket
  307. %systemd_user_postun dbus.socket
  308. %endif
  309. %post libs -p /sbin/ldconfig
  310. %postun libs -p /sbin/ldconfig
  311. %post -n compat32-%{name} -p /sbin/ldconfig
  312. %postun -n compat32-%{name} -p /sbin/ldconfig
  313. %files
  314. # dummy package
  315. %files common
  316. %dir %{_sysconfdir}/dbus-1
  317. %dir %{_sysconfdir}/dbus-1/session.d
  318. %dir %{_sysconfdir}/dbus-1/system.d
  319. %config %{_sysconfdir}/dbus-1/session.conf
  320. %config %{_sysconfdir}/dbus-1/system.conf
  321. %dir %{_datadir}/dbus-1
  322. %dir %{_datadir}/dbus-1/session.d
  323. %dir %{_datadir}/dbus-1/system.d
  324. %{_datadir}/dbus-1/session.conf
  325. %{_datadir}/dbus-1/system.conf
  326. %{_datadir}/dbus-1/services
  327. %{_datadir}/dbus-1/system-services
  328. %{_datadir}/dbus-1/interfaces
  329. %if %{with systemd}
  330. %{_sysusersdir}/dbus.conf
  331. %{_unitdir}/dbus.socket
  332. %{_userunitdir}/dbus.socket
  333. %endif
  334. %files daemon
  335. %defattr(-,root,root)
  336. %{!?_licensedir:%global license %%doc}
  337. %license COPYING
  338. %doc AUTHORS ChangeLog NEWS README
  339. %config %{_sysconfdir}/dbus-1/*.conf
  340. %ghost %dir /run/%{name}
  341. %dir %{_localstatedir}/lib/dbus/
  342. /bin/dbus-daemon
  343. /bin/dbus-cleanup-sockets
  344. /bin/dbus-run-session
  345. /bin/dbus-test-tool
  346. %{_mandir}/man*/dbus-daemon.1.gz
  347. %{_mandir}/man*/dbus-cleanup-sockets.1.gz
  348. %{_mandir}/man*/dbus-run-session.1.gz
  349. %{_mandir}/man1/dbus-test-tool.1.gz
  350. %dir /lib/dbus-1
  351. %attr(4750,root,dbus) /lib/dbus-1/dbus-daemon-launch-helper
  352. %if %{with systemd}
  353. %{_tmpfilesdir}/dbus.conf
  354. %{_unitdir}/dbus.service
  355. %{_unitdir}/messagebus.service
  356. %{_unitdir}/multi-user.target.wants/dbus.service
  357. %{_unitdir}/sockets.target.wants/dbus.socket
  358. %{_userunitdir}/dbus.service
  359. %{_userunitdir}/sockets.target.wants/dbus.socket
  360. %else
  361. %dir %{_localstatedir}/run/dbus
  362. %{_sysconfdir}/rc.d/init.d/*
  363. %endif
  364. %files tools
  365. %license COPYING
  366. /bin/dbus-send
  367. /bin/dbus-monitor
  368. /bin/dbus-update-activation-environment
  369. /bin/dbus-uuidgen
  370. %{_mandir}/man*/dbus-send.1.gz
  371. %{_mandir}/man*/dbus-monitor.1.gz
  372. %{_mandir}/man1/dbus-update-activation-environment.1.gz
  373. %{_mandir}/man*/dbus-uuidgen.1.gz
  374. %files libs
  375. %{!?_licensedir:%global license %%doc}
  376. %license COPYING
  377. /%{_lib}/*dbus-1*.so.*
  378. %files devel
  379. %defattr(-,root,root)
  380. /%{_lib}/lib*.so
  381. %{_libdir}/dbus-1.0/include
  382. %{_libdir}/pkgconfig/*
  383. %{_includedir}/*
  384. %dir %{_libdir}/cmake/DBus1
  385. %{_libdir}/cmake/DBus1/*
  386. %dir %{_datadir}/xml
  387. %dir %{_datadir}/xml/dbus-1
  388. %{_datadir}/xml/dbus-1/*
  389. %files x11
  390. %defattr(-,root,root)
  391. %{_bindir}/dbus-launch
  392. %{_datadir}/man/man*/dbus-launch.1.gz
  393. %{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
  394. %files doc
  395. %defattr(-,root,root)
  396. %{_pkgdocdir}/*
  397. %{_datadir}/gtk-doc
  398. # compat32
  399. %if %{build_compat32}
  400. %files -n compat32-%{name}
  401. /%{_lib}/*dbus-1*.so.*
  402. %files -n compat32-%{name}-devel
  403. %defattr(-,root,root)
  404. /%{_lib}/lib*.so
  405. %{_libdir}/dbus-1.0/include
  406. %endif
  407. %changelog
  408. * Wed Jul 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.20-1
  409. - new upstream release.
  410. - moved dbus-daemon-launch-helper from /lib64/dbus-1 to /lib/dbus-1.
  411. * Fri Jun 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.18-1
  412. - new upstream release.
  413. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.16-2
  414. - added subpackages: common, daemon, libs and tools.
  415. * Wed Sep 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.16-1
  416. - new upstream release.
  417. - built for systemd.
  418. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.12-1
  419. - new upstream release.
  420. - added elogind support.
  421. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.22-1
  422. - new upstream release.
  423. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.20-1
  424. - new upstream release
  425. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.18-1
  426. - new upstream release
  427. * Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.16-1
  428. - new upstream release
  429. * Sat Jan 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
  430. - new upstream release
  431. * Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.28-1
  432. - new upstream release
  433. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.24-1
  434. - new upstream release
  435. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
  436. - new upstream release
  437. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
  438. - new upstream release
  439. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
  440. - new upstream release
  441. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  442. - new upstream release
  443. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  444. - new upstream release
  445. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
  446. - remove BuildRequires: audit-libs-devel, libcap-ng-devel
  447. * Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  448. - new upstream release
  449. - remove old patches
  450. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
  451. - new upstream release
  452. - add BuildRequires: audit-libs-devel, libcap-ng-devel
  453. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
  454. - new upstream release
  455. - remove Requires: libxml2-python
  456. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
  457. - new upstream release
  458. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  459. - new upstream release
  460. - drop Patch1
  461. - create -doc sub package
  462. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  463. - new upstream release
  464. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  465. - new upstream release
  466. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
  467. - add BuildRequires: libSM-devel
  468. * Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
  469. - rebuilt with rpm-4.8.1
  470. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
  471. - new upstream release
  472. - drop Patch0
  473. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
  474. - rebuilt with new toolchain
  475. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
  476. - new upstream release
  477. * Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
  478. - new upstream release
  479. - do not restart dbus on upgrade
  480. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
  481. - added compat32 package for x86_64 arch support
  482. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
  483. - add Patch10 for workaround deny send_interface
  484. http://bugs.freedesktop.org/show_bug.cgi?id=18961
  485. Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
  486. Bare <deny send_interface=""/> rules have a far larger impact than one would think.
  487. It's really always wrong to use them without also using send_destination.
  488. - XXX: this should be fixed in each dbus configuration.
  489. * Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
  490. - new upstream release with security fix (CVE-2008-4311)
  491. * Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
  492. - new upstream release with security fix (CVE-2008-3834)
  493. * Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
  494. - new upstream release
  495. * Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
  496. - own the directories /usr/share/dbus-1/{system-services,interfaces}
  497. - set 'dbus' instead of '81' to --with-dbus-user
  498. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
  499. - import some patches from fedora
  500. - move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
  501. * Wed May 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  502. - new upstream release
  503. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
  504. - new upstream release
  505. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
  506. - rebuild with expat-2.0.1
  507. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
  508. - rebuild with new environment/toolchain
  509. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  510. - require new chkconfig to reset initscript priorities
  511. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  512. - new upstream release
  513. - split out bindings
  514. - move base binaries and libraries to /bin and /%{_lib}
  515. * Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
  516. - rebuilt for VineSeed
  517. * Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
  518. - add Vendor/Distribution tag
  519. * Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
  520. - add patch100 for fix CVE-2006-6107
  521. * Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
  522. - new upstream release
  523. * Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
  524. - disabled dbus-qt
  525. - added BuildConflicts: qt-devel
  526. - removed work around for 64 bit archs
  527. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
  528. - new upstream release
  529. * Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
  530. - new upstream release
  531. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
  532. - new upstream release
  533. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
  534. - new upstream release
  535. - enable python bindings
  536. * Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
  537. - initial build for Vine Linux based on FC package
  538. - disable python bindings
  539. - disable selinux
  540. * Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
  541. - Explicitly pass in the pid file location to ./configure instead of
  542. letting it guess based on the build enviornment
  543. * Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
  544. - Add patch to fix random users from connecting to a users session bus
  545. * Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
  546. - Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
  547. * Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
  548. - Update to upstream version 0.23
  549. - Drop all patches except for the UDI patch as they have been
  550. integrated upstream
  551. - List of API changes:
  552. * add setgroups() to drop supplementary groups
  553. * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
  554. * added support for int64 and uint64 to the python bindings
  555. * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
  556. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
  557. - rebuild against python 2.4
  558. * Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
  559. - Add a requires for glib2-devel in the devel package
  560. - Add SE-Linux backport from Colin Walters that fixes
  561. messages getting lost in SE-Linux contexts
  562. * Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
  563. - Bump up release and rebuild
  564. * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
  565. - Run /sbin/ldconfig for glib sub-package (bug #134062).
  566. * Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
  567. - Fixed patch to use dbus-1 instead of dbus-1.0
  568. - (configure.in): Exported just the datadir instead of
  569. the full path to the dbus datadir for consistency
  570. * Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
  571. - Adding patch to move /usr/lib/dbus-1.0/services to
  572. /usr/share/dbus-1.0/services
  573. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  574. - reverting BuildRequires: redhat-release because of issues with build system
  575. - added precompiled version of the messagebus init script
  576. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  577. - changed /etc/redhat-release to the package redhat-release
  578. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  579. - added python int64 patch from davidz
  580. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  581. - added BuildRequires: /etc/redhat-release (RH Bug #132436)
  582. * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
  583. - Added Steve Grubb's spec file patch (RH Bug #130201)
  584. * Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
  585. - Disabled dbus-gtk since dbus-viewer doesn't do anything right now
  586. * Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
  587. - Moved dbus-viewer to new dbus-gtk package so that dbus-glib
  588. no longer requires X or GTK libraries. (RH Bug #130029)
  589. * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
  590. - Update to new 0.22 release
  591. * Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
  592. - Added BuildRequires for libselinux-devel and Requires for libselinux
  593. * Mon Aug 02 2004 Colin Walters <walters@redhat.com>
  594. - Add SE-DBus patch
  595. * Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
  596. - Added lib64 workaround for python bindings installing to
  597. the wrong lib directory on 64 bit archs
  598. * Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
  599. - Updated console-auth patch
  600. - rebuild
  601. * Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
  602. - Update to upstream CVS build
  603. - Added console-auth patch
  604. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  605. - Workaround added to fix gcc-3.4 bug on ia64
  606. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  607. - require new Pyrex version and see if it builds this time
  608. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  609. - rebuild with updated Pyrex (0.9.2.1)
  610. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  611. - rebuilt
  612. * Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
  613. - Moved dbus-viewer, dbus-monitor and dbus-glib-tool
  614. into the dbus-glib package so that the main dbus
  615. package does not depend on glib (Bug #125285)
  616. * Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
  617. - rebuilt
  618. * Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
  619. - added my Python patch
  620. - took out the qt build requires
  621. - added a gtk+ build requires
  622. * Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
  623. - Changed build requirement to version 0.9-3 of Pyrex
  624. to fix problem with builing on x86_64
  625. * Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
  626. - update to upstream 0.21
  627. - removed dbus-0.20-varargs.patch patch (fixed upstream)
  628. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
  629. - added a dbus-python package to generate python bindings
  630. - added Pyrex build dependacy
  631. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  632. - rebuilt
  633. * Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
  634. - fix dbus error functions on x86-64 (#116324)
  635. - add prereq (#112027)
  636. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  637. - rebuilt
  638. * Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
  639. - Conflict with cups prior to configuration file change, so that the
  640. %%postun service condrestart works.
  641. * Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
  642. - rebuild in fc2, cups now updated
  643. * Wed Jan 7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
  644. - update to upstream 0.20
  645. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
  646. - hmm, dbus doesn't support uids in the config file. fix.
  647. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
  648. - put uid instead of username in the config file, to keep things working with name change
  649. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
  650. - make subpackages require the specific release, not just version, of base package
  651. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
  652. - change system user "messagebus" -> "dbus" to be under 8 chars
  653. * Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
  654. - see if removing qt subpackage for now will get us through the build system,
  655. qt bindings not useful yet anyway
  656. * Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
  657. - 0.13 fixes a little security oops
  658. * Mon Aug 4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
  659. - break the tiny dbus-launch that depends on X into separate package
  660. so a CUPS server doesn't need X installed
  661. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  662. - rebuilt
  663. * Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
  664. - 0.11.91 cvs snap properly merges system.d
  665. * Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
  666. - build a cvs snap with a few more fixes
  667. * Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
  668. - fix a crash that was breaking cups
  669. * Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
  670. - 0.11
  671. * Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
  672. - use rc.d/init.d not init.d, bug #90192
  673. - include the new man pages
  674. * Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
  675. - 0.9
  676. - export QTDIR explicitly
  677. - re-enable qt, the problem was most likely D-BUS configure
  678. * Tue Apr 1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
  679. - update from CVS with a fix to set uid after gid
  680. * Tue Apr 1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
  681. - new cvs snap that actually forks to background and changes
  682. user it's running as and so forth
  683. - create our system user in pre
  684. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
  685. - fix for "make check" test that required a home directory
  686. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
  687. - disable qt for now because beehive hates me
  688. - pull a slightly newer cvs snap that creates socket directory
  689. - cat the make check log after make check fails
  690. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
  691. - initial build