perl-Test-Refcount-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596
  1. Name: perl-Test-Refcount
  2. Version: 0.07
  3. Release: 2%{?_dist_release}
  4. Summary: Assert reference counts on objects
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Test-Refcount/
  8. Source0: http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-%{version}.tar.gz
  9. BuildArch: noarch
  10. BuildRequires: perl(ExtUtils::MakeMaker)
  11. BuildRequires: perl(Devel::Refcount)
  12. BuildRequires: perl(Devel::FindRef)
  13. BuildRequires: perl(Test::Builder)
  14. BuildRequires: perl(Test::Builder::Tester)
  15. BuildRequires: perl(Test::More)
  16. BuildRequires: perl(Test::Pod)
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. %description
  19. The Perl garbage collector uses simple reference counting during the normal
  20. execution of a program. This means that cycles or unweakened references in
  21. other parts of code can keep an object around for longer than intended. To
  22. help avoid this problem, the reference count of a new object from its class
  23. constructor ought to be 1. This way, the caller can know the object will be
  24. properly DESTROYed when it drops all of its references to it.
  25. %prep
  26. %setup -q -n Test-Refcount-%{version}
  27. %build
  28. %{__perl} Makefile.PL INSTALLDIRS=vendor
  29. make %{?_smp_mflags}
  30. %install
  31. rm -rf %{buildroot}
  32. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  33. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  34. %{_fixperms} %{buildroot}/*
  35. %check
  36. make test
  37. %clean
  38. rm -rf %{buildroot}
  39. %files
  40. %doc Changes LICENSE README
  41. %{perl_vendorlib}/Test
  42. %{_mandir}/man3/Test*.3*
  43. %changelog
  44. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.07-2
  45. - build with Perl 5.16
  46. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.07-1
  47. - initial build for Vine Linux
  48. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.07-1
  49. - update to 0.07
  50. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
  51. - Perl mass rebuild
  52. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
  53. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  54. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-3
  55. - 661697 rebuild for fixing problems with vendorach/lib
  56. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-2
  57. - Mass rebuild with perl-5.12.0
  58. * Sun Dec 27 2009 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.06-1
  59. - Update to 0.06
  60. - Remove workaround at make test for perl with debug - rhbz#514942
  61. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.05-3
  62. - rebuild against perl 5.10.1
  63. * Fri Jul 31 2009 kwizart < kwizart at gmail.com > - 0.05-2
  64. - Add missing BR
  65. - Use %%{_fixperms}
  66. - Fix %%files section
  67. - Add comment about why it fails
  68. * Thu Jul 9 2009 kwizart < kwizart at gmail.com > - 0.05-1
  69. - Initial spec