OpenImageIO-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309
  1. %bcond_with external_pugixml
  2. %global subname oiio
  3. Name: OpenImageIO
  4. Version: 2.2.6.1
  5. Release: 1%{?_dist_release}
  6. Summary: Library for reading and writing images
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://sites.google.com/site/openimageio/home
  12. Source0: https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
  13. # Images for test suite
  14. #Source1: oiio-images.tar.gz
  15. BuildRequires: cmake
  16. BuildRequires: git
  17. BuildRequires: txt2man
  18. BuildRequires: qt5-qtbase-devel
  19. BuildRequires: libboost-devel
  20. BuildRequires: libboost-python3
  21. BuildRequires: libboost-filesystem
  22. BuildRequires: glew-devel
  23. BuildRequires: OpenEXR-devel
  24. BuildRequires: python3-devel
  25. BuildRequires: python3-rpm-macros
  26. # BuildRequires: openssl-devel
  27. BuildRequires: libpng-devel libtiff-devel openjpeg2-devel giflib-devel
  28. BuildRequires: libwebp-devel
  29. BuildRequires: Field3D-devel
  30. BuildRequires: hdf5-devel
  31. BuildRequires: zlib-devel
  32. BuildRequires: jasper-devel
  33. BuildRequires: LibRaw-devel
  34. %if %{with external_pugixml}
  35. BuildRequires: pugixml-devel
  36. %endif
  37. BuildRequires: pybind11-devel
  38. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  39. # If an ABI incompatible update is done in one, the other also needs to be
  40. # rebuilt.
  41. BuildRequires: OpenColorIO-devel
  42. Obsoletes: python-OpenImageIO
  43. # We don't want to provide private python extension libs
  44. %{?filter_setup:
  45. %filter_provides_in %{python3_sitearch}/.*\.so$
  46. %filter_setup
  47. }
  48. %description
  49. OpenImageIO is a library for reading and writing images, and a bunch of related
  50. classes, utilities, and applications. Main features include:
  51. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  52. writing 2D images that is format agnostic.
  53. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  54. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  55. PNM/PPM/PGM/PBM, Field3d.
  56. - An ImageCache class that transparently manages a cache so that it can access
  57. truly vast amounts of image data.
  58. %package -n python3-%{name}
  59. Summary: Python 3 bindings for %{name}
  60. Group: programming
  61. Requires: %{name} = %{version}-%{release}
  62. %description -n python3-%{name}
  63. Python3 bindings for %{name}.
  64. %package utils
  65. Summary: Command line utilities for %{name}
  66. Group: graphics
  67. Requires: %{name} = %{version}-%{release}
  68. %description utils
  69. Command-line tools to manipulate and get information on images using the
  70. %{name} library.
  71. %package iv
  72. Summary: %{name} based image viewer
  73. Group: graphics
  74. Requires: %{name} = %{version}-%{release}
  75. %description iv
  76. A really nice image viewer, iv, based on %{name} classes (and so will work
  77. with any formats for which plugins are available).
  78. %package devel
  79. Summary: Documentation for %{name}
  80. Group: programming
  81. Requires: %{name} = %{version}-%{release}
  82. %description devel
  83. Development files for package %{name}
  84. %debug_package
  85. %prep
  86. %setup -q -n oiio-Release-%{version}
  87. %if %{with external_pugixml}
  88. # Remove bundled pugixml
  89. rm -f src/include/OpenImageIO/pugixml.hpp \
  90. src/include/OpenImageIO/pugiconfig.hpp \
  91. src/libutil/OpenImageIO/pugixml.cpp
  92. %endif
  93. # Remove bundled tbb
  94. %{__rm} -rf src/include/tbb
  95. # Install test images
  96. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  97. #tar --strip-components=1 -xzf %{SOURCE1}
  98. %build
  99. %{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
  100. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  101. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  102. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  103. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  104. -DBUILDSTATIC=OFF \
  105. -DLINKSTATIC=OFF \
  106. -DPYTHON_VERSION=%{python3_version} \
  107. -DINSTALL_DOCS:BOOL=FALSE \
  108. -DINSTALL_FONTS:BOOL=FALSE \
  109. %if %{with external_pugixml}
  110. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  111. %endif
  112. -DUSE_TBB:BOOL=FALSE \
  113. -DUSE_OPENSSL:BOOL=TRUE \
  114. -DSTOP_ON_WARNING:BOOL=FALSE \
  115. -DJPEG_INCLUDE_DIR=$(pkg-config --variable=includedir libopenjp2) \
  116. -DVERBOSE=TRUE \
  117. ../../
  118. %{__make} %{?_smp_mflags}
  119. popd
  120. %install
  121. pushd build/linux
  122. %{make_install}
  123. popd
  124. # # Move man pages to the right directory
  125. # mkdir -p %{buildroot}%{_mandir}/man1
  126. # cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  127. %post -p %{_syssbindir}/ldconfig
  128. %postun -p %{_syssbindir}/ldconfig
  129. %files
  130. %license LICENSE*
  131. %doc CHANGES.md CONTRIBUTING.md README.md
  132. %{_libdir}/libOpenImageIO.so.*
  133. %{_libdir}/libOpenImageIO_Util.so.*
  134. %files -n python3-%{name}
  135. %{python3_sitearch}/OpenImageIO.so
  136. %files utils
  137. %exclude %{_bindir}/iv
  138. %{_bindir}/*
  139. # %exclude %{_mandir}/man1/iv.1.gz
  140. # %{_mandir}/man1/*.1.gz
  141. %files iv
  142. %{_bindir}/iv
  143. # %{_mandir}/man1/iv.1.gz
  144. %files devel
  145. %doc src/doc/*.pdf
  146. %{_libdir}/libOpenImageIO.so
  147. %{_libdir}/libOpenImageIO_Util.so
  148. %dir %{_libdir}/pkgconfig
  149. %{_libdir}/pkgconfig/OpenImageIO.pc
  150. %dir %{_datadir}/cmake
  151. %dir %{_datadir}/cmake/Modules
  152. %dir %{_libdir}/cmake/OpenImageIO
  153. %{_datadir}/cmake/Modules/FindOpenImageIO.cmake
  154. %{_libdir}/cmake/OpenImageIO/*
  155. %{_includedir}/*
  156. %changelog
  157. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6.1-1
  158. - new upstream release.
  159. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
  160. - new upstream release.
  161. - built with boost-1.72.0.
  162. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
  163. - new upstream release.
  164. * Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
  165. - update to 1.8.17
  166. * Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
  167. - update to 1.8.16
  168. - change BuildRequires: qt4-devel to qt5-qtbase-devel
  169. - drop BuildRequires: openssl-devel
  170. * Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
  171. - update to 1.7.19
  172. - using macro
  173. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
  174. - rebuild with hdf5-1.8.20
  175. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
  176. - update to 1.7.17
  177. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  178. - rebuilt with LibRaw-0.17.2.
  179. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  180. - rebuild with gcc-5.4.0
  181. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  182. - new upstream release
  183. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  184. - new upstream release
  185. - remove Patch0
  186. - create python-%%{name} subpackage
  187. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  188. - rebuild with glew-1.13.0
  189. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  190. - initial build for Vine Linux
  191. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  192. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  193. - rebuild (openexr)
  194. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  195. - Update to latest upstream release.
  196. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  197. - Update to latest upstream release.
  198. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  199. - Rebuild for Field3D 1.4.3.
  200. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  201. - Rebuild for pugixml 1.4
  202. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  204. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  205. - Update to latest upstream release.
  206. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  207. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  208. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  209. - Rebuild for boost 1.55.0
  210. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  211. - rebuild for boost 1.55.0
  212. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  213. - Update to latest upstream release.
  214. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  215. - Update to latest upstream release.
  216. - Add libgif as build requirement.
  217. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  218. - rebuild (openexr)
  219. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  220. - rebuilt for GLEW 1.10
  221. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  222. - Update to latest upstream release.
  223. - Fix ppc builds (BZ#1021977).
  224. - Add conditionals to build requirements for EPEL 6.
  225. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  226. - Update to latest upstream release.
  227. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  228. - rebuild (ilmbase/openexr)
  229. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  230. - Update to latest upstream release.
  231. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  232. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  233. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  234. - Rebuild for boost 1.54.0