gl-manpages-vl.spec 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. %global codate 20121009
  2. Name: gl-manpages
  3. Version: 1.1
  4. Release: 2%{?_dist_release}
  5. Summary: OpenGL manpages
  6. Summary(ja): OpenGLマニュアルページ
  7. License: MIT and Open Publication
  8. Group: Documentation
  9. URL: http://www.opengl.org/wiki/Getting_started/XML_Toolchain_and_Man_Pages
  10. # see Source1
  11. Source0: gl-manpages-%{version}-%{codate}.tar.xz
  12. Source1: make-gl-man-snapshot.sh
  13. # FIXME: Bundle mathml and the Oasis dbmathl until they are packaged
  14. Source2: http://www.oasis-open.org/docbook/xml/mathml/1.1CR1/dbmathml.dtd
  15. Source3: http://www.w3.org/Math/DTD/mathml2.tgz
  16. # FIXME These are the old gl-manpages source which
  17. # still have some manpages that khronos doesn't.
  18. # Ship until somebody in the know helps figuring whats what.
  19. # When matching install the kronos version.
  20. Source4: gl-manpages-1.0.1.tar.bz2
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildArch: noarch
  23. BuildRequires: libxslt docbook-style-xsl
  24. %description
  25. OpenGL manpages
  26. %prep
  27. %setup -q -n %{name}-%{version}-%{codate}
  28. tar xzf %{SOURCE3}
  29. cp -av %{SOURCE2} mathml2/
  30. tar xjf %{SOURCE4}
  31. %build
  32. # FIXME Figure out how to build the GLSL manpages
  33. # FIXME Figure out how to silence the author/version etc warnings
  34. for MAN in man4 man3 man ; do
  35. pushd $MAN
  36. ls -1 *.xml | xargs -n1 xsltproc --noout --nonet --path ../mathml2/ /usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl
  37. popd
  38. done
  39. %install
  40. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
  41. cp -n {man4,man3,man}/*.3G $RPM_BUILD_ROOT%{_mandir}/man3/
  42. # install the old manpages source with 3gl -> 3G
  43. # when matchin don't clobber the khronos version
  44. for MANP in `find gl-manpages-1.0.1 -name *.3gl` ; do
  45. FN=${MANP//*\//}
  46. cp -a -n $MANP $RPM_BUILD_ROOT%{_mandir}/man3/${FN/.3gl/.3G}
  47. find $RPM_BUILD_ROOT%{_mandir}/man3/ -type f -size -100b | xargs sed -i -e 's/\.3gl/\.3G/'
  48. done
  49. %files
  50. %{_mandir}/man3/*
  51. %changelog
  52. * Mon Nov 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1-2
  53. - added Group tag
  54. * Wed Nov 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
  55. - initial build for Vine Linux
  56. * Mon Oct 15 2012 Yanko Kaneti <yaneti@declera.com> - 1.1-3.%{codate}
  57. - Fix symlinked man variants.
  58. - Preserve timestamps on the older gl-manpages.
  59. * Tue Oct 9 2012 Yanko Kaneti <yaneti@declera.com> - 1.1-2.%{codate}
  60. - Re-add the older gl-manpages for those not present in khronos
  61. * Tue Oct 9 2012 Yanko Kaneti <yaneti@declera.com> - 1.1-1.%{codate}
  62. - Try building from source
  63. * Wed Sep 5 2012 Yanko Kaneti <yaneti@declera.com> - 1.0.1-1
  64. - Initial split from mesa