wine-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689
  1. %define pkg_major_version 1.2
  2. %define pkg_name wine
  3. %define pkg_release 1.rc2%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32/64 bit programs on Unix.
  7. Summary(ja): Unix で 16/32/64ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}-rc2.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. # desktop stuff
  21. Source100: wine-notepad.desktop
  22. Source101: wine-regedit.desktop
  23. Source102: wine-uninstaller.desktop
  24. Source103: wine-winecfg.desktop
  25. Source104: wine-winefile.desktop
  26. Source105: wine-winemine.desktop
  27. Source106: wine-winhelp.desktop
  28. Source107: wine-wineboot.desktop
  29. # desktop dir
  30. Source200: wine.menu
  31. Source201: wine.directory
  32. # mime types
  33. Source300: wine-mime-msi.desktop
  34. # explain how to use wine with pulseaudio
  35. Source402: README-FEDORA-PULSEAUDIO
  36. Patch400: http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
  37. Patch401: http://art.ified.ca/downloads/winepulse-0.30.patch
  38. Patch402: http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
  39. Patch0: wine-prefixfonts.patch
  40. Patch1: wine-1.1.28-rpath.patch
  41. # fix #448338
  42. ## Patch2: wine-desktop-mime.patch
  43. # enable FontSmoothing by deafult
  44. Patch1000: wine-1.1.23-vine.patch
  45. # ADD ja
  46. Source801: wine_README.ja
  47. Source802: README-FEDORA-PULSEAUDIO.ja
  48. Source803: wine-README-Fedora.ja
  49. Source804: wine_README_add.ja
  50. Source805: fonts-replace-list.txt
  51. Source806: ja_fonts_replace-js2ipa.reg
  52. Source807: ja_fonts_replace-js2vl.reg
  53. Source808: ja_fonts_replace-ms2ipa.reg
  54. Source809: ja_fonts_replace-ms2vl.reg
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. Packager: daisuke, Takemikaduchi
  58. #--------------------------------------------------------------------
  59. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  60. #--------------------------------------------------------------------
  61. ## FedoraCore ##
  62. BuildRequires: bison, flex
  63. BuildRequires: audiofile, audiofile-devel
  64. BuildRequires: alsa-lib-devel, esound-devel
  65. BuildRequires: freeglut-devel, lcms-devel
  66. ## BuildRequires: libieee1284-devel
  67. BuildRequires: libjpeg-devel, libpng-devel
  68. BuildRequires: libstdc++3-devel, libstdc++34-devel
  69. BuildRequires: libusb-devel
  70. BuildRequires: libxml2-devel, libxslt-devel
  71. BuildRequires: openldap-devel, ncurses-devel
  72. BuildRequires: unixODBC-devel, openssl-devel
  73. BuildRequires: sane-devel
  74. BuildRequires: zlib-devel
  75. BuildRequires: desktop-file-utils
  76. BuildRequires: fontforge
  77. ## BuildRequires: gphoto2, gphoto2-devel
  78. ## BuildRequires: jack-audio-connection-kit-devel
  79. ## BuildRequires: isdn4k-utils-devel
  80. BuildRequires: cups-devel
  81. BuildRequires: dbus-devel, hal-devel
  82. ## Requires: %{_bindir}/xmessage
  83. ## X modular(fc) > X 7.2
  84. BuildRequires: libX11-devel
  85. BuildRequires: mesa-libGL-devel, mesa-libGLU-devel
  86. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  87. BuildRequires: libXrandr-devel
  88. BuildRequires: libXrender-devel
  89. BuildRequires: libXext-devel
  90. BuildRequires: libXinerama-devel
  91. BuildRequires: libXcomposite-devel
  92. BuildRequires: libXmu-devel
  93. BuildRequires: libXi-devel
  94. BuildRequires: libXcursor-devel
  95. BuildRequires: fontconfig-devel
  96. BuildRequires: giflib-devel
  97. BuildRequires: libtiff-devel
  98. BuildRequires: pkgconfig
  99. BuildRequires: libicu-devel
  100. BuildRequires: freetype2-devel
  101. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  102. Requires(post): desktop-file-utils >= 0.8
  103. Requires(preun): /sbin/chkconfig, /sbin/service
  104. Requires(postun): /sbin/ldconfig
  105. Requires(postun): desktop-file-utils >= 0.8
  106. #--------------------------------------------------------------------
  107. %description
  108. (WINE Is Not an Emulator)
  109. While Wine is usually thought of as a Windows(TM) emulator,
  110. the Wine developers would prefer that users thought of
  111. Wine as a Windows compatibility layer for UNIX.
  112. This package includes a program loader, which allows
  113. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  114. x86_64 Unixes.
  115. Wine does not require MS Windows, but it can use native
  116. system .dll files if they are available.
  117. %description -l ja
  118. (WINE Is Not an Emulator)
  119. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  120. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  121. 互換レイヤー」と考えてくれる事を好むでしょう。
  122. このパッケージはプログラムローダーを含み、これは未修正の
  123. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  124. させます。
  125. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  126. Windows システムの .dll ファイルが存在するのならば、それを使用する
  127. 事もできます
  128. #--------------------------------------------------------------------
  129. %package devel
  130. Summary: Wine development environment
  131. Summary(ja): WINE の開発ファイルです
  132. Group: System Environment/Libraries
  133. Requires: wine = %{version}-%{release}
  134. %description devel
  135. This RPM contains the header files and development tools
  136. for the WINE libraries.
  137. %description devel -l ja
  138. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  139. アプリケーション(例:winebuild)のパッケージです
  140. (development packages)
  141. #--------------------------------------------------------------------
  142. %package init
  143. Summary: WINE binfmt_misc kernel function used for init file.
  144. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  145. Group: System Environment/Libraries
  146. Requires: wine = %{version}-%{release}
  147. %description init
  148. WINE binfmt_misc kernel function used for init file.
  149. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  150. (init.d packages)
  151. ** example **
  152. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  153. from the usual binary Linux as "$ /file/to/path/arege.exe"
  154. and just be able to run.
  155. Of course, please be mindful of security.
  156. %description init -l ja
  157. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  158. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  159. ようにします。
  160. (init.d packages)
  161. ※ 例 ※
  162. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  163. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  164. だけで実行できるようになります。
  165. 無論、セキュリティに留意して下さい。
  166. #--------------------------------------------------------------------
  167. %prep
  168. %setup -q -n %{name}-%{version}-rc2
  169. ## %patch0
  170. %patch1 -p1
  171. ## %patch400 -p1
  172. %patch401 -p1
  173. ## %patch402 -p1 -b .add-pa-to-winecfg
  174. %patch1000 -p1
  175. %build
  176. export CFLAGS="$RPM_OPT_FLAGS"
  177. %{configure} \
  178. --prefix=%{_prefix} \
  179. --with-x \
  180. --without-jack \
  181. --without-capi
  182. grep "have_x=yes" config.log || exit 1
  183. %{__make} depend
  184. %{__make} %{?_smp_mflags}
  185. %install
  186. rm -rf ${RPM_BUILD_ROOT}
  187. %{__make} prefix=${RPM_BUILD_ROOT}/%{_prefix}/ install \
  188. DESTDIR=${RPM_BUILD_ROOT}
  189. #-----------------------------------------------------------FC9
  190. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  191. # Allow users to launch Windows programs by just clicking on the .exe file...
  192. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  193. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  194. # add wine dir to desktop
  195. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  196. install -p -m 644 %{SOURCE200} \
  197. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  198. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  199. install -p -m 644 %{SOURCE201} \
  200. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  201. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  202. ## %%{_datadir}/applications
  203. # install desktop files
  204. desktop-file-install \
  205. --vendor=vine \
  206. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  207. %{SOURCE100}
  208. desktop-file-install \
  209. --vendor=vine \
  210. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  211. %{SOURCE101}
  212. desktop-file-install \
  213. --vendor=vine \
  214. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  215. %{SOURCE102}
  216. desktop-file-install \
  217. --vendor=vine \
  218. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  219. %{SOURCE103}
  220. desktop-file-install \
  221. --vendor=vine \
  222. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  223. %{SOURCE104}
  224. desktop-file-install \
  225. --vendor=vine \
  226. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  227. %{SOURCE105}
  228. desktop-file-install \
  229. --vendor=vine \
  230. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  231. %{SOURCE106}
  232. desktop-file-install \
  233. --vendor=vine \
  234. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  235. %{SOURCE107}
  236. desktop-file-install \
  237. --vendor=vine \
  238. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  239. --delete-original \
  240. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  241. #mime-types
  242. desktop-file-install \
  243. --vendor=vine \
  244. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  245. %{SOURCE300}
  246. ## other files
  247. cp %{SOURCE3} README-Fedora
  248. cp %{SOURCE803} README-Fedora.ja
  249. cp %{SOURCE801} documentation/README.ja
  250. cp %{SOURCE804} documentation/README_add.ja
  251. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  252. mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
  253. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  254. # deploy pulseaudio readme (802jp)
  255. cp %{SOURCE402} .
  256. cp %{SOURCE802} .
  257. # check desktop files
  258. %check
  259. desktop-file-validate \
  260. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  261. desktop-file-validate \
  262. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  263. desktop-file-validate \
  264. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  265. desktop-file-validate \
  266. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  267. desktop-file-validate \
  268. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  269. desktop-file-validate \
  270. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  271. desktop-file-validate \
  272. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  273. desktop-file-validate \
  274. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  275. desktop-file-validate \
  276. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  277. #--------------------------------------------------------------------
  278. %clean
  279. rm -rf ${RPM_BUILD_ROOT}
  280. %post
  281. /sbin/ldconfig
  282. update-desktop-database &>/dev/null || :
  283. ### add vinelinux
  284. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  285. echo "WINEのシステムフォントをリプレースするには"
  286. echo " fonts-replace-list.txt をお読み下さい。"
  287. else
  288. echo "You need to Japanese fonts name replace, "
  289. echo "See fonts-replace-list.txt ."
  290. fi
  291. %postun
  292. /sbin/ldconfig
  293. update-desktop-database &>/dev/null || :
  294. %post init
  295. if [ $1 = 1 ]; then
  296. /sbin/chkconfig --add wine
  297. /sbin/chkconfig --level 2345 wine on
  298. /sbin/service wine start &>/dev/null || :
  299. fi
  300. ### add vinelinux
  301. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  302. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  303. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  304. echo "(ファイル名は /etc/init.d/wine です)"
  305. echo "起動時にファイルシステムのマウントが必要です。"
  306. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  307. echo "(削除も手動でお願いします)"
  308. echo ""
  309. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  310. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  311. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  312. else
  313. echo "WINE binfmt_misc feature from the boot files "
  314. echo "to be installed and enabled 2,3,4,5 runlevel."
  315. echo "(File name in the /etc/init.d/wine )"
  316. echo "Filesystem mounted at boot time is required."
  317. echo "Root privileges using the following command in the /etc/fstab"
  318. echo "please Addenda.(Please delete manually.)"
  319. echo ""
  320. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  321. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  322. echo "See also(en)http://www.linux.com/articles/56032 "
  323. fi
  324. %preun init
  325. if [ $1 = 0 ]; then
  326. /sbin/service wine stop >/dev/null 2>&1
  327. /sbin/chkconfig --del wine
  328. fi
  329. #--------------------------------------------------------------------
  330. ## deleted /usr/share/applications/wine.desktop
  331. %files
  332. %defattr(-,root,root,-)
  333. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  334. %doc README VERSION
  335. %doc README-FEDORA-PULSEAUDIO
  336. %doc README-FEDORA-PULSEAUDIO.ja
  337. %doc README-Fedora
  338. %doc README-Fedora.ja
  339. %doc documentation/README* documentation/ChangeLog*
  340. %doc documentation/ja_fonts_replace*
  341. %doc documentation/fonts-replace-list.txt
  342. ### %{_bindir}/*
  343. %{_bindir}/msiexec
  344. %{_bindir}/regedit
  345. %{_bindir}/regsvr32
  346. %{_bindir}/wine
  347. %{_bindir}/wineboot
  348. %{_bindir}/wineconsole
  349. ## %{_bindir}/wineprefixcreate
  350. %{_bindir}/winecfg
  351. %{_bindir}/wine-preloader
  352. # winelauncher --> Remove
  353. %{_bindir}/wineserver
  354. %{_bindir}/notepad
  355. %{_bindir}/winedbg
  356. %{_bindir}/winedump
  357. %{_bindir}/winefile
  358. %{_bindir}/winemaker
  359. %{_bindir}/winemine
  360. %{_bindir}/winepath
  361. ## winhelp -> renamed winhlp32.exe
  362. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  363. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  364. %{_libdir}/libwine.so.1*
  365. %dir %{_libdir}/wine
  366. %{_libdir}/wine/*.cpl.so
  367. %{_libdir}/wine/*.exe.so
  368. %{_libdir}/wine/*.exe16.so
  369. %{_libdir}/wine/*.dll.so
  370. %{_libdir}/wine/*.dll16.so
  371. %{_libdir}/wine/*.drv.so
  372. %{_libdir}/wine/*.drv16.so
  373. %{_libdir}/wine/*.mod16.so
  374. ## %{_libdir}/wine/*.*16
  375. %{_libdir}/wine/*.ds.so
  376. %{_libdir}/wine/*.ocx.so
  377. %{_libdir}/wine/*.vxd.so
  378. %{_libdir}/wine/*.acm.so
  379. %{_libdir}/wine/*.sys.so
  380. %{_libdir}/wine/*.tlb.so
  381. %dir %{_libdir}/wine/fakedlls
  382. %{_libdir}/wine/fakedlls/*
  383. %dir %{_datadir}/wine
  384. %{_datadir}/wine/*
  385. %{_datadir}/applications/vine-wine-mime-msi.desktop
  386. %{_datadir}/applications/vine-wine.desktop
  387. %{_datadir}/applications/vine-wine-regedit.desktop
  388. %{_datadir}/applications/vine-wine-uninstaller.desktop
  389. %{_datadir}/applications/vine-wine-winecfg.desktop
  390. %{_datadir}/applications/vine-wine-wineboot.desktop
  391. %{_datadir}/applications/vine-wine-notepad.desktop
  392. %{_datadir}/applications/vine-wine-winefile.desktop
  393. %{_datadir}/applications/vine-wine-winemine.desktop
  394. %{_datadir}/applications/vine-wine-winhelp.desktop
  395. %{_datadir}/desktop-directories/Wine.directory
  396. %{_mandir}/man1/wine.1.*
  397. %{_mandir}/man1/wineserver.1*
  398. ## %{_mandir}/man1/wineprefixcreate.1*
  399. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  400. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  401. #--------------------------------------------------------------------
  402. %files devel
  403. %defattr(-,root,root,-)
  404. %{_bindir}/function_grep.pl
  405. %{_bindir}/widl
  406. %{_bindir}/winebuild
  407. %{_bindir}/winecpp
  408. %{_bindir}/winedump
  409. %{_bindir}/wineg++
  410. %{_bindir}/winegcc
  411. %{_bindir}/winemaker
  412. %{_bindir}/wmc
  413. %{_bindir}/wrc
  414. %{_includedir}/wine
  415. %{_libdir}/*.so
  416. %{_libdir}/wine/*.a
  417. %{_libdir}/wine/*.def
  418. %{_mandir}/man1/widl.1*
  419. %{_mandir}/man1/winebuild.1*
  420. %{_mandir}/man1/winedump.1*
  421. %{_mandir}/man1/winegcc.1*
  422. %{_mandir}/man1/winemaker.1*
  423. %{_mandir}/man1/winedbg.1*
  424. %{_mandir}/man1/wineg++.1*
  425. %{_mandir}/man1/wmc.1*
  426. %{_mandir}/man1/wrc.1*
  427. #--------------------------------------------------------------------
  428. %files init
  429. %defattr(-,root,root,-)
  430. %{_initrddir}/wine
  431. %doc documentation/README_add.ja
  432. #--------------------------------------------------------------------
  433. %changelog
  434. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  435. - update to 1.2-rc2
  436. - fix spec file
  437. - if [ "$LANG" = "ja_JP.eucJP" ];
  438. + if [ "$LANG" = "ja_JP.UTF-8" ];
  439. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  440. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  441. - fix %files
  442. - drop patches (Patch0, Patch400, Patch402)
  443. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  444. - update BRs
  445. - remove freetype-devel
  446. - remove libungif-devel, add giflib-devel
  447. - remove gphoto2-devel, add libgphoto2-devel
  448. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  449. - update to 1.1.29
  450. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  451. - update to 1.1.28
  452. - update winepulse patches
  453. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  454. - update to 1.1.23
  455. - spec in utf-8
  456. - add patch1000 to enable FontSmoothing by deafult.
  457. - update pulseaudio patches
  458. - remove invalid Provides: Wine HQ
  459. - remove unneeded patches
  460. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  461. - Wine development release 1.1.0.
  462. - Updated specfile (for VineSeed)
  463. #--------------------------------------------------------------------
  464. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  465. - added "ja_fonts_replace-*.reg" files.
  466. - Updated specfile
  467. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  468. - version upgrade
  469. - Updated specfile
  470. - Update to 1.0
  471. - fix wine.desktop mime types (fc)
  472. - add desktop package including desktop files and binary handler (fc)
  473. - pull in some wine alsa/pulseaudio patches (fc)
  474. -- NEWS "June 17, 2008: Wine 1.0 Released"
  475. -- read http://www.winehq.org/?issue=348
  476. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  477. - Updated specfile
  478. - Update to 1.0-rc4
  479. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  480. -- ntdll: Add local defines for VIF and VIP flags.
  481. -- wininet: Include openssl/ssl.h before Windows headers.
  482. -- shell32: Fixed the French about box.
  483. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  484. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  485. -- ....others , read ChangeLog
  486. --- Bug fixes only, we are in code freeze.
  487. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  488. - Updated specfile
  489. - Update to 1.0-rc3
  490. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  491. -- The default version is now Windows XP.
  492. -- Many Richedit improvements.
  493. -- Beginning of jscript dll support.
  494. -- Shell folders now respect XDG directory configuration.
  495. -- Many translation updates.
  496. -- Lots of bug fixes.
  497. -- * Bug fixes only, we are in code freeze.
  498. --- kernel32: Add a builtin 16-bit winhelp.exe.
  499. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  500. --- executables.
  501. ---- winhelp -> renamed winhlp32.exe
  502. ---- programs: Remove winelauncher from install rules.
  503. * Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
  504. - Updated specfile
  505. - Update to 0.9.59
  506. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  507. -- * Improved support for the .NET framework.
  508. -- * Better services handling through a separate services.exe process.
  509. -- * Support for ATI fragment shader.
  510. -- * Better support for http proxies.
  511. -- * Window management fixes.
  512. -- * Pre-compiled fonts are now available in the source tree.
  513. -- * Lots of bug fixes.
  514. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  515. - Updated specfile (split wine-init package)
  516. - Update to 0.9.58
  517. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  518. -- * The default version is now Windows XP.
  519. -- * Many Richedit improvements.
  520. -- * Beginning of jscript dll support.
  521. -- * Shell folders now respect XDG directory configuration.
  522. -- * Many translation updates.
  523. -- * Lots of bug fixes.
  524. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  525. - Updated specfile (*.desktop file %check .)
  526. - Update to 0.9.57
  527. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  528. -- * Support for multiple OpenGL pixel formats.
  529. -- * Improved support for color profiles.
  530. -- * Many window management fixes.
  531. -- * Better fullscreen support.
  532. -- * Lots of bug fixes.
  533. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  534. - Updated specfile
  535. - ("Build Tool" from the wine-package to move to devel-packages)
  536. - Update to 0.9.56
  537. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  538. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  539. -- * Stubs for all the d3dx9_xx dlls.
  540. -- * Several graphics optimizations.
  541. -- * Many installer fixes.
  542. -- * Improved MIME message support.
  543. -- * Lots of bug fixes.
  544. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  545. - Updated specfile (cf. VineLinux .spec file format)
  546. - Add Installed messages for "binfmt_misc" .
  547. - *.desktop file "Name" change to japanese. (UTF8)
  548. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  549. - Import WINE - Packager: Babasaki
  550. - Updated specfile (SUSE base + FC9 cfg)
  551. - Update to 0.9.55
  552. - Update to 0.9.54 from FC9
  553. - Update to 0.9.53 from Private package
  554. # FC9 ------------------------------------------------------------- FC9
  555. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  556. - 0.9.55-1
  557. - version upgrade
  558. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  559. - 0.9.54-1
  560. - version upgrade
  561. - remove default pulseaudio workaround (#429420,#428745)
  562. - improve pulseaudio readme
  563. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  564. - 0.9.53-2
  565. - add some missing BR
  566. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  567. - 0.9.53-1
  568. - version upgrade
  569. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  570. - 0.9.52-2
  571. - fix menu bug (#393641)
  572. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  573. - 0.9.52-1
  574. - version upgrade
  575. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  576. - 0.9.51-3
  577. - add -n Wine to pulseaudio workaround
  578. - try to fix menu bug #393641
  579. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  580. - 0.9.51-2
  581. - add fix for #344281 pulseaudio workaround
  582. - fix #253474: wine-jack should require jack-audio-connection-kit
  583. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  584. - 0.9.51-1
  585. - version upgrade
  586. # ---- abbreviatio ----------------------------------------------------#
  587. # ----------and suse.
  588. # * Fri Mar 17 2006 - meissner@suse.de
  589. # - Avoid ulimit leading to out of memory situations by using
  590. # the compat address space layout personality. #152115