htdig-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. %define vine4 1
  2. %define date 20030601
  3. %define buildweb 1
  4. %define beta b6
  5. %if %{vine4}
  6. %define contentdir /var/www
  7. %define apachebin %{_sbindir}/apache2
  8. %else
  9. %define contentdir /home/httpd
  10. %define apachebin %{_sbindir}/httpd
  11. %endif
  12. Summary: ht://Dig - Web search engine
  13. Name: htdig
  14. Version: 3.2.0
  15. #Release: 6.1vl1.%{beta}
  16. Release: 7.%{beta}%{?_dist_release}
  17. License: GPL
  18. Group: Applications/Internet
  19. Url: http://www.htdig.org/
  20. Source: http://www.htdig.org/files/%{name}-%{version}%{beta}.tar.bz2
  21. Source1: htdig.conf
  22. Patch0: htdig-3.1.5-rh.patch
  23. Patch1: htdig-3.2.0b3-glibc222.patch
  24. Patch2: htdig-3.2.0b4-xopen.patch
  25. Patch3: htdig-3.2.0b4-h_hash.patch
  26. Patch4: htdig-3.2.0b5-overflow.patch
  27. Patch5: htdig-3.2.0b5-expr.patch
  28. Patch6: htdig-3.2.0b5-destdir.patch
  29. Patch7: htdig-3.2.0b5-mktemp.patch
  30. # build for gcc4
  31. Patch100: htdig-3.2.0b6-gcc4.patch
  32. BuildRequires: flex >= 2.5.4a-13
  33. BuildRequires: zlib-devel
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. %package web
  36. Summary: Scripts and HTML code needed for using ht://Dig as a web search engine
  37. Group: Applications/Internet
  38. Requires: %{name} = %{version} webserver
  39. %description
  40. The ht://Dig system is a complete world wide web indexing and searching
  41. system for a small domain or intranet. This system is not meant to replace
  42. the need for powerful internet-wide search systems like Lycos, Infoseek,
  43. Webcrawler and AltaVista. Instead it is meant to cover the search needs for
  44. a single company, campus, or even a particular sub section of a web site. As
  45. opposed to some WAIS-based or web-server based search engines, ht://Dig can
  46. span several web servers at a site. The type of these different web servers
  47. doesn't matter as long as they understand the HTTP 1.0 protocol.
  48. ht://Dig is also used by KDE to search KDE's HTML documentation.
  49. ht://Dig was developed at San Diego State University as a way to search the
  50. various web servers on the campus network.
  51. %description web
  52. The ht://Dig system is a complete world wide web indexing and searching
  53. system for a small domain or intranet. This system is not meant to replace
  54. the need for powerful internet-wide search systems like Lycos, Infoseek,
  55. Webcrawler and AltaVista. Instead it is meant to cover the search needs for
  56. a single company, campus, or even a particular sub section of a web site. As
  57. opposed to some WAIS-based or web-server based search engines, ht://Dig can
  58. span several web servers at a site. The type of these different web servers
  59. doesn't matter as long as they understand the HTTP 1.0 protocol.
  60. The %{name}-web package includes CGI scripts and HTML code needed to use
  61. ht://Dig on a website.
  62. ht://Dig was developed at San Diego State University as a way to search the
  63. various web servers on the campus network.
  64. %prep
  65. %setup -q -n %{name}-%{version}%{beta}
  66. %patch -p1 -b .rh
  67. %patch1 -p1 -b .glibc222
  68. %patch2 -p1 -b .xopen
  69. %patch3 -p1 -b .h_hash
  70. %patch4 -p1 -b .overflow
  71. #patch5 -p1 -b .expr
  72. #patch6 -p1 -b .destdir
  73. #patch7 -p1 -b .mktemp
  74. %patch100 -p1 -b .gcc4
  75. # Fix the flex output file for glibc 2.2 compatibility
  76. cd htcommon
  77. flex -oconf_lexer.cxx conf_lexer.lxx
  78. cd ..
  79. cd htlib
  80. # This is a *VERY* dirty hack, until I figure out what's
  81. # causing this to break...
  82. for i in *.cc; do
  83. mv $i $i.foo
  84. cat >$i <<EOF
  85. #include <stdio.h>
  86. #include <string.h>
  87. EOF
  88. cat $i.foo >>$i
  89. rm -f $i.foo
  90. done
  91. for i in clib.h; do
  92. mv $i $i.foo
  93. cat >$i <<EOF
  94. #include "htconfig.h"
  95. EOF
  96. cat $i.foo >>$i
  97. rm -f $i.foo
  98. done
  99. %build
  100. %configure \
  101. --enable-shared \
  102. --enable-tests \
  103. --enable-bigfile \
  104. --with-config-dir=%{_sysconfdir}/htdig \
  105. --with-common-dir=%{contentdir}/html/htdig \
  106. --with-database-dir=/var/lib/htdig \
  107. --localstatedir=/var/lib/htdig \
  108. --with-cgi-bin-dir=%{contentdir}/cgi-bin \
  109. --with-image-dir=%{contentdir}/html/htdig \
  110. --with-search-dir=%{contentdir}/html/htdig \
  111. --with-default-config-file=%{_sysconfdir}/htdig/htdig.conf \
  112. --with-apache=%{apachebin} \
  113. --with-zlib=%{_prefix}
  114. make
  115. %install
  116. rm -rf $RPM_BUILD_ROOT
  117. make install DESTDIR=$RPM_BUILD_ROOT
  118. ln $RPM_BUILD_ROOT%{contentdir}/cgi-bin/htsearch $RPM_BUILD_ROOT%{_bindir}
  119. chmod 644 $RPM_BUILD_ROOT%{contentdir}/html/htdig/*
  120. ln -sf search.html $RPM_BUILD_ROOT%{contentdir}/html/htdig/index.html
  121. # now get rid of the $RPM_BUILD_ROOT paths in the conf files
  122. for i in %{_sysconfdir}/htdig/htdig.conf /usr/bin/rundig ; do
  123. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT/$i
  124. done
  125. mkdir -p $RPM_BUILD_ROOT%{_prefix}/share
  126. mv $RPM_BUILD_ROOT%{contentdir}/html/htdig $RPM_BUILD_ROOT%{_prefix}/share
  127. mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
  128. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/htdig.conf
  129. rm -rf $RPM_BUILD_ROOT%{_includedir}
  130. %clean
  131. rm -rf $RPM_BUILD_ROOT
  132. %files
  133. %defattr(-,root,root)
  134. %doc htdoc/*
  135. %dir %{_sysconfdir}/htdig
  136. %config %{_sysconfdir}/htdig/htdig.conf
  137. %config %{_sysconfdir}/htdig/cookies.txt
  138. %{_sysconfdir}/htdig/HtFileType-magic.mime
  139. %{_sysconfdir}/htdig/mime.types
  140. %dir /var/lib/htdig
  141. %{_bindir}/*
  142. %{_libdir}/htdig
  143. %{_libdir}/htdig_db
  144. %{_mandir}/man1/*
  145. %if %buildweb
  146. %files web
  147. %defattr(-,root,root)
  148. %{contentdir}/cgi-bin/*
  149. %config %{_sysconfdir}/httpd/conf.d/htdig.conf
  150. %dir %{_datadir}/htdig
  151. %{_datadir}/htdig/*
  152. %{_mandir}/man8/*
  153. %endif
  154. %changelog
  155. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.0-7.b6vl5
  156. - applied new versioning policy
  157. * Sun Sep 2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-6.1vl1.b6
  158. - new upstream release
  159. - added Patch100 for building with gcc4
  160. * Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl1.b5
  161. - rebuild for VineSeedPlus
  162. * Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl0.b5
  163. - build for VinePlus/2.6
  164. - remove commented lines
  165. - change configure options for apache of Vine
  166. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  167. - rebuilt
  168. * Thu Feb 26 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-6
  169. - Removed buildroot cruft from HtFileFype (#116442).
  170. - Use mktemp in HtFileFype to create temporary file (#116443).
  171. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  172. - rebuilt
  173. * Thu Jan 15 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-4
  174. - Fixed missing & in if clause.
  175. * Tue Jan 13 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-3
  176. - Fixed latin1 char translation (#71921).
  177. - Fixed overflow bug in WordDBPage.cc (#110802).
  178. * Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-2
  179. - Moved /usr/share/htdig files to web package (#111938).
  180. * Fri Dec 12 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-1
  181. - Update to latest stable upstream version htdig-3.2.0b5.
  182. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  183. - rebuilt
  184. * Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-18.20030601
  185. - Update to htdig-3.2.0b4-20030601 snapshot.
  186. - Fixed build problems.
  187. * Thu Mar 06 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-17.20030302
  188. - Update to htdig-3.2.0b4-20030302 snapshot.
  189. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  190. - rebuilt
  191. * Wed Jan 8 2003 Jeff Johnson <jbj@redhat.com> 3.2.0-15.20021103
  192. - don't include -debuginfo files in package.
  193. * Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-14.20021103
  194. - Forgot to create conf.d directory. Fixed.
  195. - Fixed wrong files section.
  196. * Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-13.20021103
  197. - Removed symlink from %{contentdir}/html and replaced it with httpd.d conf
  198. file (#73518).
  199. * Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-12.20021103
  200. - Added webserver requirement for htdig-web package (#73986).
  201. * Wed Dec 04 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-11.20021103
  202. - Fix for autoFOO patch.
  203. - Fix x64_64 build.
  204. * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 3.2.0-9.20021103
  205. - rebuild on all arches
  206. * Fri Nov 08 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-8.20021103
  207. - Updated to htdig-3.2.0b4-20021103.
  208. - Fixed %files section errors.
  209. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.2.0-7.20020505
  210. - rebuilt with gcc-3.2 (we hope)
  211. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 3.2.0-6.20020505
  212. - build using gcc-3.2-0.1
  213. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.2.0-5.20020505
  214. - automated rebuild
  215. * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-4.20020505
  216. - Don't forcibly strip binaries
  217. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  218. - automated rebuild
  219. * Mon May 6 2002 Bernhard Rosenkraenzer <bero@linux-easy.com> 3.2.0-2.20020505
  220. - Fix build with current toolchain (automake 1.6, autoconf 2.53 changes)
  221. - Update snapshot, fixes some more problems
  222. * Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
  223. - Updated to latest snapshot to fix several problems.
  224. - Fixed a problem with htdig segfaulting on s390 (#58202).
  225. * Fri Jul 20 2001 Philipp Knirsch <pknirsch@redhat.de>
  226. - Added missing BuildRequires: zlib-devel (#49500)
  227. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  228. - Bump release + rebuild.
  229. * Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
  230. - rebuild for C++ exception handling on ia64
  231. * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.2.0-0.b3.4
  232. - move pictures etc. to base package and to a directory outside of
  233. /var/www - The current KDevelop search function doesn't work without
  234. them.
  235. * Mon Mar 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  236. - Add htsearch to the base package, kdevelop needs it
  237. * Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  238. - Move the web related files to a separate package
  239. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  240. - 3.2.0b2
  241. - fix build with glibc 2.2 and gcc 2.96
  242. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  243. - fix syntax error introduced in our patch (#16598)
  244. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  245. - fixed group to be a valid one
  246. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  247. - rebuilt
  248. * Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  249. - rebuild for Power Tools
  250. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  251. - rebuild for Power Tools
  252. * Sat Feb 26 2000 Nalin Dahyabhai <nalin@redhat.com>
  253. - 3.1.5
  254. * Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  255. - 3.1.4
  256. - fix URL and source location
  257. * Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
  258. - 3.1.3 for SWS 3.1
  259. * Wed May 05 1999 Preston Brown <pbrown@redhat.com>
  260. - updates for SWS 3.0
  261. * Mon Aug 31 1998 Preston Brown <pbrown@redhat.com>
  262. - Updates for SWS 2.0
  263. * Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
  264. - built against glibc
  265. - build all the fuzzy databases before packaging, because it is time
  266. consuming operation and we don't want the user to be impatient