xulrunner-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777
  1. # Minimal required versions
  2. %global nspr_version 4.8.9
  3. %global nss_version 3.13.1
  4. %global cairo_version 1.10.2
  5. %global freetype_version 2.1.9
  6. %global libnotify_version 0.7.0
  7. # gecko_dir_ver should be set to the version in our directory names
  8. # alpha_version should be set to the alpha number if using an alpha, 0 otherwise
  9. # beta_version should be set to the beta number if using a beta, 0 otherwise
  10. # rc_version should be set to the RC number if using an RC, 0 otherwise
  11. %global gecko_dir_ver 2
  12. %global alpha_version 0
  13. %global beta_version 0
  14. %global rc_version 0
  15. %global mozappdir %{_libdir}/%{name}-%{gecko_dir_ver}
  16. %global tarballdir mozilla-esr10
  17. %if %{alpha_version} > 0
  18. %global pre_version a%{alpha_version}
  19. %global tarballdir mozilla-beta
  20. %endif
  21. %if %{beta_version} > 0
  22. %global pre_version b%{beta_version}
  23. %global tarballdir mozilla-beta
  24. %endif
  25. %if %{rc_version} > 0
  26. %global pre_version rc%{rc_version}
  27. %global tarballdir mozilla-release
  28. %endif
  29. %if %{defined pre_version}
  30. %global gecko_verrel %{expand:%%{version}}-%{pre_version}
  31. %global pre_tag .%{pre_version}
  32. %else
  33. %global gecko_verrel %{expand:%%{version}}
  34. %endif
  35. Summary: XUL Runtime for Gecko Applications
  36. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  37. Name: xulrunner
  38. Version: 10.0.6
  39. Release: 1%{?_dist_release}
  40. URL: http://developer.mozilla.org/En/XULRunner
  41. License: MPLv1.1 or GPLv2+ or LGPLv2+
  42. Group: Applications/Internet
  43. # You can get sources at ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_ver}/source
  44. Source0: %{name}-%{version}%{?pre_version}.source.tar.bz2
  45. Source10: %{name}-mozconfig-vine
  46. Source12: %{name}-redhat-default-prefs.js
  47. Source21: %{name}.sh.in
  48. # build patches
  49. Patch0: xulrunner-version.patch
  50. Patch1: mozilla-build.patch
  51. Patch14: xulrunner-2.0-chromium-types.patch
  52. Patch17: xulrunner-10.0-gcc47.patch
  53. # Fedora specific patches
  54. Patch20: mozilla-193-pkgconfig.patch
  55. Patch23: wmclass.patch
  56. Patch24: crashreporter-remove-static.patch
  57. # Upstream patches
  58. Patch38: mozilla-696393.patch
  59. # https://bugzilla.mozilla.org/show_bug.cgi?id=707993
  60. Patch39: xulrunner-8.0-fix-maemo-checks-in-npapi.patch
  61. Patch40: mozilla-682832-proxy.patch
  62. # cherry-picked from 13afcd4c097c
  63. Patch41: xulrunner-9.0-secondary-build-fix.patch
  64. Patch42: mozilla-706724.patch
  65. Patch43: mozilla-file.patch
  66. # Needed to detect/use libvpx-1.0.0
  67. # https://bugzilla.mozilla.org/show_bug.cgi?id=722127
  68. Patch44: mozilla-722127.patch
  69. Patch46: mozilla-724615.patch
  70. Patch47: mozilla-691898.patch
  71. # ---------------------------------------------------
  72. BuildRequires: nspr-devel >= %{nspr_version}
  73. BuildRequires: nss-devel >= %{nss_version}
  74. BuildRequires: cairo-devel >= %{cairo_version}
  75. BuildRequires: libpng-devel
  76. BuildRequires: libjpeg-turbo-devel
  77. BuildRequires: zip
  78. BuildRequires: bzip2-devel
  79. BuildRequires: zlib-devel
  80. BuildRequires: libIDL-devel
  81. BuildRequires: gtk2-devel
  82. BuildRequires: krb5-devel
  83. BuildRequires: pango-devel
  84. BuildRequires: freetype2-devel >= %{freetype_version}
  85. BuildRequires: libXt-devel
  86. BuildRequires: libXrender-devel
  87. BuildRequires: startup-notification-devel
  88. BuildRequires: alsa-lib-devel
  89. BuildRequires: libnotify-devel >= %{libnotify_version}
  90. BuildRequires: mesa-libGL-devel
  91. BuildRequires: curl-devel
  92. BuildRequires: yasm
  93. Requires: nspr
  94. Requires: nss
  95. Provides: gecko-libs = %{gecko_verrel}
  96. Conflicts: firefox < 3.6
  97. Vendor: Project Vine
  98. Distribution: Vine Linux
  99. Packager: daisuke
  100. %description
  101. XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
  102. applications that are as rich as Firefox and Thunderbird. It provides mechanisms
  103. for installing, upgrading, and uninstalling these applications. XULRunner also
  104. provides libxul, a solution which allows the embedding of Mozilla technologies
  105. in other projects and products.
  106. %package devel
  107. Summary: Development files for Gecko
  108. Summary(ja): Geckoの開発ファイル
  109. Group: Development/Libraries
  110. Obsoletes: mozilla-devel < 1.9
  111. Obsoletes: firefox-devel < 2.1
  112. Obsoletes: xulrunner-devel-unstable
  113. Provides: gecko-devel = %{gecko_verrel}
  114. Provides: gecko-devel-unstable = %{gecko_verrel}
  115. Requires: xulrunner = %{version}-%{release}
  116. Requires: nspr-devel
  117. Requires: nss-devel
  118. Requires: cairo-devel
  119. Requires: libjpeg-devel
  120. Requires: zip
  121. Requires: bzip2-devel
  122. Requires: zlib-devel
  123. Requires: libIDL-devel
  124. Requires: gtk2-devel
  125. Requires: krb5-devel
  126. Requires: pango-devel
  127. Requires: freetype-devel
  128. Requires: libXt-devel
  129. Requires: libXrender-devel
  130. Requires: startup-notification-devel
  131. Requires: alsa-lib-devel
  132. Requires: libnotify-devel
  133. Requires: mesa-libGL-devel
  134. %description devel
  135. This package contains the libraries amd header files that are needed
  136. for writing XUL+XPCOM applications with Mozilla XULRunner and Gecko.
  137. #---------------------------------------------------------------------
  138. %prep
  139. %setup -q -c
  140. cd %{tarballdir}
  141. sed -e 's/__RPM_VERSION_INTERNAL__/%{gecko_dir_ver}/' %{P:%%PATCH0} \
  142. > version.patch
  143. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  144. %patch1 -p2 -b .build
  145. %patch14 -p1 -b .chromium-types
  146. %patch17 -p1 -b .gcc47
  147. %patch20 -p2 -b .pk
  148. %patch23 -p1 -b .wmclass
  149. %patch24 -p1 -b .static
  150. %patch38 -p2 -b .696393
  151. %patch39 -p1 -b .707993
  152. %patch40 -p2 -b .682832
  153. %patch41 -p2 -b .secondary-build
  154. %patch42 -p1 -b .706724
  155. %patch43 -p1 -b .file
  156. %patch44 -p2 -b .vpx1.0.0
  157. %patch46 -p1 -b .724615
  158. %patch47 -p1 -b .691898
  159. %{__rm} -f .mozconfig
  160. %{__cp} %{SOURCE10} .mozconfig
  161. echo "ac_add_options --disable-system-sqlite" >> .mozconfig
  162. %ifarch armv7hl
  163. echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
  164. echo "ac_add_options --with-float-abi=hard" >> .mozconfig
  165. echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
  166. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  167. %endif
  168. %ifarch armv7hnl
  169. echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
  170. echo "ac_add_options --with-float-abi=hard" >> .mozconfig
  171. echo "ac_add_options --with-fpu=neon" >> .mozconfig
  172. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  173. %endif
  174. %ifarch armv5tel
  175. echo "ac_add_options --with-arch=armv5te" >> .mozconfig
  176. echo "ac_add_options --with-float-abi=soft" >> .mozconfig
  177. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  178. %endif
  179. %ifnarch %{ix86} x86_64
  180. echo "ac_add_options --disable-methodjit" >> .mozconfig
  181. echo "ac_add_options --disable-monoic" >> .mozconfig
  182. echo "ac_add_options --disable-polyic" >> .mozconfig
  183. echo "ac_add_options --disable-tracejit" >> .mozconfig
  184. %endif
  185. #---------------------------------------------------------------------
  186. %build
  187. cd %{tarballdir}
  188. # -fpermissive is needed to build with gcc 4.6+ which has become stricter
  189. #
  190. # Mozilla builds with -Wall with exception of a few warnings which show up
  191. # everywhere in the code; so, don't override that.
  192. #
  193. # Disable C++ exceptions since Mozilla code is not exception-safe
  194. #
  195. MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
  196. %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
  197. export CFLAGS=$MOZ_OPT_FLAGS
  198. export CXXFLAGS=$MOZ_OPT_FLAGS
  199. export PREFIX='%{_prefix}'
  200. export LIBDIR='%{_libdir}'
  201. MOZ_SMP_FLAGS=-j1
  202. # On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
  203. # however builds tend to fail on other arches when building in parallel.
  204. %ifarch %{ix86} x86_64
  205. [ -z "$RPM_BUILD_NCPUS" ] && \
  206. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  207. [ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
  208. [ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
  209. %endif
  210. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS" MOZ_SERVICES_SYNC="1"
  211. #---------------------------------------------------------------------
  212. %install
  213. cd %{tarballdir}
  214. # set up our prefs before install, so it gets pulled in to omni.jar
  215. %{__cp} -p %{SOURCE12} dist/bin/defaults/pref/all-redhat.js
  216. DESTDIR=$RPM_BUILD_ROOT make install
  217. # Start script install
  218. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  219. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{gecko_dir_ver},g' > \
  220. $RPM_BUILD_ROOT%{_bindir}/%{name}
  221. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  222. %{__rm} -f $RPM_BUILD_ROOT%{mozappdir}/%{name}-config
  223. # Copy pc files (for compatibility with 1.9.1)
  224. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  225. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  226. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  227. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  228. # Fix multilib devel conflicts...
  229. function install_file() {
  230. genheader=$*
  231. mv ${genheader}.h ${genheader}%{__isa_bits}.h
  232. cat > ${genheader}.h << EOF
  233. /* This file exists to fix multilib conflicts */
  234. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__) || (defined(__sparc__) && defined(__arch64__))
  235. #include "${genheader}64.h"
  236. #else
  237. #include "${genheader}32.h"
  238. #endif
  239. EOF
  240. }
  241. INTERNAL_APP_NAME=%{name}-%{gecko_dir_ver}
  242. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  243. install_file "mozilla-config"
  244. install_file "js-config"
  245. popd
  246. # Link libraries in sdk directory instead of copying them:
  247. pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-devel-%{gecko_dir_ver}/sdk/lib
  248. for i in *.so; do
  249. rm $i
  250. ln -s %{mozappdir}/$i $i
  251. done
  252. popd
  253. # Library path
  254. LD_SO_CONF_D=%{_sysconfdir}/ld.so.conf.d
  255. LD_CONF_FILE=xulrunner-%{__isa_bits}.conf
  256. %{__mkdir_p} ${RPM_BUILD_ROOT}${LD_SO_CONF_D}
  257. %{__cat} > ${RPM_BUILD_ROOT}${LD_SO_CONF_D}/${LD_CONF_FILE} << EOF
  258. %{mozappdir}
  259. EOF
  260. # Copy over the LICENSE
  261. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
  262. # ghost files
  263. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/components
  264. touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
  265. touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
  266. #---------------------------------------------------------------------
  267. %post -p /sbin/ldconfig
  268. %postun -p /sbin/ldconfig
  269. %preun
  270. # is it a final removal?
  271. if [ $1 -eq 0 ]; then
  272. %{__rm} -rf %{mozappdir}/components
  273. fi
  274. %files
  275. %defattr(-,root,root,-)
  276. %{_bindir}/xulrunner
  277. %dir %{mozappdir}
  278. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  279. %doc %attr(644, root, root) %{mozappdir}/README.txt
  280. %{mozappdir}/chrome
  281. %{mozappdir}/chrome.manifest
  282. %{mozappdir}/dictionaries
  283. %dir %{mozappdir}/components
  284. %ghost %{mozappdir}/components/compreg.dat
  285. %ghost %{mozappdir}/components/xpti.dat
  286. %{mozappdir}/components/*.so
  287. %{mozappdir}/components/*.manifest
  288. %{mozappdir}/omni.ja
  289. %{mozappdir}/plugins
  290. %{mozappdir}/*.so
  291. %{mozappdir}/mozilla-xremote-client
  292. %{mozappdir}/run-mozilla.sh
  293. %{mozappdir}/xulrunner
  294. %{mozappdir}/xulrunner-bin
  295. %{mozappdir}/xulrunner-stub
  296. %{mozappdir}/platform.ini
  297. %{mozappdir}/dependentlibs.list
  298. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  299. %{mozappdir}/plugin-container
  300. %files devel
  301. %defattr(-,root,root,-)
  302. %dir %{_libdir}/%{name}-devel-*
  303. %{_datadir}/idl/%{name}*%{gecko_dir_ver}
  304. %{_includedir}/%{name}*%{gecko_dir_ver}
  305. %{_libdir}/%{name}-devel-*/*
  306. %{_libdir}/pkgconfig/*.pc
  307. %{mozappdir}/xpcshell
  308. #---------------------------------------------------------------------
  309. %changelog
  310. * Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.6-1
  311. - update to 10.0.6 (based on firefox-10.0.6esr source)
  312. * Wed Mar 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.3-1
  313. - update to 10.0.3 (based on firefox-10.0.3esr source)
  314. - clean up spec
  315. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
  316. - rebuild with libnotify-0.7
  317. * Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
  318. - modify gre.conf to promote internal gecko version.
  319. * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
  320. - update to 2.0.1 (sync with firefox-4.0.1)
  321. * Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
  322. - update to 2.0 (sync with firefox-4.0)
  323. - BR: libjpeg-turbo-devel >= 1.1.0
  324. - BR: nspr-devel >= 4.8.7
  325. - BR: nss-devel >= 3.12.9
  326. - BR: cairo-devel >= 1.10.2-2
  327. - add Patch130 to use omni.jar (upstream patch)
  328. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
  329. - update to 1.9.2.15 (sync with firefox-3.6.15)
  330. * Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
  331. - update to 1.9.2.14 (sync with firefox-3.6.14)
  332. * Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
  333. - update to 1.9.2.13 (sync with firefox-3.6.13)
  334. * Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
  335. - update to 1.9.2.11 (sync with firefox-3.6.11)
  336. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
  337. - rebuild with rpm-4.8.1 for pkg-config file
  338. * Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
  339. - update to 1.9.2.9 (sync with firefox-3.6.9)
  340. - add patch10 to build with libjpeg-turbo
  341. - build with sqlite-3.7.2
  342. - BR: nspr >= 4.8.6
  343. * Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
  344. - update tp 1.9.2.8 (sync with firefox-3.6.8)
  345. * Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
  346. - update tp 1.9.2.7 (sync with firefox-3.6.7)
  347. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  348. - enable ipc only on ix86/x86_64 arches
  349. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  350. - update to 1.9.2.4 (sync with firefox-3.6.4)
  351. - add patch10 to fix build failure
  352. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  353. - update to 1.9.2.3 (sync with firefox-3.6.3)
  354. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  355. - update to 1.9.2.2 (sync with firefox-3.6.2)
  356. - add patch7,9 for fix build failure
  357. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  358. - enable libnotify support
  359. - add ac_add_options --enable-libnotify
  360. - disable Necko wifi monitor
  361. - add ac_add_options --disable-necko-wifi
  362. - remove BR: wireless-tools-devel
  363. - fix %%files devel
  364. - add patch3,5 to fix jemalloc alignment assertion
  365. - add Patch8 to fix mozilla-plugin.pc
  366. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  367. - add BR: libnotify-devel, wireless-tools-devel
  368. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  369. - update to 1.9.2 (sync with firefox-3.6)
  370. - obsoletes xulrunner-devel-unstable
  371. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  372. - use internal sqlite3 on vine5
  373. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  374. - update to 1.9.1.7
  375. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  376. - update to 1.9.1.6
  377. - build with sqlite3-3.6.21
  378. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  379. - update to 1.9.1.5
  380. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  381. - update to 1.9.1.3
  382. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  383. - really update to 1.9.1.2 (<BTS:0748>)
  384. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  385. - update to 1.9.1.2 (sync with firefox-3.5.2)
  386. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  387. - update to 1.9.1.1 (sync with firefox-3.5.1)
  388. - add missing Requires to -devel
  389. - add missing BR
  390. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  391. - enable-system-cairo
  392. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  393. - update to 1.9.1 (based on firefox 3.5)
  394. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  395. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  396. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  397. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  398. - remove old patches
  399. - require nspr >= 4.8
  400. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  401. - new upstream release
  402. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  403. - update mozconfig
  404. - disable-system-cairo for stability
  405. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  406. - new upstream release
  407. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  408. - new upstream release
  409. - add ja locale
  410. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  411. - new upstream release
  412. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  413. - new upstream release
  414. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  415. - add Patch3
  416. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  417. - update to xulrunner 1.9.0.2 byild 6
  418. - build with gnome-2.24
  419. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  420. - new upstream release
  421. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  422. - initial build for Vine Linux
  423. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  424. - Update to 1.9 final
  425. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  426. - Simplify PS/PDF operators
  427. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  428. - Upstream patch to fsync() less
  429. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  430. - Ensure we enable startup notification; add BR and modify config
  431. (bug #445543)
  432. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  433. - Some files moved to mozilla-filesystem; kill them and add the Req
  434. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  435. - Clean up the %%files list and get rid of the executable bit on some files
  436. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  437. - Fix font scaling
  438. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  439. - Enabled phishing protection (#443403)
  440. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  441. - Changed "__ppc64__" to "__powerpc64__",
  442. "__ppc64__" doesn't work anymore
  443. - Added fix for #443725 - Critical hanging bug with fix
  444. available upstream (mozbz#429903)
  445. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  446. - Fixed multilib issues, added starting script instead of a symlink
  447. to binary (#436393)
  448. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  449. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  450. - Re-enable system cairo
  451. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  452. - Spec cleanups
  453. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  454. - Beta 5
  455. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  456. - Beta 5 RC2
  457. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  458. - Update to latest trunk (2008-03-27)
  459. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  460. - Update to latest trunk (2008-03-26)
  461. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  462. - Update to latest trunk (2008-03-25)
  463. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  464. - Update to latest trunk (2008-03-24)
  465. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  466. - Update to latest trunk (2008-03-20)
  467. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  468. - Update to latest trunk (2008-03-17)
  469. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  470. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  471. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  472. - Update to latest trunk (2008-03-16)
  473. - Add patch to negate a11y slowdown on some pages (#431162)
  474. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  475. - Update to latest trunk (2008-03-15)
  476. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  477. - Avoid conflicts between gecko debuginfo packages
  478. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  479. - Update to latest trunk (2008-03-12)
  480. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  481. - Update to latest trunk (2008-03-11)
  482. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  483. - Update to latest trunk (2008-03-10)
  484. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  485. - Update to latest trunk (2008-03-09)
  486. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  487. - Update to latest trunk (2008-03-07)
  488. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  489. - Update to latest trunk (2008-03-06)
  490. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  491. - Update to latest trunk (2008-03-04)
  492. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  493. - Update to latest trunk (2008-03-02)
  494. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  495. - Update to latest trunk (2008-03-01)
  496. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  497. - Update to latest trunk (2008-02-29)
  498. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  499. - Update to latest trunk (2008-02-28)
  500. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  501. - Update to latest trunk (2008-02-27)
  502. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  503. - Update to latest trunk (2008-02-26)
  504. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  505. - Update to latest trunk (2008-02-23)
  506. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  507. - Update to latest trunk (2008-02-22)
  508. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  509. - Update to latest trunk (2008-02-21)
  510. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  511. - Update to latest trunk (2008-02-20)
  512. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  513. - Update to latest trunk (2008-02-17)
  514. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  515. - Update to latest trunk (2008-02-15)
  516. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  517. - Update to latest trunk (2008-02-14)
  518. - Use system hunspell
  519. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  520. - Update to latest trunk (2008-02-11)
  521. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  522. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  523. you know, debuginfo.
  524. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  525. - Update to latest trunk (2008-02-10)
  526. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  527. - Update to latest trunk (2008-02-09)
  528. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  529. - Update to latest trunk (2008-02-06)
  530. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  531. - Update to latest trunk (2008-01-30)
  532. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  533. - rebuild agains new nss
  534. - enabled gnome vfs
  535. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  536. - fixed stable pkg-config files (#429654)
  537. - removed sqlite patch
  538. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  539. - Update to latest trunk (2008-01-21)
  540. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  541. - Update to latest trunk (2008-01-15)
  542. - Now with system extensions directory support
  543. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  544. - Update to latest trunk (2008-01-13)
  545. - Use CFLAGS instead of configure arguments
  546. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  547. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  548. - Provide gecko-devel-unstable as well
  549. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  550. - divided devel package to devel and devel-unstable
  551. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  552. - removed fedora specific pkg-config files
  553. - updated to the latest trunk (2008-01-07)
  554. - removed unnecessary patches
  555. - fixed idl dir (#427965)
  556. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  557. - Re-enable camellia256 support now that NSS supports it
  558. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  559. - updated to the latest trunk (2008-01-03)
  560. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  561. - Don't Provide webclient (xulrunner is not itself a webclient)
  562. - Don't Obsolete old firefox, only firefox-devel
  563. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  564. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  565. - added java and plugin subdirs to plugin includes
  566. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  567. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  568. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  569. - updated to Beta 2.
  570. - moved SDK to xulrunner-sdk
  571. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  572. - fixed mozilla-plugin.pc (#412971)
  573. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  574. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  575. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  576. - added xulrunner/js include dir to xulrunner-js
  577. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  578. - update to beta 1
  579. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  580. - packed all gecko libraries (#389391)
  581. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  582. - registered xulrunner libs system-wide
  583. - added xulrunner-gtkmozembed.pc
  584. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  585. - added proper nss/nspr dependencies
  586. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  587. - more build fixes, use system nss libraries
  588. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  589. - build fixes
  590. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  591. - updated to the latest trunk
  592. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  593. - build fixes for ppc/ppc64
  594. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  595. - removed conflicts with the current gecko-based apps
  596. - added updated ppc64 patch
  597. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  598. - build fixes
  599. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  600. - Initial cut at XULRunner 1.9 Alpha 7
  601. - Temporarily revert camellia 256 support since our nss doesn't support it yet