gnokii-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486
  1. # TODO: merge patches upstream where applicable
  2. Name: gnokii
  3. Version: 0.6.31
  4. Release: 1%{?_dist_release}
  5. Summary: Linux/Unix tool suite for various mobile phones
  6. Summary(ja): 様々な携帯電話向けの Linux/Unix ツール集
  7. Group: Applications/Communications
  8. License: GPLv2+
  9. URL: http://www.gnokii.org/
  10. Source0: http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
  11. #----------------------------------------------------------------------------
  12. Source2: gnokii-smsd.init
  13. Source3: gnokii-smsd.sysconfig
  14. Source4: gnokii-smsd.logrotate
  15. Source5: gnokii-smsd2mail.sh
  16. Source6: gnokii-smsd-README.smsd2mail
  17. # Patch to remove port locking and apply the system-wide /usr/sbin directory
  18. # to the path instead of the default /usr/local
  19. Patch1: gnokii-config.patch
  20. #----------------------------------------------------------------------------
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. #----------------------------------------------------------------------------
  23. BuildRequires: flex
  24. BuildRequires: gettext
  25. BuildRequires: ImageMagick
  26. BuildRequires: bluez-libs-devel
  27. BuildRequires: desktop-file-utils
  28. BuildRequires: gtk2-devel
  29. BuildRequires: libusb-devel
  30. BuildRequires: libmysqlclient-devel
  31. BuildRequires: libpq-devel
  32. BuildRequires: readline-devel
  33. BuildRequires: pcsc-lite-devel
  34. BuildRequires: sqlite3-devel
  35. BuildRequires: zlib-devel
  36. BuildRequires: libical-devel >= 0.24
  37. BuildRequires: libXt-devel
  38. BuildRequires: libXpm-devel
  39. BuildRequires: perl(XML::Parser)
  40. Requires(pre): %{_sbindir}/groupadd
  41. #----------------------------------------------------------------------------
  42. %description
  43. Gnokii provides tools and a user space driver for use with mobile
  44. phones under Linux, various unices and Win32. With gnokii you can do
  45. such things as make data calls, update your address book, change
  46. calendar entries, send and receive SMS messages and load ring tones
  47. depending on the phone you have.
  48. #----------------------------------------------------------------------------
  49. %package -n xgnokii
  50. Summary: Graphical Linux/Unix tool suite for various mobile phones
  51. Group: Applications/Communications
  52. Requires: %{name} = %{version}-%{release}
  53. %description -n xgnokii
  54. Xgnokii is graphical Linux/Unix tool suite for various mobile
  55. phones. It allows you to edit your contacts book, send/read SMS's
  56. from/in computer and more other features.
  57. #----------------------------------------------------------------------------
  58. %package smsd
  59. Summary: Gnokii SMS daemon
  60. Group: System Environment/Daemons
  61. Requires: %{name} = %{version}-%{release}
  62. Requires(pre): %{_sbindir}/useradd
  63. Requires(post): /sbin/chkconfig
  64. Requires(preun): /sbin/chkconfig
  65. %description smsd
  66. The Gnokii SMS daemon receives and sends SMS messages.
  67. #----------------------------------------------------------------------------
  68. %package smsd-pgsql
  69. Summary: PostgreSQL support for Gnokii SMS daemon
  70. Group: System Environment/Daemons
  71. Requires: %{name}-smsd = %{version}-%{release}
  72. Obsoletes: %{name}-smsd-postgresql < 0.6.4-0.lvn.2
  73. %description smsd-pgsql
  74. %{summary}.
  75. #----------------------------------------------------------------------------
  76. %package smsd-mysql
  77. Summary: MySQL support for Gnokii SMS daemon
  78. Group: System Environment/Daemons
  79. Requires: %{name}-smsd = %{version}-%{release}
  80. %description smsd-mysql
  81. %{summary}.
  82. #----------------------------------------------------------------------------
  83. %package devel
  84. Summary: Gnokii development files
  85. Group: Development/Libraries
  86. Requires: %{name} = %{version}-%{release}
  87. Requires: pkgconfig
  88. %description devel
  89. %{summary}.
  90. #----------------------------------------------------------------------------
  91. %prep
  92. %setup -q
  93. %patch1 -p0
  94. install -pm 644 %{SOURCE5} smsd2mail.sh
  95. install -pm 644 %{SOURCE6} README.smsd2mail
  96. %build
  97. %configure --enable-security --disable-rpath --disable-static \
  98. --enable-libical --with-x
  99. make %{?_smp_mflags}
  100. # xgnokii isn't built by the above make operation (Is it a bug?)
  101. make %{?_smp_mflags} -C xgnokii
  102. #----------------------------------------------------------------------------
  103. %install
  104. make install DESTDIR=$RPM_BUILD_ROOT
  105. make install DESTDIR=$RPM_BUILD_ROOT -C xgnokii
  106. # Rename smsd to gnokii-smsd
  107. mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
  108. mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
  109. sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  110. sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  111. # Remove libtool droppings
  112. rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
  113. # Fix up the default desktop file
  114. desktop-file-install \
  115. --delete-original \
  116. --vendor "" \
  117. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  118. --mode 644 \
  119. --add-category X-VineLinux \
  120. $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
  121. # Convert the default icons to PNG
  122. install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
  123. convert Docs/sample/logo/gnokii.xpm \
  124. $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  125. chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  126. # Install the configuration files
  127. install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
  128. install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
  129. install -Dpm 644 %{SOURCE4} \
  130. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
  131. cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
  132. # Install the docs
  133. rm -rf temporary-gnokii-docs
  134. mkdir -p temporary-gnokii-docs/
  135. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
  136. %find_lang %{name}
  137. %clean
  138. rm -rf $RPM_BUILD_ROOT
  139. #----------------------------------------------------------------------------
  140. %pre
  141. %{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
  142. %pre smsd
  143. %{_sbindir}/useradd -r -M -d / -g gnokii \
  144. -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
  145. %post -p /sbin/ldconfig
  146. %postun -p /sbin/ldconfig
  147. %post smsd
  148. /sbin/chkconfig --add gnokii-smsd
  149. %preun smsd
  150. if [ $1 -eq 0 ] ; then
  151. %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
  152. /sbin/chkconfig --del gnokii-smsd
  153. fi
  154. %postun smsd
  155. if [ $1 -ge 1 ] ; then
  156. %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
  157. fi
  158. #----------------------------------------------------------------------------
  159. %files -f %{name}.lang
  160. %defattr(-,root,root,-)
  161. %doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
  162. %config(noreplace) %{_sysconfdir}/gnokiirc
  163. %attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
  164. %{_bindir}/gnokii
  165. %{_bindir}/sendsms
  166. %{_bindir}/gnokiid
  167. %{_libdir}/libgnokii.so.*
  168. %{_mandir}/man1/gnokii.1*
  169. %{_mandir}/man1/sendsms.1*
  170. %{_mandir}/man8/gnokiid.8*
  171. %{_mandir}/man8/mgnokiidev.8*
  172. %files -n xgnokii
  173. %defattr(-,root,root,-)
  174. %doc xgnokii/ChangeLog xgnokii/README.vcard
  175. %{_bindir}/xgnokii
  176. %{_datadir}/pixmaps/xgnokii.png
  177. %{_datadir}/applications/*xgnokii.desktop
  178. %{_mandir}/man1/xgnokii.1*
  179. %files smsd
  180. %defattr(-,root,root,-)
  181. %doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
  182. %attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
  183. %config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
  184. %{_initrddir}/gnokii-smsd
  185. %{_bindir}/gnokii-smsd
  186. %{_mandir}/man8/gnokii-smsd.8*
  187. %dir %{_libdir}/smsd/
  188. %{_libdir}/smsd/libsmsd_file.so
  189. %{_libdir}/smsd/libsmsd_sqlite.so
  190. %files smsd-pgsql
  191. %defattr(-,root,root,-)
  192. %doc smsd/sms.tables.pq.sql
  193. %{_libdir}/smsd/libsmsd_pq.so
  194. %files smsd-mysql
  195. %defattr(-,root,root,-)
  196. %doc smsd/sms.tables.mysql.sql
  197. %{_libdir}/smsd/libsmsd_mysql.so
  198. %files devel
  199. %defattr(-,root,root,-)
  200. %{_includedir}/gnokii*
  201. %{_libdir}/libgnokii.so
  202. %{_libdir}/pkgconfig/gnokii.pc
  203. %{_libdir}/pkgconfig/xgnokii.pc
  204. #----------------------------------------------------------------------------
  205. # Maintainers: babasaki@mindgear.org
  206. #
  207. #----------------------------------------------------------------------------
  208. %changelog
  209. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.31-1
  210. - new upstream release
  211. - updated Patch1
  212. - built with libmysqlclient 10.0.15 and libpq 9.3.4
  213. - updated BR for libmysqlclient-devel and libpq-devel
  214. - added BR: pcsc-lite-devel
  215. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
  216. - new upstream release
  217. - remove Patch0
  218. - add BuildRequires: sqlite3-devel
  219. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
  220. - add BuildRequires: readline-devel
  221. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
  222. - rebuilt with postgresql-9.0.3
  223. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
  224. - rebuilt with rpm-4.8.1 for pkg-config
  225. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
  226. - rebuilt with MySQL-5.1.34.
  227. * Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
  228. - Import gnokii - Packager: Babasaki
  229. - Updated specfile
  230. #----------------------------------------------------------------------------
  231. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
  232. - Fix htmlview patch
  233. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
  234. - Update to 0.6.27
  235. * Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
  236. - Rebuild
  237. * Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
  238. - Rebuild with libical support
  239. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
  240. - Update to 0.6.26
  241. * Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
  242. - Set empty --vendor rather none for using desktop-file-install
  243. - Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
  244. * Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
  245. - Update to 0.6.25
  246. * Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
  247. - Update to 0.6.24
  248. * Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
  249. - Rebuild for GCC 4.3.
  250. * Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
  251. - Pick up new libssl .solib version dependency.
  252. * Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
  253. - Update to 0.6.22
  254. * Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
  255. - Update to 0.6.20
  256. * Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
  257. - Even better multilib fixing (#335161)
  258. * Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
  259. - Quick fix to multilib conflict (#335161)
  260. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
  261. - New upstream release
  262. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
  263. - Update license field from GPL to GPLv2+
  264. * Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
  265. - New upstream release
  266. * Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
  267. - New upstream release
  268. - Update smsd name change patch
  269. - ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
  270. upstream
  271. * Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
  272. - Rebuild to pick up new libpq IF
  273. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
  274. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  275. * Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
  276. - New upstream release.
  277. * Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
  278. - Rebuild for Fedora Extras 6.
  279. * Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
  280. - Bump because tagged before committing sources and I just
  281. dont know how the f* you delete a tag in CVS at the moment
  282. and it does seem like a too big endavour to find out just
  283. in order to have a nice release tag.
  284. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
  285. - New upstream release.
  286. - New dependency on libusb for USB serial, DKU no longer needed/wanted
  287. so now we have that troublesome issue resolved once and for all.
  288. - Remove patches to SQL files: these are now fixed upstream!
  289. * Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  290. - Rebuilding due to changed interface on libbluetooth.
  291. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  292. - Goofed up. Fixit it...
  293. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
  294. - Post-import updates.
  295. * Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
  296. - Updated after comments from Ville.
  297. * Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
  298. - New upstream tarball
  299. * Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
  300. - Updated after comments from Ville.
  301. * Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
  302. - 0.6.11
  303. - Modified to drop into the Fedora Extras as the nice package it now is
  304. - Based work off Ville's good olde package
  305. * Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
  306. - 0.6.10.
  307. - Clean up pkgconfig file and -devel dependencies from bits needed only
  308. for static libs.
  309. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
  310. - 0.6.9, desktop entry file included upstream.
  311. - Drop zero Epochs.
  312. * Sat Aug 6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
  313. - 0.6.8.
  314. - Don't ship static libraries.
  315. - Rename smsd to gnokii-smsd to avoid conflicts with smstools.
  316. - Remove not included files instead of using %%exclude.
  317. * Sat Jun 4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
  318. - BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
  319. * Thu Jun 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
  320. - 0.6.7.
  321. - Build unconditionally with bluetooth support.
  322. * Mon May 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
  323. - 0.6.5.
  324. * Fri Nov 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
  325. - Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
  326. packages in FC/Extras.
  327. * Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
  328. - Update to 0.6.4, perms and pgsql patches applied upstream.
  329. - Xgnokii help locale symlink hack no longer necessary.
  330. - Don't remove user/group on last erase, move smsd user to -smsd subpackage.
  331. - Add libical support (disabled), rebuild with "--with libical" to enable.
  332. * Mon Jul 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
  333. - Update to 0.6.3.
  334. * Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
  335. - Improve Xgnokii desktop entry according to GNOME HIG.
  336. * Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
  337. - Remove duplicate gettext build dependency (bug 95).
  338. * Sun Jun 6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
  339. - Fix chown syntax in smsd init script.
  340. - Summary and description improvements.
  341. - Trim $RPM_OPT_FLAGS out from gnokii.pc.
  342. - Make -devel require XFree86-devel.
  343. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
  344. - Update to 0.6.1.
  345. * Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
  346. - Make -devel require pkgconfig.
  347. * Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
  348. - Update to 0.6.0.
  349. * Mon Feb 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
  350. - Update to 0.5.10.
  351. * Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
  352. - Update to 0.5.9.
  353. - Specfile cleanups, small init script enhancements.
  354. * Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
  355. - Update to 0.5.7.
  356. - Move smsd man page into -smsd subpackage.
  357. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
  358. - Update to 0.5.6.
  359. - Include sample action script for forwarding SMSD messages to mail.
  360. - s/fedora/livna/.
  361. - Specfile and init script cleanups.
  362. * Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
  363. - Disable smp flags to prevent build failure
  364. * Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
  365. - Update to 0.5.2.
  366. * Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
  367. - Update to 0.5.1.
  368. - Include init script, sysconfig and logrotate config for smsd.
  369. * Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
  370. - Update to 0.5.0.
  371. * Sun Nov 3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
  372. - RedHat'ified PLD version.