neon-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.28.6
  6. Release: 3%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.webdav.org/neon/
  10. Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: expat
  13. Requires: zlib >= 1.1.4
  14. Requires: krb5-libs
  15. BuildRequires: expat-devel
  16. BuildRequires: gnutls-devel
  17. BuildRequires: krb5-devel
  18. BuildRequires: libxml2-devel
  19. #BuildRequires: openssl-devel
  20. BuildRequires: sed
  21. BuildRequires: zlib-devel
  22. %description
  23. neon is an HTTP and WebDAV client library, with a C interface;
  24. providing a high-level interface to HTTP and WebDAV methods along
  25. with a low-level interface for HTTP request handling. neon
  26. supports persistent connections, proxy servers, basic, digest and
  27. Kerberos authentication, and has complete SSL support.
  28. %package devel
  29. Summary: Development libraries and C header files for the neon library
  30. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}
  33. Requires: zlib-devel
  34. #Requires: openssl-devel
  35. Requires: expat-devel
  36. Requires: gnutls-devel
  37. %description devel
  38. The development library for the C language HTTP and WebDAV client library.
  39. %description devel -l ja
  40. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  41. ## to build compat32 for x86_64 architecture support
  42. %package -n compat32-%{name}
  43. Summary: C language HTTP and WebDAV client library.
  44. Group: System Environment/Libraries
  45. Requires: expat
  46. Requires: zlib >= 1.1.4
  47. %description -n compat32-%{name}
  48. A C language HTTP and WebDAV client library.
  49. %package -n compat32-%{name}-devel
  50. Summary: A C language HTTP and WebDAV client library.
  51. Group: Development/Libraries
  52. Requires: compat32-%{name} = %{version}
  53. Requires: compat32-zlib-devel
  54. #Requires: compat32-openssl-devel
  55. Requires: compat32-expat-devel
  56. %description -n compat32-%{name}-devel
  57. The development library for the C language HTTP and WebDAV client library.
  58. %prep
  59. %setup -q
  60. %build
  61. %configure \
  62. --with-expat \
  63. --with-ssl=gnutls \
  64. --enable-threadsafe-ssl=posix \
  65. --enable-shared \
  66. --disable-static \
  67. --with-force-ssl
  68. %__make %{?_smp_mflags}
  69. %install
  70. %__rm -rf %{buildroot}
  71. %makeinstall
  72. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  73. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  74. %find_lang %{name}
  75. ## remove unuse files
  76. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %post -n compat32-%{name} -p /sbin/ldconfig
  82. %postun -n compat32-%{name} -p /sbin/ldconfig
  83. %files -f %{name}.lang
  84. %defattr(-,root,root)
  85. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  86. %doc doc/html
  87. %{_libdir}/*.so.*
  88. %files devel
  89. %defattr(-,root,root)
  90. %{_bindir}/*
  91. %{_includedir}/*
  92. %{_mandir}/man1/*
  93. %{_mandir}/man3/*
  94. #{_libdir}/*.a
  95. #{_libdir}/*.la
  96. %{_libdir}/*.so
  97. %{_libdir}/pkgconfig/*.pc
  98. %if %{build_compat32}
  99. %files -n compat32-%{name}
  100. %defattr(-,root,root)
  101. %{_libdir}/*.so.*
  102. %files -n compat32-%{name}-devel
  103. %defattr(-,root,root)
  104. #{_libdir}/*.a
  105. #{_libdir}/*.la
  106. %{_libdir}/pkgconfig/*.pc
  107. %endif
  108. %changelog
  109. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  110. - rebuilt with krb5-libs-1.8.2
  111. - removed BR: openssl-devel
  112. - removed static library from devel package
  113. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  114. - rebuilt with rpm-4.8.1 for pkg-config
  115. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  116. - new upstream release with security fix (CVE-2009-2473, 2474)
  117. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  118. - rebuild with gnutls-2.6.3
  119. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  120. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  121. - add _smp_mflags into make section
  122. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  123. - new upstream release with security fix (CVE-2008-3746)
  124. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  125. - removed *.la
  126. - spec in utf-8
  127. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  128. - added --with-ssl=gnutls --enable-threadsafe-ssl
  129. - added BuildRequires: gnutls-devel
  130. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  131. - new upstream release
  132. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  133. - removed %%if !%%{build_compat32} case condition
  134. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  135. - rebuild with expat-2.0.1
  136. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  137. - new upstream release
  138. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  139. - add Requires: zlib-devel, openssl-devel, expat-devel
  140. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  141. - move %%configure from %%prep to %%build
  142. - remove unneeded locales.patch (for neon-0.26.x or later)
  143. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  144. - new upstream release
  145. - drop doc.patch (patch0)
  146. - use more macros
  147. - drop BuildRequires: autoconf, automake
  148. - add *.pc to -devel (and compat32's) package
  149. - change group
  150. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  151. - add doc/html instead of doc/* to %%doc
  152. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  153. - run ldconfig in %%post,postun
  154. - add locales.patch (patch0)
  155. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  156. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  157. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  158. - added compat32- packages for x86_64 architecture support
  159. - added --libdir=%{_libdir} option to configure
  160. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  161. - new upstream release
  162. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  163. - upstream release
  164. - update URL and Source0 tag: valid URL
  165. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  166. - upstream release
  167. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  168. - add Japanese Summary and %%description
  169. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  170. - build VineLinux
  171. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  172. - Updated to 0.23.5.
  173. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  174. - Upgraded to 0.23.2.
  175. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  176. - Upgraded to 0.22.0.
  177. - Fixed compilation from CVS.
  178. - Took out man pages until I can figure out xmlto program.
  179. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  180. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  181. to RedHat 7.3 versions and fixing bug in spec file.
  182. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  183. work.
  184. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  185. - Fixed file ownership problems. Made them owned by root.
  186. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  187. - Updated to neon 0.21.3.
  188. * Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  189. - Updated to neon 0.21.2.
  190. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  191. - Updated to neon 0.21.1.
  192. - Now requires zlib >= 1.1.4.
  193. - Broke into zlib and zlib-devel.
  194. - Now builds shared library.
  195. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  196. - Updated to neon 0.19.4.
  197. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  198. - Updated to neon 0.19.2.
  199. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  200. - Updated to neon 0.18.2.
  201. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  202. - Took out dependency on libxml and w3c-libwww packages.
  203. - Added dependency on expat.
  204. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  205. - Release 0.17.2-1: Updated neon.
  206. * Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  207. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  208. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  209. - Release 2001-10-20: Initial Version.