gnome-shell-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. %define pkg_version 3.2.2.1
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. Patch0: gnome-shell-3.2.1-shell_parse_argv.patch
  9. # settings for Vine
  10. Patch101: gnome-shell-vine-settings.patch
  11. Patch102: gnome-shell-vine-customize.patch
  12. Patch103: gnome-shell-ja.po-date.patch
  13. License: GPLv2+
  14. Group: User Interface/Desktops
  15. URL: http://live.gnome.org/GnomeShell
  16. Requires(post,postun): scrollkeeper >= 0.1.4
  17. Requires(post,pre,preun): GConf2 >= 2.14
  18. Requires: mutter
  19. Requires: caribou
  20. Requires: openssl
  21. BuildRequires: gnome-common
  22. BuildRequires: libtool
  23. BuildRequires: automake
  24. BuildRequires: autoconf
  25. BuildRequires: pkgconfig
  26. BuildRequires: gtk2-devel
  27. BuildRequires: clutter-devel
  28. BuildRequires: mutter-devel
  29. BuildRequires: gjs-devel
  30. BuildRequires: gnome-desktop3-devel
  31. BuildRequires: gnome-menus-devel
  32. BuildRequires: libSM-devel
  33. BuildRequires: libffi-devel
  34. BuildRequires: GConf2-devel
  35. BuildRequires: startup-notification-devel
  36. BuildRequires: gnome-doc-utils
  37. BuildRequires: desktop-file-utils
  38. BuildRequires: libcroco-devel
  39. BuildRequires: librsvg2-devel
  40. BuildRequires: gobject-introspection-devel
  41. BuildRequires: gstreamer-devel
  42. BuildRequires: dbus-glib-devel
  43. BuildRequires: telepathy-logger-devel
  44. BuildRequires: polkit-devel
  45. BuildRequires: pulseaudio-libs-devel
  46. BuildRequires: evolution-data-server-devel
  47. BuildRequires: folks-devel
  48. BuildRequires: NetworkManager-glib-devel
  49. BuildRequires: libgudev1-devel
  50. BuildRequires: openssl
  51. BuildRequires: intltool
  52. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. Packager: Takemikaduchi
  56. %description
  57. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  58. It provides core interface functions like switching to windows and launching
  59. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  60. hardware and introduces innovative user interface concepts to provide a delightful
  61. and easy to use experience.
  62. %prep
  63. %setup -q
  64. %patch0 -p1 -b .spawn
  65. %patch101 -p1 -b .vine
  66. #%patch102 -p1 -b .vine
  67. %patch103 -p1 -b .old_po2
  68. %build
  69. libtoolize --copy --force
  70. autoreconf
  71. %configure \
  72. --disable-static \
  73. --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
  74. %{__make} %{?_smp_mflags}
  75. %install
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  78. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  79. %find_lang %{name}
  80. %clean
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %post
  83. /sbin/ldconfig
  84. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  85. gconftool-2 --makefile-install-rule \
  86. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  87. > /dev/null || :
  88. touch --no-create %{_datadir}/icons/hicolor
  89. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  90. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  91. fi
  92. %pre
  93. if [ "$1" -gt 1 ]; then
  94. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  95. gconftool-2 --makefile-uninstall-rule \
  96. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  97. > /dev/null || :
  98. fi
  99. %preun
  100. if [ "$1" -eq 0 ]; then
  101. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  102. gconftool-2 --makefile-uninstall-rule \
  103. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  104. > /dev/null || :
  105. fi
  106. %postun
  107. scrollkeeper-update -q || :
  108. /sbin/ldconfig
  109. touch --no-create %{_datadir}/icons/hicolor
  110. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  111. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  112. fi
  113. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  114. %posttrans
  115. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  116. %files -f %{name}.lang
  117. %defattr(-,root,root)
  118. %doc COPYING NEWS README
  119. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
  120. %{_bindir}/gnome-shell
  121. %{_bindir}/gnome-shell-extension-tool
  122. %{_libdir}/gnome-shell/*
  123. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  124. %{_libexecdir}/gnome-shell-calendar-server
  125. %{_libexecdir}/gnome-shell-hotplug-sniffer
  126. %{_libexecdir}/gnome-shell-perf-helper
  127. %{_datadir}/applications/gnome-shell.desktop
  128. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  129. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  130. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  131. %{_datadir}/gnome-shell/*
  132. %{_datadir}/man/man1/*.1.gz
  133. %changelog
  134. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  135. - new upstream release
  136. - remove Patch1
  137. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  138. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  139. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  140. - rename Patch103 (gnome-shell-ja.po-date.patch)
  141. - drop Patch102
  142. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  143. - new upstream release
  144. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  145. - new upstream release
  146. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  147. - new upstream release
  148. - update Patch101
  149. - update Patch102
  150. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  151. - add BuildRequires: libgudev1-devel, openssl
  152. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  153. - new upstream release
  154. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  155. - add Requires: caribou
  156. - remove Patch0
  157. - update Patch101
  158. - update Patch102
  159. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  160. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  161. - rebuild with gnome-menus-3.1.5
  162. - add Patch0 (gnome-shell-git20110821.patch)
  163. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  164. - new upstream release
  165. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  166. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  167. - remove BuildRequires: xulrunner-devel
  168. - add Patch101 (gnome-shell-vine-settings.patch)
  169. - add Patch102 (gnome-shell-vine-customize.patch)
  170. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  171. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  172. - add Requires: mutter
  173. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  174. - new upstream release
  175. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  176. - initial build for Vine Linux