bind-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821
  1. %bcond_with systemd
  2. %bcond_with python
  3. %define python_executable %{__python}
  4. %define _localstatedir /var
  5. %define _unpackaged_files_terminate_build 1
  6. %define sname bind
  7. %define pname bind
  8. # example: 9.9.13.P1
  9. %define pversion 9.11.22
  10. # example: 9.9.13-P1
  11. %define sversion 9.11.22
  12. %define bind_epoch 1
  13. # fixed <BTS:VineLinux:1139>
  14. %define old_bind_version 1:9.9.2p2-1vl7
  15. %define bind_uid 25
  16. %define bind_gid 25
  17. %bcond_with readline
  18. Summary: A DNS (Domain Name System) server.
  19. Summary(ja): DNS (Domain Name System) サーバ
  20. Name: %{pname}
  21. Epoch: %{bind_epoch}
  22. Version: %{pversion}
  23. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  24. Group: servers
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: daisuke
  28. License: ISC and BSD and Public Domain
  29. URL: http://www.isc.org/bind.html
  30. Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
  31. Source1: bind-manpages.tar.bz2
  32. Source2: named.sysconfig
  33. Source3: named.init
  34. Source4: named.logrotate
  35. Source5: keygen.c
  36. Source100: named.service
  37. Source101: named-setup-rndc.service
  38. Source102: named.sysconfig.systemd
  39. Source103: bind.tmpfiles.d
  40. Source104: named.conf
  41. Patch1: bind-9.11.5-rndckey.patch
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. %if %{with python}
  44. BuildRequires: python
  45. BuildRequires: python-rpm-macros
  46. BuildRequires: python-ply
  47. %endif
  48. BuildRequires: openssl-devel glibc-devel libtool
  49. BuildRequires: libxml2-devel
  50. BuildRequires: libcap-devel
  51. %if %{with readline}
  52. BuildRequires: readline-devel
  53. %endif
  54. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  55. Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  56. Requires(pre): shadow-utils
  57. Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  58. Requires(post): coreutils
  59. %if %{with systemd}
  60. %{?systemd_requires}
  61. %else
  62. Requires(post): chkconfig
  63. Requires(preun): chkconfig
  64. %endif
  65. Conflicts: bind9 <= 9.2.1-0vl5, bind-current
  66. Obsoletes: bind9 <= 9.2.1-0vl5
  67. Obsoletes: bind-current < 1:9.9.4-1
  68. %description
  69. BIND (Berkeley Internet Name Domain) is an implementation of the DNS
  70. (Domain Name System) protocols. BIND includes a DNS server (named),
  71. which resolves host names to IP addresses, and a resolver library
  72. (routines for applications to use when interfacing with DNS). A DNS
  73. server allows clients to name resources or objects and share the
  74. information with other network machines. The named DNS server can be
  75. used on workstations as a caching name server, but is generally only
  76. needed on one machine for an entire network. Note that the
  77. configuration files for making BIND act as a simple caching nameserver
  78. are included in the caching-nameserver package.
  79. Install the bind package if you need a DNS server for your network. If
  80. you want bind to act a caching name server, you will also need to install
  81. the caching-nameserver package.
  82. %package libs
  83. Summary: Libraries used by various DNS packages
  84. Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
  85. Group: system
  86. Obsoletes: bind-current-libs <= %{old_bind_version}
  87. %description libs
  88. Contains libraries used by both the bind server package as well as the utils packages.
  89. %package utils
  90. Summary: Utilities for querying DNS name servers.
  91. Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
  92. Group: admin-tools
  93. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  94. Conflicts: bind9-utils <= 9.2.1-0vl5
  95. Conflicts: bind-current-utils
  96. Obsoletes: bind9-utils <= 9.2.1-0vl5
  97. Obsoletes: bind-current-utils <= %{old_bind_version}
  98. %description utils
  99. Bind-utils contains a collection of utilities for querying DNS (Domain
  100. Name Service) name servers to find out information about Internet hosts.
  101. These tools will provide you with the IP addresses for given host names,
  102. as well as other information about registered domains and network
  103. addresses.
  104. You should install bind-utils if you need to get information from DNS name
  105. servers.
  106. %package devel
  107. Summary: Include files and libraries needed for bind DNS development.
  108. Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
  109. Group: programming
  110. Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
  111. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  112. Conflicts: bind9-devel <= 9.2.1-0vl5
  113. Conflicts: bind-current-devel
  114. Obsoletes: bind9-devel <= 9.2.1-0vl5
  115. Obsoletes: bind-current-devel <= %{old_bind_version}
  116. %description devel
  117. The bind-devel package contains all the include files and the
  118. library required for DNS (Domain Name Service) development for
  119. BIND versions 9.x.x.
  120. You should install bind-devel if you want to develop bind DNS
  121. applications. If you install bind-devel, you'll also need to install
  122. bind.
  123. #'
  124. %prep
  125. %setup -n bind-%{sversion} -q
  126. %patch1 -p1 -b .key
  127. perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
  128. %build
  129. libtoolize --copy --force
  130. aclocal
  131. autoconf
  132. %configure \
  133. --with-libtool \
  134. --with-openssl=/usr \
  135. %if %{without readline}
  136. --without-readline \
  137. %endif
  138. --disable-openssl-version-ceck \
  139. --enable-threads \
  140. --enable-ipv6 \
  141. --with-pic \
  142. --with-dlz-dlopen \
  143. %if %{with python}
  144. --with-python=%{python_executable} \
  145. %else
  146. --with-python=no \
  147. %endif
  148. --enable-filter-aaaa \
  149. --enable-fixed-rrset
  150. make %{?_smp_mflags}
  151. %install
  152. rm -rf %{buildroot}
  153. mkdir -p %{buildroot}%{_sysconfdir}/{logrotate.d,sysconfig}
  154. mkdir -p %{buildroot}/usr/{bin,lib,sbin,include}
  155. mkdir -p %{buildroot}/var/named/data
  156. mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
  157. mkdir -p %{buildroot}/var/run/named
  158. make DESTDIR=%{buildroot} install
  159. install -c -m 640 bin/rndc/rndc.conf %{buildroot}/etc
  160. install -c -m 644 %SOURCE4 %{buildroot}%{_sysconfdir}/logrotate.d/named
  161. touch %{buildroot}%{_sysconfdir}/rndc.key
  162. gcc %{optflags} -o %{buildroot}/usr/sbin/dns-keygen %{SOURCE5}
  163. cd %{buildroot}%{_mandir}
  164. tar xjf %{SOURCE1}
  165. # newer version is contained in source
  166. rm -f man5/named.conf.5.gz
  167. install -m 644 %{SOURCE104} %{buildroot}%{_sysconfdir}/named.conf
  168. %if %{with systemd}
  169. # Systemd unit files
  170. mkdir -p %{buildroot}%{_unitdir}
  171. install -m 644 %{SOURCE100} %{buildroot}%{_unitdir}
  172. install -m 644 %{SOURCE101} %{buildroot}%{_unitdir}
  173. install -m 644 %{SOURCE102} %{buildroot}%{_sysconfdir}/sysconfig/named
  174. mkdir -p %{buildroot}%{_tmpfilesdir}
  175. install -m 644 %{SOURCE103} %{buildroot}%{_tmpfilesdir}/named.conf
  176. %else
  177. mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
  178. install -c -m 755 %SOURCE3 %{buildroot}%{_sysconfdir}/rc.d/init.d/named
  179. cp %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/named
  180. %endif
  181. chmod +x %{buildroot}%{_libdir}/*.so.*
  182. rm -f %{buildroot}%{_libdir}/*.la
  183. %clean
  184. rm -rf %{buildroot} ${RPM_BUILD_DIR}/%{name}-%{version}
  185. %pre
  186. if [ "$1" -eq 1 ]; then
  187. /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
  188. /usr/sbin/useradd -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
  189. fi;
  190. :;
  191. %post
  192. /sbin/ldconfig
  193. if [ "$1" -eq 1 ]; then
  194. if [ ! -e /etc/rndc.key ]; then
  195. /usr/sbin/rndc-confgen -a > /dev/null 2>&1
  196. fi
  197. [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
  198. # rndc.key has to have correct perms and ownership, CVE-2007-6283
  199. [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
  200. [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
  201. # Check DNSSEC settings if this is a fresh install
  202. if [ -r /etc/sysconfig/dnssec ]; then
  203. . /etc/sysconfig/dnssec
  204. [ -x /usr/sbin/dnssec-configure ] && \
  205. dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
  206. /dev/null 2>&1
  207. fi;
  208. fi
  209. %if %{with systemd}
  210. %systemd_post named.service
  211. %else
  212. if [ "$1" -eq 1 ]; then
  213. /sbin/chkconfig --add named
  214. fi
  215. %endif
  216. :;
  217. %preun
  218. %if %{with systemd}
  219. # Package removal, not upgrade
  220. %systemd_preun named.service
  221. %else
  222. if [ "$1" -eq 0 -o -x /sbin/systemctl ]; then
  223. /sbin/service named stop >/dev/null 2>&1 || :
  224. /sbin/chkconfig --del named ||:
  225. fi
  226. %endif
  227. exit 0
  228. %postun
  229. /sbin/ldconfig
  230. %if %{with systemd}
  231. # Package upgrade, not uninstall
  232. %systemd_postun_with_restart named.service
  233. %else
  234. if [ "$1" -ge 1 ]; then
  235. %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
  236. fi
  237. %endif
  238. exit 0
  239. %triggerpostun -- bind < 8.2.2_P5-15
  240. /sbin/chkconfig --add named
  241. /sbin/ldconfig
  242. %triggerpostun -- bind-current < 1:9.9.4-1
  243. /sbin/chkconfig --add named
  244. /sbin/ldconfig
  245. %post libs -p /sbin/ldconfig
  246. %postun libs -p /sbin/ldconfig
  247. %files
  248. %defattr(-,root,root)
  249. %license COPYRIGHT
  250. %doc CHANGES README*
  251. %doc doc/arm doc/misc
  252. %config(noreplace) %{_sysconfdir}/named.conf
  253. %config(noreplace) %{_sysconfdir}/logrotate.d/named
  254. %if %{with systemd}
  255. %{_unitdir}/named.service
  256. %{_unitdir}/named-setup-rndc.service
  257. %{_tmpfilesdir}/named.conf
  258. %else
  259. %config %{_sysconfdir}/rc.d/init.d/named
  260. %attr(-,named,named) %dir %{_var}/run/named
  261. %endif
  262. %config(noreplace) %{_sysconfdir}/sysconfig/named
  263. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
  264. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
  265. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
  266. %attr(-,named,named) %dir %{_var}/named
  267. %attr(-,named,named) %dir %{_var}/named/data
  268. %{_sbindir}/dnssec*
  269. %{_sbindir}/lwresd
  270. %{_sbindir}/named
  271. %{_sbindir}/named-check*
  272. %{_sbindir}/named-compilezone
  273. %{_sbindir}/rndc*
  274. %{_sbindir}/dns-keygen
  275. %{_bindir}/arpaname
  276. %{_sbindir}/ddns-confgen
  277. %{_sbindir}/genrandom
  278. %{_sbindir}/isc-hmac-fixup
  279. %{_sbindir}/named-journalprint
  280. %{_sbindir}/nsec3hash
  281. %{_sbindir}/tsig-keygen
  282. %if %{with python}
  283. %{python_sitelib}/*
  284. %endif
  285. %{_mandir}/man1/arpaname.1*
  286. %{_mandir}/man5/resolv.conf.5*
  287. %{_mandir}/man5/named.conf.5*
  288. %{_mandir}/man5/rndc.conf.5*
  289. %{_mandir}/man8/rndc.8*
  290. %{_mandir}/man8/named.8*
  291. %{_mandir}/man8/lwresd.8*
  292. %{_mandir}/man8/dnssec*.8*
  293. %{_mandir}/man8/named-checkconf.8*
  294. %{_mandir}/man8/named-checkzone.8*
  295. %{_mandir}/man8/named-compilezone.8*
  296. %{_mandir}/man8/rndc-confgen.8*
  297. %{_mandir}/man8/ddns-confgen.8*
  298. %{_mandir}/man8/genrandom.8*
  299. %{_mandir}/man8/isc-hmac-fixup.8*
  300. %{_mandir}/man8/named-journalprint.8*
  301. %{_mandir}/man8/nsec3hash.8*
  302. %{_mandir}/man8/tsig-keygen.8*
  303. %files libs
  304. %defattr(-,root,root)
  305. %{_libdir}/*.so.*
  306. %files utils
  307. %defattr(-,root,root)
  308. %{_bindir}/delv
  309. %{_bindir}/dig
  310. %{_bindir}/host
  311. %{_bindir}/mdig
  312. %{_bindir}/named-rrchecker
  313. %{_bindir}/nslookup
  314. %{_bindir}/nsupdate
  315. %{_mandir}/man1/delv.1*
  316. %{_mandir}/man1/dig.1*
  317. %{_mandir}/man1/host.1*
  318. %{_mandir}/man1/mdig.1*
  319. %{_mandir}/man1/named-rrchecker.1*
  320. %{_mandir}/man1/nslookup.1*
  321. %{_mandir}/man1/nsupdate.1*
  322. %{_mandir}/man5/resolver.5*
  323. %{_mandir}/man8/nslookup.8*
  324. %files devel
  325. %defattr(-,root,root)
  326. %{_libdir}/*.so
  327. %{_libdir}/*.a
  328. %{_includedir}/*
  329. %{_mandir}/man3/*
  330. %{_mandir}/man1/bind9-config.1*
  331. %{_mandir}/man1/isc-config.sh.1*
  332. %{_bindir}/bind9-config
  333. %{_bindir}/isc-config.sh
  334. %changelog
  335. * Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.22-1
  336. - updated to 9.11.22.
  337. * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-2
  338. - added systemd support (disabled as default).
  339. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
  340. - updated to 9.11.20.
  341. * Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
  342. - updated to 9.11.12.
  343. * Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
  344. - updated to 9.11.11.
  345. * Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
  346. - updated to 9.11.5 (new ESV).
  347. - updated Patch1.
  348. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
  349. - updated to 9.9.13.P1.
  350. - updated Patch1.
  351. * Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
  352. - update to 9.9.9.P8
  353. * Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
  354. - new upstream release.
  355. * Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
  356. - new upstream release.
  357. * Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
  358. - new upstream release.
  359. * Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
  360. - new upstream release with secrity fix (CVE-2016-1285,1286)
  361. - built with openssl 1.0.2g
  362. * Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
  363. - new upstream release with secrity fix (CVE-2015-4620)
  364. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
  365. - new upstream release with secrity fix (CVE-2015-4620)
  366. * Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
  367. - rebuilt without readline to avoid GPL infection
  368. * Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
  369. - new upstream release with secrity fix (CVE-2015-1349)
  370. - added BR: readline-devel
  371. * Fri Feb 6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
  372. - new upstream release with secrity fix (CVE-2014-8500)
  373. - used "3" as release number because of being newer than Vine Linux/6 updates
  374. * Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
  375. - update to 9.9.4(ESV)
  376. * Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
  377. - update to 9.9.2-P2
  378. - remove .la
  379. - remove Conflicts/Obsoletes from libs subpackage.
  380. - add configure options
  381. --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
  382. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
  383. - new upstream release.
  384. - added an option "--with-dlz-dlopen".
  385. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
  386. - Obosoletes: bind.* < 1:9.6.ESV.R1
  387. - fixed <BTS:VineLinux:1139>
  388. * Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
  389. - new upstream release with security fix (CVE-2011-1910)
  390. * Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
  391. - add BuildRequires: libxml2-devel, libcap-devel
  392. * Mon May 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
  393. - new upstream release with security fix (CVE-2011-1907)
  394. - fix changelog typo
  395. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
  396. - Obosoletes: bind.* < 1:9.6.ESV.R1
  397. * Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
  398. - update to 9.8.0
  399. - remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
  400. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
  401. - rebuild with openssl-1.0.0c
  402. * Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
  403. - fix Req: in bind package
  404. * Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
  405. - change package name bind -> bind-current
  406. - add epoch 1
  407. - new upstream release
  408. * Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
  409. - new upstream release
  410. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
  411. - rebuilt with gcc-4.4.3-3 on ppc
  412. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
  413. - rebuilt with new toolchains (for VineSeed)
  414. - s/BuildPrereq/BuildRequires/
  415. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
  416. - add man1/isc-config.sh.1 into devel file list
  417. * Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
  418. - new upstream release with security fix (CVE-2009-4022, 2010-0097)
  419. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
  420. - new upstream release with security fix (CVE-2009-4022)
  421. * Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
  422. - new upstream release with security fix
  423. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
  424. - new upstream release
  425. - clean up %%post/%%pre scriptlet
  426. - create named user and group in %%pre
  427. - don't remove named user/group in %%preun
  428. - use rndc-confgen to create rndc.key
  429. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
  430. - new upstream release
  431. - drop patch0 and patch14, merged in upstream
  432. * Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
  433. - new upstream release with security fix
  434. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
  435. - new upstream release with security fix
  436. - new versioning policy
  437. * Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
  438. - new upstream release with security fix
  439. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
  440. - new upstream release
  441. - build with new openssl/toolchain
  442. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
  443. - new upstream release with security fix
  444. * Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
  445. - new upstream release
  446. * Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
  447. - add Prereq sed
  448. * Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
  449. - new upstream release for security fix (CVE-2006-4095,4096)
  450. * Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
  451. - separate -libs package
  452. - remove old named.conf.5.gz
  453. - newer version is contained in source
  454. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
  455. - add bsdcompat patch (Patch4)
  456. - add fix_h_errno patch from FC
  457. - h_errno not being accessed / set correctly in libbind
  458. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
  459. - new upstream release
  460. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
  461. - added PreReq to bind-utils (see: [VineSeed:09555])
  462. * Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
  463. - new upstream release
  464. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
  465. - fix /etc/init.d/named to use rndc
  466. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
  467. - rebuild to remove unneeded dependancy
  468. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
  469. - new upstream release
  470. * Tue Mar 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
  471. - new upstream release
  472. * Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
  473. - fix dependancies.
  474. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
  475. - add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
  476. - change package name to bind for VineSeed.
  477. - use more macros.
  478. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
  479. - fixed some macros
  480. - add conflicts: to bind-* in bind9-devel and bind9-utils
  481. - add provides: bind = %%{version}
  482. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
  483. - use %%configure macros
  484. * Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
  485. - fixed inconsistent dependency
  486. * Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
  487. - updated to 9.2.2rc1
  488. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
  489. - updated to bind9(9.2.1), test packages ;)
  490. -- based on Rawhide's bind-9.2.0-8
  491. -- changed name bind9
  492. -- added Conflicts: bind
  493. * Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
  494. - release 8.3.1 includes security fixes
  495. * Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
  496. - Upgraded to current stable release 8.3.0
  497. * Mon Oct 8 2001 <zn@mbf.nifty.com>
  498. - 8.2.5-0vl0: Upgraded to new upstream version.
  499. * Thu May 24 2001 <sagami@vinelinux.org>
  500. - 8.2.4-0vl1: eliminate CVS related files from %%doc
  501. * Thu May 17 2001 <sagami@vinelinux.org>
  502. - 8.2.4-0vl0
  503. * Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  504. - 8.2.3-1vl2
  505. - built on VineSeed
  506. * Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
  507. - add doc/old
  508. - build for Vine 2.1
  509. * Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  510. - 8.2.3, fixes several security problems
  511. * Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
  512. - static libraries may be used in shared objects. Build with -fPIC on ia64
  513. * Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  514. - 8.2.2-P7 (fixes Bug #20546)
  515. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  516. - condrestart fixes
  517. * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  518. - change the init script to take condrestart, not cond-restart
  519. - add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
  520. the %pre and %post scripts
  521. * Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  522. - Don't prereq /etc/init.d
  523. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  524. - move initscript back
  525. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  526. - automatic rebuild
  527. * Sun Jul 9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  528. - add "exit 0" for uninstall case
  529. * Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  530. - add prereq init.d and cleanup install section
  531. * Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  532. - fix the init script
  533. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  534. - make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
  535. * Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  536. - Fix up the initscript (Bug #13033)
  537. - Fix build with current glibc (Bug #12755)
  538. - /etc/rc.d/init.d -> /etc/init.d
  539. - use %%{_mandir} rather than /usr/share/man
  540. * Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
  541. - fix conflict with man-pages
  542. - remove compatibilty chkconfig links
  543. - initscript munging
  544. * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  545. - modify logrotate setup to use PID file
  546. - temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
  547. - actually bump the release this time
  548. * Sun Jun 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  549. - FHS compliance
  550. * Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  551. - clean up restart patch
  552. * Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  553. - provide /var/named (fix for bugs #9847, #10205)
  554. - preserve args when restarted via ndc(8) (bug #10227)
  555. - make resolv.conf(5) a link to resolver(5) (bug #10245)
  556. - fix SYSTYPE bug in all makefiles
  557. - move creation of named user from %%post into %%pre
  558. * Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  559. - Fix TTL (patch from ISC, Bug #9820)
  560. * Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  561. - fix typo in spec (it's %post, without a leading blank) introduced in -6
  562. - change SYSTYPE to linux
  563. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  564. - pick a standard < 100 uid/gid for named
  565. * Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
  566. - Pass named a '-u named' parameter by default, and add/remove user.
  567. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  568. - fix host mx bug (Bug #9021)
  569. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  570. - rebuild to fix dependencies
  571. - man pages are compressed
  572. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  573. - It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
  574. * Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  575. - Fix up location of named-bootconf.pl and make it executable
  576. (Bug #8028)
  577. - bind-devel requires bind
  578. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  579. - update to 8.2.2-P5
  580. * Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
  581. - update to 8.2.2-P3
  582. * Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
  583. - add patch to stop a cache only server from complaining about lame servers
  584. on every request.
  585. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  586. - use real stop and start in named.init for restart, not ndc restart, it has
  587. problems when named has changed during a package update... (# 4890)
  588. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  589. - chkconfig --del in %preun, not %postun
  590. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  591. - initscript munging
  592. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  593. - fix installed chkconfig links to match init file
  594. * Sat Jul 3 1999 Jeff Johnson <jbj@redhat.com>
  595. - conflict with new (in man-1.24) man pages (#3876,#3877).
  596. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  597. - fix named.logrotate (wrong %SOURCE)
  598. * Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
  599. - update to 8.2.1.
  600. - add named.logrotate (#3571).
  601. - hack around egcs-1.1.2 -m486 bug (#3413, #3485).
  602. - vet file list.
  603. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  604. - don't run by default
  605. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  606. - nslookup fixes (#2463).
  607. - missing files (#3152).
  608. * Sat May 1 1999 Stepan Kasal <kasal@math.cas.cz>
  609. - nslookup patched:
  610. to count numRecords properly
  611. to fix subsequent calls to ls -d
  612. to parse "view" and "finger" commands properly
  613. the view hack updated for bind-8 (using sed)
  614. * Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
  615. - add ISC patch
  616. - add quick hack to make host not crash
  617. - add more docs
  618. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  619. - add probing information in the init file to keep linuxconf happy
  620. - dont strip libbind
  621. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  622. - auto rebuild in the new build environment (release 3)
  623. * Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
  624. - removed 'done' output at named shutdown.
  625. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  626. - version 8.2
  627. * Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
  628. - patch to use the __FDS_BITS macro
  629. - build for glibc 2.1
  630. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  631. - change named.restart to /usr/sbin/ndc restart
  632. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  633. - install man pages correctly.
  634. - change K10named to K45named.
  635. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  636. - don't start if /etc/named.conf doesn't exist.
  637. * Sat Aug 8 1998 Jeff Johnson <jbj@redhat.com>
  638. - autmagically create /etc/named.conf from /etc/named.boot in %post
  639. - remove echo in %post
  640. * Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
  641. - merge in 5.1 mods
  642. * Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
  643. - Several essential modifications to build and install correctly.
  644. - Modified 'ndc' to avoid deprecated use of '-'
  645. * Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
  646. - Used buildroot
  647. - patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
  648. on Redhat 5.0 instead of <nlist.h>