newt-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: A development library for text mode user interfaces.
  4. Summary(ja): テキストモードインターフェースのための開発ライブラリ
  5. Name: newt
  6. Version: 0.52.10
  7. Release: 7%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. URL: https://fedorahosted.org/newt/
  11. Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
  12. # Security fix
  13. Patch100: newt-0.52.10-reflowbuffer.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  18. BuildRequires: python-devel, popt-devel, slang-devel
  19. Provides: snack = %{version}-%{release}
  20. %description
  21. Newt is a programming library for color text mode, widget based user
  22. interfaces. Newt can be used to add stacked windows, entry widgets,
  23. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  24. etc., to text mode user interfaces. This package also contains the
  25. shared library needed by programs built with newt, as well as a
  26. /usr/bin/dialog replacement called whiptail. Newt is based on the
  27. slang library.
  28. %package devel
  29. Summary: Newt windowing toolkit development files.
  30. Summary(ja): Newt ウィンドウツールキット開発ファイル集
  31. Requires: slang-devel %{name} = %{version}
  32. Group: Development/Libraries
  33. %description devel
  34. The newt-devel package contains the header files and libraries
  35. necessary for developing applications which use newt. Newt is a
  36. development library for text mode user interfaces. Newt is based on
  37. the slang library.
  38. Install newt-devel if you want to develop applications which will use
  39. newt.
  40. ## to build compat32 for x86_64 architecture support
  41. %package -n compat32-%{name}
  42. Summary: A development library for text mode user interfaces.
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. Newt is a programming library for color text mode, widget based user
  46. interfaces. Newt can be used to add stacked windows, entry widgets,
  47. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  48. etc., to text mode user interfaces. This package also contains the
  49. shared library needed by programs built with newt, as well as a
  50. /usr/bin/dialog replacement called whiptail. Newt is based on the
  51. slang library.
  52. %package -n compat32-%{name}-devel
  53. Summary: Newt windowing toolkit development files.
  54. Group: Development/Libraries
  55. Requires: compat32-%{name} = %{version}
  56. %description -n compat32-%{name}-devel
  57. The newt-devel package contains the header files and libraries
  58. necessary for developing applications which use newt. Newt is a
  59. development library for text mode user interfaces. Newt is based on
  60. the slang library.
  61. Install newt-devel if you want to develop applications which will use
  62. newt.
  63. %prep
  64. %setup -q -n %{name}-%{version}
  65. %patch100 -p1 -b .CVE-2009-2905
  66. %build
  67. %if %{build_compat32}
  68. export CC='gcc -m32'
  69. %configure --without-tcl
  70. make CC='gcc -m32'
  71. #make CC='gcc -m32' shared
  72. %else
  73. %configure --without-tcl
  74. make
  75. make shared
  76. %endif
  77. chmod 0644 peanuts.py popcorn.py
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make instroot=$RPM_BUILD_ROOT install
  81. %find_lang %{name}
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %if %{build_compat32}
  85. %post -n compat32-%{name} -p /sbin/ldconfig
  86. %postun -n compat32-%{name} -p /sbin/ldconfig
  87. %endif
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %files -f %{name}.lang
  91. %defattr (-,root,root)
  92. %doc CHANGES COPYING
  93. %{_libdir}/libnewt.so.*
  94. %{_bindir}/whiptail
  95. %{python_sitearch}/*.py*
  96. %{python_sitearch}/*.so
  97. %{_mandir}/man1/whiptail.1*
  98. %files devel
  99. %defattr (-,root,root)
  100. %doc tutorial.sgml peanuts.py popcorn.py
  101. %{_includedir}/newt.h
  102. %{_libdir}/libnewt.a
  103. %{_libdir}/libnewt.so
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr (-,root,root)
  107. %{_libdir}/libnewt.so.*
  108. %{python_sitearch}/*.py*
  109. %{python_sitearch}/*.so
  110. %files -n compat32-%{name}-devel
  111. %defattr (-,root,root)
  112. %{_libdir}/libnewt.a
  113. %{_libdir}/libnewt.so
  114. %endif
  115. %changelog
  116. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
  117. - rebuilt with recent environment.
  118. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
  119. - rebuilt with gcc-4.4.3-3 on ppc
  120. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
  121. - rebuilt with rpm-4.8.0-3 (on ppc)
  122. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
  123. - rebuilt with python-2.6.4
  124. * Thu Oct 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
  125. - fix build_compat32 if-endif
  126. * Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
  127. - add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
  128. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
  129. - new upstream release
  130. - use %%python_sitearch macro
  131. - remove --with-gpm-support
  132. - drop obsolete patches
  133. * Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
  134. - rebuild to fix dependency problem on x86_64 architecture
  135. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
  136. - added BuildRequires: slang-devel
  137. - added newt-0.50.35-Makefile.in.patch
  138. - updated newt-0.50.35-make.patch
  139. - changed /usr/lib to %%{_libdir}
  140. - added compat32-* packages for x86_64 architecture support
  141. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
  142. - rebuild with python-2.4.1-0vl1
  143. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
  144. - rebuild with python-2.3.3-0vl1
  145. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
  146. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  147. * Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
  148. - build against python-2.2
  149. - drop Patch20
  150. * Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
  151. - updated to new upstream release 0.50.35
  152. - updated Patch11 and added Patch20
  153. (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
  154. * Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
  155. - update to new upstream release
  156. * Mon Jul 2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  157. - 0.50.22-0vl1
  158. - updated to 0.50.22
  159. - use Release No for Vine Linux
  160. - use better macros
  161. - bytecompile the snack python module
  162. * Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
  163. - fix spec file
  164. * Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
  165. - added Japanese support patch
  166. * Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
  167. - added suspend/resume to snack
  168. * Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
  169. - enable gpm support
  170. * Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
  171. - added hotkey assignment for gridforms, changed listbox.setcurrent to
  172. take the item key
  173. * Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
  174. - fixed snack callback function refcounts, as well as optional data args
  175. - fixed suspend callback ref counts
  176. * Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
  177. - added buttons argument to entrywindow
  178. * Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
  179. - multi-state checkboxtrees. Woohoo.
  180. * Mon Aug 9 1999 Matt Wilson <msw@redhat.com>
  181. - added snack wrappings for checkbox flag setting
  182. * Thu Aug 5 1999 Matt Wilson <msw@redhat.com>
  183. - added snack bindings for setting current listbox selection
  184. - added argument to set default selection in snack ListboxChoiceWindow
  185. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  186. - added checkboxtree
  187. - improved snack binding
  188. * Fri Apr 9 1999 Matt Wilson <msw@redhat.com>
  189. - fixed a glibc related bug in reflow that was truncating all text to 1000
  190. chars
  191. * Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
  192. - fixed bug that made newt apps crash when you hit <insert> followed by lots
  193. of keys
  194. * Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
  195. - fix from Jakub Jelinek for listbox keypresses
  196. * Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
  197. - fixed support for navigating listboxes with alphabetical keypresses
  198. * Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
  199. - updated descriptions
  200. - added support for navigating listboxes with alphabetical keypresses
  201. * Mon Feb 8 1999 Matt Wilson <msw@redhat.com>
  202. - made grid wrapped windows at least the size of their title bars
  203. * Fri Feb 5 1999 Matt Wilson <msw@redhat.com>
  204. - Function to set checkbox flags. This will go away later when I have
  205. a generic flag setting function and signals to comps to go insensitive.
  206. * Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
  207. - Stopped using libgpm, internalized all gpm calls. Still need some cleanups.
  208. * Thu Jan 7 1999 Matt Wilson <msw@redhat.com>
  209. - Added GPM mouse support
  210. - Moved to autoconf to allow compiling without GPM support
  211. - Changed revision to 0.40
  212. * Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
  213. - built against slang-1.2.2
  214. * Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
  215. - bugfixes for text reflow
  216. - added docs
  217. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  218. - devel package moved to Development/Libraries
  219. * Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
  220. - removed whiptcl.so -- it should be in a separate package
  221. * Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
  222. - added newtWinMenu()
  223. - many bug fixes in grid code
  224. * Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
  225. - removed newtWinTernary()
  226. - made newtWinChoice() return codes consistent with newtWinTernary()
  227. * Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
  228. - added changes from Bruce Perens
  229. - small cleanups
  230. - lets whiptail automatically resize windows
  231. - the order of placing a grid and adding components to a form no longer
  232. matters
  233. - added newtGridAddComponentsToForm()
  234. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  235. - added newtWinTernary()
  236. * Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
  237. - made Make/spec files use a buildroot
  238. - added grid support (for newt 0.11 actually)
  239. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  240. - Added patched from Clarence Smith for setting the size of a listbox
  241. - Version 0.9
  242. * Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
  243. - Touchups on Makefile
  244. - Cleaned up NEWT_FLAGS_*
  245. * Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
  246. - Cleaned up listbox
  247. - Added whiptail
  248. - Added newtButtonCompact button type and associated colors
  249. - Added newtTextboxGetNumLines() and newtTextboxSetHeight()
  250. * Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
  251. - Added changes from sopwith for C++ cleanliness and some listbox fixes.