libgnomeprint20-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352
  1. ## this could go, it's really just so we notice if the soname changes
  2. %define sover 0
  3. %define gettext_package libgnomeprint-2.0
  4. %define glib2_base_version 2.0.0
  5. %define glib2_version %{glib2_base_version}
  6. %define pango_version 1.0.99
  7. %define libxml2_version 2.4.21
  8. %define libart_lgpl_version 2.3.8
  9. %define libbonobo_version 2.0.0
  10. %define bonobo_activation_version 1.0.0
  11. %define freetype_version 2.0.3
  12. %define gtk_doc_version 0.9
  13. Summary: Printing library for GNOME.
  14. Summary(ja): GNOME プリントライブラリ
  15. Name: libgnomeprint20
  16. Version: 1.116.0
  17. Release: 0vl2
  18. License: LGPL
  19. Group: System Environment/Libraries
  20. Source: ftp://ftp.gnome.org/pub/GNOME/sources/libgnomeprint/1.116/libgnomeprint-%{version}.tar.bz2
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. PreReq: urw-fonts
  23. PreReq: ghostscript
  24. PreReq: ghostscript-fonts
  25. PreReq: libxml
  26. PreReq: perl
  27. PreReq: XOrg
  28. BuildPrereq: glib2-devel >= %{glib2_version}
  29. BuildPrereq: pango-devel >= %{pango_version}
  30. BuildPrereq: libxml2-devel >= %{libxml2_version}
  31. BuildPrereq: libart_lgpl-devel >= %{libart_lgpl_version}
  32. BuildPrereq: libbonobo-devel >= %{libbonobo_version}
  33. BuildPrereq: bonobo-activation-devel >= %{bonobo_activation_version}
  34. BuildPrereq: freetype2 >= %{freetype_version}
  35. BuildPrereq: gtk-doc >= %{gtk_doc_version}
  36. BuildPrereq: automake14
  37. # Bug fix patches
  38. # remove libexec breakage
  39. Patch3: libgnomeprint-1.105.0.90-libexec.patch
  40. # improve the printing performance
  41. Patch4: libgnomeprint-1.116.0-perfprint.patch
  42. # generate the correct PostScript
  43. Patch5: libgnomeprint-1.116.0-correctps.patch
  44. # for Vine
  45. # build with newer freetype2
  46. Patch100: libgnomeprint-1.116.0-ft2build.patch
  47. %description
  48. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  49. applications and desktop tools to be used in conjunction with a window
  50. manager for the X Window System. The gnome-print package contains
  51. libraries and fonts needed by GNOME applications for printing.
  52. You should install the gnome-print package if you intend to use any of
  53. the GNOME applications that can print. If you would like to develop
  54. GNOME applications that can print you will also need to install the
  55. gnome-print devel package.
  56. %package devel
  57. Summary: Libraries and include files for developing GNOME applications.
  58. Group: Development/Libraries
  59. Requires: %{name} = %{PACKAGE_VERSION}
  60. Requires: glib2-devel >= %{glib2_version}
  61. Requires: pango-devel >= %{pango_version}
  62. Requires: libxml2-devel >= %{libxml2_version}
  63. Requires: libart_lgpl-devel >= %{libart_lgpl_version}
  64. Requires: libbonobo-devel >= %{libbonobo_version}
  65. Requires: bonobo-activation-devel >= %{bonobo_activation_version}
  66. Requires: freetype2 >= %{freetype_version}
  67. %description devel
  68. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  69. applications and desktop tools to be used in conjunction with a window
  70. manager for the X Window System. The gnome-print-devel package
  71. includes the libraries and include files needed for developing
  72. applications that use the GNOME printing capabilities.
  73. You should install the gnome-print-devel package if you would like to
  74. develop GNOME applications that will use the GNOME print capabilities.
  75. You do not need to install the gnome-print-devel package if you just
  76. want to use the GNOME desktop environment.
  77. %prep
  78. %setup -q -n libgnomeprint-%{version}
  79. %patch3 -p1 -b .libexec
  80. %patch4 -p0 -b .perfprint
  81. %patch5 -p1 -b .correctps
  82. %patch100 -p1 -b .ft2build
  83. %build
  84. automake-1.4
  85. %configure --disable-font-install
  86. make
  87. %install
  88. rm -rf $RPM_BUILD_ROOT
  89. # It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
  90. # instead of %%makeinstall with this hack.
  91. %makeinstall FONTMAPDIR_STATIC=$RPM_BUILD_ROOT/usr/share/gnome/libgnomeprint-2.0/fonts
  92. ./mkinstalldirs $RPM_BUILD_ROOT/%{_sysconfdir}/gnome/libgnomeprint-2.0/fonts
  93. /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
  94. %find_lang %{gettext_package}
  95. #Add redhat-update-gnome-font-install
  96. cat > $RPM_BUILD_ROOT%{_bindir}/redhat-update-gnome-font-install2 << EOF
  97. #! /bin/sh
  98. /usr/bin/libgnomeprint-2.0-font-install \
  99. --aliases=%{_datadir}/gnome/libgnomeprint-2.0/fonts/adobe-urw.font \
  100. --target=%{_sysconfdir}/gnome/libgnomeprint-2.0/fonts/libgnomeprint-rpm.fontmap \
  101. --recursive --clean \
  102. /usr/X11R6/lib/X11/fonts/Type1 \
  103. %{_datadir}/fonts
  104. EOF
  105. chmod 755 $RPM_BUILD_ROOT%{_bindir}/redhat-update-gnome-font-install2
  106. # remove unpackaged files from the buildroot
  107. rm -f $RPM_BUILD_ROOT%{_datadir}/fonts/README.installer
  108. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint-2.la
  109. %clean
  110. rm -rf $RPM_BUILD_ROOT
  111. %post
  112. /sbin/ldconfig
  113. ## we could pass --dynamic here to install to /etc instead
  114. ## but I think it makes more sense to have this not be a config
  115. ## file, then people make their changes in /etc if they want
  116. /usr/bin/redhat-update-gnome-font-install2
  117. %postun -p /sbin/ldconfig
  118. %files -f %{gettext_package}.lang
  119. %defattr(-, root, root)
  120. %dir %{_sysconfdir}/gnome/libgnomeprint-2.0
  121. %doc AUTHORS COPYING ChangeLog NEWS README installer/README.*
  122. %{_bindir}/*
  123. %{_libdir}/gnome-print-2.0
  124. %{_libdir}/lib*.so.%{sover}
  125. %{_libdir}/lib*.so.%{sover}.*
  126. %{_datadir}/gnome-print-2.0
  127. %{_datadir}/gnome/libgnomeprint-2.0
  128. %files devel
  129. %defattr(-, root, root)
  130. %{_libdir}/lib*.so
  131. %{_libdir}/*.a
  132. %{_includedir}/*
  133. %{_libdir}/pkgconfig/*
  134. %changelog
  135. * Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.116.0-0vl2
  136. - added Japanese summary
  137. - changed Group to System Environment/Libraries
  138. - added Patch100 for build with newer freetype2
  139. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.116.0-0vl1
  140. - libgnomeprint20 for compatibility
  141. * Mon Dec 16 2002 Havoc Pennington <hp@redhat.com>
  142. - nuke the docs, conflicts with 2.1.x libgnomeprint, and this one is
  143. deprecated anyway
  144. * Fri Dec 13 2002 Tim Powers <timp@redhat.com> 1.116.0-3
  145. - remove unpackaged files from the buildroot
  146. - don't list the dirs twice in the file list
  147. * Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
  148. - libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
  149. * Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
  150. - libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
  151. performance issue. (#66715)
  152. * Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
  153. - includes redhat-update-gnome-font-install2 script. (#66899)
  154. - fix the install path for fontmap.
  155. - add some directory owners.
  156. * Thu Jul 11 2002 Tim Powers <timp@redhat.com>
  157. - rebuilt
  158. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  159. - 1.115.0
  160. - include gtk-doc docs
  161. - move pkg-config files to -devel package
  162. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  163. - rebuild in different environment
  164. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  165. - 1.114.0
  166. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  167. - rebuild in different environment
  168. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  169. - rebuild in different environment
  170. - add bonobo-activation requires to make build system happy
  171. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  172. - 1.113.0
  173. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  174. - rebuild for new libraries
  175. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  176. - 1.112.0
  177. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  178. - 1.111.0
  179. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  180. - Version 1.110.0
  181. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  182. - automake14
  183. * Mon Jan 7 2002 Havoc Pennington <hp@redhat.com>
  184. - 1.109.0.90 snap
  185. - remove .options patch which is upstream
  186. - remove .nofontmaps patch, upstream uses sysconfdir sometimes now
  187. and has --disable-font-install configure option
  188. - remove .fontmapdir, now fixed upstream
  189. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  190. - rebuild due to build system fuckup
  191. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  192. - cvs snap 1.106.0.90, glib 1.3.11
  193. * Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
  194. - new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
  195. * Tue Oct 9 2001 Havoc Pennington <hp@redhat.com>
  196. - remove epoch screwup
  197. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  198. - libgnomeprint package based on the gnome-print package
  199. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  200. - use 0.30 tarball
  201. * Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
  202. - new cvs snap, with headers moved
  203. * Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
  204. - Back out freetype change, for now, until we can get it in upstream.
  205. - Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
  206. Making them %config doesn't seem compatible with locating them
  207. in gnome-print/<ver>.
  208. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
  209. - no replace profiles.
  210. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
  211. - Move profiles directory to /etc/gnome-print/<ver>/profiles/
  212. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
  213. - Add freetype support patch. (Bug#50360)
  214. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  215. - Add missing directory
  216. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  217. - Upgrade to 0.29
  218. - Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
  219. - Add BuildPrereq and make -devel package require gdk-pixbuf-devel
  220. - Make libgnomeprint package require gnome-print package; otherwise
  221. packages requiring libgnomeprint might not get a runtime environment
  222. - Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
  223. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  224. - Kill output from run-gnome-font-install
  225. - s/Copyright/License/
  226. - Add post/postun scripts for the libgnomeprint subpackage
  227. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  228. - Bump release + rebuild.
  229. * Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
  230. - new version (0.28)
  231. * Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
  232. - Rebuild for GTK+-1.2.9 include paths
  233. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  234. - langify
  235. - patch it to compile (didn't include locale.h when needed)
  236. - use %%{_tmppath}
  237. * Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
  238. - Fixed font problem for Japanese.
  239. - Fixed library dependency on VFlib (Bug#28331)
  240. * Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
  241. - Fixed bugzilla bug #27417, simple specfile %post fix.
  242. * Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
  243. - Fixed PostScript broken.
  244. - Added autoheader,automake,autoconf stuff.
  245. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  246. - add libtoolize to make porting to new archs easy
  247. * Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
  248. - Updated Japanese patch for Gnumeric.
  249. Created dummy .afm.
  250. * Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
  251. - Fixed gdk_fontset_load().
  252. - Added Japanese patch for Gnumeric.
  253. * Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
  254. - Added Japanese patch.
  255. Fixed Print and Preview with Japanese.
  256. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  257. - 0.25
  258. * Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
  259. - added "|| true" to %%post so that if font-install screws up we don't get a
  260. bad exit status. gnome-font-install expects that the directory specified by
  261. HOME env. var is writable, but it isn't always if you install with 'sudo'
  262. or the equivalent. bad. bad. bad.
  263. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  264. - Up Epoch and release
  265. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  266. - redirect %%post script output to /dev/null
  267. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  268. - automatic rebuild
  269. * Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
  270. - Spec file fixes