ConsoleKit-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308
  1. %define glib2_version 2.26.0
  2. %define dbus_version 1.4.14
  3. %define dbus_glib_version 0.94
  4. %define polkit_version 0.101
  5. Summary: System daemon for tracking users, sessions and seats
  6. Summary(ja): ユーザ、セッションおよび座席を捕捉するシステムデーモン
  7. Name: ConsoleKit
  8. Version: 0.4.5
  9. Release: 1%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Daemons
  12. URL: http://www.freedesktop.org/wiki/Software/ConsoleKit
  13. Source0: http://people.freedesktop.org/~mccann/dist/ConsoleKit-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: glib2-devel >= %{glib2_version}
  16. BuildRequires: dbus-devel >= %{dbus_version}
  17. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  18. BuildRequires: polkit-devel >= %{polkit_version}
  19. BuildRequires: pam-devel
  20. BuildRequires: libX11-devel
  21. BuildRequires: zlib-devel
  22. BuildRequires: xmlto
  23. Requires: dbus
  24. Requires: dbus-glib
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. ConsoleKit is a system daemon for tracking what users are logged
  29. into the system and how they interact with the computer (e.g.
  30. which keyboard and mouse they use).
  31. It provides asynchronous notification via the system message bus.
  32. %package x11
  33. Summary: X11-requiring add-ons for ConsoleKit
  34. Summary(ja): X11 を必要とする ConsoleKit アドオン
  35. License: GPLv2+
  36. Group: System Environment/Daemons
  37. Requires: %name = %{version}-%{release}
  38. Requires: libX11
  39. %description x11
  40. ConsoleKit contains some tools that require Xlib to be installed,
  41. those are in this separate package so server systems need not install
  42. X. Applications (such as xorg-x11-xinit) and login managers (such as
  43. gdm) that need to register their X sessions with ConsoleKit needs to
  44. have a Requires: for this package.
  45. %package libs
  46. Summary: ConsoleKit libraries
  47. Summary(ja): ConsoleKit ライブラリ
  48. License: MIT
  49. Group: System Environment/Libraries
  50. Requires: pam
  51. Requires: dbus
  52. %description libs
  53. Libraries and a PAM module for interacting with ConsoleKit.
  54. %package devel
  55. Summary: Development libraries and headers for ConsoleKit
  56. Summary(ja): Development libraries and headers for ConsoleKit
  57. License: MIT
  58. Group: Development/Libraries
  59. Requires: dbus-devel
  60. Requires: pkgconfig
  61. %description devel
  62. Headers, libraries and API docs for ConsoleKit
  63. %package docs
  64. Summary: Developer documentation for ConsoleKit
  65. Summary(ja): ConsoleKit の開発用ドキュメント
  66. Group: Development/Libraries
  67. Requires: %name = %{version}-%{release}
  68. %description docs
  69. Developer documentation for ConsoleKit.
  70. %prep
  71. %setup -q
  72. %build
  73. %configure --with-pid-file=%{_localstatedir}/run/console-kit-daemon.pid --enable-pam-module --with-pam-module-dir=/%{_lib}/security --enable-docbook-docs --docdir=%{_datadir}/doc/%{name}-%{version}
  74. make
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  80. rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.a
  81. rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
  82. # make sure we don't package a history log
  83. rm -f $RPM_BUILD_ROOT/%{_var}/log/ConsoleKit/history
  84. cp AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO \
  85. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
  86. #mkdir -p %{buildroot}%{_sysconfdir}/init.d
  87. #install -m 755 %{SOURCE10} %{buildroot}%{_sysconfdir}/init.d/ConsoleKit
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %post
  91. if [ -f /var/log/ConsoleKit/history ]; then
  92. chmod a+r /var/log/ConsoleKit/history
  93. fi
  94. %post libs -p /sbin/ldconfig
  95. %postun libs -p /sbin/ldconfig
  96. %files
  97. %defattr(-,root,root,-)
  98. %doc %dir %{_datadir}/doc/%{name}-%{version}
  99. %doc %{_datadir}/doc/%{name}-%{version}/[A-Z]*
  100. %{_sysconfdir}/dbus-1/system.d/*
  101. #%{_sysconfdir}/init.d/ConsoleKit
  102. %{_datadir}/dbus-1/system-services/*.service
  103. %{_datadir}/polkit-1/actions/*.policy
  104. %dir %{_sysconfdir}/ConsoleKit
  105. %dir %{_sysconfdir}/ConsoleKit/seats.d
  106. %dir %{_sysconfdir}/ConsoleKit/run-seat.d
  107. %dir %{_sysconfdir}/ConsoleKit/run-session.d
  108. %dir %{_prefix}/lib/ConsoleKit
  109. %dir %{_prefix}/lib/ConsoleKit/scripts
  110. %dir %{_prefix}/lib/ConsoleKit/run-seat.d
  111. %dir %{_prefix}/lib/ConsoleKit/run-session.d
  112. %dir %{_var}/run/ConsoleKit
  113. %attr(755,root,root) %dir %{_var}/log/ConsoleKit
  114. %config %{_sysconfdir}/ConsoleKit/seats.d/00-primary.seat
  115. %{_sbindir}/console-kit-daemon
  116. %{_sbindir}/ck-log-system-restart
  117. %{_sbindir}/ck-log-system-start
  118. %{_sbindir}/ck-log-system-stop
  119. %{_bindir}/ck-history
  120. %{_bindir}/ck-launch-session
  121. %{_bindir}/ck-list-sessions
  122. %{_prefix}/lib/ConsoleKit/scripts/*
  123. %files x11
  124. %defattr(-,root,root,-)
  125. %{_libexecdir}/*
  126. %files libs
  127. %defattr(-,root,root,-)
  128. %{_libdir}/lib*.so.*
  129. /%{_lib}/security/*.so
  130. %{_mandir}/man8/pam_ck_connector.8.gz
  131. %files devel
  132. %defattr(-,root,root,-)
  133. %{_libdir}/lib*.so
  134. %{_libdir}/pkgconfig/*
  135. %{_includedir}/*
  136. %{_datadir}/dbus-1/interfaces/org.freedesktop.ConsoleKit.*.xml
  137. %files docs
  138. %defattr(-,root,root,-)
  139. %doc %dir %{_datadir}/doc/%{name}-%{version}/spec
  140. %doc %{_datadir}/doc/%{name}-%{version}/spec/*
  141. %changelog
  142. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
  143. - new upstream release
  144. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
  145. - new upstream release
  146. * Wed Oct 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.2-1
  147. - new upstream release
  148. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.1-2
  149. - rebuilt with rpm-4.8.1 for pkg-config
  150. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.1-1
  151. - new upstream release
  152. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-6
  153. - add patch11 to enable policy access to the Manager.GetSessions
  154. method in the default ConsoleKit.conf
  155. https://bugs.freedesktop.org/show_bug.cgi?id=20471
  156. http://bugzilla.gnome.org/show_bug.cgi?id=580259
  157. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-5
  158. - add patch10 to fix dbus permissions
  159. https://bugs.freedesktop.org/show_bug.cgi?id=19020
  160. (This patch is already committed to master)
  161. * Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-4
  162. - changed Group to System Environment/Daemons
  163. - changed x11 subpackage's Group to System Environment/Daemons
  164. - changed libs subpackage's Group to System Environment/Libraries
  165. - added %%post, %%postun section fo libs subpackage
  166. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.0-3
  167. - changed %%{_libdir}/ConsoleKit to %%{_prefix}/lib/ConsoleKit
  168. * Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-2
  169. - remove init script, console-kit-daemon is now launched from dbus.
  170. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-1
  171. - new upstream release
  172. * Tue Jul 1 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-3
  173. - fix Japanese description
  174. - spec in UTF-8
  175. - add Source10 (init.d script for console-kit-daemon);
  176. add %%post/%%preun scripts, until "initng" being introduced to Vine
  177. * Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-2
  178. - rebuilt with PolicyKit-0.8
  179. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.10-1
  180. - new upstream release
  181. - new versioning policy
  182. * Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-0vl1
  183. - initial build for Vine Linux
  184. * Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.3-2
  185. - Rebuild against new dbus-glib
  186. * Tue Sep 18 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.3-1
  187. - Update to 0.2.3
  188. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.2-1
  189. - Update to 0.2.2
  190. * Mon Aug 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.1-4
  191. - Update license field
  192. * Fri Jul 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.1-3
  193. - Add LSB header to init script (#246894)
  194. * Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-2
  195. - Set doc directory correctly
  196. * Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-1
  197. - Update to upstream release 0.2.1
  198. - Drop the patch to daemonize properly as that was merged upstream
  199. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-0.git20070402
  200. - Update to git snapshot to get a lot of bug fixes
  201. - Use libX11 rather than gtk2 to verify X11 sessions; update BR and R
  202. - Split X11-using bits into a new subpackage ConsoleKit-x11 (#233982)
  203. - Use correct location for PAM module on 64-bit (#234545)
  204. - Build developer documentation and put them in ConsoleKit-docs
  205. * Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-2
  206. - BR gtk2-devel and make ConsoleKit Require gtk2 (could just be
  207. libX11 with a simple patch)
  208. * Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-1
  209. - Update to upstream release 0.2.0
  210. - Daemonize properly (#229206)
  211. * Sat Mar 3 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301.1
  212. - Allow caller to pass uid=0 in libck-connector
  213. * Thu Mar 1 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301
  214. - Update to git snapshot
  215. - Drop all patches as they are committed upstream
  216. - New tool ck-list-sessions
  217. - New -libs subpackage with run-time libraries and a PAM module
  218. - New -devel subpackage with headers
  219. * Tue Feb 6 2007 David Zeuthen <davidz@redhat.com> - 0.1.0-5%{?dist}
  220. - Start ConsoleKit a bit earlier so it starts before HAL (98 -> 90)
  221. - Minimize stack usage so VIRT size is more reasonable (mclasen)
  222. - Make session inactive when switching to non-session (davidz)
  223. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-4
  224. - Don't mark initscripts %%config
  225. - Use proper lock and pid ile names
  226. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-3
  227. - More package review feedback
  228. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-2
  229. - Incorporate package review feedback
  230. * Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-1
  231. - Update to the first public release 0.1.0
  232. - Some spec cleanups
  233. * Mon Oct 23 2006 David Zeuthen <davidz@redhat.com> - 0.0.3-1
  234. - Initial build.