git-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. # Pass --without docs to rpmbuild if you don't want the documentation
  4. Name: git
  5. Version: 1.8.0.2
  6. Release: 1%{?_dist_release}
  7. Summary: Core git tools
  8. Summary(ja): Core git ツール
  9. License: GPLv2
  10. Group: Development/Tools
  11. URL: http://git-scm.com/
  12. Source: http://git-core.googlecode.com/files/%{name}-%{version}.tar.gz
  13. Source1: vine-default-git.el
  14. Source2: git.xinetd
  15. Source3: git.conf.httpd
  16. Source4: gitweb.conf.in
  17. Source10: %{name}-install.sh
  18. Source11: %{name}-remove.sh
  19. Source12: git-init.el
  20. Patch0: git-1.5-gitweb-home-link.patch
  21. # Security
  22. # none
  23. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel,
  24. BuildRequires: expat-devel, gettext, asciidoc
  25. BuildRequires: pcre-devel
  26. BuildRequires: xmlto
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. Requires: perl-Git = %{version}-%{release}
  29. Requires: zlib
  30. Provides: git-core = %{version}-%{release}
  31. Obsoletes: git-core <= 1.5.4.3
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: iwaim
  35. %description
  36. Git is a fast, scalable, distributed revision control system with an
  37. unusually rich command set that provides both high-level operations
  38. and full access to internals.
  39. The git rpm installs the core tools with minimal dependencies. To
  40. install all git packages, including tools for integrating with other
  41. SCMs, install the git-all meta-package.
  42. %package all
  43. Summary: Meta-package to pull in all git tools
  44. Summary(ja): すべての git ツール
  45. Group: Development/Tools
  46. Requires: git = %{version}-%{release}
  47. Requires: git-svn = %{version}-%{release}
  48. Requires: git-cvs = %{version}-%{release}
  49. %if "%{?_dist_release}" != "vl4"
  50. Requires: git-arch = %{version}-%{release}
  51. %endif
  52. Requires: git-email = %{version}-%{release}
  53. Requires: gitk = %{version}-%{release}
  54. Requires: git-gui = %{version}-%{release}
  55. Requires: perl-Git = %{version}-%{release}
  56. Requires: emacs-git = %{version}-%{release}
  57. Obsoletes: git <= 1.5.4.3
  58. %description all
  59. Git is a fast, scalable, distributed revision control system with an
  60. unusually rich command set that provides both high-level operations
  61. and full access to internals.
  62. This is a dummy package which brings in all subpackages.
  63. %package daemon
  64. Summary: Git protocol daemon
  65. Summary(ja): Git プロトコルデーモン
  66. Group: Development/Tools
  67. Requires: git = %{version}-%{release}
  68. %description daemon
  69. The git daemon for supporting git:// access to git repositories
  70. %package -n gitweb
  71. Summary: Simple web interface to git repositories
  72. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  73. Group: Development/Tools
  74. Requires: git = %{version}-%{release}
  75. %description -n gitweb
  76. Simple web interface to track changes in git repositories
  77. %package svn
  78. Summary: Git tools for importing Subversion repositories
  79. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  80. Group: Development/Tools
  81. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  82. Requires: perl(SVN::Core)
  83. %description svn
  84. Git tools for importing Subversion repositories.
  85. %package cvs
  86. Summary: Git tools for importing CVS repositories
  87. Summary(ja): CVS リポジトリを git へインポートするためのツール
  88. Group: Development/Tools
  89. Requires: git = %{version}-%{release}, cvs, cvsps
  90. %description cvs
  91. Git tools for importing CVS repositories.
  92. %if "%{?_dist_release}" != "vl4"
  93. %package arch
  94. Summary: Git tools for importing Arch repositories
  95. Summary(ja): Arch リポジトリを git へインポートするためのツール
  96. Group: Development/Tools
  97. Requires: git = %{version}-%{release}, tla
  98. %description arch
  99. Git tools for importing Arch repositories.
  100. %endif
  101. %package email
  102. Summary: Git tools for sending email
  103. Summary(ja): Eメールを送るための git ツール
  104. Group: Development/Tools
  105. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  106. %description email
  107. Git tools for sending email.
  108. %package gui
  109. Summary: Git GUI tool
  110. Summary(ja): Git の GUI ツール
  111. Group: Development/Tools
  112. Requires: git = %{version}-%{release}, tk
  113. %description gui
  114. Git GUI tool.
  115. %package -n gitk
  116. Summary: Git revision tree visualiser
  117. Summary(ja): Git リビジョンツリー可視化ツール
  118. Group: Development/Tools
  119. Requires: git = %{version}-%{release}, tk
  120. %description -n gitk
  121. Git revision tree visualiser.
  122. %package -n perl-Git
  123. Summary: Perl interface to Git
  124. Summary(ja): Git の perl インタフェース
  125. Group: Development/Libraries
  126. Requires: git = %{version}-%{release}, perl(Error)
  127. %if "%{?_dist_release}" == "vl4"
  128. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  129. %else
  130. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  131. %endif
  132. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  133. %description -n perl-Git
  134. Perl interface to Git.
  135. %package -n emacs-git
  136. Summary: Git version control system support for Emacs
  137. Summary(ja): Emacs の Git サポート
  138. Group: Applications/Editors
  139. Requires: git = %{version}-%{release}, emacsen-common
  140. %description -n emacs-git
  141. %{summary}.
  142. %package devel
  143. Summary: Header files for git-core
  144. Summary(ja): git-core 用ヘッダファイル
  145. Group: Development/Libraries
  146. %description devel
  147. Header files for git-core.
  148. %prep
  149. %setup -q
  150. %patch0 -p1
  151. %build
  152. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  153. ETC_GITCONFIG=/etc/gitconfig \
  154. USE_LIBPCRE=1 \
  155. GITWEB_PROJECTROOT=/var/lib/git \
  156. gitwebdir=/var/www/git \
  157. prefix=%{_prefix} all %{!?_without_docs: doc}
  158. %install
  159. rm -rf $RPM_BUILD_ROOT
  160. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  161. prefix=%{_prefix} mandir=%{_mandir} \
  162. ETC_GITCONFIG=/etc/gitconfig \
  163. USE_LIBPCRE=1 \
  164. NO_PYTHON=1 \
  165. GITWEB_PROJECTROOT=/var/lib/git \
  166. gitwebdir=/var/www/git \
  167. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  168. # perl-Git
  169. # Error.pm provide by perl-Error package
  170. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  171. # emacs-git
  172. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  173. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  174. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  175. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  176. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  177. # install el files
  178. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  179. # install vine-default file
  180. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  181. # install script( bytecompile el and install elc , remove )
  182. %_installemacsenscript git %{SOURCE10}
  183. %_removeemacsenscript git %{SOURCE11}
  184. mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
  185. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  186. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  187. perl -p \
  188. -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
  189. -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
  190. %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
  191. ## for gitweb sub package
  192. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  193. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  194. sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
  195. %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
  196. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  197. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  198. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  199. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  200. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  201. %if %{!?_without_docs:1}0
  202. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  203. %else
  204. rm -rf $RPM_BUILD_ROOT%{_mandir}
  205. %endif
  206. mkdir -p $RPM_BUILD_ROOT/srv/git
  207. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  208. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  209. # header files and lib
  210. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  211. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  212. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  213. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  214. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  215. %clean
  216. rm -rf $RPM_BUILD_ROOT
  217. %post -n emacs-git
  218. # bytecompile and install
  219. if [ "$1" = 2 ]; then
  220. %_emacsenPackageRemove git
  221. fi
  222. %_addemacsenlist git
  223. %_emacsenPackageInstall git
  224. %preun -n emacs-git
  225. if [ "$1" = 0 ]; then
  226. %_emacsenPackageRemove git
  227. %_removeemacsenlist git
  228. fi
  229. %files -f bin-man-doc-files
  230. %defattr(-,root,root)
  231. %{_bindir}/git
  232. %{_bindir}/git-receive-pack
  233. %{_bindir}/git-upload-archive
  234. %{_bindir}/git-upload-pack
  235. %{_bindir}/git-shell
  236. %{_datadir}/git-core/
  237. %doc README COPYING Documentation/*.txt contrib/hooks
  238. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  239. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  240. %{_sysconfdir}/bash_completion.d
  241. %files svn
  242. %defattr(-,root,root)
  243. %{_libexecdir}/git-core/*svn*
  244. %doc Documentation/*svn*.txt
  245. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  246. %{!?_without_docs: %doc Documentation/*svn*.html }
  247. %files cvs
  248. %defattr(-,root,root)
  249. %doc Documentation/*git-cvs*.txt
  250. %{_bindir}/git-cvsserver
  251. %{_libexecdir}/git-core/*cvs*
  252. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  253. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  254. %if "%{?_dist_release}" != "vl4"
  255. %files arch
  256. %defattr(-,root,root)
  257. %doc Documentation/git-archimport.txt
  258. %{_libexecdir}/git-core/git-archimport
  259. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  260. %{!?_without_docs: %doc Documentation/git-archimport.html }
  261. %endif
  262. %files email
  263. %defattr(-,root,root)
  264. %doc Documentation/*email*.txt
  265. %{_libexecdir}/git-core/*email*
  266. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  267. %{!?_without_docs: %doc Documentation/*email*.html }
  268. %files gui
  269. %defattr(-,root,root)
  270. %{_libexecdir}/git-core/git-gui*
  271. %{_libexecdir}/git-core/git-citool
  272. %{_datadir}/git-gui/
  273. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  274. %{!?_without_docs: %doc Documentation/git-gui.html}
  275. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  276. %{!?_without_docs: %doc Documentation/git-citool.html}
  277. %files -n gitk
  278. %defattr(-,root,root)
  279. %doc Documentation/*gitk*.txt
  280. %{_bindir}/gitk
  281. %{_datadir}/gitk
  282. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  283. %{!?_without_docs: %doc Documentation/*gitk*.html }
  284. %files -n perl-Git -f perl-files
  285. %defattr(-,root,root)
  286. %files -n emacs-git
  287. %defattr(-,root,root)
  288. %{_datadir}/emacs/site-lisp/git
  289. #%{_libdir}/emacsen-common/packages/install/git
  290. #%{_libdir}/emacsen-common/packages/remove/git
  291. %{emacsen_pkgdir}/install/git
  292. %{emacsen_pkgdir}/remove/git
  293. %files daemon
  294. %defattr(-,root,root)
  295. %{_var}/lib/git
  296. %{_libexecdir}/git-core/git-daemon
  297. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  298. /srv/git
  299. %files -n gitweb
  300. %defattr(-,root,root)
  301. %doc gitweb/README
  302. /var/www/git/
  303. %config(noreplace)%{_sysconfdir}/gitweb.conf
  304. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  305. %files devel
  306. %defattr(644,root,root,755)
  307. %{_includedir}/git
  308. %{_libdir}/libgit.a
  309. %{_libdir}/libgit_xdiff.a
  310. %files all
  311. # No files for you!
  312. %changelog
  313. * Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
  314. - new upstream release
  315. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
  316. - new upstream release
  317. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  318. - new upstream release
  319. - enable libpcre support, add BR: pcre-devel
  320. - add /etc/gitweb.conf
  321. - add /var/lib/git for PROJECTROOT
  322. * Mon Sep 3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
  323. - new upstream release
  324. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  325. - new upstream release
  326. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  327. - new upstream release
  328. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  329. - new upstream release
  330. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  331. - build with perl 5.12.3
  332. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  333. - new upstream release
  334. - build with openssl 1.0.0c for VineSeed
  335. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  336. - new upstream release: include security fix: CVE-2010-3906
  337. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  338. - new upstream release
  339. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  340. - apply vine-default
  341. - rename Source1: git-init.el -> vine-default-git.el
  342. - add new git-init.el file (Source12)
  343. - update git-install.sh
  344. - update %%build and %%install section for gitweb subpackage
  345. - add README in gitweb subpackage
  346. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  347. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  348. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  349. - new upstream release
  350. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  351. - disable building of unused python remote helper libs
  352. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  353. - new upstream release with security fix
  354. - drop patch10 (included in new release)
  355. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  356. - new upstream release
  357. - add patch10 git daemon extra arg parsing fix
  358. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  359. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  360. - update git-install.sh (Source10) using contributed patch
  361. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  362. - new upstream release
  363. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  364. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  365. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  366. - fix summary and description in daemon sub package
  367. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  368. - drop Error.pm: provide by perl-Error package
  369. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  370. - new upstream relase
  371. - update URL tag
  372. - add Requires: perl(SVN::Core) for svn subpackage
  373. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  374. - add git-shell in git package
  375. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  376. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  377. - added BuildRequires: xmlto
  378. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  379. - new upstream release
  380. - add devel subpackage (see [wishes:0165])
  381. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  382. - new upstream release
  383. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  384. - new upstream release
  385. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  386. - new upstream release
  387. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  388. - use %%emacsen_pkgdir macro
  389. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  390. - new upstream release
  391. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  392. - initial build for Vine Linux
  393. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  394. - git-1.5.6.4
  395. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  396. - git-1.5.6
  397. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  398. - use tar.bz2 instead of tar.gz
  399. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  400. - git-1.5.5.3
  401. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  402. - git-1.5.5.2
  403. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  404. - git-1.5.5.1
  405. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  406. - git-1.5.5
  407. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  408. - Remove the last two requires on git-core.
  409. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  410. - Remove a patch that's already upstream.
  411. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  412. - git-1.5.4.5
  413. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  414. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  415. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  416. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  417. - Install the bash completion script from contrib (bug 433255).
  418. - Include the html docs in the 'core' package again (bug 434271).
  419. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  420. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  421. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  422. - git-1.5.4.4
  423. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  424. - rebuild for new perl (again)
  425. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  426. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  427. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  428. - git-1.5.4.3
  429. - Include Kristian Høgsberg's changes to rename git-core to
  430. git and git to git-all.
  431. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  432. - git-1.5.4.2
  433. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  434. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  435. gitweb rss feeds point be commitdiffs instead of commit
  436. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  437. - git-1.5.4.1
  438. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  439. - rebuild for new perl
  440. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  441. - Add BuidRequires on gettext.
  442. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  443. - git-1.5.4
  444. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  445. - git-1.5.3.8
  446. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  447. - Have git metapackage require explicit versions (bug 247214)
  448. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  449. - git-1.5.3.7
  450. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  451. - git-1.5.3.6
  452. - git-core requires perl(Error) (bug 367861)
  453. - git-svn requires perl(Term:ReadKey) (bug 261361)
  454. - git-email requires perl-Git (bug 333061)
  455. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  456. - git-Perl requires Error package
  457. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  458. - git-1.5.3.4
  459. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  460. - git-1.5.3.3
  461. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  462. - git-1.5.3.2
  463. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  464. - Include git-gui and git-citool docs
  465. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  466. - git-1.5.3.1-1
  467. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  468. - git-1.5.2.5-1
  469. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  470. - git-1.5.2.4-1
  471. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  472. - Add git-daemon and gitweb packages
  473. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  474. - Add emacs-git package (#235431)
  475. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  476. - git-1.5.2.2
  477. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  478. - git-1.5.2.1
  479. * Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  480. - Added lib files for git-gui
  481. - Added Documentation/technical (As needed by Git Users Manual)
  482. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  483. - Added howto files
  484. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  485. - git-1.5.0.6
  486. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  487. - git-1.5.0.5
  488. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  489. - git-1.5.0.3
  490. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  491. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  492. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  493. - git-1.5.0.2
  494. * Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
  495. - Update core package description (Git isn't as stupid as it used to be)
  496. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  497. - Add git-gui and git-citool.
  498. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  499. - no need to install manpages executable (bz 216790)
  500. - use bytes for git-cvsserver
  501. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  502. - git-1.4.4.2
  503. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  504. - rebuild against the new curl
  505. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  506. - git-1.4.2.4
  507. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  508. - git-1.4.2.3
  509. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  510. - git-1.4.2.1
  511. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  512. - git-1.4.2
  513. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  514. - git-1.4.1
  515. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  516. - git-1.4.0
  517. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  518. - git-1.3.3
  519. - enable git-email building, prereqs have been relaxed
  520. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  521. - git-1.3.2
  522. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  523. - git-1.3.1
  524. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  525. - git-1.3.0
  526. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  527. - git-1.2.6
  528. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  529. - git-1.2.5
  530. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  531. - git-1.2.4
  532. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  533. - git-1.2.3
  534. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  535. - git-1.2.2
  536. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  537. - git-1.2.1
  538. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  539. - git-1.2.0
  540. * Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  541. - git-1.1.6
  542. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  543. - git-1.1.4
  544. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  545. - git-1.1.2
  546. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  547. - git-1.1.1
  548. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  549. - Update to latest git-1.1.0 (drop git-email for now)
  550. - Now creates multiple packages:
  551. - git-core, git-svn, git-cvs, git-arch, gitk
  552. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  553. - Change subpackage names to git-<name> instead of git-core-<name>
  554. - Create empty root package which brings in all subpackages
  555. - Rename git-tk -> gitk
  556. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  557. - zlib dependency fix
  558. - Minor cleanups from split
  559. - Move arch import to separate package as well
  560. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  561. - Move programs with non-standard dependencies (svn, cvs, email)
  562. into separate packages
  563. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  564. - parallelize build
  565. - COPTS -> CFLAGS
  566. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  567. - update to 0.99.6
  568. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  569. - Linus noticed that less is required, added to the dependencies
  570. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  571. - Updated dependencies
  572. - Don't assume manpages are gzipped
  573. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  574. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  575. - use RPM_OPT_FLAGS in spec file, drop patch0
  576. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  577. - use dist tag to differentiate between branches
  578. - use rpm optflags by default (patch0)
  579. - own %{_datadir}/git-core/
  580. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  581. - update spec file to fix Buildroot, Requires, and drop Vendor
  582. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  583. - Redid the description
  584. - Cut overlong make line, loosened changelog a bit
  585. - I think Junio (or perhaps OSDL?) should be vendor...
  586. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  587. - Add the man pages, and the --without docs build option
  588. * Wed Jul 7 2005 Chris Wright <chris@osdl.org>
  589. - initial git spec file