openssh-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824
  1. %define ver 8.0p1
  2. %define rel 1%{_dist_release}
  3. # SELinux
  4. %define WITH_SELINUX 0
  5. # OpenSSH privilege separation requires a user & group ID
  6. %define sshd_uid 74
  7. %define sshd_gid 74
  8. # Version of ssh-askpass
  9. %define aversion 1.2.4.1
  10. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  11. %define no_gnome_askpass 0
  12. # Use GTK3 for gnome-ssh-askpass
  13. %define gtk3 1
  14. # Build position-independent executables (requires toolchain support)?
  15. %define pie 1
  16. # Do we want to link against a static libcrypto? (1=yes 0=no)
  17. %define static_libcrypto 0
  18. # Do we want smartcard support (1=yes 0=no)
  19. %define scard 0
  20. # Disable IPv6 (avoids DNS hangs on some glibc versions)
  21. %define noip6 0
  22. # Do we want kerberos5 support (1=yes 0=no)
  23. %define kerberos5 0
  24. # Reserve options to override askpass settings with:
  25. # rpm -ba|--rebuild --define 'skip_xxx 1'
  26. %{?skip_gnome_askpass:%define no_gnome_askpass 1}
  27. # Options for static OpenSSL link:
  28. # rpm -ba|--rebuild --define "static_openssl 1"
  29. %{?static_openssl:%define static_libcrypto 1}
  30. # Options for Smartcard support: (needs libsectok and openssl-engine)
  31. # rpm -ba|--rebuild --define "smartcard 1"
  32. %{?smartcard:%define scard 1}
  33. # Option to disable ipv6
  34. # rpm -ba|--rebuild --define "noipv6 1"
  35. %{?noipv6:%define noip6 1}
  36. # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
  37. %define rescue 0
  38. %{?build_rescue:%define rescue 1}
  39. # Turn off some stuff for resuce builds
  40. %if %{rescue}
  41. %define kerberos5 0
  42. %endif
  43. Summary: The OpenSSH implementation of SSH.
  44. Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
  45. Name: openssh
  46. Version: %{ver}
  47. Release: %{rel}
  48. URL: http://www.openssh.com/portable.html
  49. Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  50. Patch0: openssh-7.6p1-vine.patch
  51. #Patch4: openssh-8.0p1-vendor.patch
  52. # Patch12: openssh-selinux.patch
  53. # Patch20: openssh-3.9p1-gssapimitm.patch
  54. Patch21: openssh-7.6p1-safe-stop.patch
  55. Patch24: openssh-7.6p1-fromto-remote.patch
  56. Patch26: openssh-5.2p1-pam-no-stack.patch
  57. # Patch27: openssh-5.1p1-log-in-chroot.patch
  58. # Patch30: openssh-5.6p1-exit-deadlock.patch
  59. # Patch31: openssh-3.9p1-skip-used.patch
  60. Patch35: openssh-8.0p1-askpass-progress-gtk3.patch
  61. # Vine Source
  62. Source100: sshd.init.vine
  63. Source110: sshd.sysconfig.vine
  64. License: BSD
  65. Group: Applications/Internet
  66. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  67. Obsoletes: ssh
  68. BuildRequires: perl, openssl-devel, tcp_wrappers
  69. BuildRequires: util-linux
  70. %if "%{_dist_release}" >= "vl7"
  71. BuildRequires: libdb-devel
  72. %else
  73. BuildRequires: db4-devel
  74. %endif
  75. BuildRequires: pam-devel
  76. BuildRequires: zlib-devel
  77. %if ! %{no_gnome_askpass}
  78. BuildRequires: libX11-devel
  79. BuildRequires: gtk3-devel
  80. %endif
  81. BuildRequires: xorg-x11-xauth
  82. BuildRequires: groff
  83. BuildRequires: libedit-devel
  84. Vendor: Project Vine
  85. Distribution: Vine Linux
  86. Packager: daisuke
  87. %package clients
  88. Summary: OpenSSH clients.
  89. Summary(ja): OpenSSH Secure Shell プロトコルクライアント
  90. Requires: openssh = %{version}-%{release}
  91. Group: Applications/Internet
  92. Obsoletes: ssh-clients
  93. Obsoletes: openssh-contrib
  94. %package server
  95. Summary: The OpenSSH server daemon.
  96. Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
  97. Group: System Environment/Daemons
  98. Obsoletes: ssh-server
  99. Requires(post): openssh = %{version}-%{release}
  100. Requires(post): chkconfig
  101. Requires(pre): shadow-utils
  102. Requires(post): initscripts >= 5.20
  103. Requires: pam
  104. %package askpass-gnome
  105. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  106. Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
  107. Group: Applications/Internet
  108. Requires: openssh = %{version}-%{release}
  109. Obsoletes: ssh-extras
  110. Obsoletes: openssh-askpass < 5.5p1-3vl6
  111. Provides: openssh-askpass = %{version}-%{release}
  112. %description
  113. SSH (Secure SHell) is a program for logging into and executing
  114. commands on a remote machine. SSH is intended to replace rlogin and
  115. rsh, and to provide secure encrypted communications between two
  116. untrusted hosts over an insecure network. X11 connections and
  117. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  118. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  119. it up to date in terms of security and features, as well as removing
  120. all patented algorithms to separate libraries.
  121. This package includes the core files necessary for both the OpenSSH
  122. client and server. To make this package useful, you should also
  123. install openssh-clients, openssh-server, or both.
  124. #'
  125. %description -l ja
  126. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  127. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  128. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  129. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  130. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  131. な通信路の中を通すことができます。
  132. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  133. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  134. アルゴリズムは分割したライブラリにわかれています。
  135. このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
  136. コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
  137. openssh-clients および/または openssh-server が必要です。
  138. %description clients
  139. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  140. into and executing commands on a remote machine. This package includes
  141. the clients necessary to make encrypted connections to SSH servers.
  142. You'll also need to install the openssh package on OpenSSH clients.
  143. #'
  144. %description -l ja clients
  145. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  146. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  147. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  148. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  149. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  150. な通信路の中を通すことができます。
  151. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  152. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  153. アルゴリズムは分割したライブラリにわかれています。
  154. このパッケージは OpenSSH をクライアントとして使用する場合に
  155. 必要なものを含んでいます。
  156. %description server
  157. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  158. into and executing commands on a remote machine. This package contains
  159. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  160. securely connect to your SSH server. You also need to have the openssh
  161. package installed.
  162. %description -l ja server
  163. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  164. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  165. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  166. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  167. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  168. な通信路の中を通すことができます。
  169. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  170. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  171. アルゴリズムは分割したライブラリにわかれています。
  172. このパッケージは OpenSSH をサーバとして使用する場合に必要な
  173. デーモンなどを含んでいます。
  174. %description askpass-gnome
  175. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  176. into and executing commands on a remote machine. This package contains
  177. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  178. environment.
  179. %description -l ja askpass-gnome
  180. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  181. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  182. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  183. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  184. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  185. な通信路の中を通すことができます。
  186. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  187. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  188. アルゴリズムは分割したライブラリにわかれています。
  189. このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
  190. %prep
  191. %setup -q
  192. %patch0 -p1 -b .vine
  193. #patch4 -p1 -b .vendor
  194. %if %{WITH_SELINUX}
  195. #SELinux
  196. #%patch12 -p1 -b .selinux
  197. %endif
  198. %patch21 -p1 -b .safe-stop
  199. %patch24 -p1 -b .fromto-remote
  200. %patch26 -p1 -b .stack
  201. # %patch27 -p1 -b .log-chroot
  202. # %patch30 -p1 -b .exit-deadlock
  203. %patch35 -p1 -b .progress
  204. autoreconf
  205. %build
  206. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  207. %if %{rescue}
  208. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  209. %endif
  210. %if %{pie}
  211. %ifarch s390 s390x sparc sparc64
  212. CFLAGS="$CFLAGS -fPIE"
  213. %else
  214. CFLAGS="$CFLAGS -fpie"
  215. %endif
  216. export CFLAGS
  217. LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
  218. %endif
  219. %configure \
  220. --sysconfdir=%{_sysconfdir}/ssh \
  221. --libexecdir=%{_libexecdir}/openssh \
  222. --datadir=%{_datadir}/openssh \
  223. --with-tcp-wrappers \
  224. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  225. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  226. --with-privsep-path=%{_var}/empty/sshd \
  227. --enable-vendor-patchlevel="VL-%{version}-%{release}" \
  228. --with-libedit \
  229. --with-xauth=/usr/bin/xauth \
  230. %if %{scard}
  231. --with-smartcard \
  232. %endif
  233. %if %{noip6}
  234. --with-ipv4-default \
  235. %endif
  236. %if %{rescue}
  237. --without-pam --with-md5-passwords
  238. %else
  239. --with-pam
  240. %endif
  241. %if %{static_libcrypto}
  242. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  243. %endif
  244. make
  245. %if %{gtk3}
  246. gtk3=yes
  247. %else
  248. gtk3=no
  249. %endif
  250. %if ! %{no_gnome_askpass}
  251. pushd contrib
  252. if [ $gtk3 = yes ]; then
  253. make gnome-ssh-askpass3
  254. mv gnome-ssh-askpass3 gnome-ssh-askpass
  255. else
  256. make gnome-ssh-askpass2
  257. mv gnome-ssh-askpass2 gnome-ssh-askpass
  258. fi
  259. popd
  260. %endif
  261. %install
  262. rm -rf $RPM_BUILD_ROOT
  263. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  264. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  265. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  266. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
  267. make install DESTDIR=$RPM_BUILD_ROOT
  268. touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
  269. install -d $RPM_BUILD_ROOT/etc/pam.d/
  270. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  271. install -d $RPM_BUILD_ROOT/etc/sysconfig/
  272. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  273. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  274. install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  275. install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
  276. %if ! %{scard}
  277. rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
  278. %endif
  279. %if ! %{no_gnome_askpass}
  280. install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  281. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  282. install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  283. %endif
  284. %if %{no_gnome_askpass}
  285. rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
  286. %endif
  287. # for contrib package
  288. install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
  289. install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
  290. mv contrib/README contrib/README.contrib
  291. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  292. %clean
  293. rm -rf $RPM_BUILD_ROOT
  294. %triggerun server -- ssh-server
  295. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  296. touch /var/run/sshd.restart
  297. fi
  298. %triggerun server -- openssh-server < 2.5.0p1
  299. # Count the number of HostKey and HostDsaKey statements we have.
  300. gawk 'BEGIN {IGNORECASE=1}
  301. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  302. END {exit sawhostkey}' /etc/ssh/sshd_config
  303. # And if we only found one, we know the client was relying on the old default
  304. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  305. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  306. # one nullifies the default, which would have loaded both.
  307. if [ $? -eq 1 ] ; then
  308. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  309. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  310. fi
  311. %triggerpostun server -- ssh-server
  312. if [ "$1" != 0 ] ; then
  313. /sbin/chkconfig --add sshd
  314. if test -f /var/run/sshd.restart ; then
  315. rm -f /var/run/sshd.restart
  316. # /sbin/service sshd start > /dev/null 2>&1 || :
  317. /sbin/service sshd start
  318. fi
  319. fi
  320. %pre server
  321. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  322. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  323. -g sshd -M -r sshd 2>/dev/null || :
  324. %post server
  325. /sbin/chkconfig --add sshd
  326. %postun server
  327. # /sbin/service sshd condrestart > /dev/null 2>&1 || :
  328. /sbin/service sshd condrestart
  329. exit 0
  330. %preun server
  331. if [ "$1" = 0 ]
  332. then
  333. /sbin/service sshd stop > /dev/null 2>&1 || :
  334. /sbin/chkconfig --del sshd
  335. fi
  336. %files
  337. %defattr(-,root,root)
  338. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW PROTOCOL* README* TODO
  339. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  340. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  341. %attr(644,root,root) %{_mandir}/man5/moduli.5*
  342. %if ! %{rescue}
  343. %attr(0755,root,root) %{_bindir}/ssh-keygen
  344. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  345. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  346. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  347. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  348. %endif
  349. %if %{scard}
  350. %attr(0755,root,root) %dir %{_datadir}/openssh
  351. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  352. %endif
  353. %files clients
  354. %defattr(-,root,root)
  355. %attr(0755,root,root) %{_bindir}/scp
  356. %attr(0755,root,root) %{_bindir}/ssh
  357. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  358. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  359. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  360. # %attr(0644,root,root) %{_mandir}/man1/slogin.1*
  361. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  362. # %attr(-,root,root) %{_bindir}/slogin
  363. %if ! %{rescue}
  364. %attr(0755,root,root) %{_bindir}/ssh-agent
  365. %attr(0755,root,root) %{_bindir}/ssh-add
  366. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  367. %attr(0755,root,root) %{_bindir}/sftp
  368. %attr(0755,root,root) %{_bindir}/ssh-copy-id
  369. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
  370. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  371. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  372. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  373. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  374. %attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
  375. %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
  376. %endif
  377. %if ! %{rescue}
  378. %files server
  379. %defattr(-,root,root)
  380. %dir %attr(0711,root,root) %{_var}/empty/sshd
  381. %dir %attr(0755,root,root) %{_var}/empty/sshd/etc
  382. %ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
  383. %attr(0755,root,root) %{_sbindir}/sshd
  384. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  385. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  386. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  387. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  388. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  389. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  390. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  391. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  392. %attr(0755,root,root) %config /etc/sysconfig/sshd
  393. %endif
  394. %if ! %{no_gnome_askpass}
  395. %files askpass-gnome
  396. %defattr(-,root,root)
  397. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  398. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  399. %endif
  400. %changelog
  401. * Sat Jun 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0p1-1
  402. - new upstream release.
  403. - moved scp to openssh-clients.
  404. - changed "PasswordAuthentication" to "no" as default.
  405. - dropped Patch4.
  406. - update Patch35 to use GTK+3 for gnome-ssh-askpass.
  407. * Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.9p1-1
  408. - new upstream release.
  409. - updated Patch4.
  410. * Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.6p1-1
  411. - new upstream release.
  412. - update patch0,4,21,24
  413. - update patch35 from fc26
  414. - drop patch12,20,30
  415. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-2
  416. - disabled rsa1 hostkey generation.
  417. * Sat Jul 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-1
  418. - new upstream release.
  419. * Wed Mar 9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.2p1-1
  420. - new upstream release
  421. - built with openssl 1.0.2g
  422. - drop slogin command and manual, this is upstream change.
  423. * Sun Jan 17 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p2-1
  424. - update to 7.1p2
  425. * Mon Dec 28 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p1-1
  426. - update to 7.1p1
  427. - remove patch100 to use default value "prohibit-password" for PermitRootLogin
  428. * Tue Oct 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.7p1-1
  429. - update to 6.7p1
  430. - fix sshd.init
  431. * Thu Aug 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.6p1-1
  432. - update to 6.6p1
  433. - remove BR: sharutils
  434. - add BR: libdb-devel instead of db4-devel
  435. * Tue Feb 04 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 6.5p1-1
  436. - update to 6.5p1
  437. - update sshd_config
  438. - generate ED25519 host key.
  439. * Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
  440. - update to 6.4p1
  441. * Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
  442. - update to 6.2p2
  443. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
  444. - update to 6.2p1
  445. * Fri Nov 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
  446. - new upstream release
  447. - add -with-xauth option in configure
  448. - patch4, 30, 35 are updated from fc18
  449. * Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
  450. - new upstream release
  451. * Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
  452. - new upstream release
  453. * Sun May 8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
  454. - new upstream release
  455. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
  456. - add our own sshd.init based on fedora's sshd.init
  457. - generate ECDSA host key.
  458. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
  459. - new upstream release
  460. * Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
  461. - new upstream release
  462. * Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
  463. - new upstream release
  464. - obsolete contrib subpackage, move ssh-copy-id to client subpackage
  465. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
  466. - rebuilt with openssl 1.0.0c
  467. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
  468. - drop x11-askpass, add Obsoletes: openssh-askpass
  469. - add BR: groff
  470. - enable --with-libedit option, add BR: libedit-devel
  471. - remove unrecognized option '--with-rsh'
  472. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
  473. - add BR: xorg-x11-xauth for X11 forwarding support
  474. * Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
  475. - new upstream release
  476. - update patch0,2
  477. - drop patch3,22
  478. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
  479. - new upstream release
  480. * Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
  481. - new upstream release
  482. * Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
  483. - rebuild with xorg-x11-7.3
  484. * Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
  485. - new upstream release with security fix (CVE-2008-1483)
  486. - drop patch31 which is included in new release (This was for CVE-2008-1483)
  487. * Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
  488. - new upstream release with security fix ("ForceCommand" Directive)
  489. - turn on daemon restart message
  490. - new versioning policy
  491. * Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
  492. - add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
  493. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
  494. - new upstream release
  495. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
  496. - build with -fpie/-pie by default.
  497. - enable ipv6 by default.
  498. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
  499. - new upstream release
  500. * Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
  501. - new upstream release
  502. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
  503. - new upstream release
  504. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
  505. - new upstream release
  506. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
  507. - new upstream release
  508. - remove build6x stuff
  509. - remove libgnome-devel from BuildRequires
  510. - cleanup BuildRequires
  511. - drop Patch200, it is merged in upstream.
  512. - import patches(25-35) from FC-devel
  513. * Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
  514. - SECURITY FIX: CVE-2006-0225
  515. - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
  516. - update BuildPreReq: s/XFree86-devel/XOrg-devel/
  517. - fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
  518. - When GNOME2 is used, using libgnome-devel
  519. - add BuildPreReq: gtk2-devel for GNOME2
  520. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
  521. - rebuild with gtk+-2.8 final
  522. * Sun Sep 4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
  523. - new upstream release
  524. - build with gtk+-2.7
  525. * Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
  526. - new upstream release
  527. * Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
  528. - cleanup obsolete patches and added patches from fedora
  529. * Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
  530. - new upstream release
  531. * Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
  532. - new upstream release
  533. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
  534. - new upstream release
  535. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
  536. - rebuild with openssl-0.9.7d
  537. * Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
  538. - new upstream release
  539. * Thu Oct 2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
  540. - create contrib package
  541. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
  542. - new upstream release
  543. - fix security issue: http://www.openssh.com/txt/sshpam.adv
  544. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
  545. - new upstream release
  546. - fix security issue: http://www.openssh.com/txt/buffer.adv
  547. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
  548. - new upstream release
  549. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
  550. - rebuild with gtk2
  551. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
  552. - new upstream release
  553. * Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
  554. - rebuild with new tool chain
  555. * Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
  556. - new upstream release
  557. - merge with upstream spec (drop anonymous mmap patch, suid of ssh)
  558. * Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
  559. - change some defines in spec files
  560. * Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
  561. - add patch110 ( 3.4p1 does not include mmap-fallback patch )
  562. * Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
  563. - new upstream release
  564. - security fix
  565. - drop patch10
  566. * Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
  567. - add patch from Solar Designer to make privsep work with a 2.2 kernel.
  568. * Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
  569. - new upstream release
  570. - add {sshd,ssh}_config.5 manpages
  571. - add ssh-keysign
  572. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
  573. - new upstream release
  574. * Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
  575. - new upstream release
  576. - drop patch1
  577. * Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
  578. - new upstream release
  579. - merged with rawhide release.
  580. - drop Patch101 (merged in upstream)
  581. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
  582. - seurity patch for off-by-one bug
  583. * Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
  584. - merged with Rawhide 3.0.2p1-2
  585. * Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
  586. - updated to 3.0.2p1
  587. * Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
  588. - updated to 3.0.1p1
  589. * Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
  590. - updated to 3.0p1
  591. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
  592. - add japanese summery and descriptions.
  593. - update x11-askpass 1.2.5
  594. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
  595. - update to openssh-2.9.9p2
  596. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
  597. - rebuilt with openssl-0.9.6b
  598. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
  599. - do not Permit RootLogin
  600. * Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
  601. - update to openssh-2.5.2p2
  602. * Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
  603. - update to openssh-2.5.2p1
  604. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  605. - update to openssh-2.5.1p2
  606. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  607. - update to openssh-2.5.1p1
  608. * Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
  609. - update to openssh-2.5.1p1
  610. * Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
  611. - remove suid bit from ssh
  612. * Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
  613. - moved man dir to /usr/share/man
  614. * Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
  615. - fixed askpass's link in ssh-add
  616. - partially used rpmmacros
  617. * Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
  618. - update to 2.3.0p1
  619. - update x11-askpass 1.0.3
  620. * Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
  621. - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
  622. Redhat 7.0 spec file
  623. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
  624. - rebuild for Vine Linux
  625. * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
  626. - Use RPM configure macro
  627. * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
  628. - Some surgery to sshd.init (generate keys at runtime)
  629. - Cleanup of groups and removal of keygen calls
  630. * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
  631. - Make building of X11-askpass and gnome-askpass optional
  632. * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
  633. - Glob manpages to catch compressed files
  634. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  635. - Updated for new location
  636. - Updated for new gnome-ssh-askpass build
  637. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  638. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  639. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  640. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  641. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  642. - Added 'Obsoletes' directives
  643. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  644. - Use make install
  645. - Subpackages
  646. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  647. - Added links for slogin
  648. - Fixed perms on manpages
  649. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  650. - Renamed init script
  651. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  652. - Back to old binary names
  653. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  654. - Use autoconf
  655. - New binary names
  656. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  657. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.