gl-manpages-vl.spec 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. %global codate 20121009
  2. Name: gl-manpages
  3. Version: 1.1
  4. Release: 1%{?_dist_release}
  5. Summary: OpenGL manpages
  6. Summary(ja): OpenGLマニュアルページ
  7. License: MIT and Open Publication
  8. URL: http://www.opengl.org/wiki/Getting_started/XML_Toolchain_and_Man_Pages
  9. # see Source1
  10. Source0: gl-manpages-%{version}-%{codate}.tar.xz
  11. Source1: make-gl-man-snapshot.sh
  12. # FIXME: Bundle mathml and the Oasis dbmathl until they are packaged
  13. Source2: http://www.oasis-open.org/docbook/xml/mathml/1.1CR1/dbmathml.dtd
  14. Source3: http://www.w3.org/Math/DTD/mathml2.tgz
  15. # FIXME These are the old gl-manpages source which
  16. # still have some manpages that khronos doesn't.
  17. # Ship until somebody in the know helps figuring whats what.
  18. # When matching install the kronos version.
  19. Source4: gl-manpages-1.0.1.tar.bz2
  20. BuildArch: noarch
  21. BuildRequires: libxslt docbook-style-xsl
  22. %description
  23. OpenGL manpages
  24. %prep
  25. %setup -q -n %{name}-%{version}-%{codate}
  26. tar xzf %{SOURCE3}
  27. cp -av %{SOURCE2} mathml2/
  28. tar xjf %{SOURCE4}
  29. %build
  30. # FIXME Figure out how to build the GLSL manpages
  31. # FIXME Figure out how to silence the author/version etc warnings
  32. for MAN in man4 man3 man ; do
  33. pushd $MAN
  34. ls -1 *.xml | xargs -n1 xsltproc --noout --nonet --path ../mathml2/ /usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl
  35. popd
  36. done
  37. %install
  38. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
  39. cp -n {man4,man3,man}/*.3G $RPM_BUILD_ROOT%{_mandir}/man3/
  40. # install the old manpages source with 3gl -> 3G
  41. # when matchin don't clobber the khronos version
  42. for MANP in `find gl-manpages-1.0.1 -name *.3gl` ; do
  43. FN=${MANP//*\//}
  44. cp -a -n $MANP $RPM_BUILD_ROOT%{_mandir}/man3/${FN/.3gl/.3G}
  45. find $RPM_BUILD_ROOT%{_mandir}/man3/ -type f -size -100b | xargs sed -i -e 's/\.3gl/\.3G/'
  46. done
  47. %files
  48. %{_mandir}/man3/*
  49. %changelog
  50. * Wed Nov 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
  51. - initial build for Vine Linux
  52. * Mon Oct 15 2012 Yanko Kaneti <yaneti@declera.com> - 1.1-3.%{codate}
  53. - Fix symlinked man variants.
  54. - Preserve timestamps on the older gl-manpages.
  55. * Tue Oct 9 2012 Yanko Kaneti <yaneti@declera.com> - 1.1-2.%{codate}
  56. - Re-add the older gl-manpages for those not present in khronos
  57. * Tue Oct 9 2012 Yanko Kaneti <yaneti@declera.com> - 1.1-1.%{codate}
  58. - Try building from source
  59. * Wed Sep 5 2012 Yanko Kaneti <yaneti@declera.com> - 1.0.1-1
  60. - Initial split from mesa