123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105 |
- %define prever rc3
- Summary: C library for embedded Linux
- Summary(ja): 組み込みLinux用のCライブラリ
- Name: uClibc
- Version: 0.9.32
- Release: 1.%{prever}%{?_dist_release}
- Group: Development/Libraries
- License: LGPLv2
- URL: http://www.uclibc.org/
- Source0: http://www.uclibc.org/downloads/%{name}-%{version}-%{prever}.tar.xz
- Source1: uClibc.config
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- %global debug_package %{nil}
- # This package only contains a static library
- ExcludeArch: ppc64
- # uclibc 0.9.30 does not support ppc64
- %description
- uClibc is a C library for developing embedded Linux systems.
- It is much smaller than the GNU C Library, but nearly all applications
- supported by glibc also work perfectly with uClibc.
- %package devel
- Summary: Header files and libraries for uClibc library
- Summary(ja): Header files and libraries for uClibc library
- Group: Development/Libraries
- Provides: uClibc-static = %{version}-%{release}
- %description devel
- uClibc is a C library for developing embedded Linux systems.
- It is much smaller than the GNU C Library, but nearly all applications
- supported by glibc also work perfectly with uClibc.
- This package contains the header files and libraries
- needed for uClibc package.
- %prep
- %setup -q -n %{name}-%{version}-%{prever}
- cat %{SOURCE1} >.config1
- iconv -f windows-1252 -t utf-8 README >README.pom
- mv README.pom README
- %build
- mkdir kernel-include
- cp -a /usr/include/asm kernel-include
- cp -a /usr/include/asm-generic kernel-include
- cp -a /usr/include/linux kernel-include
- arch=`uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/'`
- echo "TARGET_$arch=y" >.config
- echo "TARGET_ARCH=\"$arch\"" >>.config
- cat .config1 >>.config
- yes "" | make oldconfig %{?_smp_mflags}
- make V=1 %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- mkdir -p $RPM_BUILD_ROOT/lib
- make install PREFIX="$RPM_BUILD_ROOT/"
- make install_headers PREFIX="$RPM_BUILD_ROOT/" DEVEL_PREFIX=""
- cp -a kernel-include/* $RPM_BUILD_ROOT/include/
- # move libraries to proper subdirectory
- mkdir -p $RPM_BUILD_ROOT/%{_libdir}/uClibc
- mv $RPM_BUILD_ROOT/lib/* $RPM_BUILD_ROOT/%{_libdir}/uClibc/
- rm -rf $RPM_BUILD_ROOT/lib/
- # move the header files to /usr subdirectory
- mkdir -p $RPM_BUILD_ROOT/%{_includedir}/uClibc
- mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT/%{_includedir}/uClibc
- rm -rf $RPM_BUILD_ROOT/include/
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files devel
- %defattr(-,root,root,-)
- %doc README docs/Glibc_vs_uClibc_Differences.txt docs/threads.txt docs/uClibc_vs_SuSv3.txt
- %doc TODO DEDICATION.mjn3 MAINTAINERS
- %doc docs/PORTING COPYING.LIB
- %{_includedir}/uClibc
- %{_libdir}/uClibc
- %changelog
- * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.32-1.rc3
- - initial build for Vine Linux
- * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.32-0.2.rc2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Mon Feb 7 2011 Tom Callaway <spot@fedoraproject.org> - 0.9.32-0.1.rc2
- - update config for 0.9.32-rc2, busybox
- - patch getutent
- * Tue Nov 9 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 0.9.31-2
- - update to 0.9.31
- * Fri Jun 5 2009 Ivana Varekova <varekova@redhat.com> - 0.9.30.1-2
- - initial build for Red Hat
|