libproxy-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303
  1. %bcond_with mozjs
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A library handling all the details of proxy configuration
  4. Name: libproxy
  5. Version: 0.4.17
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: http://libproxy.github.io/libproxy
  12. Source0: https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. Requires: libproxy-bin = %{version}-%{release}
  15. Obsoletes: %{name}-mozjs < 1.4.15
  16. Obsoletes: %{name}-webkitgtk3 < 1.4.15
  17. BuildRequires: cmake
  18. # gnome
  19. BuildRequires: pkgconfig(gio-2.0) >= 2.26
  20. # NetworkManager
  21. BuildRequires: NetworkManager-libnm-devel
  22. BuildRequires: dbus-devel
  23. BuildRequires: glib2
  24. # webkit (gtk3)
  25. BuildRequires: pkgconfig(javascriptcoregtk-4.0)
  26. # python3
  27. BuildRequires: python3-devel
  28. BuildRequires: python3-rpm-macros
  29. Obsoletes: %{name}-python < 0.4.17
  30. %description
  31. libproxy offers the following features:
  32. * extremely small core footprint (< 35K)
  33. * no external dependencies within libproxy core
  34. (libproxy plugins may have dependencies)
  35. * only 3 functions in the stable external API
  36. * dynamic adjustment to changing network topology
  37. * a standard way of dealing with proxy settings across all scenarios
  38. * a sublime sense of joy and accomplishment
  39. Non-default rpmbuild options:
  40. --with webkit: Enable WebKit-gtk support
  41. %package bin
  42. Summary: Binary to test %{name}
  43. Group: network
  44. Requires: %{name} = %{version}-%{release}
  45. %description bin
  46. The %{name}-bin package contains the proxy binary for %{name}
  47. %package -n python3-%{name}
  48. Summary: Binding for %{name} and python
  49. Group: programming
  50. BuildArch: noarch
  51. %{?python_provide:%python_provide python3-%{name}}
  52. Obsoletes: %{name}-python3 < 1.4.17
  53. Provides: %{name}-python3 = %{version}-%{release}
  54. Requires: %{name} = %{version}-%{release}
  55. %description -n python3-%{name}
  56. The python3-%{name} package contains the python3 binding for %{name}
  57. %package gnome
  58. Summary: Plugin for %{name} and gnome
  59. Group: system
  60. Requires: %{name} = %{version}-%{release}
  61. %description gnome
  62. The %{name}-gnome package contains the %{name} plugin for gnome.
  63. %package networkmanager
  64. Summary: Plugin for %{name} and networkmanager
  65. Group: system
  66. Requires: %{name}%{?_isa} = %{version}-%{release}
  67. %description networkmanager
  68. The %{name}-networkmanager package contains the %{name} plugin
  69. for networkmanager.
  70. %package webkitgtk4
  71. Summary: Plugin for %{name} and webkitgtk4
  72. Group: system
  73. Requires: %{name} = %{version}
  74. Provides: %{name}-pac = %{version}-%{release}
  75. %description webkitgtk4
  76. The %{name}-webkitgtk4 package contains the %{name} plugin for
  77. webkitgtk4.
  78. %package pacrunner
  79. Summary: Plugin for %{name} and PacRunner
  80. Group: system
  81. Requires: %{name}%{?_isa} = %{version}-%{release}
  82. Provides: %{name}-pac = %{version}-%{release}
  83. Requires: pacrunner
  84. %description pacrunner
  85. The %{name}-pacrunner package contains the %{name} plugin for
  86. PacRunner.
  87. %package devel
  88. Summary: Development files for %{name}
  89. Group: programming
  90. Requires: %{name} = %{version}-%{release}
  91. Requires: pkgconfig
  92. %description devel
  93. The %{name}-devel package contains libraries and header files for
  94. developing applications that use %{name}.
  95. %debug_package
  96. %prep
  97. %autosetup -p1
  98. %build
  99. export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
  100. %cmake \
  101. -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
  102. -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
  103. -DWITH_PERL=OFF \
  104. -DWITH_PYTHON2=OFF \
  105. -DWITH_PYTHON3=ON \
  106. -DBIPR=OFF \
  107. -DWITH_WEBKIT3=ON \
  108. -DWITH_GNOME3=ON \
  109. -DWITH_KDE=OFF \
  110. %{nil}
  111. %cmake_build
  112. %install
  113. rm -rf $RPM_BUILD_ROOT
  114. %cmake_install
  115. %clean
  116. rm -rf $RPM_BUILD_ROOT
  117. %files
  118. %license COPYING
  119. %doc AUTHORS README
  120. %{_libdir}/*.so.*
  121. %dir %{_libdir}/%{name}
  122. %dir %{_libdir}/%{name}/%{version}
  123. %dir %{_libdir}/%{name}/%{version}/modules
  124. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  125. %files bin
  126. %{_bindir}/proxy
  127. %files -n python3-%{name}
  128. %{python3_sitelib}/libproxy.py
  129. %files gnome
  130. %{_libdir}/%{name}/%{version}/modules/config_gnome3.so
  131. %{_libexecdir}/pxgsettings
  132. %files networkmanager
  133. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  134. %files webkitgtk4
  135. %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
  136. %files pacrunner
  137. %{_libdir}/%{name}/%{version}/modules/config_pacrunner.so
  138. %files devel
  139. %defattr(-,root,root,-)
  140. %{_includedir}/proxy.h
  141. %{_libdir}/*.so
  142. %{_libdir}/pkgconfig/libproxy-1.0.pc
  143. %{_datadir}/cmake/Modules/Findlibproxy.cmake
  144. %changelog
  145. * Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.17-1
  146. - dropped ldconfig scriptlets.
  147. - dropped subpackages: kde, python2.
  148. - dropped Patch0, 1000 and 1001: fixed in upstream.
  149. * Sat Oct 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-4
  150. - imported Patch1001 to fix CVE-2020-26154 from rawhide.
  151. * Tue Sep 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-3
  152. - imported Patch1000 to fix CVE-2020-25219 from debian.
  153. - imported Patch0 to support python-3.8 from upstream.
  154. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-2
  155. - rebuilt with current environment.
  156. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
  157. - updated to 0.4.15.
  158. - enabled python3 support.
  159. - disabled mozjs as default.
  160. - switched to webkitgtk4.
  161. * Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
  162. - rebuild with gcc-5.4.0
  163. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  164. - update to 0.4.11
  165. - remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
  166. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
  167. - rebuild with python-2.7.2
  168. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
  169. - new upstream release
  170. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  171. - change BuildRequires: js-devel instead of gecko-devel
  172. - replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
  173. - detele -webkit sub package
  174. - create -webkitgtk3 sub package
  175. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  176. - new upstream release
  177. - drop Patch0
  178. - add BuildRequires: cmake, kdelibs-devel
  179. - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
  180. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
  181. - rebuild with rpm-4.8.1 for pkg-config file
  182. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  183. - rebuild with python-2.6
  184. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  185. - rebuild with gecko-1.9.1
  186. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  187. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  188. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  189. - initial build for Vine Linux
  190. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  191. - Rebuild for webkit
  192. - Raise requirement for xulrunner to 1.9.1
  193. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  194. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  195. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  196. - Merge NetworkManager module into the main libproxy package
  197. - Main Requires the -python and -bin subpackage
  198. (splitted for multilibs compliance).
  199. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  200. - Disable Gnome/KDE default support via builtin modules.
  201. (it needs to be integrated via Gconf2/neon instead).
  202. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  203. - Disable Obsoletes.
  204. - Requires ev instead of evr for optionnals sub-packages.
  205. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  206. - Use conditionals build.
  207. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  208. - Remove plugin- in the name of the packages
  209. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  210. - Move proxy.h to libproxy/proxy.h
  211. This will prevent it to be included in the default include path
  212. - Split main to libs and util and use libproxy to install all
  213. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  214. - Rename binding-python to python
  215. - Add Requires: gecko-libs >= %%{gecko_version}
  216. - Fix some descriptions
  217. - Add plugin-webkit package
  218. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  219. - Convert to Fedora spec
  220. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  221. - Updated to version 0.2.3
  222. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  223. - Extended spec file to build all available plugins
  224. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  225. - Initial spec file for Version 0.2.2