123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242 |
- %global srcname wxWidgets
- %global wxgtkname wxGTK3
- %global wxbasename wxBase3
- %global gtkver 3
- Summary: GTK port of the wxWidgets GUI library
- Name: %{wxgtkname}
- Version: 3.0.5
- Release: 1%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: wxWidgets
- URL: http://www.wxwidgets.org/
- Source0: https://github.com/wxWidgets/wxWidgets/releases/download/v%{version}/wxWidgets-%{version}.tar.bz2
- Source10: wx-config
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: gtk%{gtkver}-devel
- #Note webkitgtk (GTK2) does not appear to be supported
- BuildRequires: webkitgtk4-devel
- BuildRequires: zlib-devel
- BuildRequires: libpng-devel
- BuildRequires: libjpeg-turbo-devel
- BuildRequires: libtiff-devel
- BuildRequires: expat-devel
- BuildRequires: SDL2-devel
- BuildRequires: libGLU-devel
- BuildRequires: libSM-devel
- BuildRequires: gstreamer1-plugins-base-devel
- BuildRequires: GConf2-devel
- BuildRequires: gettext
- BuildRequires: cppunit-devel
- BuildRequires: libmspack-devel
- Provides: %{srcname} = %{version}-%{release}
- Requires: %{wxbasename}%{?_isa} = %{version}-%{release}
- %description
- wxWidgets is the GTK port of the C++ cross-platform wxWidgets
- GUI library, offering classes for all common GUI controls as well as a
- comprehensive set of helper classes for most common application tasks,
- ranging from networking to HTML display and image manipulation.
- %package devel
- Summary: Development files for the wxGTK3 library
- Group: programming
- Requires: %{name}%{?_isa} = %{version}-%{release}
- Requires: %{wxbasename} = %{version}-%{release}
- Requires: gtk%{gtkver}-devel
- Requires: libGLU-devel
- Provides: %{srcname}-devel = %{version}-%{release}
- %description devel
- This package include files needed to link with the wxGTK3 library.
- wxWidgets is the GTK port of the C++ cross-platform wxWidgets
- GUI library, offering classes for all common GUI controls as well as a
- comprehensive set of helper classes for most common application tasks,
- ranging from networking to HTML display and image manipulation.
- %package -n %{wxbasename}
- Summary: Non-GUI support classes from the wxWidgets library
- Group: system
- %description -n %{wxbasename}
- Every wxWidgets application must link against this library. It contains
- mandatory classes that any wxWidgets code depends on (like wxString) and
- portability classes that abstract differences between platforms. wxBase can
- be used to develop console mode applications -- it does not require any GUI
- libraries or the X Window System.
- #%package docs
- #Group: Development/Libraries
- #Summary: Documentation for the wxGTK3 library
- #Requires: %{name} = %{version}-%{release}
- #Provides: %{srcname}-docs = %{version}-%{release}
- #BuildArch: noarch
- #%description docs
- #This package provides documentation for the %{srcname} library.
- %debug_package
- %prep
- %setup -q -n %{srcname}-%{version}
- # in case of gtk3
- %if %{gtkver} == 3
- sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
- %endif
- # patch some installed files to avoid conflicts with 2.8.*
- sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
- sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
- sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
- # rename docs directory
- #mv %{srcname}-%{version} html
- sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
- # fix plugin dir for 64-bit
- sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
- %build
- # likely still dereferences type-punned pointers
- CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
- CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
- # fix unused-direct-shlib-dependency error:
- export LDFLAGS="-Wl,--as-needed"
- %configure \
- --with-gtk=%{gtkver} \
- --with-opengl \
- --with-sdl \
- --with-gnomeprint \
- --with-libmspack \
- --enable-intl \
- --enable-no_deps \
- --disable-rpath \
- --enable-ipv6 \
- --enable-utf8 \
- make %{?_smp_mflags}
- %install
- %makeinstall
- # install our multilib-aware wrapper
- rm %{buildroot}%{_bindir}/wx-config
- rm %{buildroot}%{_bindir}/wxrc
- install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
- # move bakefiles to avoid conflicts with 2.8.*
- mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
- mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
- %find_lang wxstd3
- %find_lang wxmsw3
- cat wxmsw3.lang >> wxstd3.lang
- %check
- pushd tests
- make %{?_smp_mflags} test
- popd
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %post -n %{wxbasename} -p /sbin/ldconfig
- %postun -n %{wxbasename} -p /sbin/ldconfig
- %files -f wxstd3.lang
- %license docs/gpl.txt docs/lgpl.txt docs/licence.txt docs/licendoc.txt docs/preamble.txt
- %doc docs/changes.txt docs/readme.txt
- %{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
- %{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
- %if %{gtkver} == 3
- %{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
- %endif
- %{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
- %files devel
- %{_bindir}/wx-config*
- %{_bindir}/wxrc-3.0
- %{_includedir}/wx-3.0
- %{_libdir}/libwx_*.so
- %{_libdir}/wx
- %{_datadir}/aclocal/wxwin3.m4
- %{_datadir}/bakefile/presets/wx3/
- %files -n %{wxbasename}
- %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
- %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
- %{_libdir}/libwx_baseu-*.so.*
- %{_libdir}/libwx_baseu_net-*.so.*
- %{_libdir}/libwx_baseu_xml-*.so.*
- #%files docs
- #%doc html
- %changelog
- * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.5-1
- - new upstream release.
- * Sun Oct 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.4-1
- - new upstream release.
- * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.2-2
- - rebuilt with new toolchain.
- * Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
- - new upstream release
- * Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
- - initial build for Vine Linux
- * Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
- - Bump to 3.0.1 RH#1076617
- * Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
- - Removed disable-catch_segvs, see RH#1076617
- * Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
- - Renable combat28 - without it causes bugs RH#1076617 and a few others
- * Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
- - Fixed GTK3 bug with wx-config
- - Fixed a unused-direct-shlib-dependency error
- * Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
- - Added patch to avoid build fail on gtk 3.10+
- - Reverted patching to make devel package compatible with wxGTK-devel
- - Added combatibility for RHEL 6+
- - Changed all mention of GTK3 and GTK2 to GTK for consistency
- * Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
- - Changed to build against gtk3
- - Add webkit to build requires
- - Removed patching to make devel package compatible with wxGTK-devel
- - Disable 2.8.* combatibility (redundant functionality)
- * Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
- - Initial build of wxwidgets version 3, mostly based on wxGTK spec
|