neon-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: An HTTP and WebDAV client library.
  3. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  4. Name: neon
  5. Version: 0.28.6
  6. Release: 1%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.webdav.org/neon/
  10. Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: expat
  13. Requires: zlib >= 1.1.4
  14. Requires: krb5-libs
  15. BuildRequires: expat-devel
  16. BuildRequires: openssl-devel
  17. BuildRequires: libxml2-devel
  18. BuildRequires: zlib-devel
  19. BuildRequires: gnutls-devel
  20. BuildRequires: krb5-devel
  21. BuildRequires: sed
  22. %description
  23. neon is an HTTP and WebDAV client library, with a C interface;
  24. providing a high-level interface to HTTP and WebDAV methods along
  25. with a low-level interface for HTTP request handling. neon
  26. supports persistent connections, proxy servers, basic, digest and
  27. Kerberos authentication, and has complete SSL support.
  28. %package devel
  29. Summary: Development libraries and C header files for the neon library
  30. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}
  33. Requires: zlib-devel
  34. Requires: openssl-devel
  35. Requires: expat-devel
  36. Requires: gnutls-devel
  37. %description devel
  38. The development library for the C language HTTP and WebDAV client library.
  39. %description devel -l ja
  40. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  41. ## to build compat32 for x86_64 architecture support
  42. %package -n compat32-%{name}
  43. Summary: C language HTTP and WebDAV client library.
  44. Group: System Environment/Libraries
  45. Requires: expat
  46. Requires: zlib >= 1.1.4
  47. %description -n compat32-%{name}
  48. A C language HTTP and WebDAV client library.
  49. %package -n compat32-%{name}-devel
  50. Summary: A C language HTTP and WebDAV client library.
  51. Group: Development/Libraries
  52. Requires: compat32-%{name} = %{version}
  53. Requires: compat32-zlib-devel
  54. Requires: compat32-openssl-devel
  55. Requires: compat32-expat-devel
  56. %description -n compat32-%{name}-devel
  57. The development library for the C language HTTP and WebDAV client library.
  58. %prep
  59. %setup -q
  60. %build
  61. %configure \
  62. --with-expat \
  63. --with-ssl=gnutls --enable-threadsafe-ssl=posix \
  64. --enable-shared \
  65. --with-force-ssl
  66. %__make %{?_smp_mflags}
  67. %install
  68. %__rm -rf %{buildroot}
  69. %makeinstall
  70. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  71. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  72. %find_lang %{name}
  73. ## remove unuse files
  74. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %post -n compat32-%{name} -p /sbin/ldconfig
  80. %postun -n compat32-%{name} -p /sbin/ldconfig
  81. %files -f %{name}.lang
  82. %defattr(-,root,root)
  83. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  84. %doc doc/html
  85. %{_libdir}/*.so.*
  86. %files devel
  87. %defattr(-,root,root)
  88. %{_bindir}/*
  89. %{_includedir}/*
  90. %{_mandir}/man1/*
  91. %{_mandir}/man3/*
  92. %{_libdir}/*.a
  93. #%{_libdir}/*.la
  94. %{_libdir}/*.so
  95. %{_libdir}/pkgconfig/*.pc
  96. %if %{build_compat32}
  97. %files -n compat32-%{name}
  98. %defattr(-,root,root)
  99. %{_libdir}/*.so*
  100. %files -n compat32-%{name}-devel
  101. %defattr(-,root,root)
  102. %{_libdir}/*.a
  103. #%{_libdir}/*.la
  104. %{_libdir}/pkgconfig/*.pc
  105. %endif
  106. %changelog
  107. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  108. - new upstream release with security fix (CVE-2009-2473, 2474)
  109. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  110. - rebuild with gnutls-2.6.3
  111. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  112. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  113. - add _smp_mflags into make section
  114. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  115. - new upstream release with security fix (CVE-2008-3746)
  116. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  117. - removed *.la
  118. - spec in utf-8
  119. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  120. - added --with-ssl=gnutls --enable-threadsafe-ssl
  121. - added BuildRequires: gnutls-devel
  122. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  123. - new upstream release
  124. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  125. - removed %%if !%%{build_compat32} case condition
  126. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  127. - rebuild with expat-2.0.1
  128. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  129. - new upstream release
  130. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  131. - add Requires: zlib-devel, openssl-devel, expat-devel
  132. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  133. - move %%configure from %%prep to %%build
  134. - remove unneeded locales.patch (for neon-0.26.x or later)
  135. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  136. - new upstream release
  137. - drop doc.patch (patch0)
  138. - use more macros
  139. - drop BuildRequires: autoconf, automake
  140. - add *.pc to -devel (and compat32's) package
  141. - change group
  142. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  143. - add doc/html instead of doc/* to %%doc
  144. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  145. - run ldconfig in %%post,postun
  146. - add locales.patch (patch0)
  147. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  148. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  149. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  150. - added compat32- packages for x86_64 architecture support
  151. - added --libdir=%{_libdir} option to configure
  152. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  153. - new upstream release
  154. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  155. - upstream release
  156. - update URL and Source0 tag: valid URL
  157. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  158. - upstream release
  159. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  160. - add Japanese Summary and %%description
  161. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  162. - build VineLinux
  163. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  164. - Updated to 0.23.5.
  165. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  166. - Upgraded to 0.23.2.
  167. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  168. - Upgraded to 0.22.0.
  169. - Fixed compilation from CVS.
  170. - Took out man pages until I can figure out xmlto program.
  171. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  172. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  173. to RedHat 7.3 versions and fixing bug in spec file.
  174. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  175. work.
  176. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  177. - Fixed file ownership problems. Made them owned by root.
  178. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  179. - Updated to neon 0.21.3.
  180. * Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  181. - Updated to neon 0.21.2.
  182. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  183. - Updated to neon 0.21.1.
  184. - Now requires zlib >= 1.1.4.
  185. - Broke into zlib and zlib-devel.
  186. - Now builds shared library.
  187. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  188. - Updated to neon 0.19.4.
  189. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  190. - Updated to neon 0.19.2.
  191. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  192. - Updated to neon 0.18.2.
  193. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  194. - Took out dependency on libxml and w3c-libwww packages.
  195. - Added dependency on expat.
  196. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  197. - Release 0.17.2-1: Updated neon.
  198. * Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  199. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  200. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  201. - Release 2001-10-20: Initial Version.