doxygen-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311
  1. # Set this to "1" if you want to build doxywizard
  2. %define wizard 1
  3. Summary: A documentation system for C/C++.
  4. Summary(ja): C/C++ 向けドキュメンテーションシステム
  5. Name: doxygen
  6. Version: 1.8.6
  7. Release: 2%{?_dist_release}
  8. Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
  9. Patch0: doxygen-1.8.6-config.patch
  10. Patch1: doxygen-1.8.5-html_timestamp_default_false.patch
  11. Patch2: doxygen-1.8.3-multilib.patch
  12. Group: Development/Tools
  13. License: GPLv2
  14. URL: http://www.stack.nl/~dimitri/doxygen/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: perl texlive texlive-collection-fontutils ghostscript gettext
  17. BuildRequires: flex bison
  18. %if %{wizard}
  19. BuildRequires: qt4-devel => 4.4
  20. %endif
  21. %description
  22. Doxygen can generate an online class browser (in HTML) and/or a
  23. reference manual (in LaTeX) from a set of documented source files. The
  24. documentation is extracted directly from the sources. Doxygen can
  25. also be configured to extract the code structure from undocumented
  26. source files.
  27. %package doxywizard
  28. Summary: A GUI for creating and editing configuration files.
  29. Group: Applications/Development
  30. Requires: %{name} = %{version}-%{release}
  31. %description doxywizard
  32. Doxywizard is a GUI for creating and editing configuration files that
  33. are used by doxygen.
  34. %prep
  35. %setup -q -n %{name}-%{version}
  36. %patch0 -p1 -b .config
  37. %patch1 -p1 -b .html_timestamp_default_false
  38. %patch2 -p1 -b .multilib
  39. %build
  40. unset QTDIR
  41. ./configure \
  42. --prefix %{_prefix} \
  43. --shared \
  44. %if %{wizard}
  45. --with-doxywizard \
  46. %endif
  47. --release
  48. make %{?_smp_mflags} all
  49. make docs
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make install DESTDIR=$RPM_BUILD_ROOT
  53. %if %{wizard}
  54. make doxywizard_install DESTDIR=$RPM_BUILD_ROOT
  55. %else
  56. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/doxywizard.*
  57. %endif
  58. # convert into utf-8
  59. iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
  60. touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
  61. mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %files
  65. %defattr(-,root,root)
  66. %doc LANGUAGE.HOWTO LICENSE README.md examples html
  67. %{_bindir}/doxygen
  68. %{_mandir}/man1/doxygen.*
  69. %if %{wizard}
  70. %files doxywizard
  71. %defattr(-,root,root)
  72. %{_bindir}/doxywizard
  73. %{_mandir}/man1/doxywizard.*
  74. %endif
  75. %changelog
  76. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.6-2
  77. - rebuild with gcc-5.4.0
  78. * Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.8.6-1
  79. - new upstream release
  80. * Wed Nov 02 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7.5.1-1
  81. - new upstream release
  82. - updated Patch0 and 1
  83. * Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
  84. - new upstream release
  85. - added Patch0, 1 from Fedora
  86. * Mon Aug 24 2009 Than Ngo <than@redhat.com> - 1.6.0-2
  87. - fix #516339, allow to enable/disable timstamp to avoid the multilib issue
  88. HTMP_TIMESTAMP is disable by default
  89. - enabled doxywizard
  90. * Tue Dec 9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7.1-1
  91. - new upstream release
  92. - disable doxywizard
  93. * Thu May 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-1
  94. - new upstream release
  95. * Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
  96. - new upstream release
  97. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
  98. - new upstream release
  99. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl3
  100. - rebuild with libstdc++34
  101. * Sun Oct 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.7-0vl2
  102. - add BuildRequires: flex
  103. * Fri Sep 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.7-0vl1
  104. - new upstream release
  105. - changed doxygen-doxywizard Group to Applications/Development
  106. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.5-0vl2
  107. - added doxygen-1.4.5-libdir.patch for x86_64 and ppc64 archtecture
  108. * Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.5-0vl1
  109. - new upstream release
  110. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.4-0vl1
  111. - new upstream release
  112. - update Requires
  113. * Wed Jun 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  114. - build for VineSeed
  115. * Wed Jun 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl1
  116. - new upstream release
  117. - build for Vine3.1
  118. - LANG=C when build and install
  119. - add man pages
  120. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
  121. - new upstream release
  122. - BuildPrereq: qt-devel => 3.2
  123. * Tue Dec 7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.9.1-0vl1
  124. - source upgrade
  125. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.7-0vl1
  126. - source upgrade
  127. - remove %%{_bindir}/doxysearch from %%files
  128. - remove about Vine2.6
  129. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl2
  130. - build for VineSeed
  131. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl1
  132. - source upgrade
  133. - add BuildPrereq: graphviz and Requires: graphviz
  134. - change spec to build both VineSeed and Vine2.5/2.6
  135. * Sat May 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
  136. - source upgrade
  137. * Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
  138. - source upgrade
  139. * Wed Jan 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.3
  140. - source upgrade to 1.3-rc3
  141. - enable %%configure --with-doxywizard
  142. * Wed Jan 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.1
  143. - source upgrade to 1.3-rc2
  144. - add BuildPrereq: libpng-devel
  145. - add Requires: XFree86-gl libexpat to %%package doxywizard
  146. - add LICENSE to %%docs
  147. - disable %%configure --with-doxywizard
  148. * Fri Jan 3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.18-0vl1
  149. - source upgrade
  150. - build with new toolchains
  151. - delete Patch2
  152. * Mon Aug 5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.17-0vl1
  153. - source upgrade
  154. - build with qt-3.0.5
  155. * Sun Jun 9 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.16-0vl1
  156. - source update to 1.2.16
  157. * Thu May 09 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.15-0vl1
  158. - source update to 1.2.15
  159. * Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.14-3vl1
  160. - build for VineSeed
  161. - delete Epoch
  162. * Fri Mar 8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.13-3
  163. - rebuild against qt 3.0.2
  164. * Tue Feb 26 2002 Than Ngo <than@redhat.com> 1.2.14-2
  165. - rebuild against qt 2.3.2
  166. * Tue Feb 19 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.14-1
  167. - 1.2.14
  168. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  169. - automated rebuild
  170. * Sun Jan 06 2002 Than Ngo <than@redhat.com> 1.2.13.1-1
  171. - update to 1.2.13.1
  172. - fixed build doxywizard with qt3
  173. * Sun Dec 30 2001 Jeff Johnson <jbj@redhat.com> 1.2.13-1
  174. - update to 1.2.13
  175. * Sun Nov 18 2001 Than Ngo <than@redhat.com> 1.2.12-1
  176. - update to 1.2.12
  177. - s/Copyright/License
  178. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  179. - rebuild with new gcc and binutils
  180. * Wed Jun 13 2001 Than Ngo <than@redhat.com>
  181. - update tp 1.2.8.1
  182. - make doxywizard as separat package
  183. - fix to use install as default
  184. * Tue Jun 05 2001 Than Ngo <than@redhat.com>
  185. - update to 1.2.8
  186. * Tue May 01 2001 Than Ngo <than@redhat.com>
  187. - update to 1.2.7
  188. - clean up specfile
  189. - patch to use RPM_OPT_FLAG
  190. * Wed Mar 14 2001 Jeff Johnson <jbj@redhat.com>
  191. - update to 1.2.6
  192. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  193. - rebuild
  194. * Tue Dec 26 2000 Than Ngo <than@redhat.com>
  195. - update to 1.2.4
  196. - remove excludearch ia64
  197. - bzip2 sources
  198. * Mon Dec 11 2000 Than Ngo <than@redhat.com>
  199. - rebuild with the fixed fileutils
  200. * Mon Oct 30 2000 Jeff Johnson <jbj@redhat.com>
  201. - update to 1.2.3.
  202. * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
  203. - update to 1.2.2.
  204. - enable doxywizard.
  205. * Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
  206. - 1.2.1 is latest stable, so we upgrade before Winston is released.
  207. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  208. - automatic rebuild
  209. * Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
  210. - Rebuild with new C++
  211. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.de>
  212. - fix QTDIR detection
  213. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  214. - compile on x86 w/o optimization, revert when compiler fixed!!
  215. * Wed Jun 07 2000 Preston Brown <pbrown@redhat.com>
  216. - use newer RPM macros
  217. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  218. - add to distro.
  219. * Tue May 9 2000 Tim Powers <timp@redhat.com>
  220. - rebuilt for 7.0
  221. * Wed Feb 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  222. - recompile with current Qt (2.1.0/1.45)
  223. * Wed Jan 5 2000 Jeff Johnson <jbj@redhat.com>
  224. - update to 1.0.0.
  225. - recompile with qt-2.0.1 if available.
  226. - relocatable package.
  227. * Mon Nov 8 1999 Tim Powers <timp@redhat.com>
  228. -updated to 0.49-991106
  229. * Tue Jul 13 1999 Tim Powers <timp@redhat.com>
  230. - updated source
  231. - cleaned up some stuff in the spec file
  232. * Thu Apr 22 1999 Jeff Johnson <jbj@redhat.com>
  233. - Create Power Tools 6.0 package.