gsoap-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443
  1. Summary: Generator Tools for Coding SOAP/XML Web Services in C and C++
  2. Name: gsoap
  3. Version: 2.8.17
  4. Release: 3%{?_dist_release}
  5. # Bump the soversion when the new version is not backward compatiple
  6. %global soversion 5
  7. # gsoap is licensed both under the gSOAP public license and under GPL version
  8. # 2 or later with an OpenSSL linking exception.
  9. #
  10. # The gSOAP public license is a modified version of the Mozilla Public License.
  11. # Due to the modifications, the gSOAP public license is non-free. You can not
  12. # use gsoap under this license for software that you intend to contribute to
  13. # fedora. If you use gsoap in fedora you must use it under the GPL license,
  14. # possibly using the OpenSSL linking exception. The specific modification that
  15. # makes the license non-free is in section 3.2:
  16. #
  17. # 3.2. Availability of Source Code.
  18. # Any Modification created by You will be provided to the Initial Developer in
  19. # Source Code form and are subject to the terms of the License.
  20. License: GPLv2+ with exceptions
  21. Group: Development/Tools
  22. URL: http://gsoap2.sourceforge.net
  23. Source0: http://downloads.sourceforge.net/gsoap2/%{name}_%{version}.zip
  24. Source1: soapcpp2.1
  25. Source2: wsdl2h.1
  26. # Create shared libraries
  27. Patch0: %{name}-libtool.patch
  28. # https://sourceforge.net/p/gsoap2/patches/111/
  29. Patch1: %{name}-private-lm.patch
  30. # https://sourceforge.net/p/gsoap2/patches/110/
  31. Patch2: %{name}-pad.patch
  32. # https://sourceforge.net/p/gsoap2/bugs/966/
  33. Patch3: %{name}-ipv6.patch
  34. # https://sourceforge.net/p/gsoap2/patches/117/
  35. Patch4: %{name}-default-paths.patch
  36. # https://sourceforge.net/p/gsoap2/patches/118/
  37. Patch5: %{name}-cleanfiles.patch
  38. # https://sourceforge.net/p/gsoap2/bugs/959/
  39. Patch6: %{name}-ai-next.patch
  40. # https://sourceforge.net/p/gsoap2/patches/120/
  41. Patch7: %{name}-einprogress.patch
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  43. BuildRequires: flex
  44. BuildRequires: bison
  45. BuildRequires: findutils
  46. BuildRequires: nkf
  47. BuildRequires: openssl-devel
  48. BuildRequires: zlib-devel
  49. BuildRequires: autoconf
  50. BuildRequires: automake
  51. BuildRequires: libtool
  52. Requires: gsoap-libs = %{version}-%{release}
  53. Requires: openssl
  54. %description
  55. The gSOAP Web services development toolkit offers an XML to C/C++
  56. language binding to ease the development of SOAP/XML Web services in C
  57. and C/C++.
  58. %package libs
  59. Summary: Runtime libraries fpr gSOAP
  60. Group: System Environment/Libraries
  61. %description libs
  62. gSOAP runtime libraries.
  63. %package devel
  64. Summary: Devel libraries and headers for linking with gSOAP generated stubs
  65. Group: Development/Libraries
  66. Requires: gsoap-libs = %{version}-%{release}
  67. Requires: openssl-devel
  68. Requires: zlib-devel
  69. Requires: pkgconfig
  70. %description devel
  71. gSOAP libraries, headers and generators for linking with and creating
  72. gSOAP generated stubs
  73. %package doc
  74. Summary: Documentation for gSOAP
  75. Group: Documentation
  76. Requires: %{name} = %{version}-%{release}
  77. BuildArch: noarch
  78. %description doc
  79. gSOAP documentation in html
  80. %prep
  81. %setup -q -n gsoap-2.8
  82. %patch0 -p1
  83. %patch1 -p1
  84. %patch2 -p1
  85. %patch3 -p1
  86. %patch4 -p1
  87. %patch5 -p1
  88. %patch6 -p1
  89. %patch7 -p1
  90. # a number of ~ files are distribute, but we do not want them
  91. find . -name "*~" -exec rm {} \;
  92. # we want all txt files to have unix end-of-line encoding
  93. nkf --unix --in-place README.txt LICENSE.txt NOTES.txt
  94. # remove .DS_Stores
  95. find . -name .DS_Store -exec rm {} ';'
  96. # remove stuff with gsoap license only - not GPL
  97. rm -rf gsoap/extras gsoap/mod_gsoap gsoap/Symbian
  98. sed 's!$(srcdir)/extras/\*!!' -i gsoap/Makefile.am
  99. # remove pre-compiled binaries
  100. rm -rf gsoap/bin
  101. rm -rf gsoap/ios_plugin/examples/*/build
  102. rm gsoap/samples/calc_vs2005/calc_vs2005/soapcpp2.exe
  103. rm gsoap/VisualStudio2005/wsdl2h/wsdl2h/soapcpp2.exe
  104. ( cd gsoap/samples/link++ ; make distclean )
  105. ( cd gsoap/samples/wcf/WS/DualHttp ; make distclean )
  106. %build
  107. # patches change autoconf and automake files, so we must reconfigure
  108. autoreconf --install --force
  109. %configure --disable-static --enable-ipv6
  110. # dependencies are not declared properly
  111. #make %{?_smp_mflags}
  112. make SOVERSION=%{soversion}
  113. %install
  114. rm -rf $RPM_BUILD_ROOT
  115. make install SOVERSION=%{soversion} DESTDIR=$RPM_BUILD_ROOT
  116. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  117. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
  118. install -m 644 -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/%{_mandir}/man1
  119. %clean
  120. rm -rf $RPM_BUILD_ROOT
  121. %check
  122. make check
  123. %post libs -p /sbin/ldconfig
  124. %postun libs -p /sbin/ldconfig
  125. %files
  126. %defattr(-,root,root,-)
  127. %doc README.txt NOTES.txt LICENSE.txt
  128. %{_bindir}/soapcpp2
  129. %{_bindir}/wsdl2h
  130. %dir %{_datadir}/gsoap
  131. %dir %{_datadir}/gsoap/import
  132. %{_datadir}/gsoap/import/c14n.h
  133. %{_datadir}/gsoap/import/dom.h
  134. %{_datadir}/gsoap/import/ds2.h
  135. %{_datadir}/gsoap/import/ds.h
  136. %{_datadir}/gsoap/import/README.txt
  137. %{_datadir}/gsoap/import/soap12.h
  138. %{_datadir}/gsoap/import/stldeque.h
  139. %{_datadir}/gsoap/import/stl.h
  140. %{_datadir}/gsoap/import/stllist.h
  141. %{_datadir}/gsoap/import/stlset.h
  142. %{_datadir}/gsoap/import/stlvector.h
  143. %{_datadir}/gsoap/import/wsa3.h
  144. %{_datadir}/gsoap/import/wsa4.h
  145. %{_datadir}/gsoap/import/wsa5.h
  146. %{_datadir}/gsoap/import/wsa.h
  147. %{_datadir}/gsoap/import/WS-example.c
  148. %{_datadir}/gsoap/import/WS-example.h
  149. %{_datadir}/gsoap/import/WS-Header.h
  150. %{_datadir}/gsoap/import/wsp.h
  151. %{_datadir}/gsoap/import/wsrp.h
  152. %{_datadir}/gsoap/import/wsse2.h
  153. %{_datadir}/gsoap/import/wsse.h
  154. %{_datadir}/gsoap/import/wsu.h
  155. %{_datadir}/gsoap/import/xlink.h
  156. %{_datadir}/gsoap/import/xmime4.h
  157. %{_datadir}/gsoap/import/xmime5.h
  158. %{_datadir}/gsoap/import/xmime.h
  159. %{_datadir}/gsoap/import/xml.h
  160. %{_datadir}/gsoap/import/xmlmime5.h
  161. %{_datadir}/gsoap/import/xmlmime.h
  162. %{_datadir}/gsoap/import/xop.h
  163. %dir %{_datadir}/gsoap/WS
  164. %{_datadir}/gsoap/WS/README.txt
  165. %{_datadir}/gsoap/WS/WS-Addressing.xsd
  166. %{_datadir}/gsoap/WS/WS-Addressing03.xsd
  167. %{_datadir}/gsoap/WS/WS-Addressing04.xsd
  168. %{_datadir}/gsoap/WS/WS-Addressing05.xsd
  169. %{_datadir}/gsoap/WS/WS-Discovery.wsdl
  170. %{_datadir}/gsoap/WS/WS-Enumeration.wsdl
  171. %{_datadir}/gsoap/WS/WS-Policy.xsd
  172. %{_datadir}/gsoap/WS/WS-Routing.xsd
  173. %{_datadir}/gsoap/WS/WS-typemap.dat
  174. %{_datadir}/gsoap/WS/discovery.xsd
  175. %{_datadir}/gsoap/WS/ds.xsd
  176. %{_datadir}/gsoap/WS/enumeration.xsd
  177. %{_datadir}/gsoap/WS/typemap.dat
  178. %{_datadir}/gsoap/WS/wsse.xsd
  179. %{_datadir}/gsoap/WS/wsu.xsd
  180. %dir %{_datadir}/gsoap/custom
  181. %{_datadir}/gsoap/custom/README.txt
  182. %{_datadir}/gsoap/custom/long_double.c
  183. %{_datadir}/gsoap/custom/long_double.h
  184. %{_datadir}/gsoap/custom/struct_timeval.c
  185. %{_datadir}/gsoap/custom/struct_timeval.h
  186. %{_datadir}/gsoap/custom/struct_tm.c
  187. %{_datadir}/gsoap/custom/struct_tm.h
  188. %dir %{_datadir}/gsoap/plugin
  189. %{_datadir}/gsoap/plugin/README.txt
  190. %{_datadir}/gsoap/plugin/cacerts.c
  191. %{_datadir}/gsoap/plugin/cacerts.h
  192. %{_datadir}/gsoap/plugin/httpda.c
  193. %{_datadir}/gsoap/plugin/httpda.h
  194. %{_datadir}/gsoap/plugin/httpdatest.c
  195. %{_datadir}/gsoap/plugin/httpdatest.h
  196. %{_datadir}/gsoap/plugin/httpform.c
  197. %{_datadir}/gsoap/plugin/httpform.h
  198. %{_datadir}/gsoap/plugin/httpget.c
  199. %{_datadir}/gsoap/plugin/httpget.h
  200. %{_datadir}/gsoap/plugin/httpgettest.c
  201. %{_datadir}/gsoap/plugin/httpgettest.h
  202. %{_datadir}/gsoap/plugin/httpmd5.c
  203. %{_datadir}/gsoap/plugin/httpmd5.h
  204. %{_datadir}/gsoap/plugin/httpmd5test.c
  205. %{_datadir}/gsoap/plugin/httpmd5test.h
  206. %{_datadir}/gsoap/plugin/httppost.c
  207. %{_datadir}/gsoap/plugin/httppost.h
  208. %{_datadir}/gsoap/plugin/logging.c
  209. %{_datadir}/gsoap/plugin/logging.h
  210. %{_datadir}/gsoap/plugin/md5evp.c
  211. %{_datadir}/gsoap/plugin/md5evp.h
  212. %{_datadir}/gsoap/plugin/plugin.c
  213. %{_datadir}/gsoap/plugin/plugin.h
  214. %{_datadir}/gsoap/plugin/smdevp.c
  215. %{_datadir}/gsoap/plugin/smdevp.h
  216. %{_datadir}/gsoap/plugin/threads.c
  217. %{_datadir}/gsoap/plugin/threads.h
  218. %{_datadir}/gsoap/plugin/wsaapi.c
  219. %{_datadir}/gsoap/plugin/wsaapi.h
  220. %{_datadir}/gsoap/plugin/wsse2api.c
  221. %{_datadir}/gsoap/plugin/wsse2api.h
  222. %{_datadir}/gsoap/plugin/wsseapi.c
  223. %{_datadir}/gsoap/plugin/wsseapi.h
  224. # Additions in 2.7.12-1
  225. %{_datadir}/gsoap/WS/WS-ReliableMessaging.wsdl
  226. %{_datadir}/gsoap/WS/WS-ReliableMessaging.xsd
  227. %{_datadir}/gsoap/WS/reference-1.1.xsd
  228. %{_datadir}/gsoap/WS/ws-reliability-1.1.xsd
  229. %{_datadir}/gsoap/import/ref.h
  230. %{_datadir}/gsoap/import/wsrm.h
  231. %{_datadir}/gsoap/import/wsrm4.h
  232. %{_datadir}/gsoap/import/wsrx.h
  233. # Additions in 2.7.13-1
  234. %{_datadir}/gsoap/import/stdstring.h
  235. %{_datadir}/gsoap/import/xsd.h
  236. %{_datadir}/gsoap/plugin/wsseapi.cpp
  237. # Additions in 2.7.16-1
  238. %{_datadir}/gsoap/custom/duration.c
  239. %{_datadir}/gsoap/custom/duration.h
  240. %{_datadir}/gsoap/plugin/httpposttest.c
  241. %{_datadir}/gsoap/plugin/httpposttest.h
  242. %{_datadir}/gsoap/plugin/wsrmapi.c
  243. %{_datadir}/gsoap/plugin/wsrmapi.h
  244. # Additions in 2.7.17-1
  245. %{_datadir}/gsoap/WS/WS-Policy12.xsd
  246. %{_datadir}/gsoap/WS/WS-SecurityPolicy.xsd
  247. %{_datadir}/gsoap/import/wsse11.h
  248. # Additions in 2.8.3-1
  249. %{_datadir}/gsoap/WS/xenc.xsd
  250. %{_datadir}/gsoap/import/xenc.h
  251. %{_datadir}/gsoap/plugin/mecevp.c
  252. %{_datadir}/gsoap/plugin/mecevp.h
  253. # Additions in 2.8.4-1
  254. %{_datadir}/gsoap/import/wsdd.h
  255. %{_datadir}/gsoap/import/wsdx.h
  256. %{_datadir}/gsoap/plugin/wsddapi.c
  257. %{_datadir}/gsoap/plugin/wsddapi.h
  258. # Additions in 2.8.7-1
  259. %{_datadir}/gsoap/import/wsdd10.h
  260. # Additions in 2.8.12-1
  261. %{_datadir}/gsoap/WS/WS-SecureConversation.xsd
  262. %{_datadir}/gsoap/WS/WS-Trust.wsdl
  263. %{_datadir}/gsoap/WS/WS-Trust.xsd
  264. %{_datadir}/gsoap/import/ser.h
  265. %{_datadir}/gsoap/import/wsc.h
  266. %{_datadir}/gsoap/import/wsrm5.h
  267. %{_datadir}/gsoap/import/wsrx5.h
  268. %{_datadir}/gsoap/import/wst.h
  269. %{_datadir}/gsoap/import/wstx.h
  270. # Additions in 2.8.16-1
  271. %{_datadir}/gsoap/import/wsc2.h
  272. %{_datadir}/gsoap/plugin/calcrest.h
  273. # Additions in 2.8.17-1
  274. %{_datadir}/gsoap/plugin/mq.c
  275. %{_datadir}/gsoap/plugin/mq.h
  276. %{_mandir}/man1/soapcpp2.1*
  277. %{_mandir}/man1/wsdl2h.1*
  278. %files libs
  279. %defattr(-,root,root,-)
  280. %doc README.txt NOTES.txt LICENSE.txt
  281. %{_libdir}/libgsoap.so.*
  282. %{_libdir}/libgsoap++.so.*
  283. %{_libdir}/libgsoapck.so.*
  284. %{_libdir}/libgsoapck++.so.*
  285. %{_libdir}/libgsoapssl.so.*
  286. %{_libdir}/libgsoapssl++.so.*
  287. %files devel
  288. %doc README.txt NOTES.txt LICENSE.txt
  289. %{_includedir}/stdsoap2.h
  290. %{_libdir}/libgsoap.so
  291. %{_libdir}/libgsoap++.so
  292. %{_libdir}/libgsoapck.so
  293. %{_libdir}/libgsoapck++.so
  294. %{_libdir}/libgsoapssl.so
  295. %{_libdir}/libgsoapssl++.so
  296. %{_libdir}/pkgconfig/gsoapck.pc
  297. %{_libdir}/pkgconfig/gsoapck++.pc
  298. %{_libdir}/pkgconfig/gsoap.pc
  299. %{_libdir}/pkgconfig/gsoap++.pc
  300. %{_libdir}/pkgconfig/gsoapssl.pc
  301. %{_libdir}/pkgconfig/gsoapssl++.pc
  302. %files doc
  303. %doc README.txt NOTES.txt LICENSE.txt gsoap/doc/*
  304. %changelog
  305. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.17-3
  306. - rebuild with gcc-5.4.0
  307. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.17-2
  308. - rebuild with openssl-1.0.2
  309. * Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.8.17-1
  310. - updated to 2.8.17 based on fc
  311. - rebuilt with openssl-1.0.1j
  312. - added BR: zlib-devel
  313. - splitted runtime and documents to subpackage
  314. - moved main package to Development/Tools Group
  315. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.7.12-2
  316. - rebuilt with rpm-4.8.1 for pkg-config
  317. * Sat May 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.12-1
  318. - initial build for Vine Linux
  319. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.12-3
  320. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  321. * Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 2.7.12-2
  322. - rebuild with new openssl
  323. * Wed Dec 24 2008 <matt@redhat> - 2.7.12-1
  324. - Updated to gsoap 2.7.12:
  325. - Numerous bug fixes - xml:lang, maxOccurs="unbounded", SSL, xmlns="", ...
  326. - New features, maintaining backward compatibility - MinGW, wsseapi, multi-endpoint connect, ...
  327. - Patches removed (incorporated upstream):
  328. - datadir_importpath-2.7.10.patch
  329. - install_soapcpp2_wsdl2h_aux-2.7.10.patch
  330. - no_locale.patch as default off, enable by defining WITH_C_LOCALE
  331. - Patches added (sent upstream):
  332. - unused_args.patch - eliminate many unused param warnings
  333. * Thu Feb 21 2008 <mfarrellee@redhat> - 2.7.10-4
  334. - Applied upd patch from upstream. It fixes glibc C locale issues,
  335. hp-ux h_errno definition, and xsd:dateTime timezone processing for
  336. WS-I
  337. - Removed tru64_hp_ux patches, they are present in upstream's upd
  338. patch
  339. - Added no_locale.patch to stop configure from checking for locale
  340. version of functions
  341. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.7.10-3
  342. - Autorebuild for GCC 4.3
  343. * Mon Feb 18 2008 <mfarrellee@redhat> - 2.7.10-2
  344. - Removed --disable-namespaces from configure, result is code compiled
  345. against gsoap does not need to call set_soap_namespaces
  346. * Sun Jan 27 2008 <mfarrellee@redhat> - 2.7.10-1
  347. - Upgraded to 2.7.10 release
  348. - Stopped hosting patches on grid.et.redhat.com
  349. - Removed import_dom_h patch, it was integrated
  350. - Removed large autotools patch, replaced with patch
  351. (use_libtool-2.7.10.patch) changing configure.in, gsoap/Makefile.am
  352. and gsoap/wsdl/Makefile.am, which enable libtool use, and a
  353. call to autoreconf
  354. - Changed soapcpp2 references to gsoap as per new layout of source
  355. distribution
  356. - Updated tru64_hp_up_c/pp patches to handle new source layout
  357. - Install of soapcpp2/import with cp removed in favor of a patch to
  358. gsoap/Makefile.am (install_soapcpp2_wsdl2h_aux-2.7.10.patch)
  359. - No pre-generated Makefiles are distributed, no longer removing them
  360. - stdsoap2_cpp.cpp not in distribution, no longer removing it
  361. - Added datadir_importpath-2.7.10.patch to set SOAPCPP2_IMPORT_PATH
  362. and WSDL2H_IMPORT_PATH, useful defaults, using ${datadir} instead of
  363. `pwd`
  364. - Added autoconf, automake and libtool to BuildRequires, because
  365. configure.in and gsoap/Makefile.am are patched
  366. - Added ?dist to Release
  367. * Fri Nov 30 2007 <mfarrellee@redhat> - 2.7.9-0.4.l
  368. - Added OpenSSL requirement
  369. * Tue Nov 27 2007 <mfarrellee@redhat> - 2.7.9-0.3.l
  370. - Decided soapcpp2/import/ files should be in /usr/share instead of
  371. /usr/include because they are not really headers gcc can
  372. process. Also, this is likely the location new versions of gsoap
  373. will install the import headers. People should use -I
  374. /usr/share/gsoap/import
  375. * Mon Nov 26 2007 <mfarrellee@redhat> - 2.7.9-0.2.l
  376. - Changed license tag to GPLv2+, which is more accurate
  377. - Resolved bz399761 by adding soapcpp2/import/*.h to the -devel
  378. package as /usr/include/gsoap, users will need to add -I
  379. /usr/include/gsoap to their soapcpp2 line
  380. * Sun Sep 30 2007 <mfarrellee@redhat> - 2.7.9-0.1.l
  381. - Updated to 2.7.9l (2.7.9k patches still apply)
  382. - Added patch for import/dom.h missing xsd__anyAttribute definitions
  383. - Removed removal of .deps directories and autom4te.cache
  384. * Mon Sep 24 2007 <mfarrellee@redhat> - 2.7.9-0.2.k
  385. - Moved pkgconfig requirement to -devel package
  386. * Tue Sep 11 2007 <mfarrellee@redhat> - 2.7.9-0.1.k
  387. - Initial release