qoauth-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. %global githash 726325d
  2. %global gitdate 20100625
  3. #global posttag .%{?gitdate}git%{?githash}
  4. %define qt4_ver 4.8.6
  5. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  6. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  7. %define _qt4_bindir %(pkg-config --variable bindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/bin)
  8. %define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
  9. Name: qoauth
  10. Version: 1.0.1
  11. Release: 6%{?_dist_release}
  12. Summary: Qt library OAuth authorization scheme
  13. Summary(ja): OAuth 認証スキームのための Qt ライブラリ
  14. Group: System Environment/Libraries
  15. License: LGPLv2+
  16. URL: http://github.com/ayoy/qoauth
  17. Source0: http://files.ayoy.net/qoauth/release/%{version}/src/%{name}-%{version}-src.tar.bz2
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: qt4-devel qca2-devel doxygen
  20. BuildRequires: qca-ossl
  21. Requires: qca-ossl
  22. %description
  23. QOAuth is a Qt-based C++ implementation of an interface to services using
  24. OAuth authorization scheme.
  25. %package devel
  26. Summary: Development files for the Qt OAuth support library
  27. Summary(ja): Qt OAuth ライブラリの開発用ファイル
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. %description devel
  31. The %{name}-devel package contains libraries, header files and documentations
  32. for developing applications that use QOAuth library.
  33. %prep
  34. %setup -q -n %{name}-%{version}-src
  35. sed -i -e '/^ *docs \\$/d' \
  36. -e "s!\(\$\${INSTALL_PREFIX}\)/lib.*!%{_libdir}!" src/src.pro
  37. sed -i -e 's\/lib\/%{_lib}\g' src/pcfile.sh
  38. %build
  39. export PATH=%{_qt4_bindir}:$PATH
  40. qmake PREFIX="%{_prefix}"
  41. make %{?_smp_mflags}
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. make install INSTALL="install -p" INSTALL_ROOT=$RPM_BUILD_ROOT
  45. doxygen Doxyfile
  46. # fix the time stamp
  47. for file in doc/html/*; do
  48. touch -r Doxyfile $file
  49. done
  50. %check
  51. make check || :
  52. %clean
  53. rm -rf $RPM_BUILD_ROOT
  54. %post -p /sbin/ldconfig
  55. %postun -p /sbin/ldconfig
  56. %files
  57. %defattr(-,root,root,-)
  58. %doc README CHANGELOG LICENSE
  59. %{_libdir}/*.so.*
  60. %files devel
  61. %defattr(-,root,root,-)
  62. %doc doc/html doc/examples
  63. %{_libdir}/*.so
  64. %{_libdir}/*.prl
  65. %{_libdir}/pkgconfig/*.pc
  66. %{_qt4_datadir}/mkspecs/features/*.prf
  67. %{_includedir}/*
  68. %changelog
  69. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-6
  70. - rebuild with gcc-5.4.0
  71. * Mon Feb 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.1-5
  72. - rebuilt on current VineSeed
  73. - added Japanese summary
  74. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  75. - rebuilt with qt-4.8.0
  76. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-3
  77. - rebuilt with qt4-4.7.2
  78. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-2
  79. - Initial build for Vine Linux
  80. * Sun Aug 08 2010 Chen Lei <supercyper@163.com> - 1.0.1-1
  81. - Update to 1.0.1
  82. * Fri Jun 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.3.20100625git726325d
  83. - New upstream version
  84. * Tue Jun 22 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.2.20100622git7f69e33
  85. - New upstream version
  86. - Add %%check section
  87. * Tue May 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.1.20100525gitec7e4d5
  88. - initial rpm build