xorg-x11-drv-synaptics-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %define tarball xf86-input-synaptics
  2. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  3. %define driverdir %{moduledir}/input
  4. Name: xorg-x11-drv-synaptics
  5. Summary: Xorg X11 synaptics input driver
  6. Summary(ja): Xorg X11 synaptics 入力ドライバ
  7. Version: 1.2.1
  8. Release: 2%{?_dist_release}
  9. URL: http://www.x.org
  10. License: MIT
  11. Group: User Interface/X Hardware Support
  12. Source0: ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. ExcludeArch: s390 s390x
  15. BuildRequires: libtool, pkgconfig
  16. BuildRequires: xorg-x11-server-sdk >= 1.6.0
  17. BuildRequires: libX11-devel, libXi-devel, libXext-devel
  18. BuildRequires: xorg-x11-util-macros >= 1.3.0
  19. Requires: xorg-x11-server-Xorg
  20. Requires: hal
  21. Provides: synaptics = %{version}-%{release}
  22. Obsoletes: synaptics < 0.15.0
  23. %description
  24. This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
  25. default operates in compatibility mode by emulating a standard mouse. However,
  26. by using a dedicated driver, more advanced features of the touchpad becomes
  27. available.
  28. Features:
  29. * Movement with adjustable, non-linear acceleration and speed.
  30. * Button events through short touching of the touchpad.
  31. * Double-Button events through double short touching of the touchpad.
  32. * Dragging through short touching and holding down the finger on the
  33. touchpad.
  34. * Middle and right button events on the upper and lower corner of the
  35. touchpad.
  36. * Vertical scrolling (button four and five events) through moving the
  37. finger on the right side of the touchpad.
  38. * The up/down button sends button four/five events.
  39. * Horizontal scrolling (button six and seven events) through moving the
  40. finger on the lower side of the touchpad.
  41. * The multi-buttons send button four/five events, and six/seven events for
  42. horizontal scrolling.
  43. * Adjustable finger detection.
  44. Multifinger taps: two finger for middle button and three finger for
  45. right button events. (Needs hardware support. Not all models implement
  46. this feature.)
  47. * Run-time configuration using shared memory. This means you can change
  48. parameter settings without restarting the X server.
  49. %description -l ja
  50. Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
  51. パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
  52. しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
  53. ます。
  54. 機能:
  55. * スピードと加速の調整が可能。
  56. * タッチパッドに短く触れたらクリック。
  57. * タッチパッドに2度短く触れたらダブルクリック。
  58. * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
  59. * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
  60. * タッチパッドの右端を上下になぞる事で縦スクロール。
  61. (ボタン4及びボタン5として動作)
  62. * 上下ボタンをボタン4及びボタン5として動作。
  63. * タッチパッドの下端を左右になぞることで横スクロール。
  64. (ボタン6及びボタン7として動作)
  65. * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
  66. * 感度の調整が可能。
  67. * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
  68. (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
  69. * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
  70. 設定を変更することができる。
  71. %prep
  72. %setup -q -n %{tarball}-%{version}
  73. %build
  74. autoreconf -v --install --force || exit 1
  75. %configure --disable-static
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. # FIXME: Remove all libtool archives (*.la) from modules directory. This
  81. # should be fixed in upstream Makefile.am or whatever.
  82. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  83. install -d $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor
  84. install -m644 fdi/11-x11-synaptics.fdi $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files
  88. %defattr(-,root,root,-)
  89. %doc COPYING README
  90. %{_datadir}/hal/fdi/policy/10osvendor/*
  91. %{driverdir}/synaptics_drv.so
  92. %{_bindir}/synclient
  93. %{_bindir}/syndaemon
  94. %{_mandir}/man4/synaptics.4*
  95. %{_mandir}/man1/synclient.1*
  96. %{_mandir}/man1/syndaemon.1*
  97. %{_includedir}/xorg/synaptics-properties.h
  98. %{_includedir}/xorg/synaptics.h
  99. %{_libdir}/pkgconfig/xorg-synaptics.pc
  100. %changelog
  101. * Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
  102. - rebuild with xserver-1.8rc
  103. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  104. - new upstream release
  105. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  106. - new upstream release
  107. - add BR: xorg-x11-util-macros >= 1.3.0
  108. * Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
  109. - new upstream release
  110. - remove Patch10: SHMconfig is not needed
  111. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  112. - new upstream release
  113. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
  114. - new upstream release
  115. * Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
  116. - new upstream release
  117. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
  118. - use bundled fdi
  119. - add patch10 to enable SHMConfig on all synaptics devices.
  120. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
  121. - new upstream release
  122. * Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
  123. - new upstream version released from x.org
  124. - rename to xorg-x11-drv-synaptics
  125. - add Obsoletes/Provides synaptics
  126. - add patch1,2 from fedora
  127. - patch1: reserve 5% on each side for edge detection.
  128. - patch2: force a click if middle button emulation times out during ReadInput cycle.
  129. * Tue Jul 8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
  130. - fixed synaptics_drv.so path by using %%{_libdir}
  131. * Sun Jul 6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
  132. - add Patch0; add BuildRequires: libpciaccess-devel
  133. - built with xorg-x11-server-1.4.99.905
  134. * Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
  135. - updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
  136. - built with xorg-x11
  137. - spec encoding converted to UTF-8
  138. * Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
  139. - source update.
  140. - build for VineSeed (4.0) Plus.
  141. * Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
  142. - build for Vine Plus/3.0.
  143. * Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
  144. - source update.
  145. - build for VineSeed Plus.
  146. * Sat Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
  147. - add man page synaptics.5.
  148. - build for VineSeed Plus.
  149. * Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
  150. - build for Vine Plus/3.0.
  151. * Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
  152. - source update.
  153. - build for VineSeed Plus.
  154. * Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
  155. - build for Vine Plus/3.0.
  156. * Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
  157. - initial build for VineSeed Plus.