nsd-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. Summary: Fast and lean authoritative DNS Name Server
  2. Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
  3. Name: nsd
  4. Version: 4.1.15
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Url: http://www.nlnetlabs.nl/%{name}/
  8. Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
  9. Source1: nsd.init
  10. Source3: nsd.sysconfig
  11. Patch0: nsd-4.1.10-config.patch
  12. Group: System Environment/Daemons
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. BuildRequires: flex, libevent-devel, openssl-devel
  17. Requires(pre): shadow-utils
  18. %description
  19. NSD is a complete implementation of an authoritative DNS name server.
  20. For further information about what NSD is and what NSD is not please
  21. consult the REQUIREMENTS document which is a part of this distribution
  22. %description -l ja
  23. NSD は Authoritative DNSネームサーバの完全な実装です。
  24. NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
  25. %prep
  26. %setup -q
  27. %patch0 -p1
  28. %build
  29. %configure \
  30. --with-configdir=%{_sysconfdir}/nsd \
  31. --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
  32. --with-zonesdir=%{_sysconfdir}/nsd \
  33. --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
  34. --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db \
  35. --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
  36. --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
  37. --with-max-ips=1024 \
  38. --with-ssl \
  39. --with-user=nsd \
  40. --enable-bind8-stats \
  41. --enable-checking \
  42. --enable-mmap \
  43. --enable-nsec3 \
  44. --enable-ratelimit
  45. %{__make} %{?_smp_mflags}
  46. #convert to utf8
  47. iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
  48. iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
  49. mv -f doc/RELNOTES.utf8 doc/RELNOTES
  50. mv -f doc/CREDITS.utf8 doc/CREDITS
  51. %install
  52. rm -rf %{buildroot}
  53. %{__make} DESTDIR=%{buildroot} install
  54. install -d -m 0755 %{buildroot}%{_initrddir}
  55. install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
  56. install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
  57. install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
  58. install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
  59. install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  60. # change .sample to normal config files
  61. mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  62. %clean
  63. rm -rf ${RPM_BUILD_ROOT}
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc doc/*
  67. %doc contrib/nsd.zones2nsd.conf
  68. %dir %{_sysconfdir}/nsd/
  69. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
  70. #%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
  71. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
  72. %attr(0755,root,root) %{_initrddir}/%{name}
  73. %ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
  74. %attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
  75. %{_sbindir}/*
  76. %{_mandir}/*/*
  77. %pre
  78. getent group nsd >/dev/null || groupadd -r nsd
  79. getent passwd nsd >/dev/null || \
  80. useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
  81. -c "nsd daemon account" nsd
  82. exit 0
  83. %post
  84. /sbin/chkconfig --add %{name}
  85. chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
  86. chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
  87. if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
  88. /usr/sbin/nsd-control-setup
  89. fi
  90. %preun
  91. if [ $1 -eq 0 ]; then
  92. /sbin/service %{name} stop
  93. /sbin/chkconfig --del %{name}
  94. fi
  95. %postun
  96. if [ "$1" -ge "1" ]; then
  97. /sbin/service %{name} condrestart
  98. fi
  99. %changelog
  100. * Wed Mar 8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
  101. - new upstream release.
  102. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
  103. - new upstream release.
  104. * Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
  105. - new upstream release.
  106. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
  107. - rebuilt with openssl-1.0.2g.
  108. * Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
  109. - new upstream release.
  110. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
  111. - new upstream release.
  112. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
  113. - new upstream release.
  114. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
  115. - new upstream release.
  116. - dropped Source2 (no longer needed).
  117. * Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
  118. - new upstream release
  119. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
  120. - new upstream release
  121. * Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
  122. - new upstream release
  123. * Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
  124. - new upstream release
  125. * Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
  126. - initial build for Vine Linux
  127. * Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
  128. - Updated to nsd 3.2.4
  129. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
  130. - Incorporated Ville Mattila's fixes to nsd.cron
  131. - Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
  132. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
  133. - rebuilt with new openssl
  134. * Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
  135. - The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
  136. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
  137. -Updated to version 3.2.3
  138. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  140. * Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
  141. - Fixed /dev/nul which cause a file \%%1 to be written by cron
  142. - Bump for EVR.
  143. * Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
  144. - Upgraded to 3.2.2 security release
  145. http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
  146. * Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
  147. - Make various file paths used by the nsd.init script configurable
  148. from /etc/sysconfig/nsd.
  149. - Add template /etc/sysconfig/nsd.
  150. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
  151. - nsd used the 'named' subsystem in one call in the init script
  152. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  154. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
  155. - Fix init script 'unary operator' error.
  156. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
  157. - Updated to new version 3.2.1
  158. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
  159. - rebuild with new openssl
  160. * Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
  161. - Updates summary as per Richard Hughes guidelines
  162. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
  163. - Bump version after pre-release version correction.
  164. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
  165. - 3.2.0-1
  166. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
  167. - updated to 3.1.1
  168. * Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
  169. - fix license tag
  170. - fix static user creation
  171. * Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
  172. - Updated to 3.1.0
  173. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
  174. - Fix /dev/null redirection [Venkatesh Krishnamurthi]
  175. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
  176. - Updated to 3.0.8
  177. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
  178. - Autorebuild for GCC 4.3
  179. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
  180. - Rebuild for new libcrypto
  181. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
  182. - Updated to new version
  183. - fix RELNOTES/README to be utf8
  184. - Fix path to nsd.db in cron job.
  185. * Thu Nov 8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
  186. - Modified cron to only rebuild/reload when zone updates
  187. have been received
  188. * Wed Nov 7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
  189. - Added hourly cron job to do various maintenance tasks
  190. - Added nsd rebuild to create the proper nsd.db file on startup
  191. - Added nsd patch on shutdown to ensure zonefiles are up to date
  192. * Tue Oct 2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
  193. - nsdc update and nsdc notify are no longer needed in initscript.
  194. * Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
  195. - Bump release for upgrade path.
  196. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
  197. - Do not include examples from nsd.conf.sample that causes
  198. bogus network traffic.
  199. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
  200. - Change locations of ixfr.db and xfrd.state to /var/lib/nsd
  201. - Enable NSEC3
  202. - Delay running nsdc update until after nsd has started
  203. - Delete xfrd.state on nsd stop
  204. - Run nsdc notify in the background, since it can take
  205. a very long time when remote servers are unavailable.
  206. * Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
  207. - Upgraded to 3.0.6
  208. - Do not include bind2nsd, since it didn't compile for me
  209. * Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
  210. - Fix init script, bug #245546
  211. * Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
  212. - Upgraded to 3.0.5
  213. * Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
  214. - Upgraded to 3.0.3
  215. * Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
  216. - Upgraded to 3.0.2.
  217. - Use new configuration file nsd.conf. Still needs migration script.
  218. patch from Farkas Levente <lfarkas@bppiac.hu>
  219. * Mon Oct 16 2006 Paul Wouters <paul@xelerance.com> 2.3.6-2
  220. - Bump version for upgrade path
  221. * Thu Oct 12 2006 Paul Wouters <paul@xelerance.com> 2.3.6-1
  222. - Upgraded to 2.3.6
  223. - Removed obsolete workaround in nsd.init
  224. - Fixed spec file so daemon gets properly restarted on upgrade
  225. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
  226. - Rebuild requested for PT_GNU_HASH support from gcc
  227. - Removed dbaccess.c from doc section
  228. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
  229. - Bump version for FC-x upgrade path
  230. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
  231. - Upgraded to nsd-2.3.5
  232. * Sun May 7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
  233. - Upgraded to nsd-2.3.4.
  234. - Removed manual install targets because DESTDIR is now supported
  235. - Re-enabled --checking, checking patch no longer needed and removed.
  236. - Work around in nsd.init for nsd failing to start when there is no ipv6
  237. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
  238. - chkconfig and attribute changes as proposed by Dmitry Butskoy
  239. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
  240. - Moved pid file to /var/run/nsd/nsd.pid.
  241. - Use _localstatedir instead of "/var"
  242. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
  243. - Added BuildRequires for openssl-devel, removed Requires for openssl.
  244. * Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
  245. - upgraded to nsd-2.3.3
  246. * Wed Dec 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
  247. - minor cleanups
  248. * Mon Dec 5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
  249. - Upgraded to 2.3.2. Changed post scripts to comply to Fedora
  250. Extras policies (eg do not start daemon on fresh install)
  251. * Tue Oct 4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
  252. - Initial version