sablotron-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. %define name sablotron
  2. %define version 1.0.3
  3. %define release 2%{?_dist_release}
  4. %define altname Sablot
  5. %define builddir $RPM_BUILD_DIR/%{altname}-%{version}
  6. %define lib_name_orig libsablotron
  7. %define lib_major 0
  8. %define lib_name %{lib_name_orig}%{lib_major}
  9. Summary: XSLT processor
  10. Summary(ja): XSLT プロセッサ
  11. Name: %{name}
  12. Version: %{version}
  13. Release: %{release}
  14. License: MPL/GPL
  15. Group: Applications/Text
  16. #URL: http://www.gingerall.cz
  17. #Source: http://www.gingerall.com:/perl/rd?url=sablot/%{altname}-%{version}.tar.gz
  18. #Source0: http://download-1.gingerall.cz/download/sablot/%{altname}-%{version}.tar.gz
  19. URL: http://sourceforge.net/projects/sablotron/
  20. Source0: %{url}/files/sablotron-%{version}/Sablot-%{version}.tar.gz
  21. Patch: sablot-lib-0.71.patch.bz2
  22. Requires: expat >= 1.95.2
  23. Requires: %{lib_name}
  24. BuildRequires: expat-devel >= 1.95.2
  25. BuildRequires: perl-XML-Parser
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. %description
  28. Sablotron is a fast, compact and portable XML toolkit
  29. implementing XSLT, DOM and XPath.
  30. The goal of this project is to create a lightweight,
  31. reliable and fast XML library processor conforming to the W3C
  32. specification, which is available for public and can be used as a base
  33. for multi-platform XML applications.
  34. %package -n %{lib_name}
  35. Summary: Main library for sablotron
  36. Summary(ja): sablotron ライブラリ
  37. Group: System Environment/Libraries
  38. Provides: %{name} = %{version}-%{release}
  39. %description -n %{lib_name}
  40. Contains the library for sablotron.
  41. %package -n %{lib_name}-devel
  42. Summary: The development libraries and header files for Sablotron
  43. Summary(ja): Sablotron の開発ライブラリおよびヘッダファイル
  44. Requires: sablotron = %{version}
  45. Group: Development/Libraries
  46. Requires: %{lib_name} = %{version}
  47. Provides: %{lib_name_orig}-devel = %{version}-%{release}
  48. %description -n %{lib_name}-devel
  49. These are the development libraries and header files for Sablotron
  50. %prep
  51. %setup -q -n %{altname}-%{version}
  52. #%patch
  53. %build
  54. export CXXFLAGS="${RPM_OPT_FLAGS}"
  55. ./configure --prefix=%{_prefix}
  56. make
  57. %install
  58. %makeinstall prefix=$RPM_BUILD_ROOT/%{_prefix}
  59. ## remove unuse files
  60. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  61. %files
  62. %defattr(755,root,root)
  63. %{_bindir}/sabcmd
  64. %{_mandir}/man1/sabcmd.*
  65. %files -n %{lib_name}
  66. %defattr(-,root,root)
  67. %{_libdir}/libsablot.so.*
  68. %doc README RELEASE
  69. %files -n %{lib_name}-devel
  70. %defattr(-,root,root)
  71. %{_bindir}/sablot-config
  72. %{_libdir}/lib*.a
  73. #%{_libdir}/lib*.la
  74. %{_libdir}/lib*.so
  75. %{_includedir}/*.h
  76. %clean
  77. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  78. %post -n %{lib_name} -p /sbin/ldconfig
  79. %postun -n %{lib_name} -p /sbin/ldconfig
  80. %changelog
  81. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.3-2
  82. - rebuilt with new toolchain
  83. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
  84. - applied new versioning policy, spec in utf-8
  85. - removed *.la
  86. * Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl2
  87. - rebuild with expat-2.0.1
  88. * Sun Jan 6 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-0vl1
  89. - updated Sablot to 1.0.3
  90. - dropt sablot-lib-0.71.patch.bz2
  91. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl5
  92. - rebuilt with new toolchain
  93. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl4
  94. - changed Group to Applications/Text
  95. * Sat Mar 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl3
  96. - added Japanese summary
  97. - changed Group:
  98. * Sat Jan 25 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.97-0vl2
  99. - added BuildRequires: perl-XML-Parser
  100. * Thu Jan 21 2003 Satoshi MACHINO <machino@vinelinux.org> 0.97-0vl1
  101. - new upstream version
  102. * Thu May 16 2002 Satoshi MACHINO <machino@vinelinux.org> 0.90-1vl1
  103. - build on Vine Linux
  104. -- modified spec
  105. * Wed Apr 03 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.90-1mdk
  106. - release 0.90.
  107. - patch to add -lexpat and -lstdc++ in libsablot.so (required for php4)
  108. * Mon Feb 04 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.82-1mdk
  109. - release 0.82.
  110. * Wed Jan 16 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.81-1mdk
  111. - release 0.81.
  112. - Removed patch for 0.80.
  113. * Tue Jan 15 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.80-1mdk
  114. - release 0.80.
  115. * Wed Nov 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.71-1mdk
  116. - release 0.71.
  117. - bzip2 the source.
  118. - remove the patch.
  119. * Tue Nov 06 2001 Philippe Libat <philippe@mandrakesoft.com> 0.70-2mdk
  120. - %macros
  121. - move sabcmd in sablotron rpm
  122. * Mon Nov 05 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.70-1mdk
  123. - first mdk release.
  124. * Tue Sep 18 2001 Petr Cimprich <petr@gingerall.cz>
  125. - sablotron 0.70 RPM release 1
  126. * Wed Aug 15 2001 Petr Cimprich <petr@gingerall.cz>
  127. - sablotron 0.65 RPM release 1
  128. * Thu Jun 14 2001 Petr Cimprich <petr@gingerall.cz>
  129. - sablotron 0.60 RPM release 1
  130. - build under RedHat 7.1 with rpm 4.0.2
  131. * Wed Apr 22 2001 Petr Cimprich <petr@gingerall.cz>
  132. - sablotron 0.52 RPM release 1
  133. - based on 0.51-5 spec by Henri Gomez
  134. * Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
  135. - sablotron 0.51 RPM release 5
  136. - apply patch to add -lexpat and -lstdc++ in libsablot.so
  137. REQUIRED for use with PHP4
  138. * Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
  139. - sablotron 0.51 RPM release 4
  140. - follow Redhat way to dispatch between pack and pack-devel
  141. * Tue Feb 20 2001 Henri Gomez <hgomez@slib.fr>
  142. - sablotron 0.51 RPM release 3
  143. - added ldconfig is post/preun and cleanup stuff
  144. - build under Redhat 6.2 + updates with rpm 3.0.5
  145. * Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
  146. - sablotron 0.51 RPM release 2
  147. - added Requires expat >= 1.95.1
  148. * Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
  149. - sablotron 0.51 RPM release 1
  150. - updated spec file