cups-filters-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465
  1. # we build CUPS also with relro
  2. %global _hardened_build 1
  3. Summary: OpenPrinting CUPS filters and backends
  4. Name: cups-filters
  5. Version: 1.0.76
  6. Release: 2%{?_dist_release}
  7. # For a breakdown of the licensing, see COPYING file
  8. # GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
  9. # imagetopdf, pstopdf, texttopdf
  10. # backends: parallel, serial
  11. # GPLv2+: filters: gstopxl, textonly, texttops, imagetops
  12. # GPLv3: filters: bannertopdf
  13. # GPLv3+: filters: urftopdf
  14. # LGPLv2+: utils: cups-browsed
  15. # MIT: filters: gstoraster, pdftoijs, pdftoopvp, pdftopdf, pdftoraster
  16. License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT
  17. Group: System Environment/Base
  18. Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
  19. Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
  20. #Patch1: cups-filters-pdf-landscape.patch
  21. Patch2: cups-filters-dbus.patch
  22. #Patch3: cups-filters-memory-leaks.patch
  23. #Patch4: cups-filters-filter-costs.patch
  24. Requires: cups
  25. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  26. # Obsolete cups-php (bug #971741)
  27. Obsoletes: cups-php < 1:1.6.0-1
  28. # Don't Provide it because we don't build the php module
  29. #Provides: cups-php = 1:1.6.0-1
  30. BuildRequires: cups-devel
  31. # pdftopdf
  32. BuildRequires: qpdf-devel
  33. # pdftops
  34. BuildRequires: poppler-utils
  35. # pdftoijs, pdftoopvp, pdftoraster, gstoraster
  36. BuildRequires: poppler-devel
  37. BuildRequires: libjpeg-devel
  38. BuildRequires: libpng-devel
  39. BuildRequires: libtiff-devel
  40. BuildRequires: zlib-devel
  41. BuildRequires: pkgconfig dbus-devel
  42. # libijs
  43. BuildRequires: ghostscript-devel
  44. BuildRequires: freetype2-devel
  45. BuildRequires: fontconfig-devel
  46. BuildRequires: lcms2-devel
  47. # cups-browsed
  48. BuildRequires: avahi-devel avahi-glib-devel
  49. # Make sure we get postscriptdriver tags.
  50. BuildRequires: python-cups
  51. # Testing font for test scripts.
  52. BuildRequires: TrueType-dejavu
  53. # autogen.sh
  54. BuildRequires: autoconf
  55. BuildRequires: automake
  56. BuildRequires: libtool
  57. Requires: poppler-utils
  58. # pstopdf
  59. Requires: bc grep sed
  60. # cups-browsed
  61. #Requires(post): systemd
  62. #Requires(preun): systemd
  63. #Requires(postun): systemd
  64. # Ghostscript CUPS filters live here since Ghostscript 9.08.
  65. Provides: ghostscript-cups = 9.08
  66. Obsoletes: ghostscript-cups < 9.08
  67. Vendor: Project Vine
  68. Distribution: Vine Linux
  69. Packager: tomop
  70. %package libs
  71. Summary: OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries
  72. Group: System Environment/Libraries
  73. # LGPLv2: libcupsfilters
  74. # MIT: libfontembed
  75. License: LGPLv2 and MIT
  76. %package devel
  77. Summary: OpenPrinting CUPS filters and backends - development environment
  78. Group: Development/Libraries
  79. License: LGPLv2 and MIT
  80. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  81. %description
  82. Contains backends, filters, and other software that was
  83. once part of the core CUPS distribution but is no longer maintained by
  84. Apple Inc. In addition it contains additional filters developed
  85. independently of Apple, especially filters for the PDF-centric printing
  86. workflow introduced by OpenPrinting.
  87. %description libs
  88. This package provides cupsfilters and fontembed libraries.
  89. %description devel
  90. This is the development package for OpenPrinting CUPS filters and backends.
  91. %prep
  92. %setup -q
  93. # Fix PDF landscape printing (bug #768811).
  94. #%patch1 -p1 -b .pdf-landscape
  95. # Include dbus so that colord support works (bug #1026928).
  96. %patch2 -p1 -b .dbus
  97. # Fix memory leaks in cups-browsed (bug #1027317).
  98. #%patch3 -p1 -b .memory-leaks
  99. # Adjust filter costs so application/vnd.adobe-read-postscript input
  100. # doesn't go via pstotiff (bug #1008166).
  101. #%patch4 -p1 -b .filter-costs
  102. %build
  103. # work-around Rpath
  104. ./autogen.sh
  105. # --with-pdftops=hybrid - use Poppler's pdftops instead of Ghostscript for
  106. # Brother, Minolta, and Konica Minolta to work around
  107. # bugs in the printer's PS interpreters
  108. # --with-rcdir=no - don't install SysV init script
  109. export IJS_CFLAGS="-I/usr/include/ijs"
  110. export IJS_LIBS="-lijs"
  111. %configure --disable-static \
  112. --disable-silent-rules \
  113. --with-pdftops=hybrid \
  114. --enable-dbus \
  115. --with-rcdir=%{_sysconfdir} \
  116. --with-test-font-path=/usr/share/fonts/TrueType-dejavu/DejaVuSans.ttf
  117. make %{?_smp_mflags}
  118. %install
  119. make install DESTDIR=%{buildroot}
  120. # https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
  121. mkdir __doc
  122. mv %{buildroot}%{_datadir}/doc/cups-filters/* __doc
  123. rm -rf %{buildroot}%{_datadir}/doc/cups-filters
  124. # Don't ship libtool la files.
  125. rm -f %{buildroot}%{_libdir}/lib*.la
  126. # Not sure what is this good for.
  127. rm -f %{buildroot}%{_bindir}/ttfread
  128. # systemd unit file
  129. #mkdir -p %{buildroot}%{_unitdir}
  130. #install -p -m 644 utils/cups-browsed.service %{buildroot}%{_unitdir}
  131. # SysV initscripts
  132. rm -rf %{buildroot}%{_sysconfdir}/rc{0,2,3,5}.d
  133. rm -rf %{buildroot}%{_sysconfdir}/rc.d
  134. mkdir -p %{buildroot}%{_sysconfdir}/rc.d
  135. mv -f %{buildroot}%{_sysconfdir}/init.d %{buildroot}%{_sysconfdir}/rc.d/
  136. %check
  137. make check
  138. %post
  139. #%systemd_post cups-browsed.service
  140. # Initial installation
  141. if [ $1 -eq 1 ] ; then
  142. IN=%{_sysconfdir}/cups/cupsd.conf
  143. OUT=%{_sysconfdir}/cups/cups-browsed.conf
  144. keyword=BrowsePoll
  145. # We can remove this after few releases, it's just for the introduction of cups-browsed.
  146. if [ -f "$OUT" ]; then
  147. echo -e "\n# NOTE: This file is not part of CUPS. You need to start & enable cups-browsed service." >> "$OUT"
  148. fi
  149. # move BrowsePoll from cupsd.conf to cups-browsed.conf
  150. if [ -f "$IN" ] && grep -iq ^$keyword "$IN"; then
  151. if ! grep -iq ^$keyword "$OUT"; then
  152. (cat >> "$OUT" <<EOF
  153. # Settings automatically moved from cupsd.conf by RPM package:
  154. EOF
  155. ) || :
  156. (grep -i ^$keyword "$IN" >> "$OUT") || :
  157. #systemctl enable cups-browsed.service >/dev/null 2>&1 || :
  158. fi
  159. sed -i -e "s,^$keyword,#$keyword directive moved to cups-browsed.conf\n#$keyword,i" "$IN" || :
  160. fi
  161. fi
  162. %preun
  163. #%systemd_preun cups-browsed.service
  164. %postun
  165. #%systemd_postun_with_restart cups-browsed.service
  166. %post libs
  167. /sbin/ldconfig
  168. %postun libs
  169. /sbin/ldconfig
  170. %files
  171. %doc __doc/README __doc/AUTHORS __doc/NEWS
  172. %config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
  173. %config(noreplace) %{_sysconfdir}/fonts/conf.d/99pdftoopvp.conf
  174. %{_bindir}/foomatic-rip
  175. %attr(0755,root,root) %{_cups_serverbin}/filter/*
  176. %exclude %{_cups_serverbin}/filter/pdftoraster
  177. %exclude %{_cups_serverbin}/filter/textonly
  178. %attr(0755,root,root) %{_cups_serverbin}/backend/implicitclass
  179. %attr(0755,root,root) %{_cups_serverbin}/backend/parallel
  180. # Serial backend needs to run as root (bug #212577#c4).
  181. %attr(0700,root,root) %{_cups_serverbin}/backend/serial
  182. %{_datadir}/cups/banners
  183. %{_datadir}/cups/charsets
  184. %{_datadir}/cups/data/*
  185. # this needs to be in the main package because of cupsfilters.drv
  186. %{_datadir}/cups/ppdc/pcl.h
  187. %{_datadir}/cups/drv/cupsfilters.drv
  188. %{_datadir}/cups/mime/cupsfilters.types
  189. %{_datadir}/cups/mime/cupsfilters.convs
  190. %{_datadir}/ppd/cupsfilters
  191. %{_sbindir}/cups-browsed
  192. #%{_unitdir}/cups-browsed.service
  193. %{_initdir}/cups-browsed
  194. %{_mandir}/man1/foomatic-rip.1.gz
  195. %{_mandir}/man8/cups-browsed.8.gz
  196. %{_mandir}/man5/cups-browsed.conf.5.gz
  197. %files libs
  198. %doc __doc/COPYING fontembed/README
  199. %{_libdir}/libcupsfilters.so.*
  200. %{_libdir}/libfontembed.so.*
  201. %files devel
  202. %{_includedir}/cupsfilters
  203. %{_includedir}/fontembed
  204. %{_datadir}/cups/ppdc/escp.h
  205. %{_libdir}/pkgconfig/libcupsfilters.pc
  206. %{_libdir}/pkgconfig/libfontembed.pc
  207. %{_libdir}/libcupsfilters.so
  208. %{_libdir}/libfontembed.so
  209. %changelog
  210. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-2
  211. - rebuild with poppler-0.37.0
  212. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.76-1
  213. - new upstream release.
  214. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.54-2
  215. - rebuild with poppler-0.26.2
  216. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.54-1
  217. - new upstream release.
  218. * Fri May 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.53-1
  219. - update to 1.0.53
  220. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.43-1
  221. - new upstream release.
  222. - initial build for Vine Linux.
  223. * Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
  224. - Adjust filter costs so application/vnd.adobe-read-postscript input
  225. doesn't go via pstotiff (bug #1008166).
  226. * Thu Nov 14 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.41-3
  227. - Fix memory leaks in cups-browsed (bug #1027317).
  228. * Wed Nov 6 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-2
  229. - Include dbus so that colord support works (bug #1026928).
  230. * Wed Oct 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-1
  231. - 1.0.41 - PPD-less printing support
  232. * Mon Oct 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-4
  233. - Fix socket leaks in the BrowsePoll code (bug #1021512).
  234. * Wed Oct 16 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-3
  235. - Ship the gstoraster MIME conversion rule now we provide that filter
  236. (bug #1019261).
  237. * Fri Oct 11 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-2
  238. - Fix PDF landscape printing (bug #768811).
  239. * Fri Oct 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.40-1
  240. - 1.0.40
  241. - Use new "hybrid" pdftops renderer.
  242. * Thu Oct 03 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.39-1
  243. - 1.0.39
  244. - Removed obsolete patches "pdf-landscape" and "browsepoll-notifications"
  245. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-4
  246. - Use IPP notifications for BrowsePoll when possible (bug #975241).
  247. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-3
  248. - Fixes for some printf-type format mismatches (bug #1014093).
  249. * Tue Sep 17 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-2
  250. - Fix landscape printing for PDFs (bug #768811).
  251. * Wed Sep 04 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.38-1
  252. - 1.0.38
  253. * Thu Aug 29 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.37-1
  254. - 1.0.37.
  255. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-5
  256. - Added build dependency - font required for running tests
  257. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-4
  258. - Added checking phase (make check)
  259. * Wed Aug 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-3
  260. - Upstream patch to re-work filter costs (bug #998977). No longer need
  261. text filter costs patch as paps gets used by default now if
  262. installed.
  263. * Mon Aug 19 2013 Marek Kasik <mkasik@redhat.com> - 1.0.36-2
  264. - Rebuild (poppler-0.24.0)
  265. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-1
  266. - 1.0.36.
  267. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-7
  268. - Upstream patch to move in filters from ghostscript.
  269. * Tue Jul 30 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-6
  270. - Set cost for text filters to 200 so that the paps filter gets
  271. preference for the time being (bug #988909).
  272. * Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-5
  273. - Handle page-label when printing n-up as well.
  274. * Tue Jul 23 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-4
  275. - Added support for page-label (bug #987515).
  276. * Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-3
  277. - Rebuild (qpdf-5.0.0)
  278. * Mon Jul 01 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-2
  279. - add cups-browsed(8) and cups-browsed.conf(5)
  280. - don't reverse lookup IP address in URI (#975822)
  281. * Wed Jun 26 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-1
  282. - 1.0.35
  283. * Mon Jun 24 2013 Marek Kasik <mkasik@redhat.com> - 1.0.34-9
  284. - Rebuild (poppler-0.22.5)
  285. * Wed Jun 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-8
  286. - fix the note we add in cups-browsed.conf
  287. * Wed Jun 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-7
  288. - Obsolete cups-php (#971741)
  289. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-6
  290. - one more cups-browsed leak fixed (#959682)
  291. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-5
  292. - perl is actually not required by pstopdf, because the calling is in dead code
  293. * Mon Jun 03 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-4
  294. - fix resource leaks and other problems found by Coverity & Valgrind (#959682)
  295. * Wed May 15 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-3
  296. - ship ppdc/pcl.h because of cupsfilters.drv
  297. * Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-2
  298. - pstopdf requires bc (#960315)
  299. * Thu Apr 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-1
  300. - 1.0.34
  301. * Fri Apr 05 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.33-1
  302. - 1.0.33
  303. - removed cups-filters-1.0.32-null-info.patch, accepted by upstream
  304. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-2
  305. - fixed segfault when info is NULL
  306. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-1
  307. - 1.0.32
  308. * Fri Mar 29 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-3
  309. - add note to cups-browsed.conf
  310. * Thu Mar 28 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-2
  311. - check cupsd.conf existence prior to grepping it (#928816)
  312. * Fri Mar 22 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-1
  313. - 1.0.31
  314. * Tue Mar 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-4
  315. - revert previous change
  316. * Wed Mar 13 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-3
  317. - don't ship banners for now (#919489)
  318. * Tue Mar 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-2
  319. - move BrowsePoll from cupsd.conf to cups-browsed.conf in %%post
  320. * Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-1
  321. - 1.0.30: CUPS browsing and broadcasting in cups-browsed
  322. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
  323. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  324. * Sat Jan 19 2013 Rex Dieter <rdieter@fedoraproject.org> 1.0.29-3
  325. - backport upstream buildfix for poppler-0.22.x
  326. * Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 1.0.29-2
  327. - rebuild due to "jpeg8-ABI" feature drop
  328. * Thu Jan 03 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.29-1
  329. - 1.0.29
  330. * Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.28-1
  331. - 1.0.28: cups-browsed daemon and service
  332. * Thu Nov 29 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.25-1
  333. - 1.0.25
  334. * Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.24-1
  335. - 1.0.24
  336. * Wed Aug 22 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.23-1
  337. - 1.0.23: old pdftopdf removed
  338. * Tue Aug 21 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.22-1
  339. - 1.0.22: new pdftopdf (uses qpdf instead of poppler)
  340. * Wed Aug 08 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-4
  341. - rebuild
  342. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-3
  343. - commented multiple licensing breakdown (#832130)
  344. - verbose build output
  345. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-2
  346. - BuildRequires: poppler-cpp-devel (to build against poppler-0.20)
  347. * Mon Jul 23 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-1
  348. - 1.0.20
  349. * Tue Jul 17 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.19-1
  350. - 1.0.19
  351. * Wed May 30 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.18-1
  352. - initial spec file