arts-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490
  1. %define beta 0
  2. %define alsa 1
  3. %define run_test 0
  4. %define make_cvs 1
  5. Name: arts
  6. Summary: aRts (analog realtime synthesizer) - the KDE 3 sound system
  7. Summary(ja): aRts - KDE 3 サウンドシステム
  8. Epoch: 1
  9. Version: 1.5.10
  10. %if %{beta}
  11. Release: 0.%{beta}%{?_dist_release}
  12. %else
  13. Release: 3%{?_dist_release}
  14. %endif
  15. License: LGPLv2
  16. URL: http://www.kde.org
  17. Group: System Environment/Daemons
  18. %if %{beta}
  19. Source: ftp://ftp.kde.org/pub/kde/unstable/%{version}-%{beta}/src/%{name}-%{version}-%{beta}.tar.bz2
  20. %else
  21. Source: ftp://ftp.kde.org/pub/kde/stable/3.5.10/src/%{name}-%{version}.tar.bz2
  22. %endif
  23. Patch1: arts-1.1.4-debug.patch
  24. Patch2: arts-1.3.92-glib2.patch
  25. Patch5: arts-1.3.1-alsa.patch
  26. Patch6: arts-1.5.8-glibc.patch
  27. Patch7: arts-1.5.0-check_tmp_dir.patch
  28. Patch8: arts-1.5.2-multilib.patch
  29. # don't pop up a dialog on CPU overload (#361891)
  30. Patch9: arts-1.5.10-cpu-overload-quiet.patch
  31. # kde#93359
  32. Patch50: arts-1.5.4-dlopenext.patch
  33. Patch51: kde-3.5-libtool-shlibext.patch
  34. # upstream patches
  35. # security patches
  36. # CVE-2009-3736 libtool: libltdl may load and execute code from a library in the current directory
  37. Patch200: libltdl-CVE-2009-3736.patch
  38. # tweak autoconfigury so that it builds with autoconf 2.64 or 2.65
  39. Patch300: arts-acinclude.patch
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  41. BuildRequires: gcc-c++ libjpeg-devel
  42. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  43. BuildRequires: libmng-devel zlib-devel audiofile-devel
  44. BuildRequires: qt-devel >= 3.3.2, libpng-devel >= 1.2.5
  45. BuildRequires: libogg-devel libvorbis-devel glib2-devel
  46. BuildRequires: esound-devel jack-audio-connection-kit-devel
  47. BuildRequires: pkgconfig
  48. %if %{alsa}
  49. BuildRequires: alsa-lib-devel
  50. %endif
  51. %if %{run_test}
  52. BuildRequires: kdelibs3
  53. %endif
  54. # We don't want to require X11, Qt or glib2, arts is perfectly usable without
  55. # them, they're just used by addons the qtmcop, gmcop and x11globalcomm addons
  56. AutoReq: off
  57. #Requires: XFree86-gl XFree86-libs freetype2 libjpeg libmng libpng zlib
  58. #Requires: audiofile glibc
  59. Obsoletes: kdelibs-sound
  60. Provides: kdelibs-sound
  61. %description
  62. arts (analog real-time synthesizer) is the sound system of KDE 3.
  63. The principle of arts is to create/process sound using small modules which do
  64. certain tasks. These may be create a waveform (oscillators), play samples,
  65. filter data, add signals, perform effects like delay/flanger/chorus, or
  66. output the data to the soundcard.
  67. By connecting all those small modules together, you can perform complex
  68. tasks like simulating a mixer, generating an instrument or things like
  69. playing a wave file with some effects.
  70. %package devel
  71. Summary: Development files for the aRts sound server
  72. Summary(ja): aRts サウンドサーバの開発用ファイル
  73. Group: Development/Libraries
  74. Requires: %{name} = %{epoch}:%{version}-%{release}
  75. Requires: glib2-devel
  76. Obsoletes: kdelibs-sound-devel
  77. Provides: kdelibs-sound-devel
  78. %description devel
  79. arts (analog real-time synthesizer) is the sound system of KDE 3.
  80. The principle of arts is to create/process sound using small modules which do
  81. certain tasks. These may be create a waveform (oscillators), play samples,
  82. filter data, add signals, perform effects like delay/flanger/chorus, or
  83. output the data to the soundcard.
  84. By connecting all those small modules together, you can perform complex
  85. tasks like simulating a mixer, generating an instrument or things like
  86. playing a wave file with some effects.
  87. Install arts-devel if you intend to write applications using arts (such as
  88. KDE applications using sound).
  89. %prep
  90. %setup -q
  91. %patch1 -p1 -b .debug
  92. %patch2 -p1 -b .glib
  93. %patch5 -p1 -b .alsa
  94. %patch6 -p1 -b .glibc
  95. %patch7 -p1 -b .check_tmp_dir
  96. %patch8 -p1 -b .multilib
  97. %patch9 -p1 -b .cpu-overload-quiet
  98. %patch50 -p1 -b .dlopenext
  99. %patch51 -p1 -b .libtool-shlibext
  100. %patch200 -p1 -b .CVE-2009-3736
  101. %patch300 -p1 -b .acinclude
  102. %build
  103. %if %{make_cvs}
  104. # hack/fix for newer automake
  105. sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
  106. make -f admin/Makefile.common cvs
  107. %endif
  108. unset QTDIR || : ; . /etc/profile.d/qt.sh
  109. %configure \
  110. --includedir=%{_includedir}/kde \
  111. --with-qt-libraries=$QTDIR/lib \
  112. --disable-rpath \
  113. --disable-debug --disable-warnings \
  114. --disable-dependency-tracking \
  115. --enable-new-ldflags \
  116. --disable-libmad \
  117. %if %{alsa}
  118. --with-alsa \
  119. %endif
  120. --enable-final
  121. make %{?_smp_mflags}
  122. %if %{run_test}
  123. make check
  124. %endif
  125. %install
  126. rm -rf $RPM_BUILD_ROOT
  127. export PATH=`pwd`:$PATH
  128. make DESTDIR=$RPM_BUILD_ROOT install
  129. ## remove references to optional external libraries in .la files (#178733)
  130. find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
  131. sed -i \
  132. -e "s|-lmad||g" \
  133. -e "s|%{_libdir}/libmad.la||g" \
  134. -e "s|-lvorbisfile||g" \
  135. -e "s|-lvorbisenc||g" \
  136. -e "s|-lvorbis||g" \
  137. -e "s|-logg||g" \
  138. -e "s|-lasound||g" \
  139. -e "s|-laudiofile||g" \
  140. -e "s|-lesd||g" \
  141. -e "s|%{_libdir}/libesd.la||g" \
  142. -e "s|-lgmodule-2.0||g" \
  143. -e "s|-lgthread-2.0||g" \
  144. -e "s|-lglib-2.0||g" \
  145. -e "s|-laudio ||g" \
  146. -e "s|-lpng -lz ||g" \
  147. -e "s|%{_libdir}/libartsc.la||g" \
  148. -e "s@-lboost_filesystem@@g" \
  149. -e "s@-lboost_regex@@g" \
  150. -e "s@-ljack@@g"
  151. #rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
  152. #chmod a+x $RPM_BUILD_ROOT%{_libdir}/*
  153. %clean
  154. rm -rf $RPM_BUILD_ROOT
  155. %post -p /sbin/ldconfig
  156. %postun -p /sbin/ldconfig
  157. %files
  158. %defattr(-,root,root)
  159. %doc COPYING.LIB
  160. %dir %{_libdir}/mcop
  161. %dir %{_libdir}/mcop/Arts
  162. %{_bindir}/arts*
  163. %exclude %{_bindir}/artsc-config
  164. %{_libdir}/mcop/Arts/*
  165. %{_libdir}/mcop/*.mcopclass
  166. %{_libdir}/mcop/*.mcoptype
  167. %{_libdir}/lib*.so.*
  168. %{_libdir}/lib*.la
  169. %files devel
  170. %defattr(-,root,root)
  171. %{_bindir}/artsc-config
  172. %{_bindir}/mcopidl
  173. %{_includedir}/kde/arts
  174. %{_includedir}/kde/artsc
  175. %{_libdir}/lib*.so
  176. %{_libdir}/pkgconfig/artsc.pc
  177. %changelog
  178. * Sat Mar 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-3
  179. - rebuilt with new toolchain
  180. - added Patch9, 200 and 300 from FC
  181. * Wed Dec 16 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.5.10-11
  182. - don't pop up a dialog on CPU overload (#361891)
  183. * Thu Dec 10 2009 Stepan Kasal <skasal@redhat.com> - 1.5.10-10
  184. - patch autoconfigury to build with autoconf >= 2.64
  185. * Sun Dec 06 2009 Than Ngo <than@redhat.com> - 1.5.10-9
  186. - fix url
  187. - fix security issues in libltdl (CVE-2009-3736)
  188. - added Japanese summary
  189. - fixed duplicated entry at last changelog
  190. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-2
  191. - added Patch1,2,5,8,50 and 51 from Fedora
  192. - added lib*.la files again...
  193. * Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-1
  194. - updated to 1.5.10
  195. - added BuildRequires: jack-audio-connection-kit-devel
  196. - removed static library
  197. * Sun Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.8-1vl5
  198. - applied new versioning policy
  199. - updated build dependancies
  200. * Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl2
  201. - rebuild for VineSeed
  202. * Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl1
  203. - new upstream release
  204. * Mon Jun 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl2
  205. - rebuild for VineSeed
  206. * Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl1
  207. - new upstream release
  208. * Wed Jan 17 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-0vl1
  209. - new upstream release
  210. * Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl5
  211. - rebuild for VineSeed
  212. * Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl4
  213. - add Patch0 [VineLinux:0369]
  214. * Sat Oct 14 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.5-0vl3
  215. - added --with-qt-libraries option
  216. - removed --libdir=%%{_libdir} option
  217. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl2
  218. - rebuild for VineSeed
  219. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
  220. - new upstream release
  221. * Mon Aug 7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl2
  222. - rebuild for VineSeed
  223. * Mon Aug 7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl1
  224. - new upstream release
  225. - drop Patch0
  226. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.3-0vl5
  227. - added --libdir=%%{_libdir} to ./configure option
  228. * Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl4
  229. - rebuild for VineSeed
  230. * Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl3
  231. - add Patch0 (CVE-2006-2916)
  232. * Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl2
  233. - rebuild for VineSeed
  234. * Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl1
  235. - new upstream release
  236. * Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
  237. - rebuild for VineSeed
  238. * Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
  239. - new upstream release
  240. * Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
  241. - rebuild for VineSeed
  242. * Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
  243. - new upstream release
  244. * Mon Dec 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-0vl3
  245. - add "%%{epoch}:" to Requires in arts-devel
  246. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
  247. - rebuild for VineSeed
  248. * Mon Nov 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
  249. - new upstream release
  250. * Fri Nov 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
  251. - new upstream release
  252. * Thu Oct 13 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.92-0vl1
  253. - new upstream release
  254. * Mon Sep 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.91-0vl1
  255. - new upstream release
  256. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
  257. - rebuild for VineSeed
  258. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
  259. - new upstream release
  260. * Mon Jun 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
  261. - add alsa support for VineSeed
  262. - add --disable-rpath to configure option
  263. * Mon Jun 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
  264. - new upstream release
  265. - use %%{?_smp_mflags} for make option
  266. - add BuildPrereq: esound-devel libmad-devel
  267. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl2
  268. - rebuild for VineSeed
  269. * Thu Mar 10 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl1
  270. - new upstream release
  271. * Tue Mar 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl0.rc1
  272. - new upstream release (1.4.0-rc1)
  273. * Mon Feb 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.92-0vl1
  274. - new upstream release
  275. * Tue Jan 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
  276. - new upstream release
  277. * Sun Dec 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl2
  278. - rebuild for VineSeed
  279. * Wed Dec 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
  280. - source upgrade
  281. * Tue Oct 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
  282. - source upgrade
  283. - refine %%files
  284. * Sun Sep 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.0-0vl1
  285. - source upgrade
  286. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl2
  287. - rebuild with qt32
  288. * Fri Jun 4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl1
  289. - source upgrade
  290. - remove lines about vine26
  291. - BuildPrereq: XOrg-devel XOrg-gl-devel
  292. * Fri Apr 30 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.2-0vl1
  293. - source upgrade
  294. * Thu Mar 4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
  295. - source upgrade
  296. * Sun Feb 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
  297. - source upgrade
  298. - add Requires: glib2 to arts-devel package
  299. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl2
  300. - rebuild for VineSeedPlus
  301. * Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl1
  302. - source upgrade
  303. - build for VinePlus/2.6
  304. - (VinePlus/2.6) BuildPrereq: autoconf258
  305. * Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl3
  306. - build for VineSeed with new toolchain and qt-3.2.3
  307. - add BuildPrereq: gcc-c++ gcc-g77 glib2-devel pkgconfig
  308. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0.26vl2
  309. - rebuild with qt-3.2.1-0.26vl3
  310. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl2
  311. - rebuild with qt-3.2.1-0vl3
  312. * Tue Sep 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl1
  313. - source upgrade
  314. - build with gcc-3.2.3
  315. * Thu Jul 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl1
  316. - source upgrade
  317. * Sun Jun 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl3
  318. - change spec to build with gcc295
  319. - change make option for SMP and add script
  320. * Wed Jun 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
  321. - build with gcc295
  322. - add KDEDIR and QTDIR
  323. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl1
  324. - source upgrade
  325. * Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl3
  326. - rebuilt with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
  327. * Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl2
  328. - rebuild with qt-3.1.2-0vl2
  329. * Sat Mar 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl1
  330. - source upgrade
  331. * Mon Feb 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
  332. - rebuild with qt-3.1.1-0vl3
  333. * Tue Feb 11 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
  334. - change spec to build both VineSeed and Vine2.5/2.6
  335. * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
  336. - OOPS! rebuild with spec that changed 1.1-0vl0.2
  337. * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
  338. - source upgrade to kde-3.1-stable
  339. * Wed Jan 22 2003 Tomoya TAKA <taka@vinelinux.org> 1.1-0vl0.2
  340. - add '-fPIC' to FLAGS on alpha
  341. * Wed Jan 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl0.1
  342. - source upgrade to kde-3.1-rc6
  343. - stop using objprelink2, it does not work with gcc3
  344. * Tue Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
  345. - objprelink2 support only i386 (add %ifarch i386 ... again)
  346. -
  347. * Thu Oct 10 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
  348. - source upgrade
  349. * Tue Oct 8 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl4
  350. - rebuild with qt-3.0.5-0vl1
  351. - BuildPrereq: qt-devel >= 3.0.5 autoconf253 objprelink2
  352. * Thu Aug 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl3
  353. - add BuildPrereq: libogg-devel libvorbis-devel
  354. * Wed Jul 10 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl2
  355. - rebuild
  356. * Mon Jul 8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
  357. - source upgrade
  358. * Thu Jul 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.2-0vl1
  359. - source upgrade
  360. * Fri Jun 7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.1-0vl1
  361. - source upgrade to 1.0.1
  362. - add BuildPrereq: objprelink for i386
  363. * Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl2
  364. - add configure option `--with-xinerama'
  365. - add `Requires: %%{name} = %%{version}-%%{release}' for arts-devel
  366. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl1
  367. - source upgrade to 1.0.0
  368. * Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.9.9-1vl1
  369. - source update to cvs-20020329
  370. - build for VineSeed
  371. - merged with 3.0-0.cvs20020313.1
  372. - Epoch: 1
  373. - add BuildPrereq: autoconf252 automake15
  374. * Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020313.1
  375. - Build with autoconf 2.53, automake 1.5
  376. * Thu Feb 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020114.1
  377. - initial package