empathy-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425
  1. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  3. ## respectively.
  4. %global gtk2_min_version 2.14
  5. %global glib2_min_version 2.18.0
  6. %global tp_mc_min_version 5.3.2
  7. %global tp_glib_min_version 0.7.35
  8. #global enchant_version 1.4.0
  9. %global aspell_version 0.50
  10. %global libcanberra_version 0.4
  11. %global gnome_keyring_version 2.22
  12. %global libnotify_version 0.4.4
  13. Summary: GNOME Instant Messaging Client
  14. Summary(ja): GNOME インスタントメッセージクラアイント
  15. Name: empathy
  16. Version: 2.28.2
  17. Release: 1%{?_dist_release}
  18. Group: Applications/Communications
  19. License: GPLv2+
  20. URL: http://live.gnome.org/Empathy
  21. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
  22. Source1: %{name}-README.ConnectionManagers
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. #BuildRequires: enchant-devel >= %{enchant_version}
  25. BuildRequires: aspell-devel >= %{aspell_version}
  26. BuildRequires: iso-codes
  27. BuildRequires: desktop-file-utils
  28. BuildRequires: evolution-data-server-devel
  29. BuildRequires: GConf2-devel
  30. BuildRequires: gettext
  31. BuildRequires: glib2-devel >= %{glib2_min_version}
  32. BuildRequires: gnome-doc-utils >= 0.17.3
  33. BuildRequires: gnome-panel
  34. BuildRequires: gtk2-devel >= %{gtk2_min_version}
  35. BuildRequires: intltool
  36. BuildRequires: libxml2-devel
  37. BuildRequires: perl(XML::Parser)
  38. BuildRequires: pygtk2-devel
  39. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  40. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  41. BuildRequires: farsight2-devel
  42. BuildRequires: telepathy-farsight-devel
  43. BuildRequires: libcanberra-devel >= %{libcanberra_version}
  44. BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
  45. BuildRequires: unique-devel
  46. BuildRequires: libnotify-devel >= %{libnotify_version}
  47. BuildRequires: libtelepathy-devel
  48. BuildRequires: libgnomecanvas-devel
  49. BuildRequires: libbonoboui-devel
  50. BuildRequires: python-devel
  51. Requires: %{name}-libs = %{version}-%{release}
  52. Requires: telepathy-filesystem
  53. ## Empathy is useless without a proper Telepathy connection manager installed.
  54. ## We hardcode dependencies on Salut and Gabble to support XMPP on a default
  55. ## install, in both the link-local and Jabber/GoogleTalk incarnations.
  56. ## (RHBZ: 308871 and 334221)
  57. ## TODO: Perhaps we can configure these to be installed "on demand" with
  58. ## PackageKit and friends?
  59. Requires: telepathy-gabble
  60. Requires: telepathy-salut
  61. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  62. ## and I'd hate for people to simply disregard it for lack of the "out of the
  63. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  64. BuildRequires: telepathy-haze
  65. # Require this for VOIP support
  66. Requires: telepathy-stream-engine
  67. Requires(pre): GConf2
  68. Requires(post): GConf2
  69. Requires(post): scrollkeeper
  70. Requires(preun): GConf2
  71. Requires(postun): scrollkeeper
  72. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  73. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  74. Provides: telepathy-haze-mission-control = 0.2.0-3
  75. %description
  76. Empathy provides a powerful multiple protocol instant messaging
  77. client using the Telepathy framework.
  78. %package devel
  79. Summary: Development files for %{name}
  80. Summary(ja): Development files for %{name}
  81. Group: Development/Libraries
  82. Requires: %{name}-libs = %{version}-%{release}
  83. Requires: pkgconfig
  84. ## Needs these for the various #include directives in its headers, as well
  85. ## as pkgconfig dependencies...
  86. Requires: glib2-devel
  87. Requires: telepathy-glib-devel
  88. Requires: telepathy-mission-control-devel
  89. Requires: libxml2-devel
  90. %description devel
  91. The %{name}-devel package contains libraries and header files for
  92. developing applications that use %{name}.
  93. %package libs
  94. Summary: Shared libraries for %{name}
  95. Summary(ja): Shared libraries for %{name}
  96. Group: Development/Libraries
  97. Requires: glib2
  98. Requires: gtk2
  99. Requires: telepathy-glib
  100. Requires: telepathy-mission-control
  101. %description libs
  102. The %{name}-libs package contains shared libraries used by Empathy.
  103. %package python
  104. Summary: Python bindings for libempathy and libempathy-gtk
  105. Summary(ja): Python bindings for libempathy and libempathy-gtk
  106. Group: Development/Languages
  107. Requires: %{name}-libs = %{version}-%{release}
  108. %description python
  109. This package contains the empathy and empathygtk Python modules, which provide
  110. bindings to the libempathy and libempathy-gtk libraries, respectively.
  111. %prep
  112. %setup -q
  113. %build
  114. ## GCC complains about some unused functions, so we forcibly show those as
  115. ## simple warnings instead of build-halting errors.
  116. %configure --with-compile-warnings=yes --disable-static
  117. ## RPATHs are yucky.
  118. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  119. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  120. ##make %{?_smp_mflags}
  121. ## don't use _smp_mflags at empathy-2.18.1
  122. make
  123. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  124. %install
  125. rm -rf $RPM_BUILD_ROOT
  126. make install DESTDIR=$RPM_BUILD_ROOT
  127. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  128. %find_lang %{name}
  129. desktop-file-install --vendor "" --delete-original \
  130. --dir %{buildroot}%{_datadir}/applications \
  131. %{buildroot}%{_datadir}/applications/%{name}.desktop
  132. %clean
  133. rm -rf %{buildroot}
  134. %pre
  135. if [ "$1" -gt 1 ]; then
  136. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  137. gconftool-2 --makefile-uninstall-rule \
  138. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas \
  139. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  140. fi
  141. %post
  142. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  143. gconftool-2 --makefile-install-rule \
  144. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas \
  145. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  146. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  147. touch --no-create %{_datadir}/icons/hicolor ||:
  148. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  149. %post libs -p /sbin/ldconfig
  150. %preun
  151. if [ "$1" -eq 0 ]; then
  152. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  153. gconftool-2 --makefile-uninstall-rule \
  154. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas \
  155. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  156. fi
  157. %postun
  158. scrollkeeper-update -q || :
  159. touch --no-create %{_datadir}/icons/hicolor || :
  160. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  161. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  162. fi
  163. %postun libs -p /sbin/ldconfig
  164. %files -f %{name}.lang
  165. %defattr(-,root,root,-)
  166. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  167. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  168. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas
  169. %{_bindir}/empathy
  170. %{_bindir}/empathy-logs
  171. %{_datadir}/dbus-1/services/*
  172. %{_datadir}/empathy
  173. %{_datadir}/applications/*.desktop
  174. %{_datadir}/gnome/help/%{name}/
  175. #{_datadir}/omf/%{name}/
  176. %{_datadir}/icons/hicolor/*/apps/%{name}*
  177. #{_datadir}/mission-control/profiles/*.profile
  178. %{_datadir}/telepathy/clients/Empathy.client
  179. %{_libexecdir}/megaphone-applet
  180. %{_libexecdir}/nothere-applet
  181. %{_libdir}/bonobo/servers/GNOME_Megaphone_Applet.server
  182. %{_libdir}/bonobo/servers/GNOME_NotHere_Applet.server
  183. %{_mandir}/man1/empathy*.1.gz
  184. %files libs
  185. %defattr(-,root,root,-)
  186. %{_libdir}/libempathy*.so.*
  187. %files devel
  188. %defattr(-,root,root,-)
  189. %{_includedir}/libempathy*/
  190. %{_libdir}/libempathy*.so
  191. %{_libdir}/pkgconfig/libempathy*.pc
  192. %{_datadir}/gtk-doc/html/libempathy*
  193. %files python
  194. %defattr(-,root,root,-)
  195. %{python_sitearch}/empathy*.so
  196. %changelog
  197. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  198. - new upstream release
  199. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  200. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  201. - rebuilt with python-2.6.4
  202. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  203. - unuse %%{?_smp_mflags} option to make
  204. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  205. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  206. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  207. - new upstream release
  208. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  209. - new upstream release
  210. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  211. - initial build for Vine Linux
  212. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  213. - Update to 2.23.92
  214. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  215. - Update to 2.23.91
  216. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  217. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  218. on telepathy-haze to keep the same protocol functionality across upgrades,
  219. for a much improved "out of the box" experience.
  220. - Reference: bug 458935.
  221. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  222. - Update to new upstream release (2.23.90)
  223. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  224. - Apply patch from Colin Walters to automagically update profile namings for
  225. the switch to using Empathy's provided profiles.
  226. - Drop the upgrade script (no longer needed since it's automatically done).
  227. - upgrade-haze-profiles.sh
  228. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  229. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  230. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  231. horribly stale...). This makes for better automagic functionality (if Haze is
  232. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  233. + upgrade-haze-profiles.sh
  234. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  235. - Update to new upstream release (2.23.6)
  236. - Use the in-tarball libtool scripts instead of the system copy to workaround
  237. 'make install' errors.
  238. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  239. - Update to 0.23.4.
  240. - Update source url.
  241. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  242. - Update to 0.23.3.
  243. - Remove reference to stream-engine in connections managers readme.
  244. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  245. - Update to 0.23.2.
  246. - Add man pages.
  247. - Use enchant-devel, instead of aspell-devel.
  248. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  249. - Rebuild for new e-d-s.
  250. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  251. - Drop multiple copies of COPYING file.
  252. - Drop BR on gnome-vfs2-devel.
  253. - Require telepathy-stream-engine for VOIP support.
  254. - Add BR on iso-codes-devel, so spell-checking is enabled.
  255. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  256. - Update to new upstream release (0.23.1)
  257. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  258. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  259. - Update to new upstream release (0.22.1)
  260. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  261. - Update to new upstream release (0.22.0)
  262. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  263. - Update to new upstream release (0.21.91)
  264. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  265. - Update to new upstream release (0.21.90)
  266. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  267. - Autorebuild for GCC 4.3
  268. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  269. - Update to new upstream release (0.21.4)
  270. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  271. - Update to new upstream release (0.21.2)
  272. - Drop backported drag-and-drop patch (fixed upstream):
  273. - svn380-fix-contact-DnD.patch
  274. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  275. note (a feed-only connection manager isn't useful for instant messaging),
  276. and fix some wording.
  277. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  278. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  279. contact from the buddy list to the current conversation window to initiate a
  280. conversation:
  281. + svn380-fix-contact-DnD.patch
  282. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  283. dragged a contact ...)
  284. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  285. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  286. is essentially useless due to the need to install an external connection
  287. manager. Also, add a README.ConnectionManagers to the installed
  288. documentation which lists other possibilities.
  289. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  290. and bug 334221 (Default empathy install is useless).
  291. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  292. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  293. only). Though it is functional, it is still deemed rather unstable by
  294. upstream. Use it at your own risk. :)
  295. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  296. - Disable VoIP support at this time, since it is deemed unstable by upstream
  297. for now. (Thanks to Brian Pepple for the notice.)
  298. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  299. - Update to new upstream release (0.14).
  300. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  301. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  302. and python bindings.
  303. - Split shared libraries into a libs subpackage for easier handling
  304. in multi-lib environments.
  305. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  306. - Add ldconfig invocations to %%post and %%postun scriptlets.
  307. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  308. - Update to new upstream release (0.12).
  309. - Build against new mission-control stack.
  310. - Update License tag (GPLv2+).
  311. - Alphabetize BuildRequires list (aesthetic-only change).
  312. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  313. - Rebuild for selinux ppc32 issue.
  314. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  315. - Update to new upstream release (0.11)
  316. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  317. - bump to 0.8
  318. - Now with aspell support (deat to teh speeling mistaks)
  319. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  320. - bump to 0.7
  321. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  322. - Add telepathy-filesystem to Requires
  323. - Move .desktop from autostart to applications
  324. - Nasty hackery to make empathy launch from the menu
  325. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  326. - Add gettext to BuildRequires
  327. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  328. - Bump to 0.6
  329. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  330. - Let Empathy own the directory and not just the files in it
  331. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  332. - Initial package