WebKit-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with libsoup : use libsoup for HTTP backend instead of cURL (default: no)
  13. %bcond_with libsoup
  14. # --with svg : experimental svg support (default: no)
  15. %bcond_with svg
  16. # --with wml: Build support for WML
  17. %bcond_with wml
  18. Name: WebKit
  19. Version: 1.1.18
  20. Release: 1%{?_dist_release}
  21. Summary: Web content engine library
  22. Summary(ja): ウェブコンテンツエンジンライブラリ
  23. Group: Development/Libraries
  24. License: LGPLv2+ and BSD
  25. URL: http://webkitgtk.org/
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: yasumichi
  29. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  31. BuildRequires: bison
  32. BuildRequires: flex
  33. BuildRequires: gperf
  34. BuildRequires: gtk2-devel
  35. BuildRequires: libicu-devel
  36. BuildRequires: libjpeg-devel
  37. BuildRequires: libtool
  38. BuildRequires: libxslt-devel
  39. BuildRequires: libXt-devel
  40. BuildRequires: pcre-devel
  41. BuildRequires: sqlite-devel
  42. BuildRequires: geoclue-devel
  43. BuildRequires: gnome-keyring-devel
  44. BuildRequires: gstreamer-devel
  45. BuildRequires: gstreamer-plugins-base-devel
  46. BuildRequires: enchant-devel
  47. %if %{with pango}
  48. BuildRequires: pango-devel
  49. %else
  50. BuildRequires: cairo-devel
  51. BuildRequires: fontconfig-devel
  52. BuildRequires: freetype-devel
  53. %endif
  54. %if %{with libsoup}
  55. BuildRequires: libsoup-devel >= 2.23
  56. %else
  57. BuildRequires: curl-devel
  58. %endif
  59. %description
  60. WebKit is an open source web browser engine.
  61. %package gtk
  62. Summary: GTK+ port of WebKit
  63. Summary(ja): WebKit の GTK+ ポート
  64. Group: Development/Libraries
  65. %description gtk
  66. %{name} is an open-source Web content engine library. This package contains
  67. the shared libraries for the WebKit GTK+ port as well as the sample
  68. GtkLauncher tool.
  69. %package gtk-devel
  70. Summary: Development package for %{name}
  71. Summary(ja): %{name} の開発パッケージ
  72. Group: Development/Libraries
  73. Requires: %{name}-gtk = %{version}-%{release}
  74. Requires: pkgconfig
  75. Requires: gtk2-devel
  76. %description gtk-devel
  77. The %{name}-gtk-devel package contains libraries, build data, and header
  78. files for developing applications that use %{name}-gtk.
  79. Please note that the WebKit/GTK+ API is not yet stable. This should
  80. only be used as a "preview" rather than a stable platform library.
  81. %package doc
  82. Summary: Documentation for %{name}
  83. Summary(ja): %{name} のドキュメント
  84. Group: Documentation
  85. %description doc
  86. %{name} is an open-source Web content engine library. This package contains
  87. the documentation for %{name}, including various LICENSE, README, and
  88. AUTHORS files.
  89. %prep
  90. %setup -q -n webkit-%{version}
  91. %build
  92. %configure \
  93. --enable-icon-database \
  94. --enable-gnome-keyring \
  95. --enable-geolocation \
  96. %{?with_coverage: --enable-coverage } \
  97. %{?with_pango: --with-font-backend=pango } \
  98. %{?with_libsoup: --with-http-backend=soup } \
  99. %{?with_svg: --enable-svg-filters } \
  100. %{?with_wml: --enable-wml }
  101. make %{?_smp_mflags}
  102. # workaround for bug 488112
  103. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  104. touch JavaScriptCore/AllInOneFile.cpp
  105. make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  106. %install
  107. rm -rf %{buildroot}
  108. make install DESTDIR=%{buildroot}
  109. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  110. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  111. ## Finally, copy over and rename the various files for %%doc inclusion.
  112. rm -f docfiles.list
  113. %add_to_doc_files JavaScriptCore/COPYING.LIB
  114. %add_to_doc_files JavaScriptCore/icu/LICENSE
  115. %add_to_doc_files WebKit/LICENSE
  116. %add_to_doc_files WebCore/LICENSE-APPLE
  117. %add_to_doc_files WebCore/LICENSE-LGPL-2
  118. %add_to_doc_files WebCore/LICENSE-LGPL-2.1
  119. %add_to_doc_files WebCore/icu/LICENSE
  120. %add_to_doc_files JavaScriptCore/AUTHORS
  121. %add_to_doc_files JavaScriptCore/pcre/AUTHORS
  122. %add_to_doc_files JavaScriptCore/THANKS
  123. %find_lang webkit
  124. %clean
  125. rm -rf %{buildroot}
  126. %post gtk -p /sbin/ldconfig
  127. %postun gtk -p /sbin/ldconfig
  128. %files -f webkit.lang gtk
  129. %defattr(-,root,root,-)
  130. %doc
  131. %{_libdir}/libwebkit-1.0.so.*
  132. %{_libexecdir}/WebKit/
  133. %{_bindir}/jsc
  134. %files gtk-devel
  135. %defattr(-,root,root,-)
  136. %exclude %{_libdir}/*.la
  137. %{_includedir}/webkit-1.0
  138. %{_datadir}/webkit-1.0
  139. %{_libdir}/libwebkit-1.0.so
  140. %{_libdir}/pkgconfig/webkit-1.0.pc
  141. %files doc -f docfiles.list
  142. %defattr(-,root,root,-)
  143. %changelog
  144. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  145. - updated to 1.1.18
  146. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  147. - change BR from libsoup to libsoup-devel
  148. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  149. - new upstream release.
  150. - add Vendor, Distribution and Packager.
  151. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  152. - update to webkit-1.1.10 release version
  153. - added BuildRequires: enchant-devel
  154. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  155. - update to webkit-1.1.6 release version
  156. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  157. - update to new upstream snapshot (svn r41944)
  158. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  159. - update to new upstream snapshot (svn r40471)
  160. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  161. - update to new upstream snapshot (svn r37056)
  162. - disable html5video by default
  163. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  164. - update to new upstream snapshot (svn r36882)
  165. - build with gnome-2.24
  166. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  167. - build without pango by default.
  168. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  169. - update to new upstream snapshot (svn r36053)
  170. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  171. - update to new upstream snapshot (svn r34655)
  172. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  173. - initial build for Vine Linux
  174. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  175. - rebuild for new icu
  176. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  177. - Update to new upstream snapshot (SVN 34279) anyway
  178. - Add BR: libXt-devel
  179. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  180. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  181. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  182. subdirectories either.)
  183. - Reference: bug 442200 (RFE: WebKit Migration)
  184. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  185. tree).
  186. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  187. - Update to new upstream snapshot (SVN 32531).
  188. - Fix bug 443048 and hopefully fix bug 444445
  189. - Modify the process of building GTK+ port a bit
  190. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  191. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  192. - Update to new upstream snapshot (SVN 31787).
  193. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  194. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  195. - Switch to using autotools for building the GTK+ port.
  196. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  197. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  198. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  199. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  200. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  201. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  202. file location mismatch)
  203. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  204. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  205. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  206. - Update to new upstream snapshot (SVN 30667)
  207. - Add some build fixes for GCC 4.3:
  208. + gcc43.patch
  209. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  210. - Autorebuild for GCC 4.3
  211. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  212. - Update to new upstream snapshot (SVN 29336).
  213. - Drop TCSpinLock pthread workaround (fixed upstream):
  214. - TCSpinLock-use-pthread-stubs.patch
  215. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  216. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  217. - Add patch to forcibly build the TCSpinLock code using the pthread
  218. implementation:
  219. + TCSpinLock-use-pthread-stubs.patch
  220. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  221. - Package renamed from WebKitGtk.
  222. - Update to SVN 28482.
  223. - Build both the GTK and Qt ports, putting each into their own respective
  224. subpackages.
  225. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  226. the build-webkit script from upstream.
  227. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  228. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  229. - Initial packaging for Fedora.