lookup-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. %define origname lookup
  5. %define origver 1.4
  6. Summary: a Search Interface for Emacsen
  7. Summary(ja): Emacs 系のエディタで利用できる辞書検索インターフェース
  8. Name: %{origname}
  9. Version: %{origver}
  10. Release: 2%{?_dist_release}
  11. Source0: http://openlab.jp/edict/lookup/dist/lookup-%{version}.tar.gz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. Source10: lookup-sample.dotemacs
  15. Source11: lookup-init.el
  16. Source12: vine-default-lookup.el
  17. License: GPL
  18. Group: Applications/Editors/Emacs
  19. URL: http://openlab.jp/edict/lookup/
  20. BuildRoot: %{_tmppath}/%{name}-%{version}
  21. BuildArch: noarch
  22. Requires: emacsen
  23. PreReq: emacsen flim
  24. %prereq_ge emacsen-common
  25. PreReq: /sbin/install-info
  26. Obsoletes: lookup-emacs, lookup-xemacs
  27. Conflicts: %{origname}-el
  28. Distribution: Vine Linux
  29. Vendor: Project Vine
  30. Packager: Tomoya TAKA <taka@vinelinux.org>
  31. %description
  32. Lookup is interface on Emacs to use some dictionaries.
  33. Lookup is developed by OpenLab, Ring Server Project.
  34. %description -l ja
  35. Lookup は Emacs 系のエディタで利用できる辞書検索インターフェースです。
  36. 市販のCD-ROM 辞書やネットワークの辞書サーバを始め、様々な情報源から簡単な操作
  37. と設定で辞書検索が行なえます。
  38. %prep
  39. %setup -q -n %{origname}-%{origver}
  40. %build
  41. %configure --prefix=%{_prefix} --infodir=%{_infodir}
  42. %install
  43. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  44. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  45. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  46. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  47. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  48. #
  49. # install el files
  50. #
  51. cp -p lisp/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  52. cp -p lisp/*.el.in %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  53. cp -p lisp/lookup-logo.* %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  54. cp -p packages/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  55. cp -p packages/dict-misc/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  56. cp -p packages/jitenban97/*.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  57. cp %{SOURCE11} %{SOURCE12} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/
  58. #
  59. # install script (bytecompile el and install elc , remove)
  60. #
  61. %_installemacsenscript %{origname} %{SOURCE1}
  62. %_removeemacsenscript %{origname} %{SOURCE2}
  63. #
  64. # install info file
  65. #
  66. mkdir -p %{buildroot}%{_infodir}
  67. cp -p texi/lookup-guide.info %{buildroot}%{_infodir}
  68. cp -p texi/lookup.info* %{buildroot}%{_infodir}
  69. #
  70. # copy sample of ~/{.emacs.el,.xemacs.el}
  71. #
  72. cp %{SOURCE10} ./sample.dotemacs
  73. %clean
  74. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  75. %post
  76. #
  77. # bytecompile and install
  78. #
  79. if [ "$1" = 2 ]; then
  80. %_emacsenPackageRemove %{origname}
  81. fi
  82. %_addemacsenlist %{origname}
  83. %_emacsenPackageInstall %{origname}
  84. /sbin/install-info --info-dir=%{_infodir} %{_infodir}/lookup-guide.info.gz
  85. /sbin/install-info --info-dir=%{_infodir} %{_infodir}/lookup.info.gz
  86. %preun
  87. if [ "$1" = 0 ]; then
  88. %_emacsenPackageRemove %{origname}
  89. %_removeemacsenlist %{origname}
  90. /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/lookup-guide.info.gz
  91. /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/lookup.info.gz
  92. fi
  93. %files
  94. %defattr(-,root,root)
  95. %doc AUTHORS COPYING ChangeLog NEWS README VERSION
  96. %doc sample.dotemacs texi/*.texi
  97. %{_datadir}/emacs/site-lisp/%{origname}
  98. %{emacsen_pkgdir}/install/%{origname}
  99. %{emacsen_pkgdir}/remove/%{origname}
  100. %{_infodir}/*
  101. %changelog
  102. * Mon Dec 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.4-2
  103. - apply vine-default
  104. - add lookup-init.el (Source11)
  105. - add vine-default-lookup.el (Source12)
  106. - update lookup-{install,remove}.sh
  107. - update sammary and description in English
  108. - rename Source10: sample.dotemacs to lookup-sample.dotemacs
  109. - add PreReq: flim :fixed <BTS:VineLinux:857>
  110. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4-1vl5
  111. - applied new versioning policy, spec in utf-8
  112. - added %%emacsen_pkgdir macro
  113. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4-0vl3
  114. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  115. - s/Copyright/License/
  116. * Fri Jul 2 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.4-0vl2
  117. - add missing SOURCES (ndeb-binary.el, ndnmz.el) in lookup-install.sh
  118. * Tue May 4 2004 IWAI, Masaharu <iwai@alib.jp> 1.4-0vl1
  119. - version up to 1.4 ( edict openlab version )
  120. - update URL and Source0 tags
  121. - update lookup-install.sh script: value of VERSION
  122. * Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 1.3-0vl4
  123. - rebuild
  124. * Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3-0vl3
  125. - lookup-el -> lookup again
  126. * Sat Dec 9 2001 Tomoya TAKA <taka@vinelinux.org> 1.3-0vl1
  127. - emacsenize
  128. * Sun Jun 24 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
  129. - 1.3-0vl1
  130. - add Prereq: /sbin/install-info, handle info pages in %%post and %%preun
  131. - some fix on spec file, use rpm macros
  132. * Mon Jun 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  133. - 1.2-0vl3
  134. - BuildArch: noarch
  135. * Wed Apr 26 2000 Masaki Kawamura <kawamura@ic.sci.yamaguchi-u.ac.jp>
  136. - release for the Vine Linux 2.0