libxcb-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define xpyb_version 1.1
  3. Summary: A C binding to the X11 protocol
  4. Summary(ja): X11 プロトコルの C による実装
  5. Name: libxcb
  6. Version: 1.5
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Libraries
  9. License: MIT
  10. URL: http://xcb.freedesktop.org/
  11. Source0: http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
  12. Source2: http://xcb.freedesktop.org/dist/xpyb-%{xpyb_version}.tar.bz2
  13. Patch10: libxcb-1.4-no-pthread-stubs.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: autoconf automake libtool pkgconfig
  16. #BuildRequires: doxygen
  17. #BuildRequires: graphviz
  18. BuildRequires: libXau-devel
  19. BuildRequires: libxslt
  20. BuildRequires: xcb-proto >= 1.6
  21. BuildRequires: xorg-x11-proto-devel
  22. BuildRequires: xorg-x11-util-macros
  23. %description
  24. The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
  25. small footprint, latency hiding, direct access to the protocol, improved
  26. threading support, and extensibility.
  27. %package devel
  28. Summary: Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: pkgconfig
  32. %description devel
  33. The %{name}-devel package contains libraries and header files for
  34. developing applications that use %{name}.
  35. %package doc
  36. Summary: Documentation for %{name}
  37. Group: Documentation
  38. %description doc
  39. The %{name}-doc package contains documentation for the %{name} library.
  40. %package python
  41. Summary: Python bindings for %{name}
  42. Group: Development/Libraries
  43. Provides: xpyb
  44. %description python
  45. Python bindings for %{name}.
  46. %package -n compat32-%{name}
  47. Summary: A C binding to the X11 protocol
  48. Summary(ja): X11 プロトコルの C による実装
  49. Group: System Environment/Libraries
  50. %description -n compat32-%{name}
  51. The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
  52. small footprint, latency hiding, direct access to the protocol, improved
  53. threading support, and extensibility.
  54. %package -n compat32-%{name}-devel
  55. Summary: Development files for %{name}
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}-%{release}
  58. Requires: %{name}-devel = %{version}-%{release}
  59. %description -n compat32-%{name}-devel
  60. The %{name}-devel package contains libraries and header files for
  61. developing applications that use %{name}.
  62. %prep
  63. %setup -q -b2
  64. %patch10 -p1
  65. pushd ../xpyb-%{xpyb_version}
  66. # XXX fix me upstream please
  67. sed -i 's@$(pythondir)@$(pyexecdir)@' src/Makefile.am
  68. popd
  69. %build
  70. autoreconf -v --install
  71. %configure --disable-static --docdir=%{_datadir}/doc/%{name}-%{version} --disable-selinux
  72. make %{?_smp_mflags}
  73. pushd ../xpyb-%{xpyb_version}
  74. autoreconf -v --install
  75. %configure
  76. make %{?_smp_mflags}
  77. popd
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
  82. install -m 644 COPYING NEWS README $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  83. pushd ../xpyb-%{xpyb_version}
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. popd
  86. find $RPM_BUILD_ROOT -name '*.la' -delete
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %post -p /sbin/ldconfig
  90. %postun -p /sbin/ldconfig
  91. %post -n compat32-%{name} -p /sbin/ldconfig
  92. %postun -n compat32-%{name} -p /sbin/ldconfig
  93. %files
  94. %defattr(-,root,root,-)
  95. %{_libdir}/*.so.*
  96. %files devel
  97. %defattr(-,root,root,-)
  98. %{_includedir}/xcb
  99. %{_libdir}/*.so
  100. %{_libdir}/pkgconfig/*.pc
  101. %files doc
  102. %defattr(-,root,root,-)
  103. %{_datadir}/doc/%{name}-%{version}
  104. %files python
  105. %defattr(-,root,root,-)
  106. %{python_sitearch}/xcb
  107. %if %{build_compat32}
  108. %files -n compat32-%{name}
  109. %defattr(-,root,root,-)
  110. %{_libdir}/*.so.*
  111. %files -n compat32-%{name}-devel
  112. %defattr(-,root,root,-)
  113. %{_libdir}/*.so
  114. %{_libdir}/pkgconfig/*.pc
  115. %endif
  116. %changelog
  117. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
  118. - new upstream release
  119. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
  120. - rebuild with python-2.6
  121. * Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
  122. - new upstream release
  123. - add libxcb python binding (xpyb)
  124. * Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
  125. - added compat32 package for x86_64 arch support
  126. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  127. - new upstream release
  128. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
  129. - spec in utf-8
  130. - added japanese summary
  131. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
  132. - new versioning policy
  133. * Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
  134. - initial build for Vine Linux
  135. * Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
  136. - libxcb 1.1
  137. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
  138. - libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
  139. abstract-namespace unix sockets to filesystem-bound sockets.
  140. * Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
  141. - Rebuild for PPC toolchain bug
  142. * Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
  143. - Initial revision.