rhythmbox-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.12.7
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source: http://download.gnome.org/sources/rhythmbox/0.12/%{name}-%{version}.tar.bz2
  13. # https://bugzilla.gnome.org/show_bug.cgi?id=596615
  14. Patch0: rb-no-HEAD-for-podcasts.patch
  15. # https://bugzilla.redhat.com/show_bug.cgi?id=540672
  16. # https://bugzilla.gnome.org/show_bug.cgi?id=602140
  17. Patch1: rb-webkit-crasher.patch
  18. # https://bugzilla.redhat.com/show_bug.cgi?id=546188
  19. Patch2: 0001-Fix-crasher-when-MusicBrainz-can-t-read-a-disc.patch
  20. # https://bugzilla.gnome.org/show_bug.cgi?id=601524
  21. # https://bugzilla.gnome.org/show_bug.cgi?id=602957
  22. Patch3: rb-playbin2-track-changes.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: libgpod-devel
  25. BuildRequires: libgnomeui-devel >= 2.18.0
  26. BuildRequires: nautilus-cd-burner
  27. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  28. BuildRequires: gettext, rarian-compat
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: sqlite3-devel
  31. BuildRequires: libffi-devel
  32. BuildRequires: gnome-vfs2-devel >= 2.18.0
  33. BuildRequires: avahi-glib-devel >= 0.6
  34. BuildRequires: libmusicbrainz-devel >= 2.1.0
  35. BuildRequires: libnotify-devel
  36. BuildRequires: libsexy-devel
  37. BuildRequires: hal-devel
  38. BuildRequires: libsoup-devel
  39. BuildRequires: dbus-devel >= 1.0
  40. BuildRequires: dbus-glib-devel
  41. BuildRequires: gnome-doc-utils >= 0.3.2
  42. BuildRequires: python-devel, pygtk2-devel
  43. BuildRequires: check >= 0.8.2
  44. BuildRequires: intltool >= 0.35.0
  45. BuildRequires: gstreamer-python
  46. BuildRequires: popt-devel
  47. BuildRequires: lirc
  48. BuildRequires: libmtp-devel
  49. BuildRequires: gnome-keyring-devel
  50. BuildRequires: gnome-media
  51. BuildRequires: libSM-devel
  52. Requires: libgpod
  53. Requires: libnotify
  54. Requires: libsexy
  55. Requires: lirc
  56. Requires: libmtp
  57. Requires: libgnomeui
  58. Requires: nautilus-cd-burner
  59. Requires: gnome-python gnome-vfs2
  60. Requires: gnome-themes
  61. Requires: gnome-keyring
  62. Requires: gstreamer-python
  63. %if %{enable_DLNA_UPnP}
  64. Requires: python-Coherence
  65. %endif
  66. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  67. Requires: scrollkeeper GConf2
  68. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  69. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  70. # # respectively.
  71. # Requires: self-build-gstreamer-plugins-ffmpeg
  72. # Requires: self-build-gstreamer-plugins-ugly
  73. %description
  74. Rhythmbox is an integrated music management application based on the powerful
  75. GStreamer media framework. It has a number of features, including an easy to
  76. use music browser, searching and sorting, comprehensive audio format support
  77. through GStreamer, Internet Radio support, playlists and more.
  78. Rhythmbox is extensible through a plugin system.
  79. %description -l ja
  80. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  81. 統合音楽管理アプリケーションです。
  82. 見やすいユーザインターフェースを備え、検索や整列ができ、
  83. GStreamer により数多くの音声フォーマットをサポート、
  84. インターネットラジオをサポート、プレイリスト管理などの
  85. 数多くの特徴を持ちます。
  86. %prep
  87. %setup -q
  88. %patch0 -p1 -b .http-head
  89. ## %patch1 -p1 -b .webkit
  90. ## %patch2 -p1 -b .mb-crasher
  91. ## %patch3 -p1 -b .track-change-hang
  92. # autoreconf -i
  93. # Use the installed louie, not the one in Coherence
  94. find plugins/coherence/upnp_coherence/ -type f \
  95. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  96. %build
  97. # work around a gstreamer bug
  98. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  99. %configure --with-ipod \
  100. --with-mtp \
  101. --with-dbus \
  102. --with-mdns=avahi \
  103. --with-libnautilus-burn \
  104. --with-cd-burning \
  105. --with-metadata-helper \
  106. --enable-lirc \
  107. --enable-python \
  108. --disable-vala \
  109. --disable-browser-plugin \
  110. --disable-static \
  111. --disable-scrollkeeper \
  112. --disable-schemas-install
  113. %__make %{?_smp_mflags}
  114. %install
  115. %__rm -rf $RPM_BUILD_ROOT
  116. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  117. %__make install DESTDIR=$RPM_BUILD_ROOT
  118. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  119. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  120. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  121. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  122. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  123. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  124. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  125. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  126. ## Don't package DLNA/UPnP plugin
  127. %if !%{enable_DLNA_UPnP}
  128. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  129. %endif
  130. %find_lang %{name}
  131. # Don't package api docs
  132. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  133. # Don't package scrollkeeper catalogs
  134. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  135. # And don't package vala
  136. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  137. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  138. # save space by linking identical images in translated docs
  139. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  140. for f in $helpdir/C/figures/*.png; do
  141. b="$(basename $f)"
  142. for d in $helpdir/*; do
  143. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  144. g="$d/figures/$b"
  145. if [ -f "$g" ]; then
  146. if cmp -s $f $g; then
  147. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  148. fi
  149. fi
  150. fi
  151. done
  152. done
  153. %clean
  154. %__rm -rf $RPM_BUILD_ROOT
  155. %post
  156. /sbin/ldconfig
  157. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  158. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
  159. update-desktop-database -q
  160. scrollkeeper-update -q
  161. touch --no-create %{_datadir}/icons/hicolor
  162. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  163. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  164. fi
  165. %preun
  166. if [ "$1" -eq 0 ]; then
  167. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  168. gconftool-2 --makefile-uninstall-rule \
  169. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
  170. fi
  171. %postun
  172. /sbin/ldconfig
  173. update-desktop-database -q
  174. scrollkeeper-update -q
  175. touch --no-create %{_datadir}/icons/hicolor
  176. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  177. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  178. fi
  179. %files -f %{name}.lang
  180. %defattr(-, root, root)
  181. %doc AUTHORS COPYING ChangeLog README NEWS
  182. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas
  183. %{_bindir}/*
  184. %{_libdir}/lib*.so*
  185. %{_libdir}/rhythmbox/plugins
  186. %{_datadir}/applications/rhythmbox.desktop
  187. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  188. %{_datadir}/gnome/help/rhythmbox
  189. %{_datadir}/icons/*
  190. %{_datadir}/omf/rhythmbox
  191. %{_datadir}/rhythmbox
  192. %{_mandir}/man1/*
  193. %{_libexecdir}/rhythmbox-metadata
  194. %changelog
  195. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
  196. - new upstream release
  197. - drop Patch1, Patch2, Patch3
  198. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  199. - rebuilt with new environment
  200. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  201. - new upstream release
  202. - dropped upstreamed/obsolete patches
  203. - added patches applied Fedora development
  204. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  205. - new upstream release
  206. - added configure options:
  207. --disable-vala
  208. --disable-browser-plugin
  209. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  210. - added Japanese description
  211. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  212. - new upstream release
  213. - dropped rb-disable-power-plugin-by-default.patch
  214. - added BuildRequires:
  215. - libSM-devel
  216. - gnome-media
  217. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  218. - rebuild with libgpod-0.7.2
  219. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  220. - new upstream release
  221. - corrected License tag
  222. - dropped rhythmbox-0.11.6-libmtp.patch
  223. - added BuildRequires:
  224. - sqlite3-devel
  225. - libffi-devel
  226. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  227. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  228. - applied rhythmbox-0.11.6-libmtp.patch
  229. - added Requires:
  230. - libgpod
  231. - libnotify
  232. - libsexy
  233. - lirc
  234. - libmtp
  235. - libgnomeui
  236. - nautilus-cd-burner
  237. - gstreamer-python
  238. - gnome-vfs2
  239. - gnome-themes
  240. - gnome-keyring
  241. - python-Coherence, if enable_DLNA_UPnP = 1
  242. - added BuildRequires:
  243. - libnotify-devel
  244. - libsexy-devel
  245. - lirc
  246. - libmtp-devel
  247. - gnome-vfs2-devel, instead of gnome-vfs2
  248. - gnome-keyring-devel
  249. - dropped --with-internal-libsexy in configure options
  250. - added in configure options:
  251. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  252. - added %%preun to remove the schema
  253. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  254. - new upstream release
  255. - changed to --with-metadata-helper in configure options
  256. - added BuildRequires:
  257. - gstreamer-python
  258. - intltool >= 0.35.0
  259. - popt-devel
  260. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  261. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  262. - rebuilt with python-2.5.2
  263. - applied new versioning policy
  264. - spec in utf-8
  265. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  266. - rebuilt with libgpod-0.6.0
  267. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  268. - new upstream release
  269. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  270. - new upstream release
  271. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  272. - rebuilt with new toolchain and libgpod-0.4.2
  273. - add BuildRequires: dbus-glib-devel
  274. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  275. - new upstream release
  276. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  277. - rebuilt for VineSeed
  278. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  279. - new upstream release
  280. - added --enable-python option to %%configure
  281. - added Requires: gnome-python
  282. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  283. - new upstream release
  284. - built with libsoup 2.2.99
  285. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  286. - added --with-cd-burner to configure
  287. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  288. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  289. - add BuildRequires:
  290. - gnome-doc-utils >= 0.3.2
  291. - python-devel
  292. - pygtk2-devel
  293. - check >= 0.8.2
  294. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  295. - rebuild with gnutls-1.4.1
  296. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  297. - new upstream release
  298. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  299. - new upstream release
  300. - run scrollkeeper-update at %post and %postun
  301. - added BuildRequires: libnotify-devel
  302. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  303. - new upstream release (dropped patch0)
  304. - added --without-metadata-helper at configure
  305. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  306. - Initial build for Vine Linux based on FC pacakge
  307. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  308. - add patch from James "Doc" Livingston to stop a hang
  309. for new users (bug 183883)
  310. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  311. - bump again for double-long bug on ppc(64)
  312. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  313. - rebuilt for new gcc4.1 snapshot and glibc changes
  314. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  315. - Update to 0.9.3.1
  316. - Use gstreamer (0.10)
  317. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  318. - Remove hack for 173869, as its no longer needed.
  319. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  320. - 0.9.3
  321. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  322. - Newer CVS snapshot
  323. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  324. - Update to latest CVS
  325. - Add hack to workaround bug #173869
  326. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  327. - Rebuild, now that gstreamer08-plugins has been fixed
  328. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  329. - bonobo multilib issue (bug 156982)
  330. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  331. - rebuild with ipod support
  332. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  333. - rebuilt again
  334. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  335. - rebuilt
  336. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  337. - rebuild
  338. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  339. - rebuild for new dbus
  340. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  341. - Update to 0.9.2
  342. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  343. - Update to 0.9.1
  344. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  345. - Add configure flags --with-bonobo --with-dbus
  346. - BR nautilus-cd-burner-devel
  347. - New upstream CVS snapshot for testing
  348. - Drop IDL file and ui .xml
  349. - Add dbus service file
  350. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  351. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  352. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  353. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  354. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  355. cell renderer for playback icon (no longer necessary) and
  356. changes the rating renderer to work with non-b&w icons
  357. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  358. - Rebuild for GCC4
  359. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  360. - New upstream version
  361. - Remove librb-nautilus-context-menu.so, killed upstream
  362. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  363. - PreReq desktop-file-utils >= 0.9
  364. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  365. - New upstream version
  366. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  367. - Fix postun to use correct syntax, thanks Nils Philippsen
  368. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  369. - New upstream version
  370. - Call update-desktop-database in post and postun
  371. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  372. - New upstream version
  373. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  374. - rebuilt
  375. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  376. - New upstream version
  377. - Remove backported patches
  378. - Gratuitiously bump various BuildRequires versions
  379. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  380. - Remove code to unregister GConf schema for now (Closes: #122532)
  381. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  382. - Apply tiny patch from 0.8 arch to fix GConf key used
  383. for initial sorting
  384. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  385. - Apply patch from 0.8 arch tree to fix a number of memleaks
  386. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  387. - Update to 0.8.3: fixes showstopper bug with internet radio
  388. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  389. - Update to 0.8.2
  390. - Fix Source url
  391. - Add smp_mflags
  392. - Bump BuildRequires on gstreamer to 0.8.1
  393. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  394. - Uninstall GConf schemas on removal
  395. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  396. - Update to 0.8.1
  397. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  398. - Update to 0.8.0
  399. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  400. - Update to 0.7.2
  401. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  402. - Remove BuildRequires on autoconf and libvorbis-devel
  403. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  404. - New major version - I know we are past major version slush, but
  405. this should have been done two weeks ago along with the GNOME 2.6
  406. upload. As upstream author as well, I believe this version is
  407. good enough for FC2.
  408. - Remove --disable-mp3
  409. - Remove id3, flac variables
  410. - Remove GStreamer major version patch
  411. - Fix typo in description
  412. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  413. - rebuild for new gstreamer
  414. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  415. - update to 0.6.8
  416. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  417. - rebuilt
  418. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  419. - update to 0.6.7
  420. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  421. - rebuilt
  422. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  423. - New upstream version
  424. - Don't re-run the autotools; upstream incorporates newer versions.
  425. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  426. - new version
  427. - remove smp_flags
  428. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  429. - remove the initial iradio channels as they all are mp3 based.
  430. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  431. - Fix category from Development/Libraries to Applications/Multimedia.
  432. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  433. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  434. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  435. - Removed unnecessary date expansion define.
  436. - Updated description, including mp3 reference removal.
  437. - Added libid3tag and flac optional support for convenient rebuild.
  438. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  439. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  440. - new version
  441. - use %{_sysconfdir} instead of /etc
  442. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  443. - rebuilt
  444. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  445. - gave up on other archs for the Beta
  446. - new version
  447. - remove werror and add missing files
  448. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  449. - update to newer cvs snap
  450. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  451. - update to cvs snap
  452. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  453. - use %%(lang)
  454. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  455. - fix post to actually install the schema
  456. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  457. - Added gconf file
  458. - Added i18n directory
  459. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  460. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  461. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  462. - removed bonobo dependency
  463. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  464. - created new spec file