tzdata-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. %bcond_with java18
  2. Summary: Timezone data
  3. Summary(ja): タイムゾーンのデータ
  4. Name: tzdata
  5. Version: 2015f
  6. %define tzdata_version 2015f
  7. %define tzcode_version 2015f
  8. Release: 1%{?_dist_release}
  9. License: Public Domain
  10. Group: System Environment/Base
  11. URL: https://www.iana.org/time-zones
  12. # These are official upstream.
  13. Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
  14. Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
  15. Source2: javazic.tar.gz
  16. Source3: javazic-1.8-37392f2f5d59.tar.xz
  17. Patch100: javazic-fixup.patch
  18. Patch101: rebase-01.patch
  19. Patch102: rebase-02.patch
  20. Patch103: 7090844.patch
  21. Patch104: 7133138.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. BuildRequires: gawk, glibc, perl
  25. BuildRequires: java-devel
  26. BuildRequires: glibc-common >= 2.5.90-7
  27. Conflicts: glibc-common <= 2.3.2-63
  28. %description
  29. This package contains data files with rules for various timezones around
  30. the world.
  31. %description -l ja
  32. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  33. %package java
  34. Summary: Timezone data for Java
  35. Group: System Environment/Base
  36. %description java
  37. This package contains timezone information for use by Java runtimes.
  38. %prep
  39. %setup -q -c -a 1
  40. mkdir javazic
  41. tar zxf %{SOURCE2} -C javazic
  42. pushd javazic
  43. %patch100
  44. %patch101
  45. %patch102
  46. %patch103
  47. %patch104
  48. # Hack alert! sun.tools may be defined and installed in the
  49. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  50. # for creating the zoneinfo files, rebase all the packages
  51. # from "sun." to "rht.". Unfortunately, gcj does not support
  52. # any of the -Xclasspath options, so we must go this route
  53. # to ensure the greatest compatibility.
  54. mv sun rht
  55. find . -type f -name '*.java' -print0 \
  56. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  57. -e 's:sun\.util\.:rht.util.:g'
  58. popd
  59. tar xf %{SOURCE3}
  60. echo "%{name}%{tzdata_version}" >> VERSION
  61. %build
  62. FILES="africa antarctica asia australasia europe northamerica southamerica
  63. pacificnew etcetera backward"
  64. mkdir zoneinfo/{,posix,right}
  65. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  66. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  67. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  68. grep -v tz-art.htm tz-link.htm > tz-link.html
  69. # Java 6/7 tzdata
  70. pushd javazic
  71. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  72. popd
  73. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  74. -d javazi \
  75. $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  76. %if %{with java18}
  77. # Java 8 tzdata
  78. pushd javazic-1.8
  79. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  80. popd
  81. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  82. -srcdir . -dstfile tzdb.dat \
  83. -verbose \
  84. $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  85. %endif
  86. %install
  87. rm -fr $RPM_BUILD_ROOT
  88. install -d $RPM_BUILD_ROOT%{_datadir}
  89. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  90. install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  91. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  92. %if %{with java18}
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  94. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  95. %endif
  96. %clean
  97. rm -fr $RPM_BUILD_ROOT
  98. %files
  99. %defattr(-,root,root)
  100. %{_datadir}/zoneinfo
  101. %doc README
  102. %doc Theory
  103. %doc tz-link.html
  104. %files java
  105. %defattr(-,root,root)
  106. %{_datadir}/javazi
  107. %if %{with java18}
  108. %{_datadir}/javazi-1.8
  109. %endif
  110. %changelog
  111. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  112. - updated to 2015f.
  113. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  114. - updated to 2015e.
  115. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  116. - update to tzdata-2012c, tzcode-2012b
  117. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  118. - rebuilt with rpm-4.8.1-3
  119. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  120. - update to tzdata-2010l, tzcode-2010l
  121. - added java subpackage
  122. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  123. - update to tzdata-2009d, tzcode-2009d
  124. - spec in utf-8
  125. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  126. - update to tzdata-2008b, tzcode-2008a
  127. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  128. - initial build for VineSeed
  129. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  130. - Upstream 2007d
  131. - Mongolia has abolished DST.
  132. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  133. than 01:00 standard time.
  134. - Cuba observed DST starting Sunday.
  135. - Resolute, Nunavut switched from Central to Eastern time last
  136. November.
  137. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  138. - Upstream 2007c
  139. - Pulaski County, Indiana, switched back to eastern time.
  140. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  141. - Upstream 2007b
  142. - Changes to the commentary in "leapseconds".
  143. - Upstream 2007a
  144. - Updates to Bahamas, they will be in sync with 2007 US DST change
  145. - New zone Australia/Eucla
  146. - Africa/Asmera renamed to Africa/Asmara, link created
  147. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  148. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  149. - Upstream 2006p
  150. - Covers changes from 2006m-2 and 2006m-3
  151. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  152. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  153. - Patch for Western Australia DST trial
  154. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  155. - Proposed upstream patch (#210058)
  156. - Jordan will switch to winter time on October 27, not September 29
  157. - Brazil's DST this year is the first Sunday in November to the last
  158. Sunday in February. (Thanks to Frederico A. C. Neves.)
  159. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  160. - Commentary and past timestamps changes
  161. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  162. - Upstream 2006m:
  163. - Adjustments for Egypt, Palestine, Uruguay
  164. - Better description of `until' field in zic (8) manpage
  165. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  166. - Upstream 2006k, 2006l:
  167. - Adjustments for Egypt, Palestine, Cuba, Honduras
  168. - Documentation changes
  169. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  170. - Upstream 2006j
  171. - Honduras stopped observing DST on Monday at 00:00
  172. - America/Bermuda will follow the US's lead next year
  173. - America/Moncton will use US-style rules next year
  174. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  175. year
  176. - New zone: America/Atikokan instead of America/Coral_Harbour
  177. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  178. - Historical changes
  179. - Commentary updates
  180. - Upstream 2006i
  181. - localtime.c fixes
  182. - Upstream 2006h
  183. - zic leapsecond fix
  184. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  185. - rebuild
  186. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  187. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  188. - Nicaragua updates
  189. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  190. - Upstream 2006f
  191. - America/Guatemala observes DST between Apr/30 and Oct/1
  192. - Historical changes for Nicaragua
  193. - Update of America/Indiana/Vincennes in zone table
  194. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  195. - Upstream 2006d
  196. - Haiti observes DST
  197. - Sri Lanka change actually took effect Apr/15
  198. - All Canada is now scheduled for 2007 US DST rules
  199. - Some historical fixes
  200. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  201. - Upstream 2006c
  202. - Time-related changes:
  203. - dozens of historical and commentary changes
  204. - Iran stopped observing DST
  205. - Sri Lanka switches from UTC+6 to UTC+5:30
  206. - America/Thule and America/Edmonton will adopt new US rules,
  207. starting 2007
  208. - Tunisia is adopting regular DST
  209. - Code:
  210. - asctime.c: Chages in format strings to silent gcc warnings
  211. - removing K&R notation from function signatures
  212. - few fixes across the code
  213. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  214. - Patch for Sri Lanka time zone change (#184514)
  215. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  216. - Upstream 2006b:
  217. - using tz64code version, as 32 is legacy according to tzdata ML
  218. - new manual pages for ctime, strftime, tzset
  219. - some source code reorganizations
  220. - no timezone/dst rule updates
  221. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  222. - Small changes in tst-timezone.c
  223. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  224. - Upstream 2006a:
  225. - private.h(scheck): changing char* to char const*
  226. - Rule changes for Palestine, zone changes for Indiana/US, both
  227. changes for Canada.
  228. - Many related doc changes.
  229. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  230. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  231. - 2005r-3
  232. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  233. so that it won't clash across updates.
  234. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  235. - 2005r
  236. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  237. northamerica to guard against old files with obsolete information
  238. being left in the time zone binary directory.
  239. - Changes for countries that are supposed to join 2007 US DST
  240. change. This includes most of Canada, however entries already in
  241. the database (Alberta, British Columbia, Newfoundland, Northwest
  242. Territories, and Yukon) were left alone for the time being.
  243. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  244. is checked for emptiness.
  245. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  246. - 2005q
  247. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  248. - SystemV timezone changes
  249. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  250. - 2005n
  251. - changes for Kyrgyzstan and Uruguay
  252. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  253. make check), update tst-timezone.c from glibc CVS (#172102)
  254. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  255. - 2005m
  256. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  257. Australia, Kazakhstan
  258. - historical timezone data changes for Japan, Poland, Northern Ireland and
  259. Mali
  260. - timezone name change for East Timor
  261. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  262. - 2005k
  263. - leap seconds update
  264. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  265. - 2005i
  266. - updates for Iran, Haiti and Nicaragua
  267. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  268. - 2005h
  269. - fixes for Kazakhstan
  270. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  271. - 2005g
  272. - fixes for Uruguay
  273. - include README and Theory from tzcode tarball in %{_docdir};
  274. Theory includes a good summary of how the timezone data files
  275. are supposed to be named
  276. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  277. - 2005f
  278. - more updates for Israel, updates for Azerbaijan
  279. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  280. - 2005c
  281. - updates for Israel and Paraguay
  282. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  283. - 2004g (#141107)
  284. - updates for Cuba
  285. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  286. - 2004e (#135194)
  287. - updates for Brazil, Uruguay and Argentina
  288. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  289. - 2004b
  290. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  291. - 2003d
  292. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  293. - 2003c
  294. - updates for Brazil (#104840)
  295. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  296. - rebuilt
  297. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  298. - initial package