SDL_gfx-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. Summary: SDL graphics drawing primitives and other support functions
  2. Summary(ja): SDLの基本的な描画機能とその他の機能を提供するライブラリ
  3. Name: SDL_gfx
  4. Version: 2.0.17
  5. Release: 1%{?_dist_release}
  6. Source0: %{name}-%{version}.tar.gz
  7. License: LGPL
  8. Group: System Environment/Libraries
  9. URL: http://www.ferzkopp.net/~aschiffler/Software/SDL_gfx-2.0
  10. BuildRequires: SDL-devel >= 1.2.0
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. %define all_x86 i386 i586 i686 athlon
  13. %description
  14. The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
  15. provided basic drawing routines such as lines, circles or polygons and
  16. SDL_rotozoom which implemented a interpolating rotozoomer for SDL
  17. surfaces.
  18. The current components of the SDL_gfx library are:
  19. * Graphic Primitives (SDL_gfxPrimitves.h)
  20. * Rotozoomer (SDL_rotozoom.h)
  21. * Framerate control (SDL_framerate.h)
  22. %ifarch %{all_x86}
  23. * MMX image filters (SDL_imageFilter.h)
  24. %endif
  25. The library is backwards compatible to the above mentioned code. Its
  26. is written in plain C and can be used in C++ code.
  27. %description -l ja
  28. SDL_gfx は SDL_gfxPrimitives コードから発展したライブラリであり、線や
  29. 円、ポリゴンの描画を行う基本的な機能と、SDL サーフェースの回転・拡大
  30. ・縮小を行う SDL_rotozoom を提供します。
  31. 現在の SDL_gfx ライブラリに含まれているのは:
  32. * 基本的な画像の描画 (SDL_gfxPrimitves.h)
  33. * SDL サーフェースの回転、拡大、縮小 (SDL_rotozoom.h)
  34. * フレームレート制御 (SDL_framerate.h)
  35. %ifarch %{all_x86}
  36. * MMX イメージフィルタ (SDL_imageFilter.h)
  37. %endif
  38. このライブラリは先に述べたコードとの後方互換性を持っています。この
  39. ライブラリは C 言語で記述されており、C++ からでも使用できます。
  40. #-----------------------------------------------------------------------------
  41. %package devel
  42. Summary: Libraries and includes to develop SDL_gfx programs
  43. Summary(ja): SDL_gfx 用の開発ライブラリおよびヘッダファイル
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}
  46. %description devel
  47. This package includes the files needed for developing and compiling
  48. applications which use the SDL_gfx library.
  49. You should install the SDL_gfx-devel package if you would like to
  50. develop applications based on SDL_gfx.
  51. %description devel -l ja
  52. このパッケージは SDL_gfx ライブラリを使用するアプリケーションを開発
  53. するのに必要なライブラリやヘッダファイルを含んでいます。
  54. SDL_gfx をベースにしたアプリケーションを開発するなら、このパッケージ
  55. をインストールしてください。
  56. #-----------------------------------------------------------------------------
  57. %package demos
  58. Summary: SDL_gfx demo programs
  59. Summary(ja): SDL_gfx デモプログラム
  60. Group: Applications/Other
  61. Requires: %{name} = %{version}
  62. AutoReqProv: no
  63. %description demos
  64. SDL_gfx demo applications and source code.
  65. It is necessary to compile to run demo applications.
  66. %description demos -l ja
  67. SDL_gfx のデモアプリケーションとソースコードです。
  68. デモアプリケーションを実行するには自分でコンパイルする必要があります。
  69. #-----------------------------------------------------------------------------
  70. %prep
  71. %setup -q
  72. %build
  73. ./autogen.sh
  74. %ifarch %{all_x86}
  75. ./configure
  76. %else
  77. ./configure --disable-mmx
  78. %endif
  79. %__make
  80. %install
  81. %__rm -rf $RPM_BUILD_ROOT
  82. %makeinstall
  83. %__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
  84. %__install -m755 %{_builddir}/%{name}-%{version}/Test/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  86. %clean
  87. %__rm -rf $RPM_BUILD_ROOT
  88. %post -p /sbin/ldconfig
  89. %postun -p /sbin/ldconfig
  90. %files
  91. %defattr(-,root,root)
  92. %doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README*
  93. %doc Docs/
  94. %{_libdir}/libSDL_gfx.so*
  95. %files devel
  96. %defattr(-,root,root)
  97. %{_libdir}/libSDL_gfx.a
  98. #{_libdir}/libSDL_gfx.la
  99. %{_includedir}/SDL/*
  100. %files demos
  101. %defattr(-,root,root)
  102. %{_datadir}/SDL_gfx-demos
  103. %changelog
  104. * Sat Sep 20 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-1
  105. - new upstream release
  106. - applied new versioning policy
  107. - spec in UTF-8
  108. * Mon Jan 15 2007 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  109. - new upstream release
  110. - added %post and %postun section
  111. * Mon Jun 26 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-1vl2
  112. - rebuild to correct version mismatch.(1vl1 already exist in Vine Plus/3.0)
  113. - change SDL_gfx-demos Group to Applications/Other.
  114. - add SDL_gfx-demos description.
  115. * Wed Aug 24 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.13-0vl2
  116. - disable MMX on non-x86 archtecture
  117. * Sat May 14 2005 kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-0vl1
  118. - initial build for VineSeed Plus.