123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- # the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
- %define java_arches %{ix86} alpha ia64 ppc s390 s390x sparc sparcv9 x86_64
- ##VINE##
- %undefine java_arches
- %define __soversion 4.8
- %define _libdb_a libdb-%{__soversion}.a
- %define _libcxx_a libdb_cxx-%{__soversion}.a
- Summary: The Berkeley DB database library (version 4) for C
- Name: db4
- Version: 4.8.26
- Release: 2%{?_dist_release}
- Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
- Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
- # patches for db1.85
- Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
- Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
- Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
- Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
- Patch20: db-1.85-errno.patch
- Patch22: db-4.6.21-1.85-compat.patch
- Patch24: db-4.5.20-jni-include-dir.patch
- URL: http://www.oracle.com/database/berkeley-db/
- License: BSD-style
- Group: System Environment/Libraries
- Obsoletes: db1, db2, db3
- BuildRequires: perl, libtool, ed, tcl >= 8.4.4
- #BuildRequires: util-linux-ng
- %ifarch %{java_arches}
- BuildRequires: gcc-java
- BuildRequires: java-1.5.0-gcj
- BuildRequires: java-1.5.0-gcj-devel
- %endif
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- %description
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. The Berkeley DB includes B+tree, Extended
- Linear Hashing, Fixed and Variable-length record access methods,
- transactions, locking, logging, shared memory caching, and database
- recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
- used by many applications, including Python and Perl, so this should
- be installed on all systems.
- %package -n compat32-%{name}
- Summary: The Berkeley DB database library (version 4) for C.
- Group: System Environment/Libraries
- Requires: db4 = %{version}-%{release}
- %description -n compat32-%{name}
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. The Berkeley DB includes B+tree, Extended
- Linear Hashing, Fixed and Variable-length record access methods,
- transactions, locking, logging, shared memory caching, and database
- recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
- used by many applications, including Python and Perl, so this should
- be installed on all systems.
- %package cxx
- Summary: The Berkeley DB database library (version 4) for C++
- Group: System Environment/Libraries
- %description cxx
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. The Berkeley DB includes B+tree, Extended
- Linear Hashing, Fixed and Variable-length record access methods,
- transactions, locking, logging, shared memory caching, and database
- recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
- used by many applications, including Python and Perl, so this should
- be installed on all systems.
- %package -n compat32-%{name}-cxx
- Summary: The Berkeley DB database library (version 4) for C++
- Group: System Environment/Libraries
- %description -n compat32-%{name}-cxx
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. The Berkeley DB includes B+tree, Extended
- Linear Hashing, Fixed and Variable-length record access methods,
- transactions, locking, logging, shared memory caching, and database
- recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
- used by many applications, including Python and Perl, so this should
- be installed on all systems.
- %package utils
- Summary: Command line tools for managing Berkeley DB (version 4) databases
- Group: Applications/System
- Requires: db4 = %{version}-%{release}
- Obsoletes: db1-utils, db2-utils, db3-utils
- %description utils
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. Berkeley DB includes B+tree, Extended
- Linear Hashing, Fixed and Variable-length record access methods,
- transactions, locking, logging, shared memory caching, and database
- recovery. DB supports C, C++, Java and Perl APIs.
- %package devel
- Summary: C development files for the Berkeley DB (version 4) library
- Group: Development/Libraries
- Requires: db4 = %{version}-%{release}
- Obsoletes: db1-devel, db2-devel, db3-devel
- %description devel
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. This package contains the header files,
- libraries, and documentation for building programs which use the
- Berkeley DB.
- %package -n compat32-%{name}-devel
- Summary: Development files for the Berkeley DB (version 4) library.
- Group: Development/Libraries
- Requires: compat32-%{name} = %{version}-%{release}
- Requires: %{name}-devel = %{version}-%{release}
- %description -n compat32-%{name}-devel
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. This package contains the header files,
- libraries, and documentation for building programs which use the
- Berkeley DB.
- %package tcl
- Summary: Development files for using the Berkeley DB (version 4) with tcl
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description tcl
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. This package contains the libraries
- for building programs which use the Berkeley DB in Tcl.
- %package -n compat32-%{name}-tcl
- Summary: Development files for using the Berkeley DB (version 4) with tcl.
- Group: Development/Libraries
- Requires: compat32-%{name} = %{version}-%{release}
- Requires: %{name}-tcl = %{version}-%{release}
- %description -n compat32-%{name}-tcl
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. This package contains the libraries
- for building programs which use the Berkeley DB in Tcl.
- %package java
- Summary: Development files for using the Berkeley DB (version 4) with Java
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description java
- The Berkeley Database (Berkeley DB) is a programmatic toolkit that
- provides embedded database support for both traditional and
- client/server applications. This package contains the libraries
- for building programs which use the Berkeley DB in Java.
- %prep
- %setup -q -n db-%{version} -a 1
- pushd db.1.85/PORT/linux
- %patch10 -p0 -b .1.1
- popd
- pushd db.1.85
- %patch11 -p0 -b .1.2
- %patch12 -p0 -b .1.3
- %patch13 -p0 -b .1.4
- %patch20 -p1 -b .errno
- popd
- %patch22 -p1 -b .185compat
- %patch24 -p1 -b .4.5.20.jni
- # Remove tags files which we don't need.
- find . -name tags | xargs rm -f
- # Define a shell function for fixing HREF references in the docs, which
- # would otherwise break when we split the docs up into subpackages.
- fixup_href() {
- for doc in $@ ; do
- chmod u+w ${doc}
- sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
- -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
- -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
- -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
- -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
- -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
- -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
- -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
- -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
- -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
- -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
- -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
- -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
- -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
- -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
- -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
- -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
- -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
- touch -r ${doc} ${doc}.new
- cat ${doc}.new > ${doc}
- touch -r ${doc}.new ${doc}
- rm -f ${doc}.new
- done
- }
- set +x # XXX painful to watch
- # Fix all of the HTML files.
- fixup_href `find . -name "*.html"`
- set -x # XXX painful to watch
- cd dist
- ./s_config
- %build
- CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
- # Build the old db-185 libraries.
- make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
- build() {
- test -d dist/$1 || mkdir dist/$1
- # Static link db_dump185 with old db-185 libraries.
- /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
- /bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
- pushd dist/$1
- ln -sf ../configure .
- # XXX --enable-diagnostic should be disabled for production (but is
- # useful).
- # XXX --enable-debug_{r,w}op should be disabled for production.
- %configure -C \
- --enable-compat185 --enable-dump185 \
- --enable-shared --enable-static \
- --enable-tcl --with-tcl=%{_libdir} \
- --enable-cxx \
- %ifarch %{java_arches}
- --enable-java \
- %else
- --disable-java \
- %endif
- --enable-test \
- # --enable-diagnostic \
- # --enable-debug --enable-debug_rop --enable-debug_wop \
- # Remove libtool predep_objects and postdep_objects wonkiness so that
- # building without -nostdlib doesn't include them twice. Because we
- # already link with g++, weird stuff happens if you don't let the
- # compiler handle this.
- perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
- perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
- perl -pi -e 's/-shared -nostdlib/-shared/' libtool
- make %{?_smp_mflags}
- # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
- LDBJ=./.libs/libdb_java-%{__soversion}.la
- if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
- sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
- fi
- popd
- }
- build dist-tls
- %install
- rm -rf ${RPM_BUILD_ROOT}
- mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
- mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
- %makeinstall -C dist/dist-tls
- # XXX Nuke non-versioned archives and symlinks
- rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
- rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
- rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
- rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
- rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
- chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
- # Move the main shared library from /usr/lib* to /lib* directory.
- if [ "%{_libdir}" != "/%{_lib}" ]; then
- mkdir -p $RPM_BUILD_ROOT/%{_lib}/
- mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
- # Leave relative symlinks in %{_libdir}.
- touch $RPM_BUILD_ROOT/rootfile
- root=..
- while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
- root=${root}/..
- done
- rm $RPM_BUILD_ROOT/rootfile
- ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
- ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
- ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
- fi
- # Move the header files to a subdirectory, in case we're deploying on a
- # system with multiple versions of DB installed.
- mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
- mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
- # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
- for i in db.h db_cxx.h db_185.h; do
- ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
- done
- %ifarch %{java_arches}
- # Move java jar file to the correct place
- mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
- mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
- %endif
- # Eliminate installed doco
- rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
- # XXX Avoid Permission denied. strip when building as non-root.
- chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %post -n compat32-%{name} -p /sbin/ldconfig
- %postun -n compat32-%{name} -p /sbin/ldconfig
- %post -p /sbin/ldconfig cxx
- %postun -p /sbin/ldconfig cxx
- %post -n compat32-%{name}-cxx -p /sbin/ldconfig
- %postun -n compat32-%{name}-cxx -p /sbin/ldconfig
- %post -p /sbin/ldconfig tcl
- %postun -p /sbin/ldconfig tcl
- %post -n compat32-%{name}-tcl -p /sbin/ldconfig
- %postun -n compat32-%{name}-tcl -p /sbin/ldconfig
- %post -p /sbin/ldconfig java
- %postun -p /sbin/ldconfig java
- %files
- %defattr(-,root,root)
- %doc LICENSE README
- /%{_lib}/libdb-%{__soversion}.so
- %{_libdir}/libdb-%{__soversion}.so
- %files cxx
- %defattr(-,root,root)
- %{_libdir}/libdb_cxx-%{__soversion}.so
- %files utils
- %defattr(-,root,root)
- %doc docs/utility
- %{_bindir}/db*_archive
- %{_bindir}/db*_checkpoint
- %{_bindir}/db*_deadlock
- %{_bindir}/db*_dump*
- %{_bindir}/db*_load
- %{_bindir}/db*_printlog
- %{_bindir}/db*_recover
- %{_bindir}/db*_stat
- %{_bindir}/db*_upgrade
- %{_bindir}/db*_verify
- %{_bindir}/db*_hotbackup
- %{_bindir}/db*_sql
- %files devel
- %defattr(-,root,root)
- %doc docs/api_c docs/api_cxx docs/api_tcl docs/index.html
- %doc docs/ref docs/images
- %doc examples_c examples_cxx
- %{_libdir}/libdb.so
- %{_libdir}/libdb-%{__soversion}.la
- %{_libdir}/%{_libdb_a}
- %{_libdir}/libdb_cxx.so
- %{_libdir}/libdb_cxx-%{__soversion}.la
- %{_libdir}/%{_libcxx_a}
- %dir %{_includedir}/%{name}
- %{_includedir}/%{name}/db.h
- %{_includedir}/%{name}/db_185.h
- %{_includedir}/%{name}/db_cxx.h
- %{_includedir}/db.h
- %{_includedir}/db_185.h
- %{_includedir}/db_cxx.h
- %files tcl
- %defattr(-,root,root)
- %{_libdir}/libdb_tcl-%{__soversion}.a
- %{_libdir}/libdb_tcl-%{__soversion}.la
- %{_libdir}/libdb_tcl-%{__soversion}.so
- %ifarch %{java_arches}
- %files java
- %defattr(-,root,root)
- %doc docs/java
- %doc examples_java
- %{_libdir}/libdb_java*
- %{_datadir}/java/*.jar
- %endif
- %if %{build_compat32}
- %files -n compat32-%{name}
- %defattr(-,root,root)
- /%{_lib}/libdb-%{__soversion}.so
- %{_libdir}/libdb-%{__soversion}.so
- %files -n compat32-%{name}-cxx
- %defattr(-,root,root)
- %{_libdir}/libdb_cxx-%{__soversion}.so
- %files -n compat32-%{name}-devel
- %defattr(-,root,root)
- %{_libdir}/libdb.so
- %{_libdir}/libdb-%{__soversion}.la
- %{_libdir}/libdb_cxx-%{__soversion}.la
- %{_libdir}/%{_libdb_a}
- %{_libdir}/%{_libcxx_a}
- %files -n compat32-%{name}-tcl
- %defattr(-,root,root)
- %{_libdir}/libdb_tcl-%{__soversion}.a
- %{_libdir}/libdb_tcl-%{__soversion}.la
- %{_libdir}/libdb_tcl-%{__soversion}.so
- %endif
- %changelog
- * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.8.26-2
- - rebuilt with gcc-4.4.3-3 on ppc
- * Mon Feb 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.26-1
- - update to 4.8.26
- - remove '--enable-rpc'
- - rpc support is removed from db4
- * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6.21-6
- - initial build of db-4.6.21 on Vine Linux
- - temporarily commented out "libtoolize" and "s_config" lines
- until Vine's autotools get updated (maybe?)
- * Fri Apr 3 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-5
- - add upstream patch to fix a race condition between checkpoint
- and DB->close which can result in the checkpoint thread self-deadlocking
- * Mon Mar 10 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-4
- - don't list headers twice in filelist (#436701)
- * Mon Feb 25 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-3
- - manual rebuild because of gcc-4.3 (#434185)
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.21-2
- - Autorebuild for GCC 4.3
- * Thu Oct 11 2007 Jindrich Novy <jnovy@redhat.com> 4.6.21-1
- - update to 4.6.21
- - own %%{_includedir}/db4 (#274251)
- * Mon Sep 3 2007 Jindrich Novy <jnovy@redhat.com> 4.6.19-1
- - update to 4.6.19 (#273461)
- * Thu Aug 29 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-2
- - rebuild for BuildID
- - BR util-linux-ng
- * Mon Jul 30 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-1
- - update to 4.6.18
- - drop upstream patches for 4.5.20 and gcj patch
- - remove nptl-abi-note.S, useless as we are definitely
- running kernel >= 2.4.20 (#245416)
- - move C++ stuff to subpackages to reduce dependency bloat (#220484)
- - package db_codegen
- - correct open() calls so that new db4 compiles with the new glibc
- * Sat Mar 24 2007 Thomas Fitzsimmons <fitzsim@redhat.com> 4.5.20-5
- - Require java-1.5.0-gcj and java-1.5.0-gcj-devel for build.
- * Mon Dec 4 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-4
- - apply upstream patches for 4.5.20
- (Java API <-> core API related fixes)
- * Fri Dec 1 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-3
- - temporarily remove ppc64 from java arches
- * Sun Nov 26 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-2
- - sync db4 and compat-db licenses to BSD-style as the result of
- consultation with legal department
- - fix some rpmlint warnings
- * Fri Nov 10 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-1
- - update to db-4.5.20 (#198038)
- - fix BuildRoot
- - drop .64bit patch
- - patch/source URLs now point to correct location
- * Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
- - rebuild
- * Wed Sep 6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
- - revert the previous fix, it crashes OOo help
- * Sun Sep 3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
- - fix memleak caused by SET_TXN macro in xa_db.c, when opening
- database created with DB_XA_CREATE flag (#204920)
- * Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
- - fix sparc64 build (#199358)
- * Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
- - rebuild because of gnu_hash
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
- - rebuild
- * Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
- - drop useless java, lfs patches
- * Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
- - apply x86_64 fix from Henrik Nordstrom (#184588)
- - don't nuke non-versioned archives twice
- * Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
- - don't package /usr/share/doc/images in the main db4 package
- and move it to db4-devel (#33328)
- - make db4 LFS capable (#33849)
- - move db4-devel, db4-tcl, db4-java to Development/Libraries
- group instead of System Environment/Libraries (#54320)
- - BuildPrereq -> BuildRequires
- - don't use RPM_SOURCE_DIR
- - Obsoletes db3, db2
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
- - New upstream release
- * Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
- - Re-enable java for ppc64
- * Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
- - Add fno-strict-aliasing for java (#168965)
- * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
- - no java for ppc64 for now (#166657)
- * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
- - FC5 is nptl only (derived from jbj's spec)
- - upgrade to 4.3.28
- * Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
- - re-enable db4-java
- * Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
- - /usr/lib/tls/ix86 dirs (#151371)
- * Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
- - add libdb_cxx.so link (#149191)
- * Fri Mar 4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
- - rebuild with gcc4.
- * Sat Jan 1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
- - upgrade to 4.3.27.
- * Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
- - upgrade to 4.3.21, no db4-java for the moment again again.
- * Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
- - on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
- the availability of an NPTL libpthread in glibc > 2.3.3-48
- - run ldconfig in db4-java's %%post/%%postun
- - when building java support, assume that libgcj is equivalent enough to 1.3
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Mon Jun 7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
- - remove dangling symlinks (#123721 et al).
- - remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
- - apply 2 patches from sleepycat.
- - resurrect db4-java using sun jvm-1.4.2.
- - cripple autoconf sufficiently to build db4-java with gcj, without jvm.
- - check javac first, gcj34 next, then gcj-ssa, finally gcj.
- - add ed build dependency (#125180).
- * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
- - fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
- * Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
- - upgrade to db-4.2.52, no db4-java for the moment.
- * Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
- - Add build requires tcl-devel
- * Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
- - symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
- that the run-time linker can find the right copy for of apps which use an
- RPATH to point at %%{_libdir}/libdb-4.1.so
- * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
- - add another section to the ABI note for the TLS libdb so that it's marked as
- not needing an executable stack (from Arjan Van de Ven)
- * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
- - build both with and without support for shared mutex locks, which require NPTL
- - make behavior wrt where we put libdb the same for all OSs
- - revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
- doesn't work
- - fix dangling HREFs in utility docs (pointed to main docs dir, while they're
- actually in the -utils docs dir)
- - run ldconfig when installing/removing the -utils subpackage, as it contains
- shared libraries
- * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
- - fix multiple-inclusion problem of startup files when building shlibs without
- the -nostdlib flag
- * Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
- - link shared libraries without -nostdlib, which created an unresolvable dep
- on a hidden symbol
- * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
- - allow compiling without tcl dependency
- * Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
- - update to 4.2.42.
- - build in build_unix subdir.
- - eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
- - create db4-tcl sub-pkg to isolate libtcl dependencies.
- * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
- - rebuild
- * Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
- - add missing tcl-devel buildrequires (#101814)
- * Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
- - rebuild
- * Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
- - build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
- - whack out libtool predep_objects wonkiness.
- * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
- - rebuild.
- * Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
- - hack out O_DIRECT support in db4 for now.
- * Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
- - replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
- cause a mismatch
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Wed Jun 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
- - change configure to only warn if JNI includes aren't found, assuming that
- the C compiler can find them
- - remove build requirement on jdkgcj -- gcj is sufficient
- * Mon May 5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
- - upgrade to 4.1.25, crypto version.
- - enable posix mutexes using nptl on all arches.
- * Mon Mar 3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
- - enabled db4-java for x86_64
- * Wed Feb 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
- - add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
- linking with -ldb-4.0 will work again
- * Tue Feb 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
- - rebuild to use link the shared object with the same libraries we use
- for the bundled utils, should pull in libpthread when needed
- - move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
- * Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
- - add java for s390x
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
- - rebuilt
- * Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
- - add java for s390
- * Tue Oct 8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
- - add java bits back in for x86 boxes
- * Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
- - Added better fix for s390/s390x/x86_64
- * Thu Sep 05 2002 Arjan van de Ven
- - remove java bits for x86-64
- * Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
- - include libdb_tcl-4.1.a library.
- - obsolete db1 packages.
- * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
- - include patch to avoid db_recover (#70362)
- * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
- - rebuilt with gcc-3.2 (we hope)
- * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
- - own %%{_includedir}/%{name}
- * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
- - build using gcc-3.2-0.1
- * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
- - Add java bindings
- - Fix C++ bindings
- * Thu May 23 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Thu May 9 2002 Jeff Johnson <jbj@redhat.com>
- - re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
- - make sure that -ldb is functional.
- * Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
- - avoid db_util name collisions with multiple versions installed.
- * Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
- - remove relocatability stuffs
- - swallow a local copy of db1 and build db185_dump statically with it, to
- remove the build dependency and simplify bootstrapping new arches
- * Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
- - have subpackages obsolete their db3 counterparts, because they conflict anyway
- * Tue Jan 8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
- - upgrade to 4.0.14.
- * Sun Aug 5 2001 Nalin Dahyabhai <nalin@redhat.com>
- - fix dangling docs symlinks
- - fix dangling doc HREFs (#33328)
- - apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
- * Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
- - turn off --enable-debug
- * Thu May 10 2001 Than Ngo <than@redhat.com>
- - fixed to build on s390x
- * Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
- - update to 3.2.9.
- * Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
- - rebuild to remove 777 directories.
- * Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
- - don't build with --enable-diagnostic.
- - add build prereq on tcl.
- - default value for %%_lib macro if not found.
- * Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
- - add /usr/lib/libdb-3.1.so symlink to %%files.
- - remove dangling tags symlink from examples.
- * Mon Oct 9 2000 Jeff Johnson <jbj@redhat.com>
- - rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
- - turn off --enable-diagnostic for performance.
- * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
- - update to 3.1.17.
- - disable posix mutexes Yet Again.
- * Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
- - add c++ and posix mutex support.
- * Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
- - put nss_db into a separate package
- * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
- - rebuild to cope with glibc locale binary incompatibility, again
- * Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
- - remove redundant strip of libnss_db* that is nuking symbols.
- - change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
- * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
- - summaries from specspo.
- - all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
- * Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
- - temporarily build nss_db in this package, should be moved
- into separate nss_db package soon
- * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
- - rebuild to cope with glibc locale binary incompatibility
- * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- - automatic rebuild
- * Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
- - upgrade to 3.1.14.
- - create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
- - FHS packaging.
- * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
- - disable tcl Yet Again, base packages cannot depend on libtcl.so.
- * Sat Jun 3 2000 Jeff Johnson <jbj@redhat.com>
- - enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
- * Tue May 30 2000 Matt Wilson <msw@redhat.com>
- - include /lib/libdb.so in the devel package
- * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
- - put in "System Environment/Libraries" per msw instructions.
- * Tue May 9 2000 Jeff Johnson <jbj@redhat.com>
- - install shared library in /lib, not /usr/lib.
- - move API docs to db3-devel.
- * Mon May 8 2000 Jeff Johnson <jbj@redhat.com>
- - don't rename db_* to db3_*.
- * Tue May 2 2000 Jeff Johnson <jbj@redhat.com>
- - disable --enable-test --enable-debug_rop --enable-debug_wop.
- - disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
- problems.
- * Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
- - add 3.0.55.1 alignment patch.
- - add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
- - add --enable-tcl (needed -lpthreads).
- * Sat Apr 1 2000 Jeff Johnson <jbj@redhat.com>
- - add --enable-debug_{r,w}op for now.
- - add variable to set shm perms.
- * Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
- - update to 3.0.55
- * Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
- - Add --enable-cxx to configure.
- * Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
- - Create.
|